About Etext Wizard

EtextWizard

目录：

一、关于Etext Wizard:

  1. 软件开发目的及软件用途
  2. 软件的主要功能
  3. 软件的安装及卸载
  4. 软件的注册
  5. 软件的下载地址

二、“北极星工作室”的其他软件：

三、我的主页及联系方式：
一、关于Etext Wizard: Top
1.软件开发目的及软件用途 Top
相信各位在上网一段时间后，硬盘里一定积攒了大量的电子文本，如：
技巧集锦、教程、技术文章、编程指南、小说、散文、传记等等，这些
精彩文件平时大量占用你的硬盘空间，一到用的时候，怎么也找不到；
读起来也很费力，一部《三国》你至少要打开一百二十个文件；而且
第二天也找不到昨天读到那里了，你说急人不急人！
   终于有一天想把他们作成帮助文件，但是，面对某个目录下的几千个
文本文件，才发现所谓的“所见即所得”的帮助文件制作软件竟然要
一个又一个地“手工重复劳作”........
  我曾经用Help&Manual手工作了一个包含两千多条Delphi技巧的帮助文件，
历时两三周终于完成，可是...手抽筋，眼发晕，食欲不振.......
  有时，真的希望有人把我想要的文本全处理好再放到网上，可是...
  面对网上成兆亿的文本难道只有手工处理吗？
  由此，萌发了我的软件开发方向：电子文档处理。

“把繁重而又重复乏味的工作全部交给电脑去做吧！
    人的智慧在于告诉它应该怎么做！”
                                —xxx如是说。

2.软件的主要功能 Top

                功能
                 | 简介

                Txt->Help
                 | 文本文件转帮助文件，支持UNIX格式的TXT，自动添加标题、目录、索引。

                Txt->Html
                 | 文本文件转网页，自动处理URL&EMAIL

                Txt->Chm
                 | 文本文件转网页帮助文件，自动添加目录、索引、
                前页、后页等

                Html->Txt
                 | 网页文件转文本，转换完成比较干净彻底
                （可处理&nbsp;等），支持部分ASP文件。

                Html->Chm
                 | 网页文件转网页帮助文件，自动添加目录、索引。

                VBcode->Html
                 | VB源程序转为网页文件便于浏览。

                FileRenamer
                 | 批量文件改名，可预览结果，众多实用选项。

                Index Maker
                 | 对一个或多个目录下的所有或部分文件作索引，
                自动提取网页的<Title>作为标题，自动提取
                TXT第一行作为标题，多种输出格式。

                Dir Maker
                 | 批量目录建造。 *

                Title Editor
                 | 文本文件的标题编辑器及文件预览器。*

                Find&Replace
                 | 批量文件字符串查找替换器
                *

                Big5->GB

       注解：带*的项目尚未最终完成

3.软件的安装及卸载 Top

运行环境： MS win95;win98;win2000. win98以前的版本运行需要VB5.0
          的链接库文件MSVBVM50.DLL。

安装：

直接运行完全安装版即可（建议初次安装使用完全安装版）；
如果你以前安装过EtextWizard，直接下载新版本的主执行文件
EtextWizard.exe覆盖原来的即可。

卸载：

运行“控制面版”的“添加和删除程序”，找到“电子文档处理器”，
  选“卸载”，再依屏幕操作即可。

4.软件的注册 Top

本软件为“共享软件”，即“先试后买”的软件。

由于目前正处于测试阶段，故软件价格待定。

5.软件的下载地址:

本软件将会不定期更新版本，请留意！

http://www.ebook007.com/softdown.htm

二、“北极星工作室”的其他软件： Top

TextVampire(网络即时贴) v1.0：Top
浏览文本或网页时，随时把你喜欢的文字很方便地存成.Txt文件。
你要做的只是选好文本，再按一下CTRL-C，这时，点击“网络即时贴”的
粘贴并生成文本文件”钮，TextVampire会自动截取所选文本的第一行（非空）
作为文件名保存起来，方便你将来收集整理、查找；同时也简化了你的击键次数。

http://www.ebook007.com/softdown.htm

三、我的主页及联系方式： Top

我的主要站点：

http://www.ebook007.com/
 (北极星书库)

(虚拟域名：http://www.ebook007.com/)

http://fengguohua.myrice.com/
 (北极星软件库)

http://go.163.com/~guohua99/(电子文档处理器)

镜像站点：

http://members.xoom.com/fengguohua/

http://guohua99.363.net/

eMail:

fengguohua@hotmail.com

警告：Top

对重要文件请先作好备份，以免造成不必要的损失；
用户试用此软件的同时由用户个人承担试用此软件的一切风险，如用户不接受
此项要求请马上把本程序从你的硬盘删除； TXT转HELP结束后，程序会自动删除
已处理过的目录下的所有RTF文件，请在运行前
检查该目录下是否有重要的RTF文件，请作好备份。
请不要使用本软件制作非法电子出版物，否则一切后果由制作人自行承担，与本软件作者无关。
请不要修改本软件的版权信息（包括随软件发布的一切文档），否则作者将保留追究其法律责任的权利。
在不修改作者版权信息及保证软件完整性的前提下，任何个人或组织可随意发布或试用本软件的免费共享版，
但不得对本软件做任何逆向工程（指反汇编、反编译，公布注册码、散发正式版等）。
本文档中所指“程序”或“本程序”均指EtextWizard(中文名：电子文档处理器)。

注：MS,Windows Help(hcw.exe,hcrtf.exe),Html Help(hhw.exe,hhc.exe)的版权均归美国微软公司所有。

All Rights Reserved, Fengguohua of North Star, 2000-05-03

Top


复杂性中的思维(克劳斯·迈因策尔)

复杂性中的思维

THINKING IN COMPLEXIT

作者：克劳斯·迈因策尔[德]

曾国屏 译
    中文版序言
    第一版序言
    第二版序言
1、导言：从线性思维到非线性思维
2、复杂系统和物质的进化
3、复杂系统和生命的进化
4、复杂系统和心－脑的进化
5、复杂系统和人工智能的进化
6、复杂系统和人类社会的进化
7、关于未来、科学和伦理学的结语
    译者后记

北极星书库||http://www.ebook007.com


Get Update News

Update Link:
http://www.ebook007.com/softdown.htm

程序会经常更新，请登陆网站以得到最新版本。如有任何意见和建议也请给我发Email。

我的Email地址： fengguohua@hotmail.com。


Goto EtextWizard's Homepage

My Homepage:
http://www.ebook007.com/

这里有许多已经经过我的“电子文档处理器”处理过的Windows帮助文件或Windows HtmlHelp格式的小说、传记等作为范本供大家参考。


克劳斯·迈因策尔—复杂性中的思维—中文版序言

中文版序言

    《复杂性中的思维》第二版问世一年后，献给中国读者的中文版现在也问世了。复杂性和非线性是物质、生命和人类社会的进化中最显著的特征。本书考察了物理和生物科学、认知和计算机科学、社会和经济科学以及哲学和科学史中的复杂系统。
    中国科学家已涉足所有这些研究领域。而且，中国是一个令人印象深刻的复杂社会的例子，它正以极大动力奔向21世纪。本书传达的思想是：自然科学、技术、经济学、管理和政治学中，线性思维显然已经过时。此外，中国文化总是具有自己的传统和特色，不同于西方的线性的机械论的世界观。因此，复杂系统探究方式就不仅能战胜自然科学和人文科学之间的隔阂，而且也能缩小西方文化和东方文化之间的距离。
    我们生活在同一个复杂的非线性世界上，处在有序和混沌的边缘。因此，对自然和社会中的复杂性和非线性的管理，成为我们共同面临的世界范围的挑战。用德国数学家、计算机先驱和哲学家、对中国文化和科学充满敬意的莱布尼茨（1646－1716）的话来说，我们必须保持全球性“多样化统一”的目标。
    我要向译者曾国屏教授的细致工作表示感谢。一本跨学科的著作，涉及数学、计算机、物理学、化学、生物学和社会学、经济学和哲学术语，翻译时需要特别的努力。他有效地掌握了这些。同样地，我还要向出版者——中央编译出版社（中国）和施普林格出版社（德国）表示感谢。它们使中文版的出版得以实现。

                                                  克劳斯·迈因策尔
                                              1996年12月于奥格斯堡

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页
前一页
回目录


克劳斯·迈因策尔—复杂性中的思维—第一版序言

第一版序言

    复杂性和非线性是物质、生命和人类社会进化中的显著特征。甚至我们的大脑也表现为受制于我们大脑中复杂网络的非线性动力学。本书考察了物理科学和生物科学、认知科学和计算机科学、社会科学和经济科学以及哲学和科学史中的复杂系统，引入了一种跨学科的方法论，以解释在自然界和精神领域以及经济和社会中有相同原理的有序的形成。
    这些方法常常被认为是预示了21世纪科学发展特征的新的复杂性科学。本书批判地分析了这种探索方式的成功之处及其局限性，它的系统基础，它的历史背景和哲学背景。最后的跋中讨论了新的伦理学行为标准，这些行为标准是自然和神经、经济和社会的复杂问题所要求的。
    本书的“核心”是一篇提交给关于复杂非线性系统的会议的论文，这次会议于1992年10月在比勒费尔德的跨学科研究中心举行，是由赫尔曼·哈肯和亚里山大·迈克赫罗夫组织的。同年12月，安格拉·M．勒海博士（施普林格出版社）建议我将该文的主题扩展为一本书。因此，我要向勒海博士的友好和有效的支持，以及对赫尔曼·哈肯在复杂系统和协同学上的多次合作表示谢意。我还要感谢德国研究基金对我的“计算机、混沌和自组织”（1990－1992：Ma 842／4－1）和“神经信息学”（1993－1994：Ma 842／6－1）课题的支持。奥格斯堡大学的关于“复杂系统”的数学研究生项目和关于“经济和管理中的非线性”的经济学课程的教学使我得到了许多灵感。1991年和1993年，北莱茵-威斯特伐利亚（杜塞尔多夫）科学研究中心邀请我参加了两次关于计算机技术、神经生物学和精神哲学的文化影响的国际会议。
    最后，我同样特别要向以英语为母语的罗斯（施普林格出版社）对本书的仔细阅读和校正，向胡塞尔和尤塔（奥格斯堡大学）为本书打字表示感谢。

                                                    克劳斯·迈因策尔
                                                  1994年6月于奥格斯堡

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页


克劳斯·迈因策尔—复杂性中的思维—第二版序言

第二版序言

    《复杂性中的思维》一书，第一版不到一年即已告罄。显然，复杂性和非线性是自然科学和社会科学都关注的跨学科“热门”话题。伊安·斯图特（沃里克大学数学研究所）关于本书的一篇精彩的书评——《兴起中的新科学》（《自然》，1995年第374卷第834页）对此进行了很好的概括：“非线性并非万能的答案，但往往是一种更好的思考问题的方式。”
    借此出第二版的机会，我对本书进行了修订和扩充。在第2．4节，补充了在超分子化学和材料科学中关于保守自组织的最新重要成果。文献中补充了一些从自组织角度对宇宙学进行的新讨论。对于活细胞中的耗散自组织的新成果，增加了一些评注（第3．3节）。对于神经技术中适应性神经修补术的成功和局限，也进行了更详细的分析（第5．4节）。原书的最后一章扩展为“关于未来、科学和伦理学的结语”，该章首先是关于传统预测方法的一个简短导言，接着从自然科学和社会科学受到非线性和复杂性制约的前提，讨论了传统预测方法的局限性和新的预测程序。特别是对科学和技术发展进行预测和建模的可能性，这是当代关于人类的未来和伦理学的争论中的兴奋点之所在。
    非线性复杂系统的一般方法必须在与自然科学和社会科学的结合中、在特定的观测、实验和理论条件下加以发展。因此，我希望借此机会对以下这些同事的极有帮助的建议表示感谢：罗尔夫·埃克米勒（波恩大学神经信息系），汉斯-耶尔格·法尔和沃尔夫·普里斯特（波恩天体物理学系和马克斯-普朗克射电天文学研究所），赫尔曼·哈肯（斯图加特理论物理和协同学研究所），本罗·里斯（海德堡马克斯-普朗克医学研究所），库迪乌莫夫（莫斯科凯尔迪什应用数学所），蕾娜特·迈恩茨（科隆马克斯-普朗克社会科学研究所），阿希姆·米勒（比勒费尔德大学无机化学系）。最后，我同样还要感谢沃尔夫·拜格尔博克（施普林格出版社），他对本书第二版的修订给予了鼓励和支持。

                                                    克劳斯·迈因策尔
                                                  1995年11月于奥格斯堡

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页


克劳斯·迈因策尔—复杂性中的思维—1、导言：从线性思维到非线性思维

1、导言：从线性思维到非线性思维

    在自然科学中，从激光物理学、量子混沌和气象学直到化学中的分子建模和生物学中对细胞生长的计算机辅助模拟，非线性复杂系统已经成为一种成功的求解问题方式。另一方面，社会科学也认识到，人类面临的主要问题也是全球性的、复杂的和非线性的。生态、经济或政治系统中的局部性变化，都可能引起一场全球性危机。线性的思维方式以及把整体仅仅看作其部分之和的观点，显然已经过时了。认为甚至我们的意识也受复杂系统非线性动力学所支配这种思想，已成为当代科学和公众兴趣中最激动人心的课题之一。如果这个计算神经科学的命题是正确的，那么我们的确就获得了一种强有力的数学策略，使我们得以处理自然科学、社会科学和人文学科的跨学科问题。
    在这些跨学科的应用中，成功的原因何在？本书表明，非线性复杂系统理论不可能还原成特殊的物理学的自然定律，尽管它的数学原理是在物理学中被发现的，并首先在物理学中得到成功应用。因此，它不是某种传统的“物理主义”，不是用类似的结构定律来解释激光、生态群体或我们的大脑的动力学。它是一种跨学科方法论，以此来解释复杂系统中微观元素的非线性相互作用造成的某些宏观现象。光波、流体、云彩、化学波、植物、动物、群体、市场和脑细胞集合体，都可以形成以序参量为标志的宏观现象。它们不能还原到复杂系统的原子、分子、细胞、机体等微观水平上。事实上，它们代表了真实的宏观现象的属性，例如场电势、社会或经济力量、情感乃至思想。有谁会否认情感和思想能够改变世界呢？
    在历史上，社会科学和人文学概念往往受到物理理论的影响。在机械论时代，托马斯·霍布斯把国家描述成一台机器（“利维坦”），其公民就是机器中的嵌齿轮。在拉美特利看来，人的灵魂归结为自动机的齿轮传动装置。亚当·斯密用类似于牛顿的万有引力的“看不见的”力来解释市场机制。经典力学中，在牛顿或哈密顿运动方程意义上，因果关系是确定论的。保守系统以时间可逆（即对称性或不变性）和能量守恒为特征。天体力学和无摩擦钟摆是著名的例子。耗散系统是不可逆的，举例来说就像没有摩擦项的牛顿力。
    而且，大自然原则上被看作一个巨大的确定论的保守系统，一旦确切知道了它的起始状态，就可以预测其未来或追溯过去的每一时刻的因果事件（拉普拉斯妖）。亨利·彭加勒则认识到，天体力学并非是一台可以透彻计算的机械钟，甚至在局限于保守性和确定论情况下亦如此。所有的行星、恒星和天体之间的因果相互作用，在其相互影响可以导致混沌轨迹的意义上，都是非线性的（例如三体问题）。在彭加勒的发现之后，几乎过了60年，A．N．科尔莫哥洛夫（1954）、V．I．阿诺德（1963）和J．K．莫泽证明了所谓的KAM定理：经典力学的相空间轨迹既非完全规则的亦非完全无规的，但是它们十分敏感地依赖于对起始条件的选择。微小的涨落可能引起混沌的发展（“蝴蝶效应”）。
    在这个世纪，量子力学成为物理学的基础理论。在薛定谔的波动力学中，量子世界被看作是保守的、线性的。用哈密顿算符描述的量子系统，取代了最初用哈密顿函数描述的量子化经典系统（例如对于电子和光子）。这些系统被假定是保守的，即非耗散的，对于时间逆转具有不变性，因而是满足能量守恒定律的。量子系统的状态用希尔伯特空间的矢量（波函数）来描述，希尔伯特空间的距离与其哈密顿算符的本征值相联系。量子状态的因果动力学由确定论的微分方程（薛定谔方程）所决定，该微分方程合乎叠加原理，因而是线性的，即如同经典光学的情形，该方程的解（波函数或态矢）是可以叠加的。量子力学的叠加或线性原理显示了组合系统的相关（“关联”）态，这在EPR实验（A·阿斯佩特，1981）中得到了高度确证。在一个关联的纯量子叠加态，一次观测仅可能得到不确定的本征值。量子系统的关联态和测量仪器相应仅可能有不确定的本征值。但是，实验室的测量仪器却显示出了确定的测量值。因此，线性的量子动力学难以解释该测量过程。
    在玻尔、海森伯等人的哥本哈根诠释中，测量过程是用所谓的“波包坍缩”来解释的，即把叠加态分裂成两个独立的具有确定本征值的测量仪器和被测量子系统的状态。显然，我们必须将量子系统的线性动力学与测量的非线性作用加以区分。这个世界的这种非线性，有时被解释成人的意识的出现。尤金特·威格纳（1961）建议，薛定谔方程的线性对于有意识的观察者可能会失效，需要代之以某种非线性程序，使两个问题都可能得到解决。但是，威格纳的解释迫使我们相信，线性的量子叠加性仅仅在宇宙的那些出现了人的或类似人的意识的角落才会分裂成独立的部分。科学史上，拟人的或目的论的论证往往表明，科学解释在此软弱无力、难以奏效。因此，一些科学家如罗杰·彭罗斯提出，量子力学的线性动力学不适合于用意识的出现来解释宇宙的进化。他主张，至少是一个把线性量子力学和非线性的广义相对论统一起来的理论，才可能解释这个世界中的宏观系统的独立状态。一台测量仪器是一个宏观系统，测量过程是远离热平衡的不可逆过程。因此，一种解释只有在一种统一的非线性理论中才可能成功。甚至把薛定谔波动方程推广到量子场论，它也是非线性的。量子场论中，有所谓的二次量子化，场函数被场算符所代替。例如，对于两粒子势场，量子场方程包含有一个非线性项，它相应于基本粒子对的形成。一般地，量子场论中基本粒子的反应本质上是非线性现象。基本粒子的相互作用导致了其量子态只具有有限的寿命，从而破坏了时间的可逆性。因此，一般地，甚至量子世界自身同样既不是保守的也不是线性的。在系统理论中，复杂性不仅仅意味着非线性，还意味着大量的具有许多自由度的元素。所有的宏观系统，如石头或行星、云彩或流体、植物或动物、动物群体或人类社会，都是诸如原子、分子、细胞或有机体这样的组元构成的。具有大量自由度的复杂系统中的单个元素的行为，既无法被人预见，也无法被人追踪。对单个元素的确定论描述，必须代之以概率分布的演化。
    第二章分析了“复杂系统和物质的进化”。前苏格拉底时期以来，自然哲学的一个基本问题是，有序是如何从复杂的、无规的和混沌的物质状态产生出来的。赫拉克利特认为，一种产生有序的能力（逻各斯）协调着无规的相互作用，创造出有序的物质状态。现代的热力学以数学的统计力学概念描述了有序的形成。我们区别两种形成有序的相变（自组织）：保守自组织和耗散自组织。保守自组织意味着热力学平衡态的可逆结构的相变。典型的例子是雪花晶体的生长或使铁磁体系统退火到临界温度值时磁性的形成。保守自组织主要是造成低温低能的有序结构，这可以用波耳兹曼分布来描述。耗散自组织是远离热平衡的不可逆结构的相变。当耗散（“开放”）系统与其环境的能量相互作用达到某个临界值时，微观元素的复杂的非线性合作产生出宏观模式。从哲学上看，所形成的结构的稳定性是由某种非线性和耗散的均衡来保证的。过强的非线性相互作用或耗散作用会使结构遭到破坏。
    由于耗散相变的条件是十分普通的，这就使之有了广泛的跨学科应用。物理学中，激光是一个典型的例子。化学的贝洛索夫-札鲍廷斯基（BZ）反应中，当特定的混合在一起的化学物质处于临界值，就出现了浓度环或螺旋卷。各个环波之间的竞争非常清楚地显示出这些现象的非线性，而叠加原理成立时这些环波应该相互穿透，如同光波那样。
    非线性的耗散复杂系统的相变由协同学来解释。我们可以更定量的方式说，旧的结构变得不稳定，并由控制参量的改变而被打破。在微观水平上，旧的状态的稳定模是受到不稳定模的支配（哈肯的“役使原理”）。它们决定着描述系统的宏观结构和系统的序参量。相变的种种不同的最终模式，对应于不同的吸引子。种种不同的吸引子可以形象地描述为流体，其速
    度被逐步加速。在最初的水平上，显示的是均匀平衡态（“不动点”）。在较高速度的水平上，可以观察到两个或两个以上的螺旋，它们是周期的或准周期的吸引子。最后，有序退化成确定论混沌，这是一种复杂系统的分形吸引子。从哲学上看，我希望进一步强调，协同学中物质的微观描述有别于宏观有序状态。于是，协同学的有序概念使我想起赫拉克利特的“逻各斯”或亚里士多德的“形式”，它们在物质的转变过程中产生出自然的有序态。当然，古人在这里用的不是数学描述。
    用更数学化一些的语言来说，复杂系统的微观观点是用态矢的演化方程来描述的，方程中每一分量都依赖于空间和时间。这些分量可以代表流体的速度分量，它的温度场，或化学反应中的化学物质的浓度。协同学的役使原理允许我们消除代表着稳定模的自由度。在主要的近似中，相应于这些系统的非线性，演化方程转变成特殊形式，在此出现了模式之间的竞争。不稳定模的主导项的幅度称为序参量。它们的演化方程描述了宏观模式的形成。最后的模式（“吸引子”）通过相变而实现，此过程可以被理解为某种对称破缺。从哲学上看，物质的进化是由赫拉克利特早已提到的对称破缺引起的。
    第三章分析“复杂系统和生命的进化”。科学史和哲学史上，人们曾相信“死”物和“生”物之间是界线分明的。亚里士多德把生命解释为一种自组织的力量（隐德来希），它推动着植物和动物朝向其最终形式生长。一个活系统能够靠自己来运动，而一个死系统只可能从外部来推动。生命用目的论来解释，即用指向某种自然目标的非因果力（“生命力”）来解释。18世纪，康德揭示了活系统的自组织不可能用牛顿物理学的机械系统来解释。他在一段著名的话中说，能够解释青草叶片的牛顿还没有出现。19世纪，热力学第二定律描述了封闭系统朝向最大熵状态或无序态的不可逆运动。人们又如何来解释在生命的达尔文进化中的有序的形成呢？波耳兹曼强调，活的有机体是开放的耗散系统，与其环境发生着交换，这并不违背封闭系统的第二定律。但是，在从波耳兹曼到莫诺的统计解释中，生命的出现仅仅是一种意外的事件，是“在宇宙边缘”的局部宇宙涨落。
    在复杂系统的框架中，生命的形成不是偶然的，而从耗散自组织意义上讲是必然的和合乎规律的。宇宙中，只有生命出现的条件（例如出现在行星地球上）才可能是意外的。一般地，生物学中将个体发生（有机体的生长）与种系发生（物种的进化）加以区别。在任何一种情形下，我们遇上的都是复杂的耗散系统。这种系统的发展，可以用远离热平衡的相变来解释，即由分子、细胞等等的非线性（微观）相互作用引起的（宏观）序参量的演化得到解释。生物系统（植物、动物等等）的形式用序参量来描述。亚里士多德关于自然目的的目的论，用相变的吸引子来解释。但是，这里不需要任何特殊的“生命力”或“目的力”。从哲学上看，生命的出现可以在非线性因果性和耗散自组织的框架中得到解释，尽管出于启发式的原因，它可能会使用目的论语言来描述。
    我要向读者指出，生物大分子的前生物进化已经由曼弗雷德·艾根等人进行了分析和模拟。斯宾塞以复杂性增加为标志的生命进化思想，可以在耗散自组织理论中得到精确化。众所周知，图林分析了有机体数学模型，将其表示成复杂元胞系统。格里斯奇、迈恩哈特等人用关于细胞聚集的演化方程描述了有机体（例如软泥霉）的生长。对于阿米巴，当环境中细胞营养物处于某个临界值，其非线性相互作用引起了如软泥霉的宏观有机体的形成。序参量的演化对应于宏观有机体相变过程中的聚集形式。成熟的多细胞体可以解释为机体生长中的“目标”或（更好的）“吸引子”。
    甚至生物群体的生态生长也可以运用协同学概念来说明。生态系统是复杂的耗散系统，包括植物或动物之间以及与其环境之间的相互的非线性代谢作用。两种群体与其营养源的共生，可以用3个耦合的微分方程来描述，爱德华·洛仑兹已经用这种方程描述了气象学中天气的发展。在19世纪，意大利数学家洛特卡和沃尔特拉描述了两个处于生态竞争中的群体的发展。两个复杂群体的非线性相互作用，由两个耦合的捕食者和被捕食者的微分方程来描述。该耦合系统的演化具有一个稳恒的平衡点。演化的吸引子是周期振荡子（极限环）。
    复杂系统理论使得我们可以对自然界生态系统的非线性因果作用进行分析。自从工业革命以来，人类社会与自然界的生态循环结合得越来越紧密。但是，线性的传统工业生产模式使复杂的自然平衡受到重大威胁。人们假定自然界中拥有无穷无尽的能源、水源和空气等等，利用它们时也不会干扰自然界的平衡。工业会生产出无穷无尽的物品，而无需考虑如同臭氧洞或废物利用那样的协同效应。生命的进化转化成为了人类社会的进化。
    第四章“复杂系统和心－脑的进化”，讨论了也许是最有思辨性的复杂系统的跨学科应用。在哲学史和科学史上，已经提出了多种多样的解决心－身问题的主张。唯物主义哲学家如德谟克利特、拉美特利等人主张，把精神还原为原子的相互作用。唯心主义者如柏拉图、彭罗斯等人则强调，精神是完全独立于物质和大脑的。在笛卡尔、艾克尔斯等人看来，精神和物质是相互作用、独立存在的实体。莱布尼茨信奉一种形而上的精神和物质的平行论，因为它们不可能进行物理性的相互作用。在莱布尼茨看来，精神和物质是在“前定和谐”中存在，如同两个同步的钟表。现代精神哲学家如西尔斯则捍卫一种进化自然主义。西尔斯争辩道，精神以意向性的精神状态为标志，它们是人大脑的生化作用的固有特征，因而不可能由计算机来模拟。
    但是，复杂系统理论不可能归结为这些或多或少片面的主张。复杂系统探究方式是一种跨学科的方法论，适用于讨论诸如大脑这样的细胞器官的非线性复杂系统。精神状态的形成（例如模式识别、情感、思想）用大脑集合体的（宏观）序参量的演化来解释，序参量是远离热平衡的学习策略中由神经细胞的非线性（微观）相互作用造成的。具有精神状态的细胞集合体被解释为相变中的吸引子（不动点、周期的、准周期的或混沌的）。
    如果大脑被看作一个神经细胞的复杂系统，那么它的动力学也就假定由神经网络的非线性数学来描述。例如，通过与应用于描述物理学、化学和生物学中模式形成的演化方程进行类比，模式识别也就解释成为一种相变。从哲学上看，我们就获得了一种跨学科的研究纲领，由此可以把神经计算的自组织解释为一种具有共同原理的物理学、化学和神经生物学演化的自然结果。正如在模式生成的情形，特定的模式识别（例如一张脸的原型）是用其特征集的序参量来描述的。一旦给出了属于该序参量的部分特征（例如脸的一部分），序参量就会完成其余的特征，使得整个系统以联想记忆方式起作用（例如在给出脸的一部分时重构出所贮存的脸的原型）。按照哈肯的役使原理，所识别的模式的特征相应于模式生成中受役使的子系统。
    对于意识、自我意识和意向性的形成，情况又如何呢？在协同学中，我们必须对大脑的外部状态和内部状态进行区分。在感知和识别的外部状态，序参量相应于神经细胞集合体，代表着外部世界的模式。大脑的内部状态只是自参照状态，即只是包括精神状态的精神状态，而不包括外部世界的状态。在传统的语言哲学中，我们说人可以反映他们自己（自反映），也能够将外部世界的状况反映到他们自己的内部情感和意向（意向性）的状态之中。在新近的神经生物学研究中，科学家们推测，意识和自我意识作为自反映的神经实现，其形成取决于“元细胞集合体”产生速率的临界值。“元细胞集合体”即是代表了细胞集合体的细胞集合体，这细胞集合体又代表着细胞集合体，如此等等。这种假说（如果是成功的），只能解释诸如意识的形成特征的结构。当然，细胞集合体的数学演化方程并不能使我们获得与他人获得的感受不同的感受。在消极的意义上，科学是盲目的。但是，它也有积极的意义：个人的主体性得到了保留：非线性动力学的计算和计算机辅助的模拟原则上是有局限性的。
    无论如何，复杂系统探究方式解决了一个传统的形而上学之谜。莱布尼茨曾经这样描述这个谜：如果我们把大脑想像为一台如碾磨机那样的大机器，我们可以进入其中的内部机制，我们将发现的只不过是如同嵌齿轮那样的一个个机器元件，而不可能找到什么精神，更不用说什么人的灵魂。当然，在微观水平上，我们只可能把神经元的发展描述为大脑中的脑部件。但是，在宏观水平上，复杂神经系统中的非线性相互作用引起了有一定序参量的细胞集合体的形成，而序参量是不可能用单个脑细胞的状态来验证的。整体并非部分之和。
    显然，复杂系统探究方式对于心－身问题提供了解答，它们超越了传统的唯心主义、唯物主义、物理主义、二元论、相互作用论等等解答。对于所谓的自然智能和人工智能之间的区分，重要的是要注意，非线性复杂系统的原理并不取决于人脑的生物化学的作用。在大脑复杂系统是物理和生物进化产物的意义上，人脑是这些原理的一种“自然的”模型。但是，由人的技术生产出其他的（“人工的”）模型也是可能的，尽管它们的实现会遇到技术上和伦理上的限制。
    第五章中，我们讨论“复杂系统和人工智能的进化”。在此描述了神经计算机和协同计算机的发展，并与图林机和基于知识的系统进行了比较。在协同计算机中，序参量方程允许一种新的（非霍布）学习方式，它是一种最大限度减少突触数目的策略。与旅晶型的神经计算机（如霍普菲尔德系统）不同，神经元并非阈值元件，而是执行一种简单的代数操作如乘法和加法。除了确定论的均匀性霍普菲尔德网络以外，还有所谓的波耳兹曼机，这是一种非确定论处理元件和分布知识表示的随机网络构造，数学上用能量函数来描述。与霍普菲尔德系统运用霍布学习策略不同，波耳兹曼机倾向于一种后向传播策略（威德劳－霍夫规则），采用具有隐含神经元的多层网络。
    一般说，学习算法的目标在于通过自组织来减少大脑的内部世界模型与真实环境之间的信息－理论测量的差距。人们最近对于神经网络领域兴趣的恢复，主要是受到统计力学和非线性动力学技术的成功运用的鼓舞，这些成功运用的领域包括固体物理学、旋晶物理学、化学平行计算机、光学平行计算机以及——在协同计算机的情形——激光系统。另外的原因是，计算资源和技术水平的最新发展，使得对非线性系统进行计算处理越来越可行。从哲学上讲，认识论的传统课题，如感知、想像和认知，都可以在跨学科的复杂系统框架中进行讨论。
    复杂系统探究方式的一个重要应用是神经仿生学和医学。人脑不仅是一台作为自然界进化产物的脑计算机，而且也是我们身体的一个中心器官，它需要医学上的治疗、康复和保健。例如，神经手术这个医学分支，专注于保持人的精神的生物载体的健康。神经仿生学的一个基本目标是关注未来的脑－心体的健康。近年来，器官移植中引入了新的诊断手段和技术设施，它们建立在从复杂动力学系统看待大脑所获得的新见解的基础上。因而临床治疗的变化是不可避免的。神经病和心理疾病可以解释成高度敏感的非线性系统中的复杂状态。甚至医学治疗也必须考虑到这个复杂器官的高度敏感性。另一种更为思辨性的新技术是电脑化空间。感知、情感、直觉和幻想可以是人工神经网络的产物吗？虚拟现实已经成为现代文化哲学中的一个关键词。
    在经历了从物质、生命、心－脑和人工智能的运动之后，本书的第六章《复杂系统和人类社会的进化》进行了黑格尔式的大综合。在社会科学中，人们通常严格地区分生物进化和人类社会史。原因在于，民族、市场和文化的发展被认为由人的意向性行为所引导，即人的决策是以意向、价值等等为基础的。从微观的角度看，我们当然可以观察到带着其意向、信仰等等的一个个的个体。但是从宏观的角度看，民族、市场和文化的发展就不仅仅是其组成部分之和。我们知道，政治和历史中的单极因果关系是错误的、危险的线性思维方式。对于处理复杂系统甚至包括人文领域这样的复杂系统，协同学表现为一种成功的策略。为了以跨学科方式运用协同学，显然不必将文化史还原成生物进化。与任何还原论的自然主义和物理主义相反，我们承认人类社会的意向性特征。因此，复杂系统探究方式可以是一种沟通自然科学和人文学科、消除其间隔阂的方法，斯诺曾在著名的《两种文化》中批评过这种隔阂。
    在复杂系统框架中，人群的行为用（宏观）序参量的演化来解释，（宏观）序参量是由人们或人类的子系统（国家、组织机构等等）的非线性（微观）相互作用引起的。社会的或经济的有序用相变的吸引子来解释。阿伦等人分析了城市区域的生长。从微观的观点看，城市区域的生长中，群体演化在数学上是用耦合的微分方程来描述的，微分方程的项和函数涉及每一地区的能力、经济生产等等。整个系统的宏观发展用计算机辅助作图示意出来，包括了工业化中心、娱乐中心等等的变化，它们是由其中的一个个城市区域的非线性相互作用引起的（例如，交通、通信等等的远近不等带来的优势和劣势）。此协同学模型的一个基本结论是，城市的发展不可能以每个人的个人自由意志来解释。尽管每个区域中的人们的行动都有其个别的意向性、计划性等等，但是全局的发展趋势却是非线性相互作用的结果。
    协同学的另一个跨学科应用的例子是维德里希的迁移模型。他区分了社会中微观水平上的个体决策和宏观水平上的动力学集体过程。具有随机涨落的概率性宏观过程用人类社会构型的主方程来描述。一个社会构型中的每一组元都涉及到一个具有特征行为矢量的子群体。社会中迁移的宏观发展可以用计算机辅助作图来示意，其中的混合、聚居、漫游和混合中心的变化，都是由社会子群体的非线性相互作用引起的。在此模型中，人的复杂系统和非人的复杂系统之间的区别是明显的。在微观水平上，人的迁移是意向性的（即受收益考虑引导的）和非线性的（即依赖于个体和集体的相互作用）。协同学的一个主要的结果又是，国家的和国际的迁移效应是不可能用单个的个人自由意志来解释的。我认为，迁移是当代的一个非常重要的课题，揭示了线性的、单极因果性的思维方式是多么的危险。只有良好的愿望而不考虑到个别决策的非线性效应是不够的。线性的思维和行动能激发起全局性的混沌，尽管我们局部的行动带着最良好的愿望。
    很遗憾，在经济学中，线性模型仍然处于支配地位。从定性的观点来看，亚当·斯密的自由市场模型已经可以用自组织来解释。斯密强调了，个体的良好的或邪恶的愿望都不是本质性的。与集中化的经济系统相反，供给和需求的平衡，并不由程序控制的中心处理者来指定，而是“看不见的手”（斯密）的结果，即只不过是消费者和生产者的非线性相互作用的结果。经济学家近来对于非线性耗散系统的兴趣，受到了以知识为基础的高技术产业发展的鼓舞，高技术产业具有正反馈效应（即生产增长依赖于技巧的增长，如电子学、计算机工业等等）；这与传统的产业具有负反馈效应形成了鲜明的对比（即生产的降低受到资源的限制如煤炭或钢铁）。一般说来，经济过程是非常复杂的，需要非线性耗散模型。回忆一下种种不同的吸引子，从经济循环到财政混乱，它们只可能以消费者和生产者、财经政策、股票市场、失业等等的非线性相互作用引起的协同效应来解释。甚至在管理领域，也讨论了可能的复杂模型，以通过所有层次上的管理和生产的非线性协同来支持创造性和创新。协同学的分析表明，经济过程是自然的生态循环之中的一个环节。正是我们使经济学和社会学非线性复杂系统成为现实这个大的政治意愿，使自然与人类社会面保持平衡。
    人们显然已经获得了一些成功地处理非线性复杂系统的策略。我们将讨论一些应用的例子，包括量子物理学、流体动力学、化学和生物学中的，以及经济学、社会学、神经病学和人工智能中的例子。这些自然科学和人类社会中的成功应用背后，原因是什么？复杂系统方式并不归结为某个特定的物理学自然规律，尽管首先从物理学中发现了其数学原理并有了成功的应用（例如激光）。它是一种跨学科的方法论，可以解释复杂系统中通过微观元素的非线性相互作用造成的一定的宏观现象。宏观
    现象的形式多种多样，可以是光波、流体、云彩、化学波、生物分子、植物、动物、群体、市场和脑细胞集合体，它们都是用序参量来标志的（表1．1）。

表1．1非线性复杂系统的跨学科应用

学科 | 系统 | 元素 | 动力学 | 序参量
量子物理学 | 激光 | 原子（光子） | 相变 | 光波形式
流体力学 | 流体 | 分子 | 相变 | 液体形式
气象学 | 天气 | 分子 | 相变 | 云彩形式
地质学 | 熔岩 | 分子 | 相变 | 六角形（贝纳德元胞）
化学 | BZ－反应 | 分子 | 相变 | 螺旋形环形（化学波）
生物学 | 生物分子 | 分子 | 相变 | 结构形式
生物学 | 有机体 | 细胞 | 机体生长 | 机体形式（植物，动物）
生物学 | 群体 | 有机体 | 群体进化 | 群体形式（相互作用形式）
经济学 | 经济系统 | 消费者，生产者等 | 市场机制（即供给和需求） | 市场形式（相互作用形式）
社会学 | 社会 | 人、制度等 | 历史 | 相互作用形式
精神病学（心理学） | 大脑 | 神经元 | 认知（学习） | 表示外部或内部（“自参照”）状态的神经细胞集合体的形式
人工智能（AI） | 神经（AI） | AI神经元 | 学习算法 | 表示外部或内部（“自参照”）状态的神经AI元注集合体的形式

    表示外部或内部（“自参照”）状态的神经AI元注集合体的形式
    从哲学角度看，重要的是要弄明白，序参量不能归结为系统原子、分子、细胞、有机体等等这些复杂的微观水平。它们有时是可测量的量（例如激光的场势），有时是定性的性质（例如模式的几何形式）。然而，序参量并不只是一个理论性的、没有任何现实性的数学概念。实际上，它们代表着真实的宏观现象的性质，诸如场势、社会或经济的力量、情感甚至思想。有谁会否认情感和思想可以改变世界呢？但是，复杂系统探究方式不是一种形而上学的过程本体论。协同学原理（以及其他原理），对于构造自然科学和人文学科中的非线性复杂系统的模型，提供了一种启发性框架。如果这些模型可以数学化，它们的性质可以量化，那么我们就获得了一种经验性模型，它们可能与数据吻合，也可能不吻合。役使原理表现了另一种优点。由于它减少了复杂系统中的大量的自由度，协同学就不仅仅是启发性的、数学化的、经验的和可检验的，而且也是经济的。这也就是说，它满足了著名的奥卡姆剃刀原理，这一原理告诉我们除掉多余的实体。
    我们的探究方式表明，物理的、社会的和精神的实在都是非线性的和复杂的。协同认识论的这个基本结论要求我们，注意我们的行为的严重后果。正如我们所强调的，在一个非线性的复杂的现实中，线性思维是危险的。作为一个例子，我们必须记住，我们需要的是一个生态学和经济学之间有着良好均衡的复杂系统。我们的医生和心理学家，必须学会把人看作复杂的精神和肉体的非线性体。线性思维可能会作出不正确的诊断。医疗中的局部的、孤立的和“线性的”治疗方法，可能会引起负面的协同效应。在政治和历史中，我们必须牢记，单极因果性可能会导致教条主义、偏执主义和空想主义。随着人类的生态、经济和政治问题已经成为全球的、复杂的和非线性的问题，传统的个体责任的概念也变得可疑了。我们需要新的集体行为模型，它们建立在我们的一个个的个别成员和种种不同见解的基础之上。简言之，复杂系统探究方式需要有新的认识论和伦理学结论。最后，它也提供了一个机会，使我们去防止非线性复杂世界的混沌，去利用协同效应的创造性可能。

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页


克劳斯·迈因策尔—复杂性中的思维—2、复杂系统和物质的进化

2、复杂系统和物质的进化

    有序何以能够从复杂的、无规的和混沌的物质状态中出现呢？古代的典籍中，哲学家试图将自然现象的复杂性追溯到第一原理。天文学家提出的数学模型，是将他们常见的、无规的、复杂的行星轨道归结为规则的、简单的球体运动。简单性被理解为真理的特征，直至哥白尼也是如此（2．1节）。牛顿和莱布尼茨把某些新东西加进了运动学模型的理论中。微积分使得科学家可以计算一个物体的瞬时速度，并将其形象地表示为该物体轨迹的切向量。速度向量场成为动力系统理论中的一个基本概念。牛顿和爱因斯坦的宇宙理论，使用的是完全确定论的动力模型（2．2节）。
    但是，彭加勒发现，从长远观点看，这些模型可能都是不可计算的（多体问题）。甚至对于一个完全的确定论世界，拉普拉斯妖——它可以长期地对宇宙进行计算——的假设也暴露出只不过是一种幻想的虚构。混沌不仅仅出现在天上，也出现在量子世界中（量子混沌）（2．3节）。从方法论的观点看，非线性是混沌的必要条件而不是充分条件。它也使有序的出现成为可能。在现代物理学框架中，宇宙中多种多样结构的出现，包括从基本粒子到恒星和活的有机体，都是用平衡态的相变和对称破缺来建模的（2．4节）。但是甚至从霍金以来，我们也仍未获得一种完整的理论来解释复杂性不断增长的物质进化。前苏格拉底的惊奇——“存在着某种东西而非一无所有”——仍然没有得到解决。
    2．1亚里士多德的宇宙和赫拉克利特的逻各斯
    前苏格拉底以来，自然哲学的一个基本问题是，有序是如何从复杂的、无规的和混沌的物质状态中出现的。前苏格拉底哲学家们所做的是把自然现象的复杂性按经验还原为“原初”即“原素”。让我们来看一些例子。米利都的泰勒斯（前625－前545）是第一个自然哲学家，据说他证明了第一条几何公理，他认为只有物质性的基本因才可能是万物的原初因。泰勒斯主张，水或湿是第一因。他的证据来自观察：万物的繁茂和种子都与湿有关，而湿物的自然基质就是水。
    阿那克西曼德（前610－前545），泰勒斯的学生和同事，扩展了泰勒斯的自然哲学。为何水是万物的第一因？它只是存在于连续的紧张和对立之中的物质的多种形式之一：热对冷、湿对干……因此阿那克西曼德主张，“存在物的起源和第一因”是“无限的不定性”的原初物质，相反形式的物质从中产生出来。相应地，我们必须把“无限的不定性”想像为原始状态，此时物质不受限制，也没有对立，因而在任何地方都有相同的特征。因此，这是一种完全均匀的、对称的初始态。对称性后来发生了对称破缺，于是世界及其所有可观测的对立和紧张就产生出来：
    不断发生着的物质分裂创造了这个世界，火球从中产生出来，它包围着气，气又包围着土，如同树皮围绕树干；当它进而分裂开来，就形成了一串圆圈，太阳、月亮和星星都各处其所。
    阿那克西曼德在其宇宙起源论中所描述的随后的物质状态因此就决不是混沌的；相反它们是由新的部分有序所决定的。阿那克西曼德早期的生物进化思想更有吸引力。他主张，最初的人为海中动物所生，出生后他们很快就能独立谋生，正如他观察到有几种鲨鱼的情形就是如此。一个世纪以后，人们开始寻找海中动物的化石证据，来证明人是从海中诞生的。第三位著名的米利都自然哲学家是阿那克西米尼（约前525），他被认为是阿那克西曼德的同事。他把变化看作是凝聚和稀散的外部力的结果。在他看来，各种形式的物质都可以作为基本物质。他选择了气：
    稀散，使之成火；凝聚，成风；然后，成云；进一步，更强的凝聚，就成水；再后，成土；最后，成石头；万物都是由这些东西产生出来的。他还主张，永恒的运动是转化的缘由。－－他说，冷使物质收缩和凝聚，相反，热却使之稀薄和散开。
    因此，阿那克西米尼主张，外部的力量使得多种多样的物质状态从共同的原初物质产生出来，并相互转化。
    爱菲索的赫拉克利特（约前500）常常被称作“晦涩哲人”，他对我们的主题具有特别显著的意义。他的语言的确深奥难懂，多为预言式语言而不是严肃的科学语言，充满着深层隐喻。他采用了阿那克西曼德关于自然界充满斗争和对立面紧张的学说。他认为，原初物质——万物之源，自身处于变化中，因而也就是火：
    闪电（即火）指引着一切。——这个世界的秩序也是如此，一切都不是任何上帝创造的，也不是任何人所创造的，但它过去、现在都是永恒的活火，按照一定的尺度燃烧和熄灭。
    赫拉克利特进一步阐述了所有的物质状态如何能够被理解为原初物质——火——的熄灭形式。在我们的时代，物理学家维纳·海森伯声称：
    在这一点上，我们能够以某种方式说，现代物理学十分接近于赫拉克利特的教导。如果我们替换一下“火”这个词，就几乎一字一句地重复赫拉克利特的说法来作为我们现代概念的表达。能量的确是质科，所有的基本粒子，所有的原子，以至万物总的说来都是由它构成，而且同时能量也是那运动着的东西……能量可以转化成运动、热、光和张力。能量可以被看作是世界上的一切变化的原因。
    的确，这个物质世界由对立条件和倾向构成，然而它们却借存在于隐藏着的和谐而保持着统一性：“对立事物的斗争走向联合，从多样性中产生出最美的和谐，斗争使得万物以这种方式产生出来。”隐藏着的对立面的和谐因而就是赫拉克利特的宇宙规律，他称之为“逻各斯”。
    当对立面的斗争结束时情况如何呢？按照赫拉克利特的看法，这个世界就进入到一个绝对的平衡终态。爱利亚的巴门尼德（约前500）描述了这种物质状态，在此不再有（虚空）空间的变化和运动。物质在任何地方都是平均（均匀）分布，没有任何一个方向对于可能运动是优先的（各向同性）。值得注意的是，无限被看成是不完美的，因而假定有限的物质分布。以这种方式，巴门尼德提供了一种世界图像，它是坚固的、有限的、均一的质料球体，没有时间、运动或变化。这种无变化存在的爱利亚哲学，的确是要批判赫拉克利特的永恒变化哲学，认为它不过是一种感官的幻觉。这种爱利亚哲学，在历史上对后来的柏拉图的影响，体现在他对虚假变化的批判中：虚假变化是在感官的感知中产生的，而真实的世界是不变的理念存在。但是从自然哲学的观点来看，巴门尼德描述的世界并不必然与赫拉克利特的教导相对立；在他的宇宙发生论中，它完全可以被理解为最高对称性的奇点终态。
    在把水、气和火当作原初元素之后，就容易将它们设想为世界的原材料。恩培多克勒（前492-前430）迈出了这一步，并把土作为第上四种元素加入到火、水和气之列。这些元素可以自由地以各种比例混合和结合，也可以分解和分开。那么恩培多克勒把什么作为自然界的不断变化和运动背后的永久原素呢？他认为，首先是存在着四种元素，它们来自自然和机遇，而不是来自任何意识意向。变化是这些元素之间的反复作用即混合和分离引起的：“我要告诉你们另一件事：任何质料事物都既不会诞生，也不会走向毁灭。有的只是：混合和混合物的交换。”元素之间的这些反复的作用，是两种基本的力量引起的；他将吸引称之为“爱”，排斥称之为“恨”。这类似于中国哲学中的阴和阳。恩培多克勒提倡一种不断的转化过程，即元素的结合和分离，在此过程中元素则保持下来。他并没有把这些转化过程设想为完全机械性的（后来的原子论者则这样设想），而是设想为生理性的，特别是他把有机体的代谢过程看得高于无生命的自然界。
    在他的医学理论中，平衡被理解为真正的比例关系。因此，健康就意味着相反成分的某种特殊的均衡，只要其中一方占了上风就会引起疾病。如果我们考虑现代细菌学及其对于人体中抗体的理解，那么恩培多克勒的这种观点是多么的贴切。
    阿那克萨戈拉（前499-前426）被认为在许多方面都精练了前人的教导。他像恩培多克勒一样，发展了一种物质混合理论。但是他将恩培多克勒的四种元素代之以数目无限的实体，构成这种实体的是种子微粒或同样大小的微粒。它们数目无限，也无限地小，即假定物质是无限可分的。颗粒连续不断的思想就不可避免要产生出来。阿那克萨戈拉也试图以这种方式来解释颜色的混合，他说过雪在一定程度上也是黑色的，不过白色在此处于支配地位。所有的事物都包含在每一事物之中，但是其中一些在混合关系中处于支配地位。
    比起他的一些前人，阿那克萨戈拉显然试图在自然哲学中给天体现象和运动以物理解释，在古希腊的数学天文学中仅仅是从运动学角度描述它们的。于是在他的宇宙学中，他已不停留在单一的起始态：均匀的物质混合。阿那克萨戈拉把一种非质料的原初力量称作“精灵”，它使得混合物进入漩涡运动之中，并根据它们各自的速度把种种事物分离开来。土聚集在漩涡的中间，而更重的石块则向外猛冲而去，形成了恒星。它们的发光被解释成其群体的发热，并被归结为它们的飞快的速度。阿那克萨戈拉的漩涡理论，到近代在笛卡尔那里再现出来，后来又以更精致的形式再现在康德-拉普拉斯行星系统的机械起源理论中。
    近代自然科学中，原子论已被证明是一个极为成功的研究纲领。哲学史上，德谟克利特的原子理论常常被看作赫拉克利特的变化哲学和巴门尼德的不变存在原理的结果。德谟克利特区分了“充满”和“虚空”，最小的不可毁灭的原子和虚空相应于巴门尼德的“存在”和“非存在”。赫拉克利特的复杂性和变化性，从原子的不可区分的构型中衍生出来。虚空空间被假设为均匀的和各向同性的。
    在质料组合中，原子的不同在于其形式、位置以及种种构型。为了表示出原子的构型，将其比作语词中的字母序列，就导致了这样的假设，即原子思想只有在使用拼音文字的文化中得到发展。事实上，在中国，传统上使用的不是拼音文字而是象形文字，人们不知道粒子的思想，流行的是自然过程的场和波的概念。德谟克利特的原子按照必然性以不断旋转的方式运动。在此，与后来的亚里士多德的概念不同，运动仅仅是指虚空中的位置变化。所有的现象，所有的生成和腐朽，都是组合和分离的结果。物质的聚集态如气体、液体或固体，都用原子的不同密度和运动潜力来解释。用今天的结晶学的观点看，德谟克利特的思想——甚至固体中原子在其位置上也发生着振动——是值得注意的。
    柏拉图在他的对话《蒂迈欧》中，引入了第一个数学的原子论模型。变化、混合和分离，都要追溯到前苏格拉底时期就已经说过的不可改变的数学规则性。在恩培多克勒的四元素即火、气、水和土中，已经有了一种分类，立即就可以借用。泰阿泰德全部采取了完全确定性的规则物体，它们在三维（欧几里得）空间都是可能的：四面体、八面体、二十面体、立方体和十二面体。因此，柏拉图所主张的，也就是要以这些几何建筑块来解释恩培多克勒的四元素。
    柏拉图对其元素有意要避开德谟克利特的“原子”表示法，因为它们可以分解成独立的平面图形。于是，四面体和二十面体具有等边三角形的面，它们分成两半时得到直角三角形，其边长分别是1、2和 [image] ，而立方体的面分成两半时得到直角三角形，其边长为1、1和平方根 [image] 。结果是，像水、气和火那样的“流体”是可以相互结合的，而以土作为建筑块所构成的固体，因其不同的三角形，只可能转变成其他的固体。
    于是柏拉图就发展起一种基本粒子的物理学，其中特定的元素是可以相互转变的，“基本粒子”（即相应的组元三角形）可以按照几何定律发生着“反复的作用”。例如，元素的转变是沿其边切开造成的。柏拉图之所以使其成为可能，这有赖于固体角度的锋锐。较为锋锐的平面角可以劈开具有规则角度的多面体。于是，所有的四面体、立方体、八面体、二十面体，排在前面的都可以劈开排在后面的多面体，但不能劈开排在前面的多面体或同样的多面体。这种自然哲学的结论中，火可以分离或分裂所有其他元素，土只可以分离或分裂气和水，气则仅仅可以分离或分裂水。
    柏拉图断言，元素的大小是不一样的。例如，为了解释火能够引起固态形式的水转变成液态形式的水，他认为，元素在液态时尺寸要小一些，更有流动性，而在固态时其尺寸就要大一些。
    离开火被称作冷却，在离开火以后的状态称固化。火和气可以通过土建筑块（立方体）中间的间隙而不受阻碍，也不会分裂土元素。气凝聚起来后不可能被分解，也不毁灭此元素。气的凝聚意味着八面体以最佳表面构型积累起来。即使是火也难以穿透进其中必然会留下的间隙，因其体面角度比所有元素的都要小，不会破坏八面体。对于水，只有火才可能破坏最强的凝聚。相邻二十面体的体面角度之间的间隙既不允许土穿透也不允许气穿透。只有火（四面体）可以穿透和分解此种结合。
    的确，柏拉图发展了一种内部目洽的数学模型，如果人们接受他的学说——尽管它有点专断——作为对元素进行解释的起点，实体的各种聚集态和反复作用都可以由此得到解释。这种自然哲学自然会引出一些奇怪的荒谬结论。不过，我们在此遇上了科学史上以简单的几何定律来解释物质及其状态的首次尝试。这在现代基本粒子物理学中得到了高度发展。海森伯注意到了这一点：“……基本粒子具有柏拉图描述的形式，因为这是数学上最美、最简洁的形式。因此，现象的终极根源不是物质，而是数学规律、对称性、数学形式”。在古代和中世纪，柏拉图的数学原子论没有得到多少支持。对于他的后继者来说，他的几何学物质理论的基本问题在《蒂迈欧》中已经是明明白白的了。如何来解释活的有机体的功能呢？一定的肉体形式是为了满足一定的生理目的（例如，食管的形状是为了同化食物），这种主张，在任何情形下都难以从规则固体的理论中推演出来。此外，以几何图形的“活跃”和“僵死”为基础来解释生命的变化动搏过程，在那个时代的人们看来也必定是完全不自然的、推测性的和冷僻遥远的。在我们这个时代，人们仍然难以理解这种迂回：今天的科学解释中采取的是复杂的抽象数学理论。亚里士多德的自然哲学就从这里开始了。
    亚里士多德主要以活的有机体如植物和动物的功能为基础，来阐述他关于自然的均衡或“平衡”的概念。生命的过程和周期是我们从日常经验中所熟知的。用我们熟知的东西来解释这个世界，比起用那些我们不熟悉的陌生的东西来进行解释，不是更清楚一些吗？按照亚里士多德的见解，科学的任务就是对自然的复杂性和变化的原素和功能作出解释。这是对那些自然哲学家的一种批评，他们用个别的实体来作为原素的证明。一个个的植物或一个个的动物，都不仅仅是其质料建筑块的相加之和。亚里士多德把构成个体存在的东西称作一般形式。由形式塑造的东西称作物质。形式和物质都不是自己能单独存在的，相反它们是通过抽象提取出来的自然的原素。因此，物质也是以使之形成的潜能为标志的。在物质形成之前就已存在着实在。
    我们所观察到的真正的活的生物体都处在不断的变化之中。赫拉克利特在此是正确的，而巴门尼德把变化看作幻觉则是错误的。变化是真实的。按照亚里士多德的看法，赫拉克利特用特定实体（火）来证明变化也是不对的。亚里士多德是用第三种原素来解释那些变化，这第三种原素与物质和形式并列，没有形式就没有适当的变化。幼苗和孩子是弱小的、不成熟的。它们得以生长是因为它们与其自然趋势（形式）相一致，这意味着长大变强和成熟起来。因此，一般地说，变化决定着运动，使之从可能变成现实，即“潜能实现”（中世纪人们的说法）。物理学的任务，就是研究自然界中在此综合性意义上的运动。自然——与人所制作的艺术品或技术工具相反——被理解为所有事物，它自己带着运动的原素。如果我们按照亚里士多德的指示来进行思考，则正如日常经验告诉我们的，首先是对于植物、动物和人们的生命过程，他的说法完全是合理的、适当的。自然并非一块巨石，可以任凭人们将其破裂成一块块石块。自然自身被设想为一个理性的有机体，其运动是必然的、合目的的。亚里士多德区分了两类运动，即由大小的增加或减少引起的量的变化，由特征转变引起的性质变化，以及由位置改变引起的空间变化。亚里士多德规定了因果性的四个方面作为变化的原因。为何植物会生长？这是因为：①其质料组分使得生长成为可能（质料因）；②生理功能决定了其生长（形式因）；③外部环境（土、水和阳光等等营养物）推动着生长（动力因）；④与其终极目的相一致，即奔向其最完美的形式（目的因）。
    亚里士多德然后就运用这些同样的原理——它们显然是从植物、动物和人的生命循环中推演出来的——去解释狭义上的物质，即后来被称作无机部分的自然。亚里士多德在此又从直接的经验推进了。我们在此遇到的，不再是作为自然界独立建筑块的众多元素；而是我们所经验的特性，如温暖和寒冷、湿润和干燥。这些特性的结合产生出以下决定元素的特性对：热－干（火）、热－湿（气）、冷－湿（水）、冷－干（土）。这里排除了同时出现热－冷和湿－干。因此，元素只有4种。这种推演后来受到了批评，它是主观任意的，但是它表明了亚里士多德的方法，即不是从抽象的数学模型进行推导，而是直接从经验出发进行推导。在真实的物体中，都或多或少、或强或弱地含有火、气、水和土，它们都处在不断的转化之中。按照亚里士多德的观点，用热的手段来驱除水中的冷就形成了气，而排除气中的湿就形成了火。自然的变化就被解释为成熟和转化过程。
    这种处于支配地位的有机自然哲学就其那时的状况，如何能为数学自然科学提供物理解释呢？基本的空间运动只有两种，即直线运动和圆周运动。因此必定有某些元素，使这些基本运动自然地出现。其他物体的运动是由这些元素及其自然的运动来决定的，每一种运动都受此运动支配。最完美的运动是圆周运动。它是可以一直运动下去的，这就是为什么要规定一种不朽的元素。这就是第五种元素（精英），它构成了不变的大球和恒星。尘世（月下）世界中的不断变化性，与天上（月上）世界
    的不变现则性区分开来。这些转变过程中伴随着那四种元素，它们具有独特的直线运动，特别是具有指向世界中心的运动，其中重元素土和水竞相奔向其自然的中心，而指向月球圆周的直线运动中，轻元素竞相向上奔向其自然的归宿。
    在这些自然的运动中，还有自由落体运动。但是，亚里士多德并没有像伽利略那样，以理想实验形式从独立的运动出发来进行探讨。在复杂环境中观察到的落体，没有从其摩擦（“耗散”）力中抽象出来。在其自由降落过程中，落体在空气介质中下落如同石头在水中下沉。因此，亚里士多德把自由降落想像为一种流体动力学过程，而不是一种真空中的加速过程。他假定了一种恒定的降落速度u，它正比于物体的重量p，反比于介质（例如空气）的密度d，用现代表示法就是。u-P／d。这个比例方程同时也为亚里士多德反对原子论者的虚空提供了一种证据。在真空中，密度d＝0，所有的物体都将无限快地降落，这显然是不会发生的。
    （人为）推动的运动的一个典型例子是投掷，它也是在其复杂的“耗散”力的环境中来考察的。按照亚里士多德的观点，非生命物体的运动只是不断的外部运动因的结果。想像一下，古希腊的颠簸的道路上的两轮车，当驴子（或奴隶）停止推或拉时，车就会停下来。但是为何当一块石头从手中投掷出去后它还继续运动呢？在亚里士多德看来，在虚空中是不可能有超距作用的。因此，亚里士多德说，投掷者把运动传递给了石头周围的连续介质，这将石头推到远处。对于推动或拉动的速度u，亚里士多德断言，这里有比例关系U-K／p，K是所施加的力。当然，这些并非是与测量的量相联系的数学方程，而是定性的决定性因素的比例，在中世纪的亚里士多德派的物理学中它首次被表述成了这种形式。于是，与伽利略-牛顿的动力学相反，在亚里士多德的动力学中，所有的位置（直线）变化都需要有某种运动因（力）。中世纪的冲力论改变了亚里士多德的动力学，把运动因归结到投掷出去的物体中的“冲力”，而不是由外部媒介进行的传递。
    亚里士多德派的动力学是如何解释天上的宇宙规律的呢？宇宙模型的中心对称性以（未受力的）球体的圆周运动——这被认为对于“天上”元素是自然的——为基础，以及以宇宙中心的自然中心理论为基础。托勒密进一步以这个各向同性模型为基础，用一种三段论的充足理由律来解释地球的位置。假定所有方向都是完全等价的，地球为何要向这一方向或那一方向运动就是没有理由的。
    地球处于中心的中心对称模型是亚里士多德的老师柏拉图提出来的；在地球周围的整个天空，都围绕着一条穿过地球的天轴向右旋转。太阳、月亮和行星都在球面向左旋转，它们与地球的距离依次是：月亮、水星、金星、太阳、火星、木星和土星。最外层是带着恒星的球面。按照柏拉图-毕达哥拉斯概念，旋转周期相互之间具有整数关系。所有的旋转时间有共同的倍数，在其结束处所有的行星正好又处在相同位置。它们的运动都会各自产生出一种声音，因此球体运动的音调合在一起就形成了天球的和谐，与校好的音阶一致。宇宙的几何的、算术的和美学的对称性，在环宇中奏响一种天球的和谐音乐。随后，精确的观察使人们对这种强调宇宙对称性的模型产生疑问。一个困难的问题来自不规则的行星轨道，特别是它们的逆行运动。天空中的不规则性引起了人们的不安，特别对于承袭毕达哥拉斯传统的哲学家更是如此，他们已经习惯于把天上——与地球相反——理解为永恒对称的、和谐的领域。
    柏拉图提出了一个著名的问题，以减少天上运动的复杂性：使用规则、有序的圆周运动来“拯救”行星现象；这是一种运动学的解释。当波加的阿波罗尼（约前210）建议放弃天球的共同中心时，已经提出一个观察曲线的精确模型。但是，仍然保持了球形的行星运动和等速球体。按照这种主张，行星在球面上作匀速转动（本轮），它们的中心被设想成沿中心点（地球）的一个大圆圈（均轮）上作匀速运动。通过适当地调节速度和两个圆圈运动的直径并变动其运动方向，就有可能作出某种未预料的曲线，而这些在从开普勒到托勒密的天文学中都找到了部分应用。一个个模型的球体对称性因而得到了保留，即使它们不再有共同的中心而是有种种不同的中心时也是如此。
    下面的本轮-均轮技巧显示出，通过适当地把匀速的圆周运动结合起来，可以得到多种表现的运动形式。这使得柏拉图派的哲学家的观点更容易理解：在现象的变化背后是永恒的不变的形式。在图2．1中，一个椭圆的轨道是由均轮的运动与本轮的运动结合而成的。图2．2显示了一种封闭的旋轮线。以这种方式，行星与地球之间的距离的变化也就被表示出来。原则上，甚至角度的形象也可以产生出来。当本轮的直径接近于均轮的直径时，就完全是一条直线了。如果人们改变一个行星的从东到西运动的速度，使之沿一个本轮从西到东运动，那么通过适当地组合一个本轮运动和一个均轮运动，还可以产生出三角形和长方形。

    如果人们使天体沿第二个本轮作圆周运动，这第二个本轮的中心点是沿第一个本轮运动的，那么就可以产生出多种椭圆轨道、反映-对称曲线、周期曲线以及非周期轨道和反对称曲线。从纯粹的数学和运动学的观点看，柏拉图的“拯救现象”问题是完全解决了。因此，柏拉图式的以匀速圆周运动（被阿波罗尼和托勒密进行了修订）来减少复杂性的做法，原则上也许直至今日还对科学有影响。无论如何，它是不可能由曲线途径的现象学描述来否证的。特别是，从这种观点来看，无论是在所谓的哥白尼革命中将地球和太阳的位置对换，还是把圆周轨道改变成椭圆轨道的开普勒变化，都显得是次要的，因为他们的起始条件都可以追溯到与本轮-均轮技巧符合的对圆周运动的组合。这就带来了两个问题：①这种断言是如何在数学上得到支持的？②如果它得到这种支持，那么它为何在现代科学的曲线理论的应用中却没有起作用呢？为了精确地对第一个问题作出一般性的回答，有必要返回到分析几何的现代结构。但是在历史上，哥白尼和开普勒也知道，他们所用的曲线（例如椭圆）也是可以通过本轮-均轮技巧来重构的。
    首先，我们必须记住，平面上的点可以用复数X＝X＋iy＝reiθ来代表，相应的笛卡尔坐标是（x，y）或极坐标是（r，θ）。复数的加法相当于向量的加法。一个具有中心c、半径r和周期T的匀速圆周运动可以表示为
    z＝c＋rei((2πt/T)＋α)＝c＋re((2πt/T)＋α)（2.1）
    式中该点的时刻是t，初相是α。现在假定点A按照方程z＝f（t）运动。让点B相对于A作圆周运动，它有半径r，周期T，初相a。B点的运动就由如下方程描述
    z＝f（t）＋rei（2πt/T＋α）（2.2）
    于是它就可能描述点B沿某个本轮的运动，其本轮中心绕A运动。新的本轮的加法在数学上是把一个新项re ei（2πt/T＋α）加到z的表达式中。显然，r ei（2πt/T＋α）＝reiαe2πit/T＝aeikt其中复数a≠0，K是实数。在逆行运动情形下，T或k分别为负。n个本轮叠加成的运动于是表示为方程
    z＝asu1sueik1t＋asu2sueik2t＋…＋asunsueiknt （2．3）
    让我们首先考虑平面Z＝f（t）上的周期运动（例如其周期为2π）数学上，我们假定f在有限变化中是连续的。那么对于f可以表示为一个均匀收敛级数f(t)＝
    （2.4）
    n＝－8
    因此，容易从数学上证明f（t）以通过求和获得近似
    Sn(t)＝
    （2．5）
    其精确度随着N的增加而增加。
    函数f的确是均匀收敛的。因此对于任意小的ε＞O，可选择No使得对于所有的N≥No和所有的t，都有
    |f（t）－SsuNsu（t）|ε（2．6）
    令人惊奇之处在于，这种结果意味着，一条（有限变化的）恒定运动轨道，可以用有限的本轮运动的叠加，获得任意精确的近似值。
    显然，我们迄今所用的不过是本轮周期的叠加，本轮周期如±2π、±π、±（2／3）π、±（1／2）π、±（2／5）π、…。特别是，只有可公度的叠加才是允许的，这可以用整数的比来表达，从而符合毕达哥拉斯传统。但是，如果我们允许不可公度周期，那么事实上非周期曲线也可用本轮叠加来近似。这种结果在数学上为哈罗德·玻尔关于近周期函数的命题所支持（1932）。第二个问题是，为何解释运动轨道的本轮－均轮技巧被抛弃了，指出观察中遗漏了曲线是无法作出回答的。数学上，观察曲线——无论它是多么的稀奇，只要用柏拉图－阿波罗尼的古代的降低复杂性的策略，原则上就是可以解释的（前述是非常宽的数学条件）。
    不过，在此决定性的问题是，行星的“真正”运动是什么，它们本来是组合的、匀速的和末受外力的圆周运动，是我们在地球上看起来显示为椭圆轨道，还是它们事实上是受外力被迫循着椭圆轨道运动。这是难从几何学和运动学上来确定的，而只能从动力学上来确定，即要用相应的受力理论来确定，因而也就是要从物理学上才能确定。
    除了本轮－均轮技巧以外，托勒密还使用了假想的均衡点，相对于它，采取了匀速的圆周运动，即相对于地球作为中心，显示出非匀速的运动。这种技巧被证明在计算上是很有用的，但是违背了中心对称性，因而具有先验假设的效果，这在自然哲学看来是不能令人信服的，后来哥白尼就特别对此进行了批评。哥白尼交换了地球和太阳的位置，其理由来自处于支配地位的运动学。也就是说，某种运动学简化的描述是可能以较大对称性来实现的。因此，在日心说模型中，行星的逆行运动可以被解释为地球周年运动的效应，在哥白尼看来它比外层的木星、火星或土星运动得慢，而比内层的水星和金星运动得快。但是，哥白尼完全坚持了保守的自然哲学立场，因为他在“自然”圆周运动的意义上把更大的简单性看作是接近实在的标志。
    近代天文学的第一位伟大的数学家约翰奈斯·开普勒认为，简单性信念也是颠扑不破的。他在1596年的《神秘的星际旅行者》中，开始多次尝试把规则体引入行星系统中，两行星之间的距离正是此规则体的内接球面和外切球面。土星、木星、火星、地球、金星和水星这6颗行星所相应的6个球面，恰好是一个处于另一个之中，而且以如下顺序分开：立方体、四面体、十二面体、二十面体和八面体。当然，开普勒的推测不可能推论到适合于一个世纪以后发现的天王星、海王星和冥王星。
    开普勒是一位不折不扣的自然科学家，不能长期沉湎于柏拉图式的推测中。他在1609年写的《天文学通论》是一篇独特的文献，是在精确观测结果的不断增加的压力下，通过一步一步的研究来解决古老的柏拉图简单性概念。与哥白尼不同，开普勒将新颖的动力学论据加进了其运动学研究中。他与哥白尼的不同还在于，太阳不再被看作处于运动学的非正圆心点的没有物理学功能的东西，而是被看作行星运动的动力因。新的任务也就是要从数学上来确定这些力。开普勒的用磁场进行的动力学解释只是一次（不成功的）最初尝试。在后来的牛顿引力理论中才取得了成功。
    天上（“月上”）世界的简单性和尘世（“月下”）世界的复杂性，在其他文化中也是普遍的。让我们来看一看古代中国的道家自然哲学。它确实是处在神话的边缘，逻辑论证也比古希腊自然哲学要少，更多是激起直觉和神往；然而，两者之间也有类似之处。道家把自然描述为巨大的有机体，受控于循环运动和节律，诸如世代、朝代和个体从出生到死亡的的生命循环，由植物、动物和人类构成的食物链，季节的更替，白天和黑夜，行星的升起和降落，如此等等。所有的事物都与其他事物处于联系之中。一个节律跟着一个节律犹如水波。什么样的力量是自然界中这种模式的终极因呢？如同恩培多克勒那样，道家理论中区别了两种相反的力量，即阴和阳，随其节律的增加或减少就支配着这个世界。《鬼谷子》（公元前4世纪）一书中写道：“阳循环返回其起点。阴极大时就返回到阳。”亚里士多德认为，所有的个体都带着其自然目的而自我运动。这里则是阴阳之道决定着个体的内部节律，那些能量也总是要返回其起点。道的循环运转模型，可以提供一系列的解释：天文学中历法的制订，气象学中的水循环、食物链和生理学中的循环系统。它对于自然中的生命节律是极富说服力的，人们天天都在体验着这种循环，并可以用来指导自己的生活。自然界表现为一个目的性的机体。
    值得注意的是，中国的自然哲学中没有原子微粒概念，因而没有发展出西方文艺复兴意义上的数理力学。相反，其核心是自然界和谐的模型，其中节律波和场使得所有的事物都与其他事物相关联。声学的领先以及早期关于磁效应和电效应的见解，在这种自然哲学中成为可理解的。道家的观点更像斯多葛派的自然哲学，而不像亚里士多德的自然哲学。斯多葛派的自然哲学关注的核心也是如同水波的巨大连续统的传播效应。这个连续统就是斯多葛派的普纽玛，其紧张和振动被认为是决定了种种自然状态。自然的丰富多采的形式仅仅是由普纽玛的紧张变化造成的短暂模式。当然，现代的思维方式已经跃进为水波、声波的驻波模式或磁场的模式。然而，无论是斯多葛派还是道家的启发性背景，都不会导致可与以原子论自然哲学为背景的伽利略力学相媲美的声场或磁场的发展。对于从复杂、无规和混沌的物质状态中出现有序所进行的描述，仅仅是定性的，而且对地下和天上运用了不同的模型。
    2．2牛顿宇宙、爱因斯坦宇宙和拉普拉斯妖
    自古以来，天文学家和哲学家都相信，天上的运动是由简单的几何定律支配着。简单性不仅仅理解为方法上简单省力所需，而哥白尼却把它作为真理的一个特征。因此，从柏拉图到哥白尼的天文学学说都声称：要将天上系统的表面的复杂性归结为某种简单的真实运动的框架中！欧几里得几何学的基本概念赋予其简单的建筑块：圆周（罗盘）和直线（尺子）。与月上世界的简单性相反，月下的尘世世界倒是真正复杂的。因此它的动力学也就至少是不能在欧几里得几何学的框架中进行数学化的。那就是柏拉图的数学原子论很快就被忘记了的原因，而亚里士多德的见解——复杂的定性的自然动力学在原则上是不可能数学化的——影响着直到文艺复兴的科学研究。
    早期的物理学家如伽利略克服了月上（“简单”）世界和月下（“复杂”）世界的界限。他们相信，天上和地下的自然动力学都是由同样的数学规律统治着。在技术上，伽利略简化了例如自由落体的动力学，他选择了一些可观测的、可测量的量而忽略了
    另一些约束。简言之，他创造出运用一种理想化实验情形的简化的数学模型。当然，甚至物理定律的天体模型也只考虑了几个参量，诸如行星的角速度和位置，并忽略了其他多种多样的约束条件（例如大球的密度、质量和摩擦）。从现代的观点看，甚至前苏格拉底哲学家，通过选择某些主导“参量”（例如水、火和土），也提出了关于自然界的复杂动力学的定性“模型”。
    一般地说，观测一个系统，无论它是物理的生物的还是社会的，都可以从不同状态来进行。为观测现象建立模型的策略，自古以来可能已有变化，但是建模活动的目标在某种意义上却是相同的：被观测系统中状态变化的动力学。显然，真实的状态不可能仅仅用几个可观测参量来描述，但是却假定这是可以做到的。在早期的天文学和力学中，这是数学理想化的第一步，并导致了一组理想状态的几何模型，这在今天称作模型的态空间。前苏格拉底的自然“模型”不同于现代的模型，不仅仅在于数学化和可观测性，还在于真实系统的实际状态与几何模型点之间的关系被认为是本体论上所需要的，而在现代系统中它却是由于理论、预测等等缘故而保留下来的虚构。
    最简单的框架是一个参量的模型。早期医学对哺乳动物的认识指出，健康或生病的状态与温度这个参量有关联。许多动物所表现的一些特征可以说也就是对其他动物的情绪状态：狗的耳朵状态相应于它的害怕状态，而犬齿暴露程度则是其愤怒程度的定性“参量”。把两者组合起来，就更恰当地代表了狗的情绪状态。行星的状态在中世纪可用其角速度和场所来定义。其他系统的状态可能需要两种以上的特征来定义（例如用温度、血压和脉搏速率来表示哺乳动物的健康状态）。
    在任何情况下，如果这些参量是用数值显示的，那么相应的状态空间就可以用几何空间来表示。因此，二维状态空间中的单个点所表示的两个数值参量的值，就可以表示在欧几里得几何平面上。系统状态的实际变化是可观测的，可以表示成该态空间的一条曲线。如果这条曲线上的每一个点带着记录下观测时间的标志，那么我们就获得了该模型的轨迹。有时，引进另一个时间坐标，用其时间序列来代表参量的变化，这也是很有用的。这种表示叫做轨迹图。
    中世纪的动力学概念，包括了这两种表示法。在十四世纪五十年代，波斯经院哲学家尼科尔·奥雷斯密引入了作图表示法或特质强度的几何图形。他主要是讨论了线质的情形，其延长用空间或时间（“特质经度”）线段来度量。他主张，间隔的每一点的强度，用该点的垂直纵坐标（特质纬度）来度量。线质的量的图示为两个参量的图形。在图2．3中，相应于经度AB的间隔时间的匀加速运动中，AB的每一P点的纬度是纵坐标PQ，其长度是相应于该瞬间的速度。此图形的直线DC代表速度状态的轨迹图。所谓的默顿规则立即就从图2．3的几何证明中推导出来：从图2．3中的梯形的面积公式中得出通过的距离：
    s＝1/2（vsuosu＋vsufsu）t。

    也许这种解释是以把这种面积看成是由许多垂直线段（“不可见量”）为基础构成的，每一线段都代表以非常短（“无限小”）时间中的速度。默顿规则表明，甚至在这很早的状态空间探究方式中，一个好的几何表示就不仅仅是一种有用的形象化，而且还发现了关于动力学的新的概念。当然，奥雷斯密和默顿这些学者最初都只是想把关于特质的亚里士多德类型的物理学加以数学化。但是，他们的工作却在欧洲引起了广泛的沮丧，从而引起伽利略写了一部著作。伽利略著名的《关于两种新科学的谈话》（1638）中，引入了近代力学的基本概念，提出了众所周知的关于从静止开始的匀加速运动（自由落体）的距离公式S＝1/2at2，并给出了相应的证明及类似于奥雷斯密思想的几何图形。

    由于牛顿和莱布尼茨，动力系统理论被加入了新内容。微积分允许人们把瞬时速度计算为速度函数的导数，并可以图示为相应曲线的切矢量（图2．4a）。速度矢量场已经成为动力系统理论中的一个基本概念（图2．4b）。用微积分的微分程序通过轨迹决定速度矢量。与此相反，微积分的积分方式使人们可以通过速度矢量决定轨迹。
    动力系统的建模策略首先是选择一个态空间，观测结果可以用几个参量来代表。连续的观测得出了此态空间的许多轨迹。在牛顿和莱布尼茨的微积分的意义上，速度矢量可以在这些曲线上的任意点导出，并描述它们在该点的固有动力学趋势。对于态空间任意点的速度矢量的描述，就定义了一个速度矢量场。充满着轨迹的态空间称作该动力系统的“相图”（图2．4c ）。这个动力系统的基本概念最初是亨利·彭加勒引人的。速度矢量场通过微分方法从相图推导出来。
    当然，速度矢量场形象地表示了被建模的系统的动力学。实际上，进行长时间的广泛的观测，对于揭示系统——由相应的速度矢量场代表——的动力学趋势是必要的。此建模程序是恰当的，如果我们假定了：（a）一个观测轨迹的速度矢量在任意一点都精确地等于由该动力系统说明的矢量，（b）模型的矢量场是平滑的；“平滑”一词指的是直觉地认为在此不存在跳跃、不存在尖锐的拐角。在一维态空间的情形，矢量场由平面上的图像来说明。因此，如果此图像连续，其导数也连续，此图像就是平滑的。历史上，条件（b）相当于莱布尼茨著名的连续性原理，它在经典物理学框架中处于某种支配性地位。
    一般地说，我们把建模程序概括如下：一个动力模型，它总是针对某一实验提出来的。我们可以设想一下如伽利略和牛顿使用过的实验室物理装置，或者生物学家对某些有机体进行的观察，或者甚至社会学家对某些社会群体的考察。动力学模型由态空间和矢量场构成。态空间是该实验情形的几何空间（例如，欧几里得平面或一般地某个拓扑流形）。矢量场代表了状态变化的习惯趋势，被称作该模型的动力学。我们如何才能找出轨迹从而找出系统的行为呢？从技术上看，这个问题是由获得该系统的相图来解决的。这意味着，我们必须要构造出该动力系统的轨迹。给定一个态空间和一个（“平滑”）矢量场，如果在切矢量的意义上，其速度矢量与矢量场的一致，在态空间的一条曲线就是该动力系统的一条轨迹［图2．5］。相应于零时刻的点叫做轨迹的起始态。这些轨迹被认为是，描述了系统的在一定时间间隔中的观测行为。而且，物理学家曾经雄心勃勃地力图实现对于无限长时间未来的预测，并计算出大自然的途径，就像大自然是一架大钟一样。

    让我们扼要看一看牛顿的宇宙。它表现为通过使用牛顿、莱布尼茨和欧拉等人的数学工具，对动力系统理论的成功应用。牛顿用3个定律支配着实物物体的行为。第一定律（“惯性定律”）说，一个物体将保持匀速的直线运动，如果没有外力作用于它。如果的确有外力作用于它，那么其质量乘以其加速度就等于该外力（第二定律）。再加上第三定律就完成了基本框架：对于每一个作用总是有一个相反的大小相等的反作用。牛顿的宇宙由微粒构成，在空间作圆周运动，它服从欧几里得几何定律。这些微粒的加速度由作用于其上的力所决定。作用于每一微粒的力，是所有其他微粒的力的矢量和。如果此种力是一种引力，那么它在两个物体之间的吸引作用的强度，与两个质量的乘积成正比，与它们之间的距离的平方成反比。当然，在此还可能有其他类型的力。
    实际上，牛顿的第二定律被理解为宏观宇宙和微观宇宙的所有自然力的一般图式。借助特定的力的定律，牛顿图式就翻译成精确的系统动力方程系统。如果已知种种微粒某一时刻的位置。速度和质量，那么它们以后所有的位置和速度都在数学上确定了。简言之，牛顿宇宙中的一个物体的状态，由位置和速度两个参量加以规定。牛顿轨迹由运动的动力方程来确定。如果起始状态已知，那么牛顿宇宙的行为看来就是完全确定的。这种形式的确定论对18世纪和19世纪的哲学有巨大的影响。牛顿的动力学被理解为大自然建立模型的基础科学。但是，这种力学模型当然只有在忽略摩擦的有限情形下才是有效的，它们从来没有在实验上完全实现过。大自然是如此的复杂，以致物理学家宁可观测非自然的（“人工的”）有条件限制的情形。在后面，我们将看见，物理学家对简单规律的信奉，完全忽略了起始条件和约束条件的复杂性，因而造成了确定论的、可以彻底计算的幻想模型。
    按照牛顿的观点，在一种绝对空间－时间框架中只有一个真实的物质世界，我们可以在其中选择相对的参考系。这意味着，任意两个事件都被看作是客观可确定的，而不论它们是同时发生的还是在同一位置发生的。数学上，牛顿的绝对空间用三维欧几里得空间来表示，其尺度用尺子来度量，而时间则被看作是一维的欧几里得空间，其坐标t由标准钟来度量。
    因为其绝对同时性，牛顿四维空间－时间被同时事件的最大子集划分为不同层次。每一层是一个可能的事件e的三维超平面t＝t（e），它将其因果性的未来——t＞t（e）层，与其因果性的过去——t＜t（e）层——分隔开来。在图2．6a中，忽略了第三维空间，以使每一层都形象地表示为二维平面。这个因果结构包括了牛顿的假设：存在着任意远的以超距同时作用的信号。

    牛顿的相对空间被兰格准确地描述为：不受外力以恒定速度沿直线运动物体的参考系的惯性系。在这许多可能的惯性系中使用哪一个，这并没规定从一个惯性系变换到另一个惯性系（伽利略变换），也给出了相应的坐标。力学定律对于这些变换是守恒的（不变的）。由于每一伽利略变换都有10个连续的参量（时间1个，旋转、恒速和平移共3乘3个），于是就可以推导出10个守恒定律。例如，时间坐标的伽利略不变量意味着能量守恒定律。非惯性系的参考系具有典型的效应。一个相对于固定恒星旋转的圆盘，其径向力是伽利略变换所消除不了的。简言之，在牛顿的空-时中，匀速运动被看作绝对的优先于加速运动。它的结构由伽利略变换群来定义。
    本世纪初，爱因斯坦证明了牛顿的空－时模型局限在相对于高速光运动的低速运动。与任何运动参考系无关的常数c，是麦克斯韦电动力学中的一个因子。因此，牛顿的速度加和定律和伽利略的不变量在电动力学中不可能成立。在狭义相对论中（1905），爱因斯坦假定，光速恒定，物理定律相对于所有惯性系具有不变性（“狭义相对性原理”）；并为电动力学和力学推导出一个共同的空-时框架。闵可夫斯基用四维几何为爱因斯坦的狭义相对论的空－时建立起来模型。我们不应对四维性感到吃惊，因为牛顿的空－时中已经是三维（笛卡尔）空间以及一维时间坐标。
    为了简单性起见，选取单位时规定光速等于1，从而长度和时间单位可以交换。空－时中的每一点都代表一个事件，它意味着在某一时刻的空间的某一点。由于粒子在时间中持续，因此它并不由点来代表，而是由一条线来代表，这条线被称作粒子的世界线。为了把闵可夫斯基模型表示出来，可以画出一个空－时系统，以标准时间坐标来度量垂直方向，两个空间坐标来度量水平方向（图2．6b）。
    匀速运动的粒子由直线来表示，加速运动的粒子由曲线来表示。由于光粒子（光子）以基本速度c匀速运动，它们的世界线是直线，与垂直方向的夹角为45度。它们形成了一个光锥，具有共同的原点0。在所有的空－时点的光锥系统，被称作相对论空－时的闵可夫斯基模型。

    光子的世界线的每一点总是处于光锥上，与此不同，任何以低于c运动的实物粒子的加速或匀速运动，其世界线每一点都必定总是处于光锥之中。由于实物粒子或光子的运动速度不可能高于光速，因此只有处于光锥上或是落在光锥内部的世界线才是物理上确定的。一个事件被看作是晚于0的，如果它处在0以上的未来光锥中；它被看作是早于0的，如果它处于低于0的过去光锥中。因此，光锥决定了相对空－时的因果结构。
    在闵可夫斯基模型与普通的欧几里得表象之间，基本的差异在于，世界线的长度被解释为由物理钟度量的时间。因此，与牛顿绝对时间假设相反，时间测量变得与路径有关。所谓的“孪生子悖论”极为形象地表达了这种效应。在图2．6c中，一个孪生子留在匀速、缓慢运动的地球R之上，而另一个孪生子以极大的接近光速的速度进行了一次到靠近恒星S的地方的旅行。闵可夫斯基几何学预言，进行了旅行的那位孪生子在他从Q处返回时仍然年轻，而呆在家中的那一位孪生子却变成了一位老人。这当然不是科学幻想，而是闵可夫斯基世界线的时间测量长度的结果：闵可夫斯基距离RQ大于距离RS和SQ之和，这与通常的欧几里得解释相反。今天，对于以接近光速c运动的基本粒子，这些效应已经从实验上得到了很好的确证。
    在闵可夫斯基空－时框架中，物理定律对于特定惯性系的不变性已经由洛仑兹变换所实现。具有伽利略不变性的牛顿空－时在极限的情形下仍然保持：诸如行星天体或地面上的弹子球的运动，它们的速度要远小于常数c。在此意义上，爱因斯坦空－时是经典物理学的顶点，而不是一场打破牛顿空－时的革命。
    由莱布尼茨首先引入经典物理学的一个重要概念是能量，它包括系统的动能T和势能U。使质点从位置1移动到位置2完成的机械功，相当于在位置1和位置2之间的动能之差。如果机械功与从位置1到位置2的路径无关，则相应的力场叫做保守力场。摩擦力不是保守力。在一维情形，忽略掉摩擦力时，所有的力都必定是保守的，因为此时从直线上的一点到另一点只有唯一的路径。总能量T＋U在保守力场中是一个常量。
    牛顿力学的一个重要应用是谐振子，如小振幅的单摆或弹簧上重锤的上下振动。在物理学各个领域中甚至在化学和生物学中，谐振子都是一种模型。例如，回忆一下电磁光波，在此发生着电场能和磁场能的振动。谐振子在技术中也为人们所熟知，例如线圈和电容中振荡的电流，这里摩擦力相当于电阻。在18世纪和19世纪的哲学中，单摆是机械宇宙的一个象征，它显得是完全确定的，并可由运动的牛顿方程进行计算。
    因此，单摆可以看作动力学建模程序的一个经典例子。这种模型假定，摆杆轻巧而又坚固，上端的结合部完全无摩擦，底部的重锤沉重但体积非常小。重力总是将其垂直下拉。在图2．7a中，二维欧几里得平面中的单摆升高角度为a，重力为F，沿摆杆的拉力为Fcosa，力Fsina使之回摆。为了形象地表示出单摆的动力行为，必须建立起态空间和相图的动力学模型。单摆的状态是完全由角度变量α（α＝0和α＝2π表示同样的角度）和角速度v决定的。因此，我们获得一种二维态空间，它可以形象地表示为图2．7b中的循环圆柱。在圆柱中部的垂直圆圈代表了零角速度v＝0的状态。圆柱下部从前至后的直线是（零倾斜α＝0）轴线，单摆在此处于最低点。在起点（α，v）＝（0，0），单摆处于最低的静止位置。

    由于在此没有摩擦和空气阻力，把单摆稍微向左边动一下后就会使它不断地来回摆动。在此态空间，相应于这个振荡运动的完整轨迹是一个圆圈，或封闭的环。在下一种情形中，单摆在顶部处于平衡状态，这是不稳定平衡。在左边的一个细微的触动会使得它向右边落下，并加快速度。当单摆通过摆动的底部时，角速度达到其极大值。在再向顶部返回时，单摆会慢下来。单摆再次在其顶部达到平衡。但是，当其处于旋转始态时，用了较大的力使之向右运动，那么其角速度就要大一些。在再次返回运动时，它会变慢，但是不足以在顶部静止下来。于是，单摆就会不停地顺时针旋转下去。在圆柱态空间的相应轨迹是一个循环圈。与慢的振荡不同，快的循环绕圆柱转动。实施多次的试验将揭示这个动力模型的相图（图2．8a）。在此有两个平衡点。在顶部是一个鞍点。在起始处是一个涡旋点，它不是附近轨迹的极限点。当把圆柱沿着直线通过顶部的鞍点从前向后劈开时（图2．8b），相图就更容易看清楚。

    如果此系统不是封闭的，而是像物理现实中包括了摩擦效应，在起始处平衡点就不再是涡旋点（图2．8c）。它成为螺旋类型的吸引子。由于摩擦，单摆的任何运动最终都将静止下来，任何代表此单摆接近底部的慢运动，都将对称地趋向这个极限点。

    在两维或更多维的情形下，还可以有其他类型的轨迹和极限集。例如，一个环可以是反对称的轨迹极限集（图2．9）；在三维系统中，可能出现环形圆纹曲面的极限集，甚至是其他更奇怪的极限集。
    极限集使我们能够为一个演化系统建立平衡态的模型。关键的概念是被称作“吸引子”的极限集。数学上，一个极限集（极限环、循环、环形圆纹曲面等等）被称作一个吸引子，如果所有轨迹都反对称地趋向于该极限集的集合是开放的。大致地说，吸引子接受了极限集邻域中的绝大多数轨迹。代表了系统的可能动态平衡点的所有极限集中，吸引子是最引人瞩目的。在外在极限点的情形下，一个吸引子代表了一个静态平衡，而作为吸引子的一个极限环标志了一个振荡周期性平衡。单摆、弹簧或乐器的振动只是机械应用的若干种例子。我们在后面还将看到，振荡动力系统的周期平衡在物理学、化学、生物学和社会科学中都起着重要的作用。

    在典型的相图中，将有一个以上的吸引子。相图将被划分为它们的不同的趋向吸引子的区域。划分的边界或区域被称作分区。图2.10中，有两个点吸引子，各具自己趋向轨迹的开放集和自己的分区。
    在现实中，一个动力系统不可能被看作是独立于其他动力系统的。为了获得更适合的模型，我们将研究两个耦合的系统。一个简单的例子是两个时钟的耦合。历史上，17世纪克里斯蒂安·惠更斯观察到了这种特殊的系统。他注意到，挂在同一面墙上的两个时钟趋向于同步。这种现象是通过墙壁的弹性由非线性耦合引起的。的确，任何两个动力系统，通过构造出两个相应的态空间的笛卡尔乘积，都可以组合成一个系统。这种组合系统的一个小的扰动叫做两个系统的一个耦合。这种组合系统的状态的几何模型以如下方式形成。

    时钟A和B都是一种振荡子。为了形象地表示出两个振荡子的渐进线行为，瞬时行为被忽略，位移和速度两个参量的绕起点的极限环的欧几里得平面二维状态模型也就用该极限环来代替。振荡子A的一个状态，用一个相应于它的相的角度a来说明（图2．11a），振荡子B的一个状态则用角度B来说明（图2．11b）。
    为了构造出这两个振荡子组合系统的态空间，我们设想时钟A的极限环在水平平面上。这个平面循环中的每一点代表A的一个相状态。我们将这样一个点看作时钟B的极限环的中心，时钟B垂直于时钟A的水平平面（图2．11。）。该垂直循环上的每一点代表了B的一个相状态。相对（a，B）就代表了组合系统的状态。

    如果振荡子A停止在相a，振荡子B通过一个完整循环，那么组合的相点横穿过图2．11c中的垂直循环。如果振荡子A也运动通过一个完整循环，那么图2．11c中的垂直循环也沿着水平循环运动，描出图2．11d中的环形圆纹曲面。因此，两个振荡子的组合系统的态空间是环形圆纹曲面，它是两个循环的笛卡尔乘积。两个振荡子的实际状态的模型当然是四维的，而不是我们的示意图中仅仅是二维的。
    为了获得组合系统的动力学行为的相图，我们必须研究环形圆纹曲面态空间的矢量场和轨迹。我们首先假定，每一个时钟的状态都与另一个时钟的状态完全无关。在这种情形下，两个时钟是没有耦合的。相应于每一时钟的时间相的环形圆纹曲面上的轨迹点，都围绕环形圆纹曲面。如果每一时钟的速率都是恒定的，那么在此扁平垂直的环形圆纹曲面模型上，轨迹是一条直线（图2．12）。这条线的斜度是时钟B的速率与时钟A的速率的比值。如果两个时钟具有相同的运行速率，则比值等于1。给出相同的时间意味着两个时钟具有相同的相。于是，扁平环形圆纹曲面上的轨迹是图2．12a中的对角线。
    系统中的微小变化，将导致两个振荡子的速率或频率比值的微小变化。于是，在环形圆纹曲面上的轨迹从周期轨迹变化成准周期轨迹，或变化成多次缠绕的周期轨迹，而不仅仅是一个周期轨迹（图2．12b）。如果两个振荡子是耦合的（例如惠更斯的两个时钟的共同墙面），那么一个小的矢量场就必须加到代表非耦合系统的动力模型中。几何分析中的一个著名定律指出，在小的扰动并不导致相图发生显著的变化的意义上，环形圆纹曲面上的轨迹边缘是结构上稳定的。从实验上看，这个结果已从惠更斯对于同一面墙上两个时钟的同步现象的观察中得到了验证。

    对于为大自然建模的程序，振荡子是一个中心动力学范式。它们并不局限于机械应用。在19世纪，赫尔曼·冯·赫尔姆霍兹发明了一种电振荡器，瑞利勋爵研究了早期无线电发射器中的真空管振荡子的耦合系统。在本世纪，冯·德·波洱运用进一步发展起来的无线电频谱电子学来理解耦合振荡子。
    在牛顿的宇宙中，耦合振荡子提供了多体问题的例子。关于多个运动质点的质点系统，其中质点之间有相互作用时，对此有何共性的东西呢？两个质点的系统有简单的精确解。在具有共同向心力的两个质点的两体问题中，（12个）未知量由关于两个粒子的（10个）守恒量定律和牛顿的运动定律来确定。两个质点的问题可以成功地归结为已经解决了的单质点问题，这里利用了微分矢量r和质点m1、m2的归并质量u＝m1m2／（m1＋m2）的牛顿运动方程。历史上，伽利略假定，地球围绕太阳运动，太阳是静止的。他从而把天上的运动归结为简单的两体问题。正如我们知道的，太阳实际上围绕着地一日系统的组合质心而运动，此质心落在太阳表面之内。但是，这个假设当然仍是不精确的，因为许多行星都在同时围绕着太阳运动，它们相互之间又有相互作用。
    弹子球的三体碰撞，是另一个多体问题的例子。假如弹子球仅仅成对碰撞，没有发生三体或更高级的碰撞，那么此情形就归结为两体问题。其结果不断地依赖于起始状态。起始状态的充分微小的变化，仅仅导致结果的小的变化。如果三个弹子球碰在一起，结果行为就完全取决于哪些球首先碰在一起。因此，结果是不连续地依赖于输人，而与莱布尼茨的连续性原理相反，莱布尼茨曾运用这一原理来批评笛卡尔对碰撞的探索。牛顿宇宙中，在所有时间——木论是将来还是过去——用位置和速度可以在数学上完全确定其物理行为的意义上，弹子球和行星的多体问题可以用确定论的模型来描述。但是，此种模型实际上可能是不可计算的，或对于长期来说是不可计算的。在行星理论中，对于长达数百万年的情形在计算机上进行数值模拟，可能会得到极为错误的结果，因为起始位置和速度是不可能精确知道的。在起始数据中的一个非常小的变化，可以会迅速地产生出结果的巨大变化。这种行为上的不稳定性，对于多体问题是典型的。甚至在完全确定论的世界，拉普拉斯妖的假设，即认为可以对牛顿宇宙进行长期的计算，终将暴露出完全是一种幻象。
    2．3哈密顿系统、天上的混沌和量子世界的混沌
    在18世纪和19世纪，牛顿力学看来是揭示了一个永恒自然之序。从现代的观点看，牛顿系统仅仅是一种在建立实在模型中有用的动力系统。为了说明牛顿系统的起始状态，必须知道其中所有粒子的位置和速度。在19世纪中叶前后，数学家威廉姆·哈密顿引入了一种非常优美的有效的数学形式。他富有成果的思想是用所谓的哈密顿函数H来标志一个保守系统，此函数H用所有位置和动量变量来表达系统的总能量（＝动能加上势能）。一个微粒的速度不过是其位置对于时间的变化率，动量则是其速度乘以质量。牛顿系统用牛顿运动第二定律来描述，此定律涉及到加速度，即位置变化率的变化。因此，在数学上，它们由二阶方程来定义。在哈密顿表达式中，有两组方程。一组方程描述粒子的动量怎样随时间而变化，另一组描述位置怎样随时间而变化。显然，哈密顿方程描述了量（例如位置或动量）的变化率。因此，我们获得了一种以一阶方程进行数学描述的还原，此方程当然是确定论的。对于具有3个独立空间方向的n个未约束粒子的动力系统，就有3n个位置坐标和3n个动量坐标。
    由于适当地选用哈密顿函数H，哈密顿方程就可以用来标志任何经典动力系统，而不仅仅是牛顿系统。甚至在麦克斯韦电动力学中，就其任一给定时间的数值而言，类哈密顿方程也提供了电场和磁场随时间的变化率。唯一的区别在于，麦克斯韦的方程是场方程而不是粒子方程，描述系统的状态时需要无限数量的参量，在空间的所有点上都使用场矢量，而不是使用无限多个参量——对每一粒子都使用3个位置坐标和3个动量坐标。对于狭义相对论和（进行了某种修订的）广义相对论，哈密顿方程都是有效的。玻尔对应原理实现的由经典力学向量子力学转变的关键性步骤，甚至也采取哈密顿表达式的框架。这些应用将在后面进行解释。现在只须记住，对于物理学中建立动力学模型，哈密顿方程提供了一种普遍的表达方式。
    相应的态空间允许我们把动力系统在每一“阶段”的演化形象化。因此，它们被称作相空间。对于n个粒子的系统，相空间的维数是3n＋3n＝6n。相空间的一个点代表着其中有n个粒子的可能复杂系统的整个状态。哈密顿方程决定着相空间的相点的轨迹。整体上看，它们描述了所有相点的变化率，因此定义了该相空间的一个矢量场，决定着相应系统的总的动力学。
    经验应用中的一个众所周知的事实是，不可能任意精确地测定动力学模型的状态。一个数量的测量值可能有些微小的差异，它们是由测量仪器、环境的约束等等原因造成的。相应地，相点集中在某些小的邻域之中。由此引出了一个关键性问题，在其具有邻近终态的意义上，从邻近的起始态出发的轨迹是否是局域稳定的。在图2．13a中，时刻零的起始态的相状态区域Ro被矢量场的动力学拖到后来的时间t的区域Rt（当然，实际的大量数目的坐标在这种相空间的形象表示中必须忽略掉）。
    在此情形中，相似的起始状态导致了相似的终态。这个假设不过是一种以哈密顿动力学语言描述的经典性因果关系原理：类似的原因将导致类似的结果。历史上，从莱布尼茨到麦克斯韦的哲学家和物理学家都相信这个因果关系原理，它似乎保证了测量过程的稳定性以及预测的可能性，而可以不管显著的不精确性差距。
    值得注意的是，哈密顿表达式的表象允许一种关于经典动力系统的因果关系一般性陈述。由数学家刘维的著名定理，即在任何哈密顿动力学中，因而对于任何的保守动力系统，相空间的任一区域的体积都必定保持不变。结果是，在图2．13a中的起始区域Ro的大小，是任何哈密顿动力学都不可能使之增大的，如果我们把“大小”正确地理解为相空间的体积。但是，它的保守性并不排除，其起始区域的形状被扭曲并扩展到相空间的大范围（图2．13b）。

    我们可以想像一下一滴墨水在容器里的水中扩散。相空间的可能扩散结果意味着，刘维定理不能保证轨迹的局域稳定性。起始数据中的一个非常小的变化，可能会引出结果有大的变化。大体力学和弹子球的多体问题仍然是长期不可计算的，尽管其动力学是确定论的。然而，刘维定理对于可以由哈密顿动力学从而也就是保守动力系统所显示的最终区域，意味着某些一般性结果。回忆一下，其起点有不同平衡点的有摩擦单摆（这不是保守系统）的相图2．8c。非保守系统有螺旋型的点吸引子（图2．14a），而保守系统具有不是吸引子的涡旋点（图2．14b）。

    在图2．14a中，轨迹收缩到一个域点，而其起始区域的体积发生蟋缩。在图2．14b中，轨迹沿涡旋点旋转，起始区域的体积保持不变。因此，由刘维定理我们可以得出一般性结论：在任何保守系统中，吸引子都必须排除掉。起始区域的蜷缩效应，在极限环的轨迹中也容易形象地表示出来。由于同样的数学的先验理由，保守系统中也不可能有当作吸引子的极限环。
    这些结果是由哈密顿系统的影响深远的数学定理首先导出的。我们必须意识到，像行星系统、单摆、自由落体等等保守的物理系统，只不过是哈密顿系统的一些经验应用。哈密顿系统是由一类特殊的数学方程（哈密顿方程）来定义。哈密顿系统的特征是从相应方程的数学理论推导出来的。结果是，用哈密顿系统来建立实在的模型，意味着我们可以从认识论上预测某些先验的特征，例如在此不可能存在静态平衡的极限点吸引子，也没有周期平衡的极限环吸引子。
    从哲学上看，这种观点显然在某种变通的意义上与康德的认识论相符合。如果我们假定某些动力系统的数学框架，那么我们当然就可以对于我们的经验模型得出某些先验的陈述，而不涉及到它们在若干学科中的经验应用。但是康德的认识论和动力学研究方式在如下的意义上是不同的：不仅仅有一种范畴框架（例如牛顿系统），而且有多种系统来为实在建立模型也可以取得程度不一的成功。因此，把保守系统甚至运用于认知科学、经济科学中，也并非物理主义或还原主义。
    哈密顿（保守）系统的进一步的推演认为，在此有不规则的。混沌的轨迹。在18世纪和19世纪，物理学家和哲学家都相信，大自然是由牛顿类型的或哈密顿类型的运动方程所确定的。如果现在事件的起始状态已经明确知道了，宇宙的未来和过去状态就至少原则上是可计算的。从哲学上看，这种信念由拉普拉斯妖形象化了，它如同一台没有物理局限的巨大计算机，可以贮存和计算出所有的必然状态。数学上，这种拉普拉斯妖的信念必须假定，经典力学中的系统是可积的，从而也就是可解的。1892年，彭加勒已经意识到，经典力学中的不可积的三体问题可能导致完全混沌的轨迹。大约60年以后，科尔莫哥洛夫（1954）、阿诺德（1963）和莫泽（1967）证明了他们的著名的KAM定理：经典力学的相空间的运动既非完全规则的也非完全无规的，但是轨迹的类型敏感地依赖于对于初始条件的选择。
    由于天体力学是由经验上确证了的哈密顿系统的动力学模型，KAM定理拒绝了某些传统的关于“月上”世界的见解。天上，既非一个亚里士多德宇宙意义上的规则世界，也非一个拉普拉斯妖意义上的永恒的规则世界。显然，它不是上帝的居所。然而，它并非完全混沌的。天上，如哈密顿系统已经认识到的，具有或多或少的规则性和无规则性。比起前人的信念，它显得更像我们人类的日常生活。这点可能会激起作家们对于哈密顿系统的好奇心。但是，让我们先看一看一些数学事实。
    可积系统的一个最简单例子是谐振子。在实践上，任何有n个自由度的可积系统的运动方程，等同于一组n个未耦合谐振子。相应的相空间是2n维的，其中有n个位置坐标，n个动量坐标。对于n＝1的谐振子，我们得到了一个循环，对于n＝2的两个谐振子得到一个环形圆纹曲面（对照图2．11d）。因此，n个可积运动的存在，把可积系统的2n维格空间的轨迹限制于n维流形中，其拓扑是一个n维环形圆纹曲面。对于两个自由度的和四维相空间的可积系统，轨迹可以形象地表示在环形圆纹曲面上。轨迹的封闭轨道，只有在两个相应的振荡子的频率比值是有理数时，才可以出现（图2．15）。对于无理数的频率比值，轨迹的轨道则决不会重复自己，而是无限地趋近环形圆纹曲面上的所有的点。

    亨隆和海里斯于1964年研究了一个天体力学的不可积系统。此动力学模型由一对可积谐振子构成，它们之间有不可积的坐标立方项的耦合。如果模型的起始状态的两个位置坐标q1、q2和两个动量坐标p1、p2都是已知的，那么其总能量E就由相应的依赖于这些坐标的哈密顿函数H所确定。此系统的轨迹在四维相空间的一个三维超平面上移动，此超平面由H（q1，q2，p1，p2）＝E来定义。
    E的值可以用来研究规则运动和无规运动的共存，这种运动是KAM定理所预见了的。对于小的E值，动力系统是有规则的行为，而对于大的E值，它就变得混沌了。为了形象地表示出这种行为的变化，我们考虑具有二维平面坐标q1和q2的轨迹的截面（彭加勒映射）。对于E＝1／24（图2．16a）和E＝1／12（图2．16b），彭加勒映射显示出只有规则运动的有些变形的环形曲面的截面。在临界值E＝1／9以上，绝大多数（但不是全部）环形曲面都消失了，不规则点也随机地出现了。对于E＝1/8（图2．16c），彭加勒映射显示出一种规则运动和无规运动共存的过渡状态。对于E＝1／6（图2．16d），运动就显出完全是无规的、混沌的。

    如下的天体力学的三体问题中，给出了一个经验应用的例子，它是不可积的。图2．17中示意了木星运动对于围绕太阳运动的一颗小行星运动的扰动。

    木星和该颗小行星被解释为两个具有一定频率的振荡子。按照KAM定理，小行星的稳定和不稳定的运动可以根据频率比值来加以区分。
    一般地，我们必须意识到稳定的以及不稳定的轨迹都是数学上明确定义的。结果是，甚至不可积的多体问题也描述着确定论的世界模型。打一个比方，我们可以说，莱布尼茨和牛顿的上帝都毫无困难地预见了规则的和无规的轨迹，而毋需一步一步地计算其发展。观测到的混沌行为，既不是由于大量的自由度（一个天体的三体问题只有不多的自由度），也不是人类知识的不确定性。无规是由哈密顿方程的非线性引起的，其起始的封闭轨迹在相区域中指数地快速分开。由于其起始条件只可能以有限的精确度来测量，而误差是指数地快速增加，这些系统的长期行为是不可能预见的。因此，计算机辅助计算将随着改进了越来越多的测量数字而更快地推动此种误差。
    天体力学、小行星世界、行星、恒星和星系的宏观世界，是由规则和无规行为共存所确定的。天上的确定论混沌虽非处处皆有，然而是局域可能的，因此可能引起在原则上不能排除的宇宙灾变。量子力学的微观世界，即光子、电子、原子和分子的量子世界中，情况又怎样呢？在量子世界中有混沌吗？为了回答这个问题，我们首先需要了解一些有关量子世界的客体的哈密顿系统和相空间的基本概念。
    1900年，马克斯·普朗克提出，电磁振荡子仅仅以量子方式出现，其能量E对于频率。具有确定的关系E＝hv，其中h是常数（“普朗克量子”）。在20世纪的物理学中，除了爱因斯坦的巨大光速常数c以外，普朗克的微小量子常数是大自然的第二个基本常数。普朗克关系得到了实验上的支持，例如黑体辐射实验的支持。1923年，路易斯·德布罗意提出，甚至物质粒子往往也具有波一样的行为。对于一个质量m的粒子，德布罗意的波动频率。满足普朗克关系。与爱因斯坦相对论中著名的定律E＝mc2结合起来（“质量是能量的特殊状态因此可以通过辐射而转变为能量”），我们获得了一种关系：v通过hv＝mc2而与m联系起来。于是，在量子世界，场的振动频率，依赖于普朗克常数和爱因斯坦常数，只以不连续的质量单位出现。显然，量子世界中的现象，既可以看作波也可以看作粒子。这就是所谓的波粒二象性，它在许多实验中得到了明确的证明，实验中根据所预备的试验条件，揭示了如光子或电子这样的量子系统的波动或粒子特征。
    尼尔斯·玻尔在1913年引入了他的“行星”原子模型，该模型可以极为精确地解释观察到和测量到的不连续稳定能级和光谱频率。玻尔的规则要求，绕核运动轨道上的电子的角动量只能以h＝h/2x的整倍数出现。他的成功的、但带有几分预设性的规则，仅仅提供了一种近似的几何模型，它必须从量子世界的动力学理论中推导出来，对应于可以解释开普勒的行星定律的牛顿和哈密顿经典力学。量子世界的动力学是由海森伯和薛定谔的量子力学奠定的，它成为了20世纪物理学的基础物质理论。
    量子力学的基本概念可以启发式地引入，即以普朗克常数为基础考虑到进行必要的修改，从而类似于相应的哈密顿力学的概念。这个程序叫做玻尔对应原理（图2．18）。因此，在量子力学中，经典的矢量如位置或动量都必须用某些算符来代替，这些算符满足某种依赖于普朗克常数的非对易（非经典）关系。如果h消失（h→O），我们就获得众所周知的例如位置和动量的经典对易关系，它们允许我们对矢量进行任意精确的测量。量子力学中非对易关系的一个直接结果是海森伯不确定性原理△p△q≥h/2。如果一次测量中，位置q精确到△q，那么对于动量P的一个扰动是△P。因此，在量子世界中显然不存在轨迹或轨道，轨迹或轨道要求粒子具有精确的位置和动量的值。玻尔的流行的电子轨道只是一种极为粗略的几何形象化［2．29〕。
            经典力学——————————————→量子力学
                              对应原理
             ↑　　　　　　　　　　　　　　　　　　　　 ↑
        经典的可　　　　 空-时（伽　　　　　　　　 非经典的
        观测量代　　　　 利略的或　　　　　　　　　可观测量
        数　　　　　　　　相对论的　　　　　　　　　代数
    图2.18玻尔对应原理
    按照玻尔对应原理，哈密顿函数描述的经典系统，必须代之以用算符描述的量子系统（例如电子或光子），这里（对于位置和动量）使用的是算符而不是矢量。在经典物理学中，哈密顿系统的状态是由相空间的点来确定的。在量子力学中，恰当的类似概念是希尔伯特空间。量子系统的状态由希尔伯特空间的矢量来描述，其哈密顿算符的本征值决定了此希尔伯特空间的距离。
    为了稍稍详尽一些说明这种数学的特点，让我们想像一粒量子微粒。在经典理论中，一粒微粒是由它的空间的位置和它的动量来确定的。在量子力学中，微粒可能具有的每一位置，都是所有位置的集合中的一种交换组合，其权重为复数。于是，我们得到了一个关于位置的复函数，即所谓的波函数Ψ（x）。每一位置x，Ψ（x）的值标志了该粒子在X处的波幅。在此位置的某个一定的小间隔中找到此粒子的几率，由波幅的平方模|Ψ（x）|2给出。各个可能的不同动量的波幅也是由波函数确定的。因此，希尔伯特空间是一个量子系统状态的复空间。
    量子状态的因果动力学由偏微分方程来确定，这叫做薛定谔方程。经典可观测量是可对易的，与此相反，量子系统的非经典可观测量是不可对易的，一般没有共同的本征值，自然也就没有确定的本征值。对于量子状态的可观测量，只可能计算出统计的预期值。
    薛定谔量子表达式的一个基本性质是叠加原理，这表明了它是线性的。例如，考虑两个发生相互作用的量子系统（例如一对以相反方向离开共同光源的光子）。甚至当它们在远距离处已没有物理相互作用时，它们也保留着共同的状态叠加性，这是不可能分离开或局域化的。在这样的关联的（纯的）量子叠加态，两个量子系统的某一个可观测量只可能有不确定的本征值。量子力学的叠加或线性原理提供了组合系统的相关的（关联的）状态，这已经在EPR实验中得到了高度的确证。从哲学上看，（量子）整体大于其部分之和。非局域性是量子世界的一个基本性质，这不同于经典的哈密顿系统。我们在讨论心－脑和人工智能的出现时，将返回到这个问题（第4－5章）。
    玻尔的对应原理引出了这样一个问题：经典的哈密顿系统中存在混沌运动是否将导致相应的量子系统中的无规性。我们对量子力学基本概念的概括给出了某些线索：在从经典的混沌系统转变成相应的量子力学系统时，可望有些变化。与经典力学相反，量子力学仅仅允许统计期望值。尽管薛定谔方程在叠加原理的意义上是线性的，并可以（例如对谐振子）精确求解，而且波函数是由薛定谔方程严格确定的，但这都并不意味着量子状态的性质可以精确地加以计算。我们只可能计算出，在某个空－时点上找到光子或电子的几率密度。
    因为海森伯的不确定性原理，在量子世界没有轨迹。因此，用接近的轨迹以指数快速分离来确定性混沌，对于量子系统是不可能的。不确定性原理的另一个方面涉及到的混沌是值得注意的：具有如图2．16所示混沌区的经典相空间。不确定性原理意味着，体积hn中的2n维相空间众多的点是不可分辨的。原因在于小于hn的混沌行为在量子力学中是无法表达出来的。只有在这些混沌区域之外的规则的行为才有可能被表达出来。在此意义上，微小而有限的普朗克常数值可能抑制了混沌。
    在量子力学中，人们区分了与时间无关的稳恒系统和与时间相关的哈密顿系统。对于具有稳恒哈密顿量的系统，薛定谔方程可以归结为所谓的线性本征值问题，它允许人们计算出例如氢原子的能级。只要这些能级是分离的，波函数的行为就是规则的，就不会有混沌。这里引出的问题是，具有规则的经典限度的量子系统的能谱，与其相应的经典系统表现出混沌的量子系统的能谱，它们之间是否有区别。时间相关的哈密顿量被用来描述诸如基本粒子和分子的时间演化。
    按照玻尔对应原理，可以从研究某些经典哈密顿系统来入手对量子混沌进行考察。它们可以是可积的，近可积的或者混沌的。因此，能量超平面上的轨迹可以是规则的，近规则的或者近混沌的。用相应的算符来代替位置和动量的矢量，使得哈密顿函数量子化，我们就获得相应量子系统的哈密顿算符。接下来就可以推导薛定谔方程和本征值方程。现在，我们可以问一问，经典系统及其可积、近可积或混沌行为的特性，是否可以转变成相应的量子系统。能谱、本征函数等等的情况怎样？这些问题都概括在“量子混沌”的标题下。例如，一些计算表明，一个圆柱势垒中的自由量子粒子的能谱（经典运动对此是混沌的），与圆周上的自由量子粒子的能谱（经典运动对此是规则的）是完全不一样的。
    在图2．19中，相邻能级之间的距离的分布用两个例子来说明。图2.19a，b中，一个由两个振荡子耦合构成的系统显示出有两个不同值的耦合系数。图2．19a的经典动力学是规则的，而图2．19b的经典动力学则是近混沌的。
    图2．19c，d显示了在均匀磁场中的氢原子的例子。图2．19c相应的经典动力学是规则的，而图2．19d的经典动力学则是近混沌的。规则的与混沌的情形可以由能级的不同分布（油松分布和威格纳分布）来区分，能级的计算是求解相应的薛定谔方程。它们已经在一些数值模型以及实验室激光光谱的测量中得到了确证。在此意义上，量子混沌不是幻象，而是量子世界的复杂的结构特性。哈密顿系统是发现宏观世界和微观世界的混沌的一把钥匙。但是，我们当然不能把确定论混沌的复杂数学结构与通常的无序思想混为一谈。

    2．4保守系统、耗散系统和有序突现
    由于彭加勒的天体力学（1892），人们从数学上认识到，某些时间演化受非线性哈密顿方程支配的力学系统可能会出现混沌运动。但是，只要科学家没有获得适当的工具去处理不可积系统，对确定论混沌就仅仅是保持着一种好奇而已。在本世纪的最初10年中，发展起来了多种数值程序，用来（至少是近似地）处理非线性微分方程的数学复杂性。现代高速计算机的计算能力和发展了的试验技巧，支持了自然科学和社会科学中非线性复杂系统探究方式取得新的成功。计算机辅助技术使非线性模型可视化，推动了跨学科的应用，在许多科学分支取得了深远的结果。在这种科学背景中（1963），气象学家爱德华·洛仑兹（他曾是著名数学家伯克霍夫的学生）观察到，3个耦合的一级非线性微分方程的动力系统可以导致完全混沌的轨迹。从数学上看，非线性是混沌的一种必要条件，但不是充分条件。它是必要条件，因为线性微分方程可以用人们熟知的数学程序（傅立叶变换）来求解，这并不导致混沌。洛仑兹用来为天气动力学建模的系统，主要是由于其耗散性不同于彭加勒所用的哈密顿系统。大致说来，一个耗散系统并非保守系统，而是“开放”系统，由外部控制参量可以将其调整到临界值，从而引起向混沌的转变。
    更准确地说，保守系统以及耗散系统都是以非线性微分方程标志的：x＝F（d，Y）；矢量x＝（x1，…，xd）的非线性函数F依赖于外部的控制参量Y。按照刘维定理，保守系统在相空间的体积元随时间会改变其形状，但是仍旧保持其体积，而耗散系统与此不同，耗散系统的体积元会随时间的增长而蜷缩（参见图2．13和图2．14）。
    洛仑兹在模拟全球天气模式中发现了出现扰动的确定论模型。地球在太阳的温暖下，从底部加热着大气。而那寒冷的外部空间，则从大气外壳吸取热量。底层的空气会上升，而上层的空气则力图下降。贝纳德在一些实验中为这种层与层之间的交流建立了模型。大气层中的空气流可以形象地表示为层之间跨越。大量冷暖空气之间的竞相交流，用循环涡旋来代表，叫做贝纳德元胞。在三维情形下，一个涡旋可以是热空气以环状上升，冷空气则从中心下降。于是，大气构成了三维贝纳德元胞的海洋，如同紧密堆积的六面体点阵。从沙漠、雪地或冰原的规则山丘和低谷中，我们可以窥见这种大气涡旋海洋的踪迹。
    在典型的贝纳德实验中，重力场中的流体层被从底部加热（图2．20a）。底部被加热的流体力图上升，而顶部的冷流体则力图下降。这两种受到粘滞力的运动是相反的。对于小的温度差△T，粘滞性占有上风，流体保持静止，均匀的热传导进行着热的输送。系统的外部控制参量是所谓的粘滞性瑞利数R，它与△T成正比。在R的临界值，流体的状态变得不稳定，稳恒的对流卷模式发展起来（图2．20b）。

    超出了某个较大的临界值R时，出现了向混沌运动的转变。描述贝纳德实验的复杂微分方程，被洛仑兹简化了，从而获得了他著名模型的3个非线性微分方程。每一个微分方程的3个变量中，变量X正比于环状流体的流速，变量Y标志下降和上升流体元之间的温度差，变量Z正比于垂直温度对其平衡值的偏差。从这些方程中可以推导出，相应的相空间的某一种表面的任一体积元都是随时间指数收缩的。因此，洛仑兹模型是耗散的。
    利用计算机辅助计算，可以使得由洛仑兹模型的3个方程产生的轨迹形象化。在一定的条件下，在此三维相空间的特定区域被轨迹所收缩，使得一个圈在右边，然后又有几个圈在左边，再后又跑到了右边，如此等等（图2．21）。

    这些轨迹的路径非常敏感地依赖于起始条件。它们的值的细微偏差可以导致很快偏离开原路径若干圈。因为它的奇怪的形象，看起来形如猫头鹰的两只眼睛，所以将洛仑兹相的吸引区域叫做“奇怪吸引子”。显然，奇怪吸引子是混沌的。随着轨迹越来越密集的又不互相切断的缠绕，轨迹最终将实现何种拓扑结构呢？这是一个说明所谓分形维定义的例子：
    令M是此n维相空间的吸引子的子集。现在，让相空间被边长为E的立方体所覆盖。设N（ε）是立方体的数目，立方体中包含了吸引子M的片断。如果ε收缩到零（ε→O），那么N（ε）与ε的对数比值的负极限即D＝－lim InN（ε）/lnε被称作分形维。
    如果此吸引子是一个点（图2．14a），则分形维为零。对于稳定的极限环（图2．9），分形维为1。但是对于混沌系统，分形维不是一个整数。一般地，分形维只可能通过数值计算得到。对于洛仑兹模型，奇怪吸引子的分形维D≈2．06±0．01。
    另一个已对其混沌运动进行了实验研究的耗散系统是贝洛索夫-札鲍廷斯基反应。在此化学过程中，一个有机分子被溴离子氧化，此氧化被氧化还原系统所催化。化学反应系统中的反应物浓度的变化率，又是用非线性函数的非线性微分方程来描述的。标志贝洛索夫-札鲍廷斯基反应中的混沌行为的变量，是此氧化还原反应系统中的离子浓度。从实验中观察到，适当地组合反应物的浓度，就得到了无规的振荡。这些振荡显示为分立的颜色环。这种分立使非线性形象地显示出来。线性的演化会满足叠加原理。在这种情形下，振荡环对于叠加将互相穿透。
    相应的微分方程是自律的，即它们并不明显地依赖于时间。借助计算机辅助的可视化技术对微分运动方程描述的动力系统中的流进行研究通常很方便。它们通过离散方程，以（d-1）维彭加勒映射构造出相应的d维相空间中的轨迹截面点（参见图2．16）。所构造的点，随时间点n的增加标记为x（1），x（2），…，x（n），X（n＋1），…。这个相应的方程，对于x（n）＝（Xsu1su（n），…，xsud－1su（n）的相继的点x（n＋1），具有形式x（n＋1）＝G（x（n），λ）。这种保守系统与耗散系统的分类，可以概括从流直到彭加勒映射。一个离散的映射方程，如果它导致相空间的体积发生收缩，它就被称作耗散的映射方程。
    一个著名的离散映射的例子是所谓的逻辑映射，它在自然科学以及社会科学中都有许多应用。从非线性到混沌的复杂动力系统的基本概念，可以借用相当简单的计算机辅助方法以这种映射来说明。因此，让我们先扼要地说明一下这个例子。在数学上，逻辑映射用二次（非线性）迭代映射来定义：xsunsu＋1＝axsunsu（1-xsunsu）；其区间0≤x≤1，控制参量a在0≤a≤4之间变化。序列xsu1su，xsu2su，xsu3su，…的函数值可以由简单的袖珍计算机来计算。对于a＜3，结果收敛到一个不动点（图2．22a）。如果a继续增加到超过了临界值a1，在一定过渡时间之后序列的值就在两个值之间周期地跳跃（图2．22b）。如果a进一步增加，超过了临界值a2，周期的长度将增加一倍。如果再进一步地一增再增，那么周期每次都增加一倍，相应有临界值序列a1，a2，…。但是在超过了某个临界值ac以后，此发展就变得越来越无规和混沌（图2.22c）。图2．23a中的倍周期分叉序列受一个常数定律的支配，这是格罗斯曼和托麦在逻辑映射中发现的，后来又被费根鲍姆重新认识为一整类函数的一个普适性质（费根鲍姆常数）。超过了a的混沌区域示意在图2．23b中。

    在图2．24a－c中，示意了不同控制参量的xsunsu向xsunsu＋1的映射，以构造出相应的吸引子，不动点，两点之间的周期振荡，无任何点吸引子或周期性的完全无规性。
    相当令人吃惊的是，像逻辑斯蒂映射这样的简单的数学定律也产生出分叉的复杂性和混沌，其可能的发展示意在图2．23a，b中。一个必要的但非充分的原因是此方程的非线性。在此情况下，复杂性增加的程度由分叉的增加来定义，分叉的增加导致了最复杂的分形情景的混沌。每一分叉说明了该非线性方程的一种可能的分支解。在物理上，它们标志了从平衡态向新的可能的平衡态的相变。如果平衡态被理解为一种对称状态，那么相变就意味着由涨落力引起的对称破缺。

    从数学上看，对称性由某种定律的不变性来定义，即关于在相应的观察者的参照系之间的一些变换的不变性。在此意义上，开普勒定律的对称性是由伽利略变换来定义的（参见图2．6a）。描述从底层加热的流体层的流体动力学（图2．20a）对于所有水平平移是不变的。化学反应方程（在无限延伸的介质中），是对于观察者使用的参照系的所有平移、旋转和反映不变的。

    然而，这些高度对称的定律允许相变到具有较少对称性的状态。例如，在贝纳德实验中，加热的流体层变得不稳定，发展起来稳恒对流涡旋（图2．20b）。这种相变意味着对称破缺，因为细微涨落引起涡旋卷偏向其中的一个或两个可能的方向。我们的例子表明，相变和对称破缺是由外部参量的变化引起的，最终导致了系统的新的宏观空-时模式，突现出有序。
    显然，热涨落自身具有不确定性，或更精确地说，具有几率性。一粒随机来回运动的粒子（布朗运动），可以用随机方程来描述，此随机方程支配着几率分布随时间的变化。确定一个过程的几率分布的最重要的手段之一，是所谓的主方程。将此过程形象化，我们可以想像一颗粒子在三维点阵中的运动。
    在时刻t找到系统在点x处的几率，随着从其他点x’向该点迁移（“移入”）而增加，但随着迁移离开（“移出”）而减少。由于“移入”构成了所有的从起始点x’到x的迁移，所以它是这些起始点之和。和的每一项，亦即找到此粒子在点x’的几率乘以（单位时间）从x’到x的迁移几率。类似地，向外的迁移就是发现了“移出”。因此，一个过程的几率分布的变化率是由随机微分方程所确定的，它是由“移入”和“移出”的差来定义的。
    涨落是由大量随机运动的粒子引起的。一个例子是流体与其分子。随机过程的分叉也就只能由几率分布的变化来确定。在图2．25中，几率函数从一个吸引子集中的浓度（图2．25a）变化到平坦的分布（图2．25b），最终变成了两个吸引子的两个极值（图2．25c），当此控制参量的增加超过了相应的临界值时。图2．25c示意了随机的对称破缺。

    在此方面，复杂性意味着一个系统有大量的自由度。当我们从外部控制一个系统时，我们可以改变其自由度。例如，在升高温度时，水分子的蒸发变得更自由而不受相互牵扯。当温度降低时，形成液滴。这种现象是分子发生关联运动并保持相互间平均距离的结果。在冰点，水结成具有了固定的分子序的冰晶。人类很早就已经熟悉了这些相变。水有不同的聚集状态，也许这就是人们将水看作一种物质基本元素的哲学观念的原因（参见2．1节）。
    材料科学提供了另一个例子。当铁磁体加热时，超过一定临界值它会失去磁性。但是，当温度降低时，磁体又重新获得其磁性。磁性是一种宏观特征，可以从微观上用自由度的变化来解释。铁磁体由许多原子磁体构成。在高温下，基元磁体随机地指向种种方向。如果将相应的磁矩加和，它们就相互抵消掉了。这在宏观水平上就观察不到磁性。低于某个临界温度时，原子磁体排列成宏观有序，产生出磁化作用的宏观特征。在两个例子中，宏观有序的突现都是由降低温度引起的，此结构在低温时形成，不丢失能量。因此，它是一种保守的（可逆的）自组织。在物理上它可以用波耳兹曼分布定律来解释，这一定律适用于能量较低，主要是在较低温度下实现的结构。
    在小分子向超分子物质实物和材料的演化中，保守自组织过程起着主要作用。在此情形下，自组织意味着在接近平衡条件下自发地形成有序结构。性质已知的简单小分子的建筑块，在此过程中自装配成为中观（或纳米）尺度的非常大的具有全新性质的复杂聚集体。这些自装配过程的化学实现方式是多种多样的。它们可以通过化学模板和基质的作用来排列成复杂的分子结构。通过自装配，已经获得了若干个巨集束，其尺寸上相当于小蛋白，包含了300个以上的原子，分子量大约为1 道尔顿。图2．26中的巨集束具有未曾预料的新颖结构性质和电子性质：在此有不同的磁性，它们对特殊的固体状态结构是典型的，对于材料科学具有重大意义。一种显著的结构性质是在大集束中存在纳米尺度的空穴。

    分子空穴可以用来作为其他化学药品，甚至人的机体中要输送的化学物的容器。许多高等有机体中都有一种贮存铁的蛋白质，叫做铁蛋白。它是一种不寻常的寄-宿系统，其构成中包括一种有机宿主（一种蛋白质）和一种可变的无机寄主（一种铁核）。根据外部的需要，铁可以从此系统中排出，也可以结合进来。经常发现，复杂化学聚集体如Polyoxometalates，以规则的凸多面体为基础，如同柏拉图固体。但是，它们的集体的电子性质和（或者）磁性质不可能归结为这些建筑块的已知性质。根据“从分子到材料”的结合酶，超分子化学应用此保守自组织的“蓝本”，在纳米尺度上去建筑起复杂的材料，它们在催化、电子、电化学、光学、磁和光化学诸方面具有新颖的性质。复合性质的材料是极为有趣的。超分子晶体管是一个例子，它可能会激起化学计算机的革命性的新发展。
    在自然进化中，非常大和复杂的分子系统也是由基因指导的过程逐步产生的。纳米分子化学的保守自组织过程是非基因控制的反应。只有保守自组织和非保守自组织的聪明结合，才可以激发起基因出现之前的前生物进化。但是甚至在复杂有机体进化期间，保守自组织也必定会出现。在人类的技术进化中，这一原理被一再发现并得到应用。
    另一方面，有一些系统，其有序和功能发挥并非是降低温度来实现的，而是保持某种通过其间的能量和物质流来实现的。熟悉的例子如动植物那样的活系统，它们需输入生物化学能。这种能量过程可以引起宏观模式如植物的生长、动物的行进等等的形成。但是这种有序的形成，决非是活系统专有的（参见第3章）。它是一种远离热平衡的耗散（不可逆）自组织，在物理学、化学和生物学中都可以发现。
    正如热力学第二定律所说，与环境没有任何能量和物质交换的封闭系统，将向近平衡的无序状态发展。无序的程度由一种叫做“熵”的量来度量。热力学第二定律说，封闭系统中熵总是向其极大值增加。例如，使得一个冷物体与一个热物体接触，热的交换将使得两个物体都获得同样的温度，即一种无序的均匀的分子序。把一滴牛奶滴入咖啡中，牛奶最终扩散成一种无序的、均匀的牛奶咖啡混合物。人们从来没有观察到相反的过程。在此意义上，按照热力学第二定律，过程是不可逆的，具有唯一的方向。
    流体力学中的一个例子是贝纳德不稳定性，它已经在2．4节的开头描述过。当加热流体层（图2．20a）达到某个临界值时，它开始了一种宏观运动（图2．20b）。因此，一个动态的很有序的空间模式是从无序的均匀的状态中出现的，只要保持了通过此系统的一定的能量流。
    流体动力学中的另一个例子是流体绕一个圆柱流动的流。外部的控制参量又是流速的瑞利数R。在低速时，此流以均匀的方式出现（图2．27a）。高速时，出现了具有两个涡旋的新的宏观模式（图2.27b）。速度进一步增高，涡旋开始变成振荡（图2．27c－d）。在一定的临界值时，在圆柱后出现了湍流的无现和混沌的模式（图2．27e）。图2.27a－e示意出可能的吸引子：一个或多个不动点，分叉，振荡和准振荡吸引子，最终是分形混沌。

    现代物理学和技术中，激光是一个著名的例子。固体激光器中有一根嵌进了特殊原子的材料棒。每一原子都可以由外部能量激发，导致光脉冲发射。材料棒末端的镜子可以用来对这些脉冲进行选择。如果脉冲是沿铀方向的，那么它们就会被多次反射，在激光器中呆的时间就比较长，而在其他方向上就会离去。在泵浦能量小时，激光器如同一盏普通白炽灯，因为此时原子相互独立地发射光脉冲（图2．28a）。到达一定的泵浦能量时，原子以一定的相振荡，形成单一有序的巨大长度的脉冲（图2．28b）。

    激光束是一个由远离热平衡的耗散（不可逆）自组织形成宏观有序的例子。激光的能量的交换和处理过程表明，它显然是一个远离热平衡的耗散系统。
    若是在从前，科学家便会假设是某种妖或神秘的力导致了这些系统变成有序的新模式。但是，正如在保守自组织的情形，耗散自组织可以用一般框架来解释，它具有大家熟知的精确的数学形式。例如，让我们从一个旧结构——均匀流体或杂乱发射的激光——出发。旧结构的不稳定性由外部参量的变化引起，最终导致新的宏观空－时有序。在接近不稳定点，我们可以区分出稳定的和不稳定的集体运动或波（模）。不稳定模开始影响和决定稳定模，因此稳定模可以被消除掉。赫尔曼·哈肯贴切地把这一过程称作“役使原理”。实际上，稳定模在一定的阈值受到不稳定模的“役使”。
    在数学上，这种程序被称作快弛豫变量的“绝热消去”，例如，从描述相应系统中几率分布变化的主方程进行绝热消去。显然，这种消去程序可以减少大量的自由度。新结构的形成在于：剩余的不稳定模作为序参量，决定了系统的宏观行为。微分方程描述了宏观参量的演化。与微观水平上系统元素（如原子、分子等等）的性质不同，序参量标志着整个系统的宏观特征。在激光的情形，一些慢变化的（“无阻尼的”）模的幅度可以作为序参量，因为它们开始役使该原子系统。在生物学语言中，序参量方程描述了模之间的“竞争”和“选择”过程。但是，这些当然只是一种比喻的说法，它们是可以用上述的数学程序来精确表达的。
    一般地讲，作为概括，一个耗散结构可以在一定阈值变得不稳定，可以被打破，从而形成新的结构。作为相应的消去了大量自由度的序参量的引入，耗散有序的形成伴随着复杂性的巨大降低。耗散结构是复杂系统的一个基本概念，它们在本书中被用来为自然科学和社会科学的过程建立模型。耗散结构的不可逆性，可能使我们回想起赫拉克利特的名言：一个人不能两次踏进同一条河流。显然，不可逆性违反了时间的不变对称性，这种对称性是牛顿和爱因斯坦的经典的（哈密顿的）世界的标志。但是这种经典的观点最终将被证明，它只不过是一个平稳变化世界中的特例。另一方面，赫拉克利特还相信，某个生序原理使无规的相互作用得到和谐，并创造出物质的新的有序态。我们必须要看一看，耗散系统的数学框架是否适合于这种规律的普遍特征。

    一个物质进化的一般性框架将以所有物理力统一的理论为基础（图2．29）。从爱因斯坦的广义相对论推导出来的宇宙演化的标准模型，必须能够为量子理论的原理所解释。迄今为止，只有几个关于宇宙演化的数学模型或多或少令人满意，可以部分地接受实验的确证。然而，这些模型的大意是，复杂性不断增加的结构（基本粒子、原子、分子、行星、恒星、星系等等）的形成，可以用宇宙相变或对称性破缺来解释。
    在宇宙进化中，在不可能一般地区分出基本粒子（尽管它们可以互相转变）的意义上，起始状态被假定是近均匀的和对称的。在宇宙演化过程中，临界值是随着对称破缺而一步一步地实现的，在此临界值处对称性被偏差和涨落打破，新的粒子和力产生出来，皮埃尔·居里说：“对称创造出现象。”但是我们必须意识到，对称破缺和相变的宇宙过程是通过高能物理学的实验和理论而进行的一种数学外推。
    今天，物理学区分了四种基本力：电磁力、强力、弱力和引力。它们在数学上用所谓规范场来描述。基本粒子物理学力图用一种相应于宇宙起源状态的基本力把这四种物理力统一起来。电磁力和弱力已经在欧洲核子研究中心（CER）的加速环中非常高的能量区统一起来了（图2．29）。统一意味着，在非常高的能量状态，不可能区分开“感觉到的”弱力（电子、中子等）与“感觉到的”电磁力。它们可以用同样的对称群（U（1）×SU（2））来描述，即它们对于这种群的变换具有不变性。在较低能量的特定的临界值，此种对称性破缺成相应于电磁力和弱力的部分对称（U（1）和SU（2））。
    物理上，这种对称性破缺意味着相变。它与两种新的物理力及其基本粒子的形成相联系。自发的对称破缺过程是众所周知的。例如，我们早餐食用的鸡蛋在其顶部的对称性位置是不稳定的。往何微小的波动都使得它自发地落到不对称的、但能量上稳定的位置。冷却到临界温度，铁磁体发生从无磁性到有磁性状态的相变。基本的两极自发地选取两种可能磁性方向之一，打破了自旋对称性，形成了新的宏观性质（磁性）。
    重子（质子、中子等）与介于通过强力相互作用的复杂多样性，是由所谓的有3个自由度——即所谓的红、绿和蓝“颜色”——的夸克造成的。例如，一个重子由3个夸克构成，这些夸克是可以用3种颜色加以区别的。在其强子对于环境是中性的（没有颜色）意义上，这3种颜色是互补的。数学对称群（U（3））标志了夸克的这种颜色变化是人们所熟知的。
    在电磁相互作用和弱相互作用统一起来以后，物理学家又力图实现弱电力和强力的“大统一”，并在最后实现所有四种力的“超统一”（图2．29）。已经提出了几种超统一研究纲领，例如有超引力理论和超弦理论。数学上，它们用具有更一般的对称结构的张量（“规范群”）来描述，其中包括了四种基本力的部分对称性。技术上，统一步骤的实现将伴随着非常高的能量值的增加。但是，“大统一”要求的能量状态难以在实验室里实现。因此，大统一的高能物理学，只能利用某些结果来确证，这些结果是实验室中可检验的或宇宙中可观测的（例如质子的衰变）。所有力的超统一将要求能量状态的无限增加，其物理原理仍然是未知的。所谓的“暴胀宇宙”假设了宇宙早期状态尺度极小，但是能量极高（“量子真空”），它由于量子真空态的斥力（反引力）面非常迅速地膨胀到宏观尺度。这种宇宙相变允许人们解释观测宇宙的一些熟知的性质，诸如恒星和物质的相对均匀的分布。在此暴胀期间，对于对称性和均匀性的某些细微的偏差会得到放大，直至其充分大以至可解释观测到的宇宙结构。在膨胀的宇宙中，物质的密度在各处并不完全均匀。因此，引力就会使得较密区域降低其膨胀速度并开始收缩。这些局域的事件导致了恒星和星系的形成。
    一般地，从基本粒子到恒星和活的有机体的结构多样性的形成，是用相变来解释的，它们相应于平衡状态的对称破缺（图2．30，图2．31）。在此意义上，宇宙的物质进化被理解为伴随着保守结构和耗散结构形成的自组织过程。但是，我们必须意识到，宇宙的自组织在今天还仅仅是一种“常规的研究思路”，正如康德所说：我们得到的是一些或多或少合理的动态模型，它们或多或少得到了经验上的确证。宇宙演化的最初开端仍然是未知的。

    如果我们仅仅采取经典的爱因斯坦的广义相对论原理，那么，如罗杰·彭罗斯和斯蒂芬·霍金从数学上证明的、宇宙演化的标准模型具有一个起始奇点，它可以被解释为大爆炸，即宇宙形成于一个数学点。但是，如果我们假定广义相对论（即爱因斯坦的引力相对论）和具有虚时间（而非实时间）的量子力学的统一，那么，如霍金已从数学上证明的，一个“平滑”而无任何开端的宇宙模型就是可能的，它只是一种按照统一的相对论量子物理学的数学原理
    的存在。

    从哲学上看，这个模型使我们回想起巴门尼德的不变存在的世界。但是，量子力学的不确定性原理意味着，早期的宇宙不可能是完全均匀的，因为那里必定有粒子的位置和速度的某些不确定性或涨落。因此，宇宙可能已经经历了一个由暴胀模型描述的快速膨胀的时期，经过很长时期才导致了我们的复杂的宇宙。假定了“平滑”时间而没有奇点的量子物理学基本原理，将巴门尼德世界的平衡打破了，使之转变成了一个进化的复杂的赫拉克利特世界。
    赫尔曼·邦迪、托马斯·哥尔德和弗里德·霍依尔已经在1948年引入了一个没有开端、没有终结的“永恒”宇宙的宇宙学模型。这些作者不仅仅假定在所有时间都有空间的均匀性和各向同性（大爆炸标准模型的“宇宙学原理”），还假定了时间的均匀性和各向同性：他们的“完全宇宙学原理”提出，宇宙不仅仅在所有的点和所有的方向，而且在所有的时间上，从整体看都是相同的，从而导致了一个定态模型。按照哈勃的见解，在红移和膨胀星系的距离增加之间有一种相关性。因此，如果要每个适当单位体积中的平均星系数保持不变，就必须形成新的星系以填补坐标网格同时变宽时出现的空穴。一个定态宇宙学的先验假设是物质的连续创造所必需的。
    在最近的准定态宇宙学中，物质偶然地、非局域地创生这一奇怪的假设，是用宇宙所有地点和所有时间中都有新星系的局域诞生来进行解释，局域大爆炸的条件被假定在老星系的超质量中心得到实现。红移也被看作是标志了星系的年龄。在总的大爆炸以后相继出现基本粒子。原子、分子、星系、恒星等等的均匀进化（图2．30），被没有总开端的也没有终极的自催化、自复制的宇宙所代替，这里只有局域的星系的诞生、成长和死亡。在此情形，老的正在死亡的星系创造出新的星系物质，如承载新生命种子的植物和有机物。宇宙动力学将是巨大而永无终极的非线性的物质循环过程。
    从神学观点看，这些模型并不需要任何创造者，因为它们的世界只不过一直是而且将来也是自满足和自组织的，没有开端也没有终极。从数学观点看，这些模型可以是非常精致的。但从方法论的观点看，我们认为，我们还没有获得一个完整的和自洽的结合了量子力学和相对论引力的理论，它将解释物质及其复杂性不断增长的进化。因此，我们仅仅能确信的只是这种统一理论应具有的某些性质。

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页


克劳斯·迈因策尔—复杂性中的思维—3、复杂系统和生命的进化

3、复杂系统和生命的进化

    如何解释达尔文生命进化中的有序的形成？在哲学史和生物学史上，生命用目的论的指向自然的某种目标的非因果性力（“生命力”）来解释。在一句很著名的话中，康德说：“解释青草叶片的牛顿”还不可能出现（3．1节）。波耳兹曼已经表明，活的有机体是开放的耗散系统，它并不违反热力学第二定律：麦克斯韦妖没有必要解释生命有序的出现，尽管按照热力学第二定律封闭系统中不断的熵增将导致无序。然而，从波耳兹曼到莫诺的统计解释中，生命的出现仅仅是某种偶然的事件，是宇宙边缘的某种局域宇宙涨落的结果（3．2节）。在复杂系统框架中，生命的出现不是偶然的，而在耗散自组织的意义上是必然的合乎规律的。有机体和物种的生长的建模，是作为远离热平衡的相变中，由分子、细胞等等的非线性（微观）相互作用引起的宏观模式的突现。甚至生态群体也被理解为复杂的耗散结构，发生着植物和动物的相互作用以及它们与环境的代谢作用（3．4节）。斯宾塞的生命由复杂性增长的结构进化来决定的思想，也可用复杂的动力系统进行数学处理。“活生生的牛顿”出现了吗？复杂动力系统理论并没有解释什么是生命，但是它可以为生命形式在一定条件下是如何出现的建立模型。因此，我们的生命存在对我们来说如同对于我们的先人一样仍然是未知的，即使我们最终将建立复杂的生命动力学的模型。
    3．1从泰勒斯到达尔文
    在讨论复杂系统和生命进化之前，我们先回顾一下早期的生命哲学。一个惊人的事实是，现代生态学的许多方面使我们回想起早期的自组织思想。在神秘的解释中，生命被理解为生长和衰亡、出生和死亡的循环运动。动物和人类，不过是在适应如同潮起潮落、季节交替、星移斗转、丰产歉收等自然大循环中而生存。大自然自身似乎是一个巨大的有机体，人类被看作部分包含在自然的发展之中。自然宗教的神话及其仪式，用来向自然力祈祷，以与自然的秩序和谐地生活。
    当人们开始追问生命的基本原理时，当他们不再把妖魔和上帝当做人格化的自然力量时，神话就被放弃了，而转向了自然哲学。在公元前6世纪，前苏格拉底的哲学家米利都的泰勒斯提出，水是万物的本原。阿那克西曼德看来已经有了某些早期的进化思想：
    最初的生命据说在湿元素中形成，带着有刺的外壳。随着年龄的增加，它们爬进干元素中，所有的外壳都会脱去，很快就现出另一种生命形式。
    关于人的出现，阿那克西曼德表述了一种完全是现代的概念。他观察到人类的小孩需要长时期的被照料和保护，因而得出结论认为，如果他们总是需要保护，人类就将不能生存。所以他们早期必定是不同的。恩培多克勒以熟悉的元素水、气、火和土的混合和转变来解释生命的形成过程。
    虽然这些生命的有机解释对于那时的人们在直觉上有说服力，但是，德谟克利特的原子论把生命归结为不可见的原子的相互作用，被认为是相当抽象的。甚至人的意识和灵魂也用微观的微小物质元素的相互作用来解释。于是，德谟克利特与其学派就不仅仅被攻击为唯物主义，还被攻击为无神论。柏拉图力图用几何图形和构造来给最初的物质元素及其结合建立模型。
    从现代科学的观点看，德谟克利特的原子论和柏拉图的数学模型都是早期的还原主义生命纲领。他们力图将生理学和生物学过程归结成物理元素的相互作用。但是这种以僵死的几何图形或物质原子为基础来解释生命的变化和搏动的思想，必然被看作是完全不自然的、推测性的，远离了那个时代的人们。总之，“真实”的生命显得是难以理解的“复杂”，而欧几里得的数学则过于“简单”。所以，欧几里得的数学保留给“月上”的恒星世界，而不适用于“月下”的尘世生命世界。
    这就是亚里士多德的生命哲学开始的地方。柏拉图授毕达哥拉斯传统从几何中取来概念，亚里士多德则从大自然中提出他的过程概念，他主要是基于生命有机体如植物和动物的功能作用。生命的过程和周期是我们日常经验中所熟知的。将世界的其余未知的陌生部分用人们熟悉的东西来解释和比拟，还有什么比这更为明白的？按照亚里士多德的说法，物理学的任务是对自然的复杂性和变化的原理及其功能作出解释。用现代术语来说，亚里士多德拒绝了原子还原主义以及推测性的、不现实的将生命数学化。
    生命用自我运动的特征来定义，与僵死的石头要靠外部推动恰恰相反。从这种亚里士多德的定义上看，生命意味着“有灵魂”，它被理解为一种（生命力论的）物质的组织力（隐德来希）。用现代的术语来说，生命的自组织被亚里士多德解释为一种功能控制的指向一定目的“吸引子”（目的论）的过程。例如，从一粒种子长成一棵树，其目的是达到其最终形式。用现代术语来说，标志着有机体生长的形式的变化是某种类似于（定性的）序参量演化的东西，它被亚里士多德叫做有机体的“潜能”。但是，与现代序参量的主要差别在于，亚里士多德批评了任何形式的将宏观形式的相互作用还原为原子或微观相互作用。
    值得注意的是，亚里士多德主张一种连续的程度不同的自然生命状态，拒斥对于“生”和“死”的绝对划分。他已经在寻找不同复杂性的有机体之间的中介或关联。例如，对于古希腊人，例如亚里士多德，他生活在植物和海藻繁茂的地中海边，容易观察到有机体如睡莲“到底是植物还是动物，因为其底部生长像植物，但它食鱼又像动物”。以连续性为背景，亚里士多德提出了一种生物遗传规律：“在动物的胚胎初期看来是有一种像植物的生命；在其后来的发育中，才可以谈论敏感性和思维灵魂。”
    亚里士多德不仅仅是一位理论家，他也是一位早期的使用观察方法的植物学家、动物学家和生理学家。他设计了根据不同特征来进行植物和动物的解剖，并力图描述生命的生理学过程。他的主导生命范式是自组织的有机体的思想，反对任何原子、分子或某种有机还原论。亚里士多德的生命哲学影响了直至今日的生物学的发展。
    在罗马时期，甚至医学也受到亚里士多德传统的影响。罗马大帝马可·奥里略的医生盖仑教导说，在我们的身体中，器官必须完全适应其功能。他追随亚里士多德的目的论，把消化器官描述为生命过程选择食物的“合目的”部分而分离掉“无用部分”。中世纪，艾伯特·马格努斯把亚里士多德的生命哲学与基督教义结合起来。在亚里士多德目的论的背景下，艾伯特发展起来早期的生态学，要求人的生活必须与其自然环境相和谐。在神的安排下，有机体及其环境通过大量地交换空气、食物、排泄物等等而相互关联，并处于自然均衡之中（“平衡态”）。艾伯特认为，甚至人的灵魂的健康也依赖于健康的环境及健康的空气、气候、植物和动物。灵魂和身体不是分离的，而是一个有机整体。
    现代物理学的决定性条件是数学、观察、实验和工程的结合，这是文艺复兴时期伽利略所实现的。牛顿奠定了一种大自然的新的数学和实验哲学，它叫做《自然哲学的数学原理》（1687）。几何和力学变成了自然科学的新范式。在科学史上，这一时期被称作自然的机械论时期，自然被想像为只不过是一台巨大的机械钟。数学家和哲学家勒奈·笛卡尔和物理学家克里斯蒂安·惠更斯教导说，所有的自然系统，都是由分离的元素如同钟表的嵌齿轮构成的。自然的所有效应都被看作可以归结到线性的因果链上，如同钟表中的嵌齿轮序列一般。显然，笛卡尔的机械论与亚里士多德的整体论是冲突的。
    甚至生命过程的生理活动也应该机械地加以解释。例如，心服被看作是一台机械泵。一般地说，笛卡尔认为，动物和人体的运动都可以从器官的力学中推导出来，“它们从位置到其重量和齿轮形式都具有如同钟表机制一般的必然性”。自从文艺复兴以来，人体解剖实践是笛卡尔分析方法的一种应用。笛卡尔认为，为了用几何和机械定律来解释功能，每一系统都可以分离成基本建筑块。
    意大利物理学家和生理学家博雷利（1609-1679）奠定了所谓的物理疗法作为早期的一种生物物理学。他把伽利略在物理学中的一段名言转移到生物学中，还写进他的《关于动物的运动》一书中加以强调：
    正如所有这些事物的科学认识都建立在几何学基础上，正确的看法是，上帝应用几何学来创造动物机体，我们要理解它们就需要几何学。因此，它是唯一合适的科学，如果人们希望阅读和懂得神在动物世界的杰作的话。
    虽然笛卡尔还相信人有不朽的灵魂，但是拉美特利按照他的《人是机器》（1747）的箴言把人也约化成一种没有灵魂的自动机。在他看来，人体和动物体仅仅是由其复杂性和组织化的程度来区分的。在物理学之后，亚里士多德传统中的目的论也应该从生理学和医学中驱除出去。在启蒙运动时期，生命的机制从唯物主义哲学和无神论哲学的角度来解释。伏尔泰讲了一个关于拉美特利的颇为有趣的故事：拉美特利在丰盛的宴会上突然病了，几天后由于不消化而去世；据害怕上帝的世人说，唯物主义者因其贪得无厌而只能死去。
    然而，机械论时代也仍然在讨论亚里士多德的一些概念。例如，莱布尼茨假定了一种自然的等级秩序，生机的尺度是连续地从小的建筑块（“单子”）到复杂的有机体。莱布尼茨试图把亚里士多德的思想与物理学的机械论结合起来，因而成为复杂系统动力学的早期先驱之一。关于人在自然中的位置，莱布尼茨主张：
    因此，所有的活的机体都是一种神圣的机器或天然的自动机，它无限地超过了一切人工的自动机。
    在莱布尼茨的鼓舞下，动物学家邦尼特（1720－1793）提出了一种自然的等级（“Echelles des etres naturelles”）作为复杂性的尺度，它显得是相当现代的。邦尼特强调“组织”是物质的最重要特征。实现着一定数量的不同部分的最大效果的组织，被看作最完满的组织。
    18世纪末，伊曼努尔·康德批评牛顿力学运用于生物学：“不可能找到解释青草叶片的牛顿。”康德提出批评的主要原因在于，在18世纪机器的概念只是在牛顿力学中得到了精确化。因此，在他的著名的《判断力批判》中，康德写道，一个有机体“不可能是一台机器，因为一台机器不过是移动着的力；但是一个有机体却具有组织力……这是不能只用机器运动来解释的”。康德还批评了亚里士多德的目的论和作为隐喻的拟人化的自然“目标”和“目的”的假设。一个有机体的描述必须使用“自组织存在物”的模型来解释。
    与康德类似，歌德也反对生命的唯物主义-机械论的解释，而这是例如法国百科全书学派的学者霍尔巴赫在他的《自然系统》中所坚持的。在歌德春来，自然的机械模型是“灰色的…如同死亡……如同幽灵，没有阳光”。他相信，生命是有机地、和谐地发展的，如同植物变态或人的精神成熟。
    在歌德时代和康德对机械唯理论的批判的背景下，19世纪初德国出现了一种浪漫主义自然哲学。它是对抗机械论的有机论范式的复兴。弗里德希·谢林（1775－1854）设计了一门“生命的科学”，假定组织和繁殖是生命的主要特征。医生和自然哲学家奥肯（1779－1851）描述了一种“行星过程”，用磁力、化学历程和流电的综合来解释生命有机体。从现代的观点看，“自组织”和“自复制”是浪漫主义自然哲学的有深远影响的概念。但是，在那些日子，因为还缺乏实验和数学基础，它们只不过是推测或富有灵感的直觉。
    一幅有机的、和谐的形态变化的和平图像，很快就被生物学抛在了一边。查理·达尔文的进化理论在解释生命时根本不需要目的性力量。“适者生存”（赫伯特·斯宾塞）取决于对于一定环境条件（例如食物、气候）的较大选择优势。达尔文受到拉马克的一些思想的鼓舞，例如获得性遗传。达尔文进化由物种的（遗传）变异性（“突变”）和自然选择所支配，朝向某一方向发展。斯宾塞教导说，生命正在向更大的复杂性推进，它受到选择的控制。在许多同时代的人看来，达尔文主义不仅仅是一种自然科学的理论。达尔文理论似乎提供了一种与19世纪社会极为相似的生命图像。“适者选择”成为“社会达尔文主义”的一个政治口号。
    19世纪下半叶，海克尔概括了生命从单细胞有机体到人类的进化。但是在那时，进化理论还无法与高度确证了的物理理论和化学理论相比拟。达尔文只可能提供一些形态学的比较研究。他描述了物种的变异和自然选择，但是不可能对此进行数学化的解释，并提供如同物理学那样的可检验定律。孟德尔的遗传定律（1865）还不为达尔文以及许多同时代人所知。然而，19世纪的最伟大的物理学家之一路德维希·波耳兹曼，对他的世纪作了一个深刻扼要的概括：
    如果人们追问我的最深层信念，问我们的世纪是钢铁的世纪还是蒸汽机的世纪抑或是电的世纪，我都将毫不犹豫地回答，这是一个达尔文的世纪。
    3．2波耳兹曼的热力学和生命的进化
    在19世纪，自然科学、社会科学和哲学的主题变成了“进化”和“历史”。而这些思想的生物学来源要追溯到达尔文的进化理论，热力学中也开始讨论物理学的不可逆过程。热力学的最初的原理是由卡诺发展起来的（1842）。他的原理是在分析蒸汽机产生的机械力中发现的。大体上，热力学第一定律说，能量既不能创造也不能消灭。不管是机械功、电能，还是化学转化，自然界中能量在不断地转化，一个封闭系统中的总能量却保持不变。与爱因斯坦的质能相当性相一致（对照2．2节），第一定律在本世纪已经扩展为质量能量守恒原理。
    克劳修斯注意到第二定律在物理演化中具有根本性的重要意义，他从古希腊词汇中借来“熵”这个术语，用于描述演化或转化。数学上，一个系统的熵变化被定义为可逆地加到系统的热除以其绝对温度。按照依利亚·普里戈金的见解，人们必须涉及这样一个事实：所有的系统都有其环境。因此，更一般地说，在某一时刻的熵的变化，应是环境供给系统的熵变化率与系统内部熵产生率之和。按照热力学第二定律，系统内部的熵的产生率大于或等于零。对于封闭和孤立系统，熵不会由环境供给（或释放到环境中），我们就得到了经典的克劳修斯陈述：熵不断增加或当热力学平衡达到时就保持不变。换言之，自然界中包括物理、化学、生物或（正如我们将看到的）信息转化的过程，都不会不以能量为代价——以熵来表述——而自发地发生。
    熵是系统的一种宏观性质，如同体积和大小。因此，热力学最初只是一种唯象理论，描述了宏观系统的可能的热分布。波耳兹曼对这种实证主义态度不满，试图提供一种统计力学的解释，把系统的这种宏观状态归结为例如供给微观分子的热的力学。受到微观-宏观差别——这是进化理论的关键——区分的驱动，波耳兹曼赋予热力学最初的统计解释。统计热力学中，不可逆性就以这种差别为基础。
    一般来说，统计力学用微观态来解释如密度、温度等宏观态。在此意义上，可观测的宏观态被认为是由大量微观态W实现的。为了定义数目W，大量的同种类的例如原子、分子、晶体等等独立机制要加以考虑。它们从不同起始相状态按照其运动方程发展其微观态。如果一个宏观态由W个微观状态实现了，那么相应宏观态的波耳兹曼嫡量H就可以假定为与W的对数成正比，即H＝kln W，k是波耳兹曼常数。在一个连续的态空间，波耳兹曼表达式可以用速度分布函数的积分来概括。在波耳兹曼看来，H度量相应系统的观测宏观态的分子排列几率。
    波耳兹曼的还原论在历史上遭到了物理学家、数学家和哲学家的强烈反对。实证主义的物理学家和哲学家如恩斯特·马赫批评波耳兹曼的分子和原子假设那时它们是经验上无法确证的。但是在分子、原子被成功地发现以后，这种批评就成为历史往事了。
    洛喜米特可逆悖论是最重要的反对意见。由于力学定律对于时间反转具有不变性（对称性），每一过程都是时间可逆过程。这似乎与不可逆过程的存在相抵触。波耳兹曼回答说，对于他所谓的H定理形式的热力学第二定律，不可能仅仅从（可逆的）力学定律推导出来，而需要附加上极度不可几的起始条件。第二定律被认为对于非常高度可几事件有效，但是并没有保证。不可逆过程仅仅是频度的或几率的，可逆过程是罕见的不可几的。因此，第二定律允许局域的涨落偏差（例如布朗运动）。
    另一种反对意见是亨利·彭加勒和恩斯特·泽梅罗提出来的。他们强调，具有有限多个自由度的力学系统的每一状态，必定在一定时间间隔之后至少大致地重现。因此，就不可能有一个与熵增相联系的时间之失。波耳兹曼回答道，随着自由度的增加，返回时间变得极度地长。宇宙学中，在波耳兹曼的意义上有两种观点：（1）宇宙开始于极其不可几的起始条件；（2）当宇宙充分大时，就可能在某些地方出现偏离均匀分布。图3．1示意出波耳兹曼的涨落假设。他假定，整个宇宙处于热平衡状态，即最无序状态。波耳兹曼相信，时间的两个方向是完全对称的。因此，局域熵在两个时间方向上类似地增加，达到熵极大时变成扁平。
    生命作为发展着的有序系统，仅仅在熵发生强烈变化的区域、即图3．1中熵曲线的两个倾斜部分才是可能的。两个箭头标示了波耳兹曼的局域世界，在此可以出现生命。因此，在波耳兹曼的意义上，在此不存在客观的唯一的时间箭头，只存在熵增的两个可能方向之一，它是生活在图3．1示意的倾斜区的两个可能局域世界之一的人们的主观经验。在我们对波耳兹曼的观点提出详细批评之前，让我们先扼要回顾一下他以热平衡热力学为背景的生命理论，它对本世纪科学产生的影响延续至今。
    路德维希·波耳兹曼（184－1906）是第一位试图将生物学进化理论归结为19世纪的热力学和化学的科学家。对于上个世纪末的科学家来说，热力学第二定律似乎预见了自然的最终的无序、死亡和腐朽，而达尔文的进化论体现了有序活系统的复杂性不断增加的发展，这似乎是个大问题。当然，第二定律是针对封闭系统的，而活系统必定是开放的，发生着与其环境的不断的能量、物质和信息交换。然而，在一个无序和热平衡的海洋中，局域复杂性的增加如何是可能的？

    波耳兹曼主张的解释，已经在向我们提示现代生物学的分子自催化和代谢概念。最初的原始生命的起源（如细胞），被归结为无生命的分子建筑块的存在，波耳兹曼将此设想为类似布朗运动过程。植物作为细胞的聚集体是有序的复杂系统。因此，在热力学第二定律的意义上它们是不可几的结构，它们必须在阳光下与它们体内的自发熵增趋势进行抗争。由于太阳的高温，大地获得了熵相对低的能量，这被用来补偿植物的自发熵增。这个过程是由光合作用来实现的，波耳兹曼在1886年提出了一种物理学解释：
    因此，一般的生存斗争，既不是为了基本材料……也不是为了能量……而是为了使熵从灼热太阳那里转移到冷凉大地而变得有用。
    波耳兹曼将他的以物理学为基础的进化理论推广到神经系统的历史和记忆、意识的形成。他争辩道，原始有机体对外部印象的敏感性，导致了特殊神经和视觉、听觉、感觉、运动等等特殊器官的发展：
    大脑被看作建立世界模型的装置或器官。因为这些模型对于种族生存有巨大益处，人的大脑按照达尔文的理论如同长颈鹿脖子或白鹤长嘴那样完美地发展起来。
    甚至建立概念和理论的能力也用进化来解释。波耳兹曼试图论证，人的空间、时间和因果性范畴是大脑为适者生存而发展起来的工具。他毫不犹豫地把生物进化推广到甚至是社会文化发展和人类史方面。1894年，威尼斯的医生S．埃克斯纳以波耳兹曼精神讨论了《作为人生斗争武器的道德》。1905年波耳兹曼自己发表了冠以迷人题目的演讲《熵定律解释和用几率原理来计算爱情》。显然，波耳兹曼的达尔文主义达到了极点。
    在本世纪之初，生命仍然不可能用物理学和化学基础来解释。经典力学——这个17世纪和18世纪自然科学的基础——假定了确定论的、时间可逆的自然定律，对生命的不可逆过程提供不了任何解释。一个无摩擦的摆钟作为一个振荡的力学系统，时间可逆地运动着，原则上将无限地运动下去。人有出生、成长和死亡，这是为什么？19世纪的热力学处理的不可逆过程针对的是将被推向极大熵或无序状态的封闭系统。复杂的活系统的发展如何得到解释？在波耳兹曼统计解释的意义上，有序和生物复杂性的形成只能是不可几的事件，是（如同雅克·莫诺后来说的）“处于宇宙边缘的”局域宇宙涨落，它们对处在热平衡的整体宇宙是没有意义的，最终将消失掉。按照莫诺的观点，我们只不过是一种阿尔贝·加缪的存在主义的哲学选择，人类的尊严将最终消亡在无意义的生物和文化进化中。天才的路德维希·波耳兹曼的悲剧性死亡——他1909年的去世被认为是自杀，并被看作是这种态度的一个象征。但是，波耳兹曼的热力学并没有明确解释生命起源。他仅仅是证明了，他的对热力学第二定律的统计解释与达尔文进化并不抵触。
    在17世纪和18世纪的经典力学和19世纪的热力学之后，量子力学成为物理学的基础理论。尽管有海森伯的不确定性原理，量子力学的定律与经典力学都是以时间可逆为特征的。在处理复杂性的还原论纲领上，一个极大的成功是分子的量子化学可以用量子力学定律来解释。1927年海特勒和伦敦成功地将适用于原子、亚原子的薛定谔方程，修订应用于分子系统。在化学中没有其他的特殊的力，只不过是人们熟知的物理力，目的论看来在化学中也被排除了。
    化学是否已经完全还原为物理学了呢？严格地说，完全没有！分子轨道的结构模型仅仅是对量子力学相关性的抽象而引入的。相反，例如原子的电子在包利原理的意义上是不可分辨的，它们被化学家用来作为准经典客体，沿着原子核的明确区分的轨迹运动。有一些众所周知的化学抽象程序（波恩-奥本海默和哈特-福克程序），以近似的非经典量子世界的准经典模型的方式引入电子轨道。进一步说，尽管数值量子化学取得了惊人的成功，我们还必须考虑到，对于复杂分子的薛定谔方程进行计算具有实践上的局限性。这种化学向物理学的弱还原，看来是证明了科学家应该继续走还原论的道路，以将基本粒子、原子、分子以及最终将有机体统统都归结为物理学和化学。
    在二十世纪二、三十年代，物理学还原论与新活力论之间的斗争很难在实际上决出胜负。例如，物理学家海特勒，生物学家杜里希和哲学家柏格森、怀特海明确提出了亚里士多德传统的种种新活力论主张。他们争辩道，特殊的生物学规律往往使得物理学和化学规律失效。从亚里士多德到歌德和谢林一再提到的是，生命从活细胞到具有自觉意识的人的有目的的自组织性和自发性表明，物理学还原主义是不可能的。整体性是有机的一个基本特征，它不可能被还原为其建筑块之和。受到尼尔斯·玻尔所谓的量子力学的哥本哈根解释的鼓舞，一些物理学家试图用玻尔的互补性概念来弥合物理主义和活力论。玻尔用互补性来为量子力学中的互斥性概念如粒子－波动作辩护。因此，被认为是不可通约的物理学－化学和生物学两类规律，就采取了互补性解释。我们必须要记住，互补性不是一种物理规律，而是一种对量子力学的哲学解释，埃尔文·薛定谔是不赞成这种解释的。他知道20世纪30年代和40年代间的物理主义和活力主义之间的斗争并没有得到解决，而互补性仅仅是一种描述所论状态的概念。薛定谔在《生命是什么？》一书中写道：
    总之，只要我们涉及活物质的结构，我们就必须面对这样一个事实：它是以不能还原成通常的物理学定律的方式起作用的。原因不在于某种“新的力”或某种类似的东西支配着活的机体中的一个个原子，而是其结构不同于任何我们已从试验室研究中认识的东西。
    薛定谔使人想起一位熟悉蒸汽机并希望探索新的电动机的工程师的形象。由于两种发动机以颇为不同的方式工作，他会产生这样的念头：电动机是某种幽灵推动的。薛定谔采取了莱布尼茨传统，期望把活的有机体理解为“按照上帝的量子力学基本原理产生的最精致的杰作”。
    薛定谔面对的问题是：他和莫诺都力图按照波耳兹曼热力学框架来描述有序和生命的出现。他正确地批评了目的论的力或有序的妖，它们是物理学家在上一个世纪末就提出来的。虚构出来的小妖能够逆转封闭系统中按照第二定律的熵增，而没有任何外部效应，因此它如同第二类永动机一样地起作用，这要追溯到詹姆士·克里克·麦克斯韦。1879年，威廉姆·汤姆逊（后来叫卡尔文勋爵）引入了“麦克斯韦分类妖”，它可以使封闭容器中处于静态平衡和均匀速度分布的气体分子自发地分离开来，成为快分子和慢分子两部分。
    显然，“分类妖”是一种先验的假设，不可能在19世纪的物理学框架中加以解释。波耳兹曼热力学以及牛顿力学都不足以为复杂有序的形成，从而为活系统的起源和生长建立模型。热力学第一定律和第二定律都有重要的条件，它们并不一般地适用于所有自然。这些定律假定，所有的能量交换都是发生在封闭和孤立的系统中。随着能量和物质疏通过宇宙中的大部分区域，自然系统很少是封闭的。由于太阳能量辐射在地球上，它不可能被看成是一个封闭的和孤立的系统。
    尽管热力学第一定律和第二定律并没有错，但是它们在经验上局限于近似孤立的微观子系统、宇宙系统或实验室中制备的条件。这一情形可以与牛顿的经典力学相比拟。在爱因斯坦提出了狭义相对论以后，它并不就是错了，而是不再成为物理学的普遍框架了，现在只适用于相对光速较慢的运动。自然界的绝大部分现象，都必须用动力系统来建模，动力系统并不存在于波耳兹曼的一般平衡条件中，因为它们只存在于能量流和物质流之中。
    历史上，诸如麦克斯韦或吉布斯的基本贡献，只是适用于处理平衡的情形或无限地接近平衡的情形。非平衡热力学的先驱性工作是由例如皮埃尔·杜恒在本世纪初开创的。但是他的工作直到昂萨格（1931）以后才引起人们的注意，后来还有普里戈金学派，哈肯学派，以及其他人开始研究远离热平衡的复杂系统行为。从历史的观点看，此情形可以与混沌理论和复杂哈密顿系统的发展相比较（参见2．3节）。彭加勒、麦克斯韦和其他人都已经发现并熟知了混沌现象。但是与非线性系统相联系的数学问题阻碍了绝大多数科学家去研究相应的模型。
    3．3复杂系统和有机物的进化
    开放系统不仅具有熵产生的内部来源，还有外部的伴随着能量或物质转化进入（或来自）其环境的熵产生来源。这些系统通过耗散和消耗能量而保持其结构，被伊利亚·普里戈金称作“耗散结构”。我们已经了解了非生命的耗散系统如流体、激光和云彩，它们都是依赖于外部的能量流来保持其结构和组织的。非平衡系统与其环境交换能量和物质，保持自己一段时间处于远离热力学平衡态，并在局部出现熵减的状态。小的不稳定性和涨落导致不可逆的分叉，从而增加了可能行为的复杂性。
    对于亚里士多德的生长着和消亡着的“月下”世界，非线性演化方程的耗散结构数学理论为此提供了建模框架。人们惊奇地承认，亚里士多德的循环自然的思想，与作为相应微分方程的解的吸引子或极限环相对应。这些系统的循环本性，不仅仅适用于发展起稳定性，而且还适用于发展起其中的复杂结构等级。一个古代已经描述过的活系统循环，已成为借助进化反馈的自催化循环。
    其要点已被斯宾塞和波耳兹曼表述过，他们假定了前生物系统的进化，即可以通过一系列的转化而引起越来越复杂状态的等级。但是，与波耳兹曼的假设相反，这些转化只可能出现在远离热平衡态的非线性系统中。超过了一定的临界值，定态方式就变得不稳定，系统将演化到某种新的构型。通过一系列的不稳定性而进化，一个活系统必定要发展起某种程序，以增加其非线性作用和离开平衡态的距离。换言之，每一转化都必然使系统增加其熵产生。伊利亚·普里戈金、曼弗雷德·艾根以及其他人的进化反馈意味着，系统控制参量变化到超过一定的阈值，就会引起某种通过涨落的不稳定性，使耗散增加，从而又对阈值产生影响。
    随之而来的是，生命并非从某种简单的极其不可能的事件中起源，生命的进化并不违反物理学规律。正如我们已经知道的，波耳兹曼和莫诺的极大地超过生物进化的时间的巨涨落的思想，来自平衡态热力学。在平衡统计力学中发生耗散结构的几率（例如贝纳德问题的周期性时间过程）是微小的，而在远离平衡态时其发生的几率却等于1。因此，普里戈金争辩道：
    生命的出现遵从适合于特定运动学框架和远离平衡的条件的物理学规律，远不是麦克斯韦妖军队所为。
    在非线性复杂系统的数学框架中，人们提出了许多模拟生命的分子起源的模型。分子尺度上的复杂性是以大量潜在状态数为标志的，它居于现实的时间和空间的限度之中。
    例如，一个典型的小蛋白质分子包含的肽链大约有10[2]个氨基酸基。自然的氨基酸有20种，这种长度的可能性序列为20100或10130种。构成细菌细胞的基因组的DNA分子，代表了从101 00种可能序列中的一种或为数不多的几种选择。显然，自然界只可能检验了其中的一小部分。数学上，一条包含了人类v个残基的序列，允许有
    种可能拷贝在k个位置被取代。图3．2示意一个基因，它是对129个氨基酸编码的序列。
    某些微观态可能会强烈地影响宏观行为。这样的涨落可能放大并引起先前的稳定态被打破。非线性通过远离热平衡的过程加入进来。
    生命的经典的必要条件是：（1）自复制（以保持物种，而不致被稳步解体），（2）变异和选择（以放大和完善物种的可能性，偏爱某种价值标准），（3）代谢（以补偿稳定的熵产生）。
    曼弗雷德·艾根提出了一种方案，可以通过数学优化过程来实现这些标准。在此模型中，自复制的成核和进一步进化的系统，在诸如蛋白质和核酸这样的随机大分子序列的分布中，以一定的期待值出现。自复制的起始拷贝的选择是偶然的，但是后继的进化优化到独特效率水平是受物理原理引导的。在此模型中，无论何地，只要物理的和化学的条件得到满足，就可能发现生命，尽管某些分子结构表现出与我们所知的系统没有多少相似性。

    最后的结果是一种独特的结构，例如，某种优化了的分子序列。达尔文的适者生存原理进行了数学处理，即对可能的分子序列的微观态进行优化。这里假定，在简单的情形下，生物分子通过自催化而倍增。例如，两种生物分子A和B，从底物GS通过自催化而倍增，但是一种分子除了倍增以外，它还得到另一种的支持，且反之亦然（图3．3a）。在更复杂的有多种生物大分子的情形下，后一种采取了循环催化的方式进行倍增（艾根的“超循环”）（图3．3b）。这种伴随着突变的机制能够实现进化过程。

    艾根提出了一个进化优化的简化模型：生物细胞的机制在某一个有4种构成基因的化学物质A、T、G、C的序列中编码。每一基因都代表了一个功能单元，它是优化地适应了其环境的特定目的。自然界的基因的长度一般很少超过1000个序列位置。因此，对于4种符号，长度为1000，就有41000种可能的基因（“突变”）。在科学记法中，这大约是10600种可能性。为了获得对这种巨大数目的印象，我们应该记住，整个宇宙中的物质量相当于1074个基因，宇宙的年龄小于1018秒。
    因此，如果所有的宇宙物质从其一开始（“大爆炸”）就用来进行替换，从而每秒钟产生出一种新的长度为1000的基因，那么至今也仅应检验了1093种突变。艾根得出结论：代表优化功能单元的基因不可能是在随机过程中产生出来的，而必定是通过自优化过程发展起来的。
    数学上，适应过程可以设想为一系列的位置置换，其目标是获得最后的（“优化的”）序列。这是一种典型的计算机科学中的问题求解方式的解释。为了成功地求解一个问题，我们必须找到一种合适的自优化策略的空间表象。因为对于大量的数目，一个三维空间显然是不合适的。策略的长度，即从基因到其优化变异体的距离，是太长了。人们会误入歧途。进一步，高度相似的序列不可能在三维空间的邻域中得到适当的表示。因此，人们提出以如下方式来改变维数。
    一条具有n个位置的序列定义为n维空间的一个点。对于两个符号0和1，有2n种可能的序列，它们是此空间的点。每一点具有n个近邻，它们代表了仅有一个位置不同的突变（“1个误差突变”）。在两个仅仅为0或仅仅为1的端点之间，有n！个可能的关联。在图3．4a－d中，对此二元情形有一些n维序列空间的例子。这些空间的巨大优点在于其非常短的距离和密集的可能关联的网络。举一个例子，在1000维空间中最长的距离仅仅是1000个单元，在1014个点的23维空间中仅仅是23个单元。
    以米为单位，二十三维空间足以代表地球表面所有的点。在这个空间，优化策略可以设计为在地球上的某个区域中找到最高的山峰。为做到这一点，我们引入价值函数，它与每一点以一个数值“高度”相联系。设想一下去阿尔卑斯山的旅游。你没有一个目标（例如去某一特定的山峰），但只有大致的去向：你希望获得登山、到达山顶的感受。从数学上看，你的途径的梯度是知道的，并决定了你去的方向。在真实的阿尔卑斯山上，你追上了山峰的一维的边缘和通道，你达到优化点的机会是受限制的。在23维空间中，你可以走向23个方向，不同的途径具有不同的梯度，即k个“上山”方向，23-k是个“下山”方向（k≤23）。在你周围，达到优化点的机会很多。

    在基因的n维序列空间中，点的价值由“选择价值”给予。突变并非完全无规地或混沌地出现，而是依赖于分布中先前最频繁发生的事件。分布中究竟是哪些事件最为频繁地发生，有赖于它们相对于分布中的优化变异的选择价值。选择价值的分布并非无规地分布，而是分布在关联区域中。例如，地球上的高山像珠穆朗玛峰并非座落在平坦的大地，而是处于喜马拉雅山脉之中。
    一般地说，一个进化过程可能会产生新的物种。一种物种可以被看作一种生物分子、细菌、植物或动物的群体。这些群体以基因来标志，基因经历着产生出新特征的突变。虽然突变随机地出现，但它们可能受到外部环境因素的影响，诸如温度的变化或化学药物的作用。在一定的临界突变压力下，群体中新的个体出现了。这些个体的变化率用进化方程来描述。随着这些个体取得新的特征，它们的生长和死亡因素也改变了。当群体和环境中出现了涨落，一个变化（突变）才是可能的。因此，进化方程决定了变化率是涨落之和与生长和死亡因素之差。
    我们可以给选择压力建模，表示出种种不同的子物种为相同的生存条件（即相同的食物供应）而竞争。如果一种物种突变体的突变率很小，仅仅是具有最高获得因素和最小失去因素的突变体即最适者才能生存。竞争压力可以用役使原理来模拟：不稳定的突变体决定着稳定的突变体。值得注意的是，新物种是由于突变和选择而出现的，这可比拟为激光的非平衡相变。
    一个活细胞是一个开放的系统，能量流通过其间。正如埃尔文·薛定谔已经表明的，能量流创造着可以强烈地偏离热力学平衡态的条件。普里戈金等人认为，这导致了耗散自组织和模式形成的模型，其参量是由遗传作用以及渐成作用所制约的。不过，这样会引起误解，认为预期活细胞中的自组织过程，只不过是提供了宏观反应-扩散系统中的模式生成的还原复本。当物理学规律运用于不同尺度特别是亚细胞过程时，可能会影响所涉及到的机制并产生出大量新性质。以这种反应和扩散为基础的空间模式的生成，不可能出现在非常小的尺度上。化学过程的时间自组织，以不同周期性以及它们之间的相互作用的形成表现出来，在活细胞中起着基本性的作用。因此，从方法论的观点看，只知道耗散自组织的一般框架是不够的。但是，我们必须从实验上探索，它在特定的时间、空间和化学约束条件下在细胞中的应用。
    然而，在物理-化学系统与生物结构之间的联系可以用可能存在于活细胞中的耗散来为之建模。一个重要的例子是免疫系统受到破坏会引起许多非常危险的疾病，例如艾滋病。它涉及抗体-抗原动力学，一种新的抗体可以相继地产生出来，在此某些抗体作为抗原起作用。这种过程导致一种非常复杂的总系统动力学。
    正如我们已经知道的，在耗散系统的特征中，最显著的是振荡现象。在亚细胞水平上，有一系列的振荡的酶反应。糖酵解作用是一种具有重要意义的活细胞过程。调节给出的振荡，其周期从两分钟到90分钟。关于振荡的实验表明，当均匀的状态变得不稳定时，就出现了极限环类型的振荡。
    另一个代谢振荡的例子是，细胞软泥霉中环状AMP的周期合成。这种物种展示了在两个不同组织状态之间的过渡。起初，阿米巴是独立的和分离开来的细胞。饥饿发生时，它们开始转变成聚集体，最终成为结实的多细胞体。单个的细胞，受到营养的驱动，作为对中心放出环状AMP的响应，围绕中心在中心波中聚集起来。环状AMP的合成，表现为极限环类型。聚集过程自身代表了超出不稳定性出现的自组织。
    在复杂系统框架中对此种过程建模，我们首先考虑分离的、均匀的细胞群体。一个控制参量标志了营养的供给，它可以转变成饥饿的临界值。然后，放出环状AMP，并克服阿米巴的随机运动，均匀态就变得不稳定了。在宏观水平上，细胞开始分化出几种功能并开始合作。宏观水平上可以观察到聚集的中间态，这最终将导致新形式的成熟的多细胞体。产生出独立的胞芽，软泥霉的生命循环重复着上述的相变状态（图3．5）。机体形式的自发形成好像是生命的一个奇迹。因此，在科学史上，形态发生是生物学中反对物理学还原论的一个著名反例。今天，形态发生是用复杂动力系统为生物生长建模的著名例子。歌德对于他所喜爱的形态发生的数学模型会说什么呢？在这方面，模式的形成被理解为复杂过程，其中同一细胞发生分化，产生出新的明确定义的空间结构。形态发生的最初的动力学模型是拉什夫斯基、图林等人提出来的。让我们回顾一下拉什夫斯基关于植物生长形态发生（“叶序”）模型吧。

    图3.6a显示一个理想化的葡萄茎梗发出一个枝芽的某一时刻，它出现在对于3个枝芽对称旋转的方向。在生长中的茎梗的顶部，生长出来一个芽，包含着未分化的全能细胞。叶序问题涉及作为叶芽细胞、分枝细胞和其他导致叶芽和分枝的分化细胞的生长模式的形成。拉什夫斯基模型涉及到围绕着茎梗周围生长的细胞环，它靠近顶部的生长芽。
    一个细胞被看作是一个流体袋，其中有均匀的化学组分。其中的一种化学组分是生长激素，叫做形态素。这种形态素的浓度x是此模型的观察参量。随着参量在0和1之间变动，模型的态空间是一条线段（图3．6b）。如果这种形态素的浓度超过了一定的临界值，细胞的生长函数开始起作用，细胞分裂，枝芽开始出现。
    接下去，把两个细胞看作开放系统。在这个系统中，一种形态素可以在两个细胞系统及其环境之间交换。如果把第二个细胞的形态素浓度记为y，那么整个系统的状态空间就相应于单位面积中的一个点（x，y），它被解释为系统的态空间。在图3．6c中，态空间划分为4个区域：（A）“细胞1停止而细胞2生长”；（B）“两个细胞生长都停止”；（C）“细胞1生长而细胞2停止”；（D）“两个细胞都生长”。

    最后一个步骤，把3个细胞看作是一个环，每一个细胞都具有均匀的形态素浓度。单位立方体中的点（x，y，z）代表了系统的状态。在三维空间中，具有一种形态素的3细胞封闭系统的态空间用x＋y＋z＝1的三角形来表示，即浓度和是恒定的（图3．6d）。

    在图3．6e中，具有周期性吸引子的动力学系统加进态空间。3个细胞周期地相继开始起作用，然后停止。在图3．6f中，茎梗建模为一迭细胞环，每一个环都代表了图3．6d的三角形模型的一个精确的拷贝。茎梗不断向上生长，由时间与向上方向的结合来表示。图3．6e的周期吸引子转变成为不断向上的周期的时间序列螺旋。
    在此简化的形态发生的动力学模型中，一个中心问题仍然未解决。起初末分化的细胞是如何知道向何方以何种方式进行分化的？实验表明，这种信息并非是预先一个个赋予给细胞的，而是在细胞系统中的细胞从其环境中接受到了它的位置信息。一个著名的例子是水螅，它是一种微小的动物，大约由15种1 0个细胞构成。沿着其长度方向，它分成不同的区域，例如它的头在一端。如果水螅的一部分被移植到接近旧的头部区域，由细胞的激活就生长出新的头。某种实验证据表明，激活分子和抑制分子都是确实存在的。

    在吉瑞和迈因哈德的数学模型中，提出了两个演化方程，描述了激活子和抑制子的浓度变化率。它们依赖于空间-时间坐标。变化率取决于产生率、分解率和扩散项。显然，抑制子和激活子必须能够在某些区域扩散，以影响某个移植的相邻细胞。然后，还必须为抑制子造成的阻碍自催化效应建立模型。图3．7中，激活子和抑制子之间的相互作用导致了生长周期结构，这可以用计算机辅助方法进行计算并作图。
    对于导出这种模式，基本之处在于，抑制子扩散比激活子扩散要容易。长程的抑制和短程的激活是非振荡模式所要求的。通过数学分析方法，用吉瑞和迈因哈德方程描述的演化模式可以特别确定。一个控制参量允许人们区分出稳定和不稳定构型（“模”）。
    在临界值，不稳定模开始按照役使原理影响和支配稳定模。数学上，稳定模可以消除，不稳定模提供的序参量决定着实际的模式。因此，实际的模式是通过某种不稳定解的竞争和选择而出现的。按照役使原理，选择意味着减少复杂系统中大量自由度引起的复杂性。

    生物化学上，这种形态发生的建模是基于这样的思想：形态发生场是由一定化学物质的反应和扩散形成的。这种形态发生场导通基因，使之开始细胞分化。与特定的生物化学机制无关，形态发生表现为受物理学和生物学中一般的模式形成原则所支配。我们从完全对称的全能细胞群体着手。然后，细胞的分化受到控制参量变化的影响，相应地有对称破缺。结果是一种远离热平衡的不可逆相变。在图3．8中，激活子和抑制子浓度的相变以计算机模拟示意出来。
    与对称破缺的共同原则无关，在物理－化学和生物学模式形成之间有一个重要的区别。当能量及物质的输入停止时，物理和化学系统就会丢失其结构（参照例如激光或札鲍廷斯基反应）。生物系统能够至少是在相对长的时间中保持它们的大部分结构。因此，它们近似地表现为保守结构和耗散结构的结合。

    自古以来，人们总是假定活系统是为了某种目的和任务的。动物和人的器官是典型的功能结构的例子，是由生理学和解剖学探讨的。医学的功能结构在复杂系统框架中如何来理解呢？
    脉管网的复杂分叉是分形结构的一个例子。树木、蕨类、珊瑚和其他一些生长系统，用分形都可以很好地描述。在第5章“人工智能”中，我们还将讨论模拟树木的分形生长的递归和计算机辅助的程序。心脏的血管树向我们显示了分支和主干的复杂网络。人们感叹血管通过毛细管延伸进细胞分裂、分化区而出现生长，这却是相当自然的。
    伸进开放空间的树枝有扩展的余地。但是，心脏、肺和其他器官占据了有限的空间。神经网和其中的脉管是服务于这些空间的基本占据者的。微血管网络的结构实际上完全是由器官的细胞来定义的。在骨胳肌肉和心脏肌肉中，微血管平行于肌肉细胞进行排列，有一些交叉分支。神经或脉管系统为获取最小阻力线路的需要，引导着系统的生长。
    这导致了医学上相当有趣的问题，分形的生长和脉管网络的形式是否导致了为人们观察到的心脏中流的异质性的出现。分支网的一个简单算法示意在图3．9中，它导致适当的局域流的几率密度函数。一个器官的分形系统成为了一种功能结构。
    支气管网络的分形例子，对于医生把这些探究方式运用于肺部是一个启发。从银河星团到分于扩散，物理系统常常显示出分形行为。显然，活系统也常常是可以用分形算法很好描述的。脉管网络、扩散过程和透膜输送可能具有心脏的分形特征。这些分形特征提供了一个基础，使得医生能够理解更多的整体性行为，如心房或心室纤维震颤和渗透性。

    正如我们已经在2．4节中看到的，非线性动力学允许我们描述湍流的出现，这是动脉血管中血液流动的一个大的医学问题。湍流可以是极限环的基础，如同水流通过圆柱管时表现出来的那样。有许多种控制系统会产生振荡。也许可以期待，某些振荡控制系统会表现出混沌行为。
    心房和心室纤维震颤，是显示出混沌的经典现象。在临床陈述中，心房纤维心率震颤是不规则的无规行为。心房表面以明显混沌的方式脉动。不过，对重返现象和心室纤维震颤的研究表明了激发模式的存在，再一次说明了这是组织起来的（“数学的”）混沌。对此已提出了分形和混沌算法。图3．10的两条曲线示意出现则的和混沌的心脏跳动。
    然而，混沌状态不可能一般地被看作疾病，而规则状态也不能一般地代表健康。有限的混沌吸引子保护着有机体免受危险的僵死性。当环境迅速地、难以预料地发生变化时，器官必须要能够以灵活的方式作出反应。心脏搏动率和呼吸率决非如同理想摆的力学模型那样一成不变。

    人体中单个器官和整个机体，都必须被理解为具有高度敏感性的非线性复杂动力系统的系统。将它们的控制参量调节到临界值，可能引起不可逆发展的相变，显示着人体健康的不同程度的危险景象。耗散的复杂结构是开放系统，它不可能与其周围环境分离开来。因此，在复杂动力系统探究方式的背景中，必须大力批判经典的“机械论的”医学观点——把人体分成由高度专业化的专家来处理的种种特定部分。整个身体大于其部分之和。令人惊奇地看到，从现代复杂动力系统的观点来看，自古以来的对传统医生的需求再一次得到了支持，即医学不仅仅是一门分析的科学，它也是一种治疗的艺术，它必须考虑健康和生病的整体性。
    3．4复杂系统和群体生态学
    生态系统是自然界物理的、化学的和生物的组分有结构有功能地组织起来的系统。生态学是关于自然界的这些活的和死的组分如何在功能上结合起来的科学。显然，在复杂系统探究方式的框架中，生态学必须涉及极其复杂的耗散的和保守的结构，它们依赖于其中涉及到的个别物理、化学和生物系统的复杂性以及它们之间的相互作用。
    1860年，亨利·索罗在《森林树木的演替》的演讲中，提出了一个对生态进行经验研究的早期案例。他观察到，自然界的植物发展过程中所展现的一系列的树种变化，是可观察、可预见的。如果生态系统不受干扰，从荒原出发，会顺序形成草原、灌丛、松林，最后是栎树－山黑桃树林，可预见这个周期大约是150年，至少在19世纪的麻省是这样。
    几乎在同一年，查理士·达尔文发表了他的著名的以变异和选择机制基础的进化理论。达尔文认为有机体的不断变化来源于竞争和适应从而优化地适应其生态生境，来自太阳和化学反应的能流，使得生命处于运动过程中，并得到保持。波耳兹曼已经认识到，对于活物体的组织，生物圈付出的代价是提取了高能熵。这些过程以生态系统的生物组分为基础，同时还影响了非生物组分。
    詹姆士·洛夫洛克已经提出，活系统推动着地球上主要的地球化学循环。他指出，全球的大气组分不仅仅是由活系统发展起来的，而且也是由全球生态系统控制的。“自然的平衡”已经成为标志着地球上人类生态系统的复杂平衡网的一个常见主题。
    复杂系统的数学理论，使得人们可以为某些简化的生态案例的研究建立模型。要解释的现象主要是物种的丰度和分布。它们可以显示出典型的耗散结构的特征，如时间振荡。在20世纪初，亚得里亚海地区的渔民观察到，鱼群数目发生着周期性变化。这些振荡是由捕食鱼类和被捕食鱼类之间的相互作用引起的。如果捕食鱼类过多地吃掉了被捕食鱼类，被捕食鱼类的数目就会减少，然后捕食鱼类的数目也会减少。结果又造成被捕食鱼类数目的增加，然后再导致了捕食鱼类的增加。从而出现了两种群体的循环变化。
    1925年，洛特卡和沃尔特拉提出了一个非线性的动力学模型。模型的每一个状态由捕食鱼类的数目和被捕食鱼类的数目来决定。于是，模型的态空间就由一个两维欧几里得平面来代表，其坐标分别是捕食鱼类和被捕食鱼类。对两群体的长时间观察结果，在平面上描出虚线。出生和死亡以整数形式改变着坐标，每次改变一点。为了运用连续的动力学，虚线必须理想化成连续曲线。
    态空间的矢量场可以大致地用4个区域来描述（图3．11a）。在区域A中，两个群体都相对较小，捕食鱼类由于被捕食鱼类的缺乏而减少，而被捕食鱼类则由于捕食鱼类较少而增加。这种习惯趋势作为受约束的速度矢量，在图中示意为带箭头的曲线。在区域B中，被捕食鱼类较多，捕食鱼类较少。当被捕食鱼类较多和捕食鱼类较少时，两种种群都增长。这用矢量示意在区域B中的矢量来示意。在区域C中，两个群体都相对较大。捕食鱼类因食物充分而增加，而被捕食鱼群则减少。这种趋势用区域C中的矢量来示意。在区域D中，被捕食鱼类不多而捕食鱼类较多。两个群体都在减少。这种趋势用矢量示意在区域D中。这种系统的相图可以用封闭的轨迹形象地表示出来，因为此种变动趋向于循环。
    在图3．11b中，相图是一组围绕着一个中心平衡点的封闭轨迹。正如动力学系统理论告诉我们长期可期待的是什么，相图可使生态学家知道两个群体从长远看会发生什么。捕食鱼类和被捕食鱼类的起始群体都将周期地再现。
    如果将某种生态摩擦加进模型中，中心就将成为一个点吸引子。这将是一个静止平衡态的生态系统模型（图3.11c）。对此模型进行另一种（但是可能更现实的）修订，导致了如图3．11d的相图，只有一个周期轨迹。

    从分析的观点看，群体的演化受群体大小的变化率的方程所支配。显然，群体中个体的数目按照其生长率减去其死亡率而变化。进一步的参量必须考虑到有限的食物供给或食物源的耗尽。群体的生活条件有若干种，这些都必须在模型中加以考虑。如果不同的物种以不同的食物为生，不发生相互作用，那么它们就可以共存。
    如果不同的物种在类似的条件中生活，那么食物供给的交叠就必须在群体的演化方程中加以考虑。如果把食物随时间的变化略而不计，那么就极大地减少了复杂性。所形成的演化方程达到稳定构型时，允许有几种共存方案。
    在生物学上，稳定态相应的生态生境对于物种的生存是重要的。由洛特卡-沃尔特拉方程实现的两个群体的捕食者-被捕食者关系，表现为图3．11中的相图。自然界的一种特殊的合作形式是两个物种的共生。用演化方程为某种共生建立模型时，必须要考虑到，一种物种的增加率也依赖于另一种物种的存在。
    动物群体可以以其社会行为的复杂性程度为标志。有一些昆虫群体具有复杂的社会结构，社会生物学对它们颇感兴趣。尼科利斯等人进行了尝试，试图用复杂动力学系统为白蚁的社会组织建立模型。白蚁的个体之间的相互作用，在物理上是借声音、视觉。触觉和化学信号的发送来实现的。
    系统的复杂的有序是由功能结构如组织等级的规则、巢穴建筑、途径形成、材料或食物输送等等来决定的。白蚁合成调节其行为的化学物质。它们有这样的习性，即追随化学分子密度达到其极大值所处的方向。小动物们集体的和宏观的运动，由这些化学物浓度来调节。
    为了给此种集体运动建立模型，需要两个方程，要考虑到昆虫和化学物质浓度的变化率。在序参量（“趋化性系数”）的临界值，稳恒的均匀解变得不稳定。系统于是演化成为一种稳恒的不均匀状态。相应地，不同的分支结构将出现，正如在不同的白蚁社会中观察到的那样。图3．12示意出白蚁的集体运动中，两种不同物种有两种类型的结构特征。

    这种活动早已被观察到，并已对此进行了实验探讨。一个典型的观察实例是，在特定点的建筑材料的堆积，刺激起昆虫开始在此处积累起更多的建筑材料。这是一种自催化反应，它与昆虫的随机堆放一起可以用3个微分方程来建立模型。这些方程包括了这样的观察：白蚁在操作其建筑材料时，放出特定的化学物质气味，它们在大气中扩散，并将昆虫吸引到最大密度的地点，在此已有建筑材料的堆积。
    因此，第一个方程描述建筑材料浓度的变化率，它正比于昆虫的浓度。第二个演化方程涉及到气味的变化率，气味具有一定的扩散系数。第三个演化方程描述了昆虫浓度的变化率，包括昆虫、扩散和朝向气味源运动的昆虫流。
    筑巢的复杂社会性活动对应于这些方程的解。因此，最初的不协调的活动阶段对应于这些方程的均匀解。如果某处出现了因许多建筑材料堆积而产生大涨落，那么就会出现某根柱子或某堵墙。宏观有序的形成，在此表现为昆虫的巢穴建筑物，是由微观相互作用的涨落引起的。
    上述类型的模型现在常常运用于生态学。有必要提到的是，它们仍然处于相当简单的水平。在现实中，人们不得不考虑到许多其他的效应，诸如时间滞后、季节变化、不同的死亡率、不同的反应行为。一般地，出现的往往不仅仅是一种或两种复杂群体及其（简化了的）环境的相互作用，而且还有大量不同的相互作用着的群体。它们的非线性动力学的相图至少允许进行长时间的总体预测。
    在传统的达尔文观点中，生物进化——它们的建模必须采用复杂动力系统——有两种重要的力量在起作用：突变压力和选择。在生物学群体中，个体的行为唯一受其基因支配，新型个体的放大相应于通过突变的自然选择的达尔文进化，这是系统中自发出现的。在高等动物的情形，有了行为变化（“创新”）和通过信息来适应的可能性。在生态学进化中，新的生态生境出现了，它们为特定的物种所占据。显然，进化没有某种简单的图式，而是某种不同等级的复杂的变化和稳定化策略，它们是从前生物进化到生态学进化中形成的，最终是具有人的学习策略的文化进化（参见第6章）。
    复杂系统探究方式显示出大量的可能的进化，其方向难以预料，由随机涨落引起。全局的优化是没有的，全局的收益函数也是没有的，全局的选择函数同样是没有的，其他简化的进化策略仍然是没有的，发生的只是一系列的接近分叉点的不稳定性。简言之，达尔文的观点仅仅是进化的一个特殊方面。对于他的同时代人来说，他好像是以叫做“进化”的非人格化神代替了叫做“上帝”的人格化神，并以简单规律支配这个世界。这种19世纪的世俗化宗教态度后来得到延续。政治思想家如卡尔·马克思相信一个叫做“历史”的非人格化神，它以简单的社会规律支配着人类的命运。
    在18世纪，康德已经在抱怨“自然”一词似乎是表示了一个非人格化的神。但是，正如康德所说，“自然”只不过是人的“调控性思想”。从现代的观点看，实际上我们可以仅仅承认具有或多或少复杂性的动力学模型，它们以或多或少的精确性适合于观察数据。在告别了自然界和人类史上的某些显赫的先知以后，给我们的情感唯一留下的，也许是危险的混沌涨落。但是，另一方面，正是这些涨落可能导致真正的创新，真正的选择和真正的自由。

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页


克劳斯·迈因策尔—复杂性中的思维—4、复杂系统和心－脑的进化

4、复杂系统和心－脑的进化

    人们如何解释心和脑的形成呢？本章首先扼要回顾一下心－身问题的历史。除了宗教传统以外，前人所持有的心和身的概念常常受到科学和技术的最高级标准的影响（4．1）。在复杂系统框架内，大脑的模型是非线性动力学的复杂细胞系统。精神状态的形成（例如模式识别、感情、思维）被解释为大脑集合体中（宏观）序参量的演化，序参量是远离热平衡的学习策略中神经细胞的非线性（微观）相互作用引起的。例如，模式识别就被解释为某种相变，显示出与决定着物理学、化学和生物学中模式形成的演化方程有相似之处。在神经生理学的认知心理学的最新研究中，科学家甚至推测，意识和自我意识的形成也取决于作为自反映的神经实现的“元细胞集合体”的产生率。弗洛伊德的无意识，被解释为某些注意状态和序参量的（部分）关闭。甚至我们的做梦和情绪也表现为是受非线性动力学支配的。
    “人的脑和心问题上的牛顿”被找到了吗？当然没有。复杂系统探究方式不能解释精神是什么。但是，我们可以为在一定条件下的某些精神状态动力学建立模型。甚至原则上也包括为意向性行为建立模型。复杂系统不需要类似于大脑中的“小人”这种虚构的中心处理者。因此，瓦丘的富有嘲笑意味的观察过时了，他的观察中没有发现人体中有任何灵魂，甚至经过了上百次的解剖也是如此。精神气质被理解为复杂系统的一种整体状态，由其部分的局域非线性相互作用引起，但是不可能被还原为部分。我们的奇妙的情感、想像和创造性，自从人类文化开始以来一再为诗人和艺术家所赞颂，但是复杂系统方式还没有触动这些问题，尽管我们将模拟其非线性动力学的某些方面。
    4．1从柏拉图的灵魂到拉美特利的《人是机器》
    自然中的最复杂的器官之一是人的大脑。今天，我们知道，由于有了大脑，才使得人的精神、意识和人格的形成成为可能，而这一切自从人的思维出现以来一直被看作是人的最大的奇迹之一。运用复杂系统探究方式，我们可以用复杂神经网络的非线性相互作用来为人的感知和思维的形成建立模型。因此，复杂系统的模型就有助于我们去理解心-身过程是如何工作的，是如何在一定条件下的自然进化中出现的。基于这种观点，从长远来看，对于符合自然进化规律的意识和精神的形成，也就不会感到惊奇了。但是，它的产生仍是一个谜。
    在我们探讨复杂系统和心－身的进化之前，让我们先回顾一下早期的精神哲学和神经生理学史。对照历史背景，我们可以看到，传统的心－身问题中的哪些问题已经由复杂系统探究方式解决了，哪些问题还没有得到解决。
    在前面的几章中，我们已经指出早期的神话和宗教信念都试图解释人们生活的世界并对自然力作出想像。显然，人的欲望、恐惧、愤怒和想像力，如同自然的强制力那样，支配着人所生活的世界。意识或心灵或精神或灵魂都是生命所经历的，它们似乎在人死后就“离开”了人体。人们已经力图用自己熟悉的关于相互作用着的物理事物的经验，来为这些未知的过程建立模型。精神或意识状态被假定为叫做“灵魂”的特殊的实体或某种类似的东西，正是它们造成了人的意向性行为。伴随着这种精神状态的假设，引出了这样一个问题：灵魂处于身体中何处。通常的回答是，它是由身体提供的，或它是集中在某些器官中，例如心脏和肺部。尽管这种惊人的“事物”效应显然是真实的，但是它不能像上帝或幽灵那样，是不可见、抓不住的。因此，人们普遍地相信，它具有某种神性的起源。前苏格拉底的哲学家们，在对传统的信仰和宗教信念的批判中，从自然中寻求原因和原素。一些思想家把“灵魂”看作诸如“气”和“火”这样的物质，因为，它们被看作最精细、最轻盈的物质形式。在阿那克萨戈拉看来，精神是运动和有序的原则，因此也就是生命的原素。在赫拉克利特看来，灵魂如同由宇宙的规律（逻各斯）所控制的火焰。灵魂如同火，被水消灭：“死就是灵魂变成水”。这些探索就是用熟悉的已知的东西来为未知的东西建模。
    值得注意的是一位早期的医学思想家、毕达哥拉斯派学者、克劳东的阿尔克梅翁，他看来是第一位把感觉和思维定位在大脑的古希腊思想家。像古希腊早期的太阳中心宇宙中的天体模型一样，这种天才的思想很快就淹没在亚里士多德的权威之中，亚里士多德认为心脏是意识的场所，大脑仅仅是用空气来进行冷却的机器。尽管亚里士多德深受古希腊医学思想家的影响，但是他不同意希波克拉底的伟大洞见：大脑是“意识的信使，并告诉它发生什么”。
    德谟克利特捍卫了早期的还原主义精神哲学。他力图把精神状态还原为最小原子的相互作用。他的还原论中，“灵魂”当然就仅仅由特殊的物质（但不可观测的）原子来定义。与物质的定义或类比相反，毕达哥拉斯哲学家把人或动物的灵魂解释成非物质性精质，因为它可以想像为非物质的思想，如数字和关系。换言之，灵魂是用数学的比例系统来建模的，它的和谐或不和谐代表着如同音乐旋律的精神状态。
    毕达哥拉斯的概念影响了柏拉图关于人类灵魂的哲学，这种哲学与他的形式或理念论结合在一起。在他的对话《美诺篇》中，柏拉图表明，一个未受训练的奴隶是可以求解数学问题的。在柏拉图看来，所有的人在获得任何（先验的）经验之前都有某种永恒的知识。人通过分有永恒的形式和理念具有某种先验的知识例如数学，这些形式和理念是ante rem即与存在物的失真的、暂时的表面现象无关。
    亚里士多德批评了柏拉图的实在背后的理念世界的假说。理念是人对形式的抽象，形式在自然中发挥着作用。灵魂被描述为活物体的形式（“实质”），即“原初隐德来希”，它是一种目的性力。但是，它并不与物质分离。灵魂是人体中的一种潜能。按照亚里士多德的说法，人的机体被理解为一个整体。
    然而，在亚里士多德和斯多葛传统中，已经发现了神经系统的解剖学。盖仑相信，神经把心灵普纽玛输送到肌肉，从而引起运动。心灵普纽码不仅仅是一种如同呼吸和空气那样的物质材料，也是一种生命精灵。在中世纪，亚里士多德和斯多葛派的自然哲学对伊斯兰传统中的医学思想家有巨大的影响，如阿维森那，他建立了一个医学学派，在手术、药理、治疗和康复中都留下了令人印象深刻的活动。后来，这些波斯和阿拉伯世界的医学准则只为少数几个基督教中世纪的思想家如艾伯特·马格努斯所认识。在关于心和脑的哲学方面，例如，有关人的意识问题的科学讨论总是被宗教意识形态所掩盖，解剖尸体长期以来也是相当危险的事情。
    与亚里士多德和阿维森那传统中的整体论哲学相反，笛卡尔的理性主义倡导了一种二元论的本体论，把精神和物质、灵魂和身体严格两分。人体是一台物质机器，是按照机械和几何定律构造起来的。它受到天赋观念的引导和控制，天赋观念体现在人的精神之中。在他的《沉思录》中，笛卡尔通过怀疑一切事物的方法而得到人的精神的最基本直觉。方法上的怀疑是要找到那不容置疑的东西。笛卡尔能够怀疑所有的科学的结果、常识的结果和感知的结果，但是他不可能怀疑他自己的存在，这样的存在使得认识过程如怀疑成为可能。
    那我是什么呢？是那进行思考的东西。所思考的东西是什么呢？它在进行着怀疑、理解、肯定、否认、下决心、反驳，它还在进行想像和感受。
    当然，笛卡尔理论的困难之处在于精神和身体的相互作用。他假定人的机体以及它的种种器官都是受到座落于大脑中的精神所引导的。神经是进出于大脑的消息通道。它们作为发令的精神和执行的肌肉之间的因果链而起作用。按照他的力学的钟表范式，笛卡尔相信，在神经通道中快速地运动着所谓的“动物精灵”的细微物质粒子，它们相互推动着，从而把来自大脑的输入传递给肌肉。
    与自然界的所有机械效应相反，人的精神可以自由地决定运动的方向。因此，精神对动物精灵的作用就使它们的运动转向。这并不违反笛卡尔的物理学规律，只要“运动的量”是守恒的（即后来所谓的动量守恒定律）。图4．1示意出笛卡尔的机械感知模型：微小的光线粒子撞击着人的眼睛，通过特定的神经激发了大脑及其“动物精灵”。手臂的运动由大脑中的精神的感知所协调。
    在《灵魂的情感》一书中，笛卡尔甚至试图把所有的情绪状态如害怕和热爱分析为被动的物理结果，种种“动物精灵”的流动都由外部事件引发。如果在笛卡尔的机械模型中，用生物化学物质和物理电效应如荷尔蒙和神经激发来取代动物精灵，那么这种神经活动概念就显得相当现代了。

    笛卡尔的主要困难是非物质的中介相互作用问题，也就是无广延的不可见的精神，与物质性的即有广延的可见的身体之间的相互作用问题。笛卡尔把精神植于非常小的脑器官——松果腺之中，而松果腺驾驭着动物精灵的运动。但是，无广延的精神是如何作用于有广延的粒子如动物精灵的呢？在力学的框架中，这种相互作用问题原则上是无法解决的，从而引起了精神哲学的若干发展。
    在偶因论哲学家如马尔布兰奇看来，所有的因果关系都是不可思议的。上帝必定干预了所有特定情形的因果作用。因此，心-身问题就赋予了神学的特设假说。斯宾诺莎把笛卡尔的心和身的二元论归结为单一实体的一元论。上帝就是万物的唯一实体。自然、精神和身体的一切外表，都仅仅归结为宇宙“实体”的属性（“状态”）。任何时候都没有奇迹。但是，上帝和人的精神都自然化了，自然也就在宇宙泛神论中变得神圣了。
    按照复杂系统探究方式，正是莱布尼茨提供了最令人瞩目的精神哲学。与其自然哲学相联系，我们回想起莱布尼茨的宇宙，它与笛卡尔和斯宾诺莎的宇宙相反，是由无限的许多实体（“单子”）构成的，它们相当于空间中不同点的观察，或多或少地透视了整体。因此，单子被看作一种类似灵魂的实体，被赋予了感知和记忆，但是其意识的清晰程度有差别。有些实体例如人，与动物、植物和石头（它们的意识程度是逐次降低的）相比，具有较大感知和较高程度的意识。甚至上帝也可以植于莱布尼茨的单子论中，它作为中心单子，对整体具有最高程度的意识和最好的感知，但仍然是一种个体和有差异的实体。
    显然，莱布尼茨没有笛卡尔的相互作用论的形而上学问题。他实际上试图把经典的力学与传统的亚里士多德自然目的论结合起来，因为他意识到机械论缺少的精神哲学成份。从现代的观点看，莱布尼茨的类似灵魂的实体显得有些奇怪，它们具有感知和记忆，具有或多或少的生机。但是，对他来说，在具有或多或少复杂性的自动机框架中，用单子论来建立模型却毫无困难。莱布尼茨提出，每一实体都可以用一种单子的自动机来建立模型，单子的不同状态相应于单子的不同的感知。其意识程度是用其复杂性程度来度量的，标志着单子状态空间和信息处理能力的大小。莱布尼茨的具有不同复杂性的自动机的状态，都在关联网中相互关联，用他的名言来说就是单子没有“窗户”、没有相互作用，但是像巴罗克建筑中的镜子一样相互反映。在第五章“复杂系统和人工智能的进化”中，将更详尽地讨论莱布尼茨的单子之网。总之，莱布尼茨假定了，精神不仅仅属于人类，而且也是系统的一种特征，这些系统按照其复杂程度表现出不同程度的强度。
    英国经验主义哲学家如洛克和休谟批判了笛卡尔－柏拉图的如下信念：精神状态可以用反省和纯粹思维的方式进行分析，而无需感觉经验。在经验主义哲学家看来，精神只不过是一块白板，一个接受感觉数据的贮藏室，它是通过联想和抽象而形成概念的。想像只是感觉印象的不那么生动的复本；感知印象可以形象地结合起来，形成如同独角兽那样的概念。
    从复杂系统探究方式来看，休漠发展了一种著名的联想心理学理论。他主张，自然中没有因果机制，精神中也没有因果规律，因果关系只不过是对于那些感觉印象的无意识的联想反映，它们在若干情形如闪电和雷鸣以关联的方式出现。我们可以说，大脑具有无意识的建造感觉印象模式的能力。概念只不过是标志具有或多或少复杂性的感觉印象模式的术语。除了数学以外，再没有建立在感知基础上的明确概念，只有一些关于事件的或多或少概率断言的模糊模式。在《人类的本性》一书中，休谟写道：
    在我面前的桌子仅其外表就足以得到广延的观念。于是，这种观念是从印象中获得并表现的，是在这一时刻显示给感觉的。但是，我的感觉向我传达的印象，不过是有颜色的点，处于某种方式。如果眼睛可以更进一步地感知事物，我就希望它可以向我揭示这一切。但如果它不可能进一步显示出任何东西，我们就可以得出有把握的结论，广延的观念只不过是这些颜色点以及它们的表现方式的复本。
    按照笛卡尔的理性主义，人的精神支配着身体机制，如同他所处的专制主义时代的君主统治着国家。对于休谟来说，不存在脱离的人的精神实体。存在的只不过是一个自组织的区域，其中不断地发生着新模式的生成和旧模式的消失，这都由强度不同的感觉印象的联想所引起。休谟的感觉印象的自发结合和分离，可以比做民主社会中的自由公民，他们以群体或党团形式结合起来，而不是听命于君主。
    康德试图把理性主义和经验主义综合起来。经验主义的观点是，认识始于经验和感觉资料。但是，理性主义是对的，因为我们需要精神结构、认知图式和范畴，以组织经验和认知。康德试图引人奠定牛顿力学公理的哲学范畴。他的认识论的主要特征是，认识并不是我们大脑的白板对外部世界的被动印象所引起的。在康德意义上的认识，是一种主动的过程，由先验的范畴产生着世界的模型。物理事件的空间和时间顺序被归结为直觉
    的几何形式。在康德意义上的感知是主动的信息处理过程，受到先验预期的调控。通过先验的因果范畴，事件的因果联系在哲学上成为可能。
    因果关系是不能感觉在这点上休谟是对的，但是，在休谟看来，为了精确预见和计算弹子球弹出的路径，只是重复弹出弹子球几次并重复联想感觉印象几次还是不够的。我们必须预期，原因和结果可以由某种确定论的关系联系起来。康德认识论中的一般（确定论的）因果图式实现了这一点。但是，哪一种特定的原因作用是合适的，这个问题要由物理实验来确定和检验。认知图式已经在日常生活中运用着。它们在计算机科学中甚至用编程语言的数据图式来建立了模型（参见5．2节）。因此，康德的认识论可以解释为现代认知科学的重要先驱，在认知科学中假定由认知图式整理大量的经验材料。但是，与康德相反，这些认知图式可以在历史发展中发生变化，正如相对论中从欧几里得空间转变到非欧几何空间所表明的那样。
    斯宾诺莎主张一种精神的一元论，以跳出笛卡尔的二元论，而拉美特利却支持一种唯物主义一元论。笛卡尔的分离中类似灵魂的实体的假设被认为是多余的，因为所有的精神状态都应该归结为人体中的机械过程：“人是机器”。拉美特利主张，在人和动物之间并无根本性差异。智能和反映行为都应该用神经的“冲动”来解释，而不是用“机械中的幽灵”来解释。但是，在18世纪的力学框架中，拉美特利的革命性观点只是鼓舞了生理学研究纲领。
    著名的数学物理学家和生理学家赫尔曼·冯·赫姆霍兹（1821－1894）是一位后康德哲学家。他支持一种自然化的认知范畴框架，它是构造任何对世界的特定感知所要求的。当然，康德以后，范畴也发生了变化。然而，仍然有一些基本的图式如空间、数目、测量和因果性概念标志着19世纪的物理学理论。例如，赫姆霍兹意识到了非欧几何的数学可能性。因此，他认为，正确的物理几何必须由物理测量来确定。
    在生理学理论方面，赫姆霍兹起初是约翰尼斯·米勒（1801-1858）的学生，约翰尼斯·米勒常常被人们称作现代生理学之父。米勒坚持一种特殊的神经能定律，它要求每一神经都具有其自身特定的能量或品质。他发现，感觉是可以由机械影响或化学影响、热、电等等所激发的。康德有关感知的一面现在自然化了，因为它证明了，脑必须根据其对于神经的效应来重构世界。然而，米勒坚持一种非物质的动物精气的概念。他相信，动物精气是不可能测量的，因为它们的速度太快了。
    赫姆霍兹从数学方面探讨了能量守恒定律。由于能量可以转化，但是不可能创造或消灭，生命的非物质的能量超出了守恒定律因而显得没有意义。赫姆霍兹偏向于这样的理论，即一旦涉及到能量问题，身体就可以看作是把能量从一种形式变换为另一种形式的机械装置，而无需特殊的力或精气。化学反应可以产生出机体所产生的所有物理活动和热。肌肉的活动是由肌肉中的化学和物理变化所实现的。赫姆霍兹进一步测量了神经传导速度，并揭示出，它甚至比声速还要慢。从哲学上看，这些结果被解释为对米勒的生命力论的驳斥。
    埃米尔·德·博伊斯-雷蒙德（1818－1896）是米勒的另一位学生。他认为，神经效应实际上是一种电活动波。在那时，组织学借助显微镜开始发现独立的细胞体和纤维。按照这些结果，神经活动和大脑看来是复杂的神经细胞（“神经元”）系统，具有复杂联结网络。20世纪初，人们首次描述了神经元通信结构，其中一个神经元向另一个神经元发送信号。但是，对于突触联系的观察，在本世纪中叶左右开始运用电子显微镜之前是不可能的。
    感知、思想和情感的出现如何从这些神经解剖学和神经生理学的描述中得到解释呢？一位最先用神经网络的细胞集合体来解释精神状态的思想家，是美国哲学家和生理学家威廉·詹姆士。詹姆士在他的简明教程《生理学》（1890）中，坚持达尔文主义和进化观点，认为大脑并非是为了进行抽象思维在进化中构造起来的，而是为了保证生存才构造出来的。他以实用主义的方式假定，大脑具有许多良好的工程求解问题的特征，它们适用于精神操作：
    离开了进行认识的物理环境，精神因素就不可能得到适当的研究……总之，精神和世界必须一起进化，因此也就是某种相互适合的结果。
    大脑组织在进行算术演算和形式逻辑推导时显得十分可怜。但是，形成概念和联想的能力，作出好的猜想和提出假说，却是大脑的显著特征。詹姆士提出了一种关于联想的机械模型，它可追溯到休谟的先驱性工作，并启发了我们后来的联想神经网络。以更定性的方式来看，他提出了某些原理，其中一部分为现代复杂神经网络的数学模型所吸收：
    1．詹姆士相信，联想是机械性的，是大脑皮层的功能。
    2．詹姆士的联想原理：
    当两个基元脑过程一起被激活或随即相继被激活时，其中之一具有再现出将激发传播给另一个的趋势。
    3．詹姆士的脑活动的加和规律：
    脑皮层中任意给定点的活动量，都是所有其他点向它放电的趋势之和，这种趋势（1）正比于该点伴随的激活次数；（2）正比于这种激发的强度；（3）正比于竞争点的缺少，这种点与第一个点没有功能联系，向其中放电可能转移。
    如果在第二个原理中，用“神经元”代替“脑过程”这个术语，那么我们就获得了一种突触的描述，突触是霍布后来引入的（参见4．2节）。如果在第三个规则中，用“神经元”代替“大脑皮层中的点”，我们就获得了突触输入的线性加和规则，这与某些霍布类型的神经网络模型很接近。詹姆士还讨论了部分联想的网络通过某种特殊的细胞联结程序将遗失部分重建起来的能力。尽管詹姆士虽然是不熟悉计算机辅助建模的，但是他已经抓住了复杂系统探究方式的基本见解，即复杂的事件是由大量子联想构成的，它们是通过诸如突触这样的基本机制联结起来的。
    在论述“联想”的一章中，詹姆士讲到了一个人对一个晚宴聚会的思考。此人在考虑晚宴的所有活动时，首先只是想到第一步具体做什么。这第一步的所有细节的组合又只是随后提醒下一步，如此等等。对于图4．2，詹姆士概括地描述了这种过程：
    例如，如果a、b、c、d、e是由晚宴聚会最后活动所激发的基无神经迹，可将其称作动作A；l、m、n、o、p是要穿过夜幕回家的基元神经迹，我们将其称作B；因为a、b、c、d、e的每一个和全部放电都将通过此路径向l放电。类似地，它们向m、n、o、p放电；这些后来的基元神经迹每一个都将加强另一个动作，因为在经验B中，他们已经共振起来。图4．2［4.19，图5.7］中的线段示意了放电进入每一个B的组元的加和，这些影响的组合强化了其中的处于加和的B，使B被唤醒。

    詹姆士坚信，“精神质料表现出的有序只是脑生理过程引起的”。在现代的复杂系统探究方式中，序参量被用来描述精神状态，它们是由宏观的神经元集合体引起的。在后面的各节中，我们将看到，从前苏格拉底哲学家到康德和詹姆士，他们对于精神操作的许多基本见解，甚至今天也并没有从根本上被改变。
    4．2复杂系统和神经网络
    19世纪，生理学家发现了诸如感觉、视觉和肌肉运动等等依赖于个体细胞的神经系统的宏观效应。这些细胞通过引发电流或对电流作出反应，从而能够接收和传送信号。显然，神经系统和大脑是自然界进化中的一种最为复杂的系统。人的大脑中至少有100亿个神经细胞（神经元）。每一个神经元都接受其他细胞的输入，并把输入整合起来，产生出某种输出，并将它送给其他的神经元。输入由特定的突触所接收，输出由特定的输出线所发送，这种输出线叫做轴突。
    一个神经元自身就是一个复杂的电化学装置，其中包含有连续的内部膜电势。如果膜电势超过了一定的阈值，神经元就传送一个数字作用电势给另外的神经元。在细胞体中产生的神经脉冲，沿着一个或数个轴突传播。神经学家通常区分出激发突触和抑制突触，这使之有些类似于神经元的发放动作电势。围绕着突触的树突可以接收来自数个到数千个其他神经元发送来的信号。一个神经元的活性是用它的发放频率来度量的。生物神经元并非二元的，因为输出是连续的。不过，许多神经网络模型都进行了简化，运用二元计算单位。
    大脑是这种细胞的复杂系统。虽然单个神经元没有视觉，不会推理，也不能记忆，但是大脑却可以具有这些能力。视觉、推理和记忆被理解为较高级的功能。倾向于自下而上策略的科学家提出，只有每一神经元和突触的特殊性质都得到探讨和解释以后，大脑的较高级的功能才能得到认识和理解。
    复杂系统探究方式的一种重要洞见是揭示了，整体系统的突现效果不可能还原成单个元素的系统效果。从哲学上看，整体大于其部分之和。因此，对于大脑的纯粹的自下而上的探索策略是注定要失败的。另一方面，纯粹自上而下策略的拥护者主张认知完全独立于神经元系统，他们又置身于老笛卡尔的两难境地：“幽灵是如何驱动机器的？”
    在精神哲学中传统的做法（参照4．1节）总是或多或少地倾向于其中的一种研究策略。在18世纪，莱布尼茨和后来的动物学家邦尼特已经指出，自然界中存在着组织发展程度不同的复杂性。在图4．3中，示意了神经系统中的组织水平。解剖学的组织等级包括不同的大小尺度，从分子尺度到整个中枢神经系统。

    这种尺度考虑了分子、膜、突触、神经元、核、环路、网络、皮层、映射、系统和整个神经系统。在图的右边底部示意了化学突触，中间的网络模型示意了神经书细胞如何连接成一个简单的视皮层细胞，在上部示意视皮层的可视区的亚组织，左边是整个的中枢神经系统。
    对这些等级水平的研究透视，可能涉及到这样一些问题，例如，信号是如何在树突中整合起来的，神经元是如何在网络中相互作用的，网络是如何在例如视觉系统中相互作用的，系统是如何在中枢神经系统中相互作用的，或者中枢神经系统是如何与其环境相互作用的。每一层都可以用决定其特定结构的序参量来标志，序参量是相应的特定等级层次的子系统的复杂的相互作用引起的。例如，从底部出发，我们可以区分出不同次序：离子运动、通道构型、动作电势、电势波、行进、感觉、行为、情感和推理。
    十分显然的是，神经系统的一种重要功能是支配和控制机体在环境中的生活条件。例如，一个初级可控状态的例子是有机体的温度。在环境状态变化的最高水平上需要有预先计划和社会相互作用，这就导致了在复杂的文化进化中出现了人类的书面通信功能、创造艺术、解决数学问题等等。
    从达尔文的观点来看，神经系统及其复杂性层次不断增加的进化，表现为受自然界的最基本目的——适者生存——所推动。一些脑科学家甚至强烈主张：诸如抽象思维这样的精神现象的形成，也仅仅是某种“副现象”，它并非是自然自身所倾向的。关于自然的意向性和目的性的信念，当然仅仅是人的一种隐喻，假定了某种世俗化的神性——称之为“自然”——在支配着进化。按照复杂系统探究方式，每一中枢神经系统水平都具有其自身的功能特征，是不可还原为较低层次的功能特征的。因此，从层次透视来看，抽象思维只能被看作某个层次例如体温控制系统的某种“副现象”。
    为了给大脑及其复杂的能力建立模型，区别出如下的范畴是十分合适的。在神经元水平的模型中，研究集中在每一神经元的动力学性质和适应性质上，以把神经元描述为单元。在神经网络水平上，均一的神经元相互关联起来展示出突现的系统功能。在神经系统水平上的模型中，若干个网络结合起来展示出更复杂的感知功能、原动功能、稳定控制等等。在精神操作水平的模型中，描述的基本的过程是认知、思维和问题求解等等。它们的模拟与人工智能框架密切相关（参照第5章）。
    从方法论的观点看，我们必须意识到，模型决不可能穷尽一切，也不可能是实在的同构映射。例如，在物理学中，单摆模型忽略了摩擦。在化学中，分子模型将轨道中的电子看作类似于太阳系中的行星，而不理睬海森伯不确定原理。然而，这些模型在一定应用条件下都是有用的。大脑模型的条件由大脑组织的水平给出。如果建立起一定水平上的大脑组织的功能模型，该模型就应该考虑到该水平之上和之下层次的条件。较高水平的性质常常是无关的。一般地，建立模型的方法论由计算方法的代价和收益来决定。一个试图在各个方面都是现实的人脑模型就需要过于高昂的分析和建构。它可能永远难以满足所希望的目的，因此是不实际的。科学家在致力于为大脑组织的一个个水平建立模型时，对有关的下一层次进行简化，就将更为成功。另一方面，模型必须是富有成果的，以能揭示大脑组织的根本性的复杂特征。
    按照复杂系统探究方式，大脑功能的建模应该采用适当的描述大脑活动的动力学轨迹的态空间和相图。法国数学家和哲学家勒奈·笛卡尔已经在（欧几里得）几何框架中描述了感觉、手臂运动和大脑的合作（图4．1）。
    今天，神经网络是用矢量空间和神经矩阵来进行几何描述的。神经元的电化学输入与输出之间有权重联结。在小脑的图式区（图4.4）中，神经矩阵的权重Wij允许网络通过矩阵相乘从输入矢量计算出输出矢量。

    图4．4的例子涉及3×4的神经元矩阵。神经生理学建模要求巨大的灵活性，因为神经网络可能是相当复杂的。但是，联结矩阵可以有效地将高维态空间变换到其他的不同维数。在数学上，这些高维的变换可能引起几何问题，使用初等形式分析几何难以求解。在这种情况下，就需要广义的张量网络理论，以管理复杂的坐标。从历史上看，令人惊奇的是，从欧几里得几何转变到更一般的拓扑空间和度量空间，不仅仅可以在相对论中表述外部世界，同时还可以表述神经系统的内部特征。
    用笛卡尔早期的方法，让我们涉及一种基本的感知原动坐标，它由矢量或张量变换来代表。动物如何抓住一个被它的感官所感知的对象（图4．5a）？在一个简化的模型中，两眼的位置最先在一个感知数据的二维空间进行编码。这个态空间可以形象表示为一个二维拓扑图。从感知态空间的某一点发出一个脉冲到相应的原动态空间的一个点，原动态空间也是由一个二维拓扑图来代表的。原动态空间的一个点为相应的手臂位置进行编码（图4．5b）。

    眼前庭反射是另一个感知原动坐标的例子。生物藉此神经排列，通过与头部运动方向相反的眼球的短弛像运动，从而把影像稳定在视网膜上。在此神经系统中，涉及两种神经结构，它们可以由中枢神经系统固有的不同的坐标系来代表。首先，我们必须分析耳前庭器的半圆通道，每一边有3个通道，可由三维坐标系来代表。其次，每一个眼球都有6条外眼肌，这相应于六维坐标系。因此，眼前庭反射感知原动坐标，用几何方法由三维（共变）向量的张量变换来描述。这种数学框架可以用来计算任何的由一定前庭输入造成的眼肌激活。

    在神经元和神经网络水平上，人工单元的网络用来模拟和考察大脑组织。这些单元被假定在0和1之间变化。每一单元接收来自其他单元的信号，其间通过突触以不同的权重联结起来。接受和发送表示是值的有序集合，输出单元是适当激活了的。数学上，这种程序可以解释为作为证据的某种输入对于作为功能值的输出的一个映射。功能规则是由权重的排列所决定的，它们依赖于神经网络的拓扑。
    在大脑中，神经元常常构成了作为输入层的群体（图4．6）。这些细胞的轴突发送到第2层神经元。在这第2层细胞的轴突又可以投射到第3层细胞群体上，如此等等。在所有输入单元中的自发激活的集合体是作为矢量的输入刺激的网络表示。这种输入矢量及其活化层次向上面的中间层次传播。结果是一组活化层次，它们由输入层的输入矢量，以及从输入单元的分枝末端到中间层那些关联权重所决定。这种中间层的活化矢量向上传播到最高的单元层，在3层网络的情况下产生了一个输出矢量。这个输出矢量由中间层的活化矢量和处于中间单元到输出单元的分枝的终端的关联权重决定。
    一个仅仅具有输入层和输出层的两层网络是一种简单的刺激-反应图式，具有可观测的、可测量的输入和输出。在3层网络的情况下，中间层的单元及其权重常常难以直接测量，而只是被假设为某种处于黑箱中的隐藏机制。因此，它们被称为隐含单元。

    当然，真实的神经系统显示出多得多的单元和层次。例如，对于人来说，大脑皮层的结构包含了至少6层各异的神经元。顺便指出，图4．4所示的小脑的神经矩阵的输入对于输出的映射，可以等价地由具有输入和输出的两层神经网来描述。3层神经网络等价于顺序相连的两个神经矩阵。但是这种多层的网络不可能推广到整个大脑和神经系统，因为在实际大脑中细胞群体往往在给定层次中表现出广泛的细胞与细胞的关联。这需要在某些不同的模型中加以考虑。
    按照复杂系统探究方式，特定层的神经元可以被解释为态空间轴线，代表了该层可能活性状态。状态的发展，即其动力学由轨迹来说明，轨迹可由该特定网络的某种学习过程所引起。
    例如，感知可以用神经网络的矢量处理来解释。最初，来自外部世界的对于输入神经元的刺激样品（例如，作用于眼睛的电磁光信号、颜色，或者作用于耳朵的声波），它们在神经网络中被加工，产生出某种输出矢量，代表了例如外部世界的视觉或嗅觉图像。但是神经网络必须学会在大量的输入信号中区别和识别出正确的形式、颜色、声音等等。
    学习程序只不过是一种对于众多极重的调节，以获得所希望的输出矢量（例如感知）。学习程序可以由数学算法来加以模拟，这是人工智能研究中的重要课题（参见5．3节）。它们在每一神经层次上（也是由矢量来代表）产生出权重构型。在任一给定的时间，突触值的完整集定义了一个权重空间，在每一轴线上的点说明了每一特定权重的大小。一般来说，学习意味着使得最适解（感知、思想等等）和不适解之间的错误和差异最小化。因此，学习过程可以形象表示为权重空间的轨迹，轨迹从初始的随机集合位置出发，到达最终的最小误差位置（图4．7a）。这种建模的关键意味着，可以通过算法程序使某个函数具体化来获得网络中的权重。业已假定，任何可表示的世界都可以通过权重的构型在网络中得到表示。
    图4．7a示意了学习过程中突触权重空间的轨迹。这个空间进行了简化，只有3个权重，代表了3层网络中突触的所有权重值的组合（图4．6）。图4．7示意了相应的活化矢量空间，其轴线是3层网络中的隐含单元（图4．6）。

    权重空间和活化空间是类似的空间，因为代表类似事物类似矢量由位置近似来反映。权重构型把类似的事物集合在一起，考虑了权重空间可能对于事物之间的细微差异的敏感性。因此，在活化空间，我们可以区分出原型矢量，它们代表了具有细微差异的类似事物，细微的差异由其到原型矢量的距离来度量。在观察和行为的宏观水平上，这些原型矢量可以代表特定的范畴，如树木、植物、果实、人物等等，它们都有或多或少的相似性。在复杂系统动力学的框架中，原型矢量可以被解释为点吸引子，把态空间划分为若干个区域。
    类似的原动行为（诸如抓拿、行走等等）用原动态空间的类似轨迹来表示。正如我们看见的，学习意味着权重依据某种算法程序重新构型。关键性问题在于：成千上万的细胞和突触如何知道它们在什么时候应该变化其状态而不需要小妖的指引？
    唐纳德·霍布在他的著名的《行为组织》（1943）一书中提出，学习必须被理解为一种复杂脑模型中的自组织。如同生命有机体的进化，组织“妖”的信念可以去掉，用复杂系统探究方式的自组织程序来代替。历史上，这是首次清楚地提出了生理学的突触变化的学习规则。霍布在关于复杂的脑模型中使用了“联结主义”一词。他引入了突触概念，后来被称为“霍布突触”。如果两个神经元同时发放，两个神经元之间的联结就得到加强。
    当细胞A的轴突充分靠近细胞B使之激发，并可以反复地或持续地向其发放，在细胞之一或两者之中就发生了某种生长过程或代谢变化，使得A向B的发放效率也就增加了。
    “霍布规则”在1949年还只能是一种假设的实体。今天，它的神经生理学上的存在得到了经验确证。霍布规则并非一种精确的数学陈述。我们在后面还将看到可能霍布类型的联结主义学习规则。霍布规则的一种简单的数学表述要求，神经元A映射到神经元B的权重WBA的变化△WBA正比于A的发放速率vsuAsu和B的发放速率vsuBsu的平均值，即△WBA＝εUAUB，其中ε是常数。
    在霍布类型的规则主张的图式中，强化神经元的前提倾向于是“毋需［外部〕教师”。在此意义上，它是一种自组织的方法，使得神经元发放与成群的刺激模式越来越好地关联起来。霍布意识到，大脑运用相互联结的神经元的整体模式来表示某种事物。他明确地运用了“细胞集合体”一词，这对于现代神经科学是关键性的。激活的细胞集合体可以相应于复杂的感觉或思维。哲学上，霍布的细胞集合体的思想使我们想起休谟的联想概念，但他的联想只具有脑心理学上的基础而没有脑生理学的基础。
    霍布的生理学概念是如何溶进现代的神经网络复杂系统之中的呢？这个联想网络的基本概念要求，一个输入矢量与输出矢量用某种变换而“联结起来”。在数学上，两种矢量类似性可以由其内积来度量，内积即由两个矢量相乘，其中的元素乘以元素，然后将这些乘积加起来。在几何上，内积是正比于矢量之间角度的余弦。在两个矢量总相等的情况下，角度为零，这意味着相似性是完全等同的。
    因此，所贮存的原型矢量（例如典型树的原型图）与输入矢量（例如对于特定树的感觉）之间的相似性，就可以在联想网络中由其内积来计算。原型矢量假定贮存于联结网络中的输入和输出的权重矩阵之中。图4．8a示意的网络中，有代表着输入元素的水平输入线、垂直输出线和联结的权重（这里采用二进制，空心圆圈为零，实心圆圈为1）。

    如果一般地，输入矢量（xj）与输出矢量（yj）通过线性变换从yj＝EWijXj联结起来，其中Wij是贮存的权重矢量，于是我们就获得了一种简单的线性联想子。这种联想网络，能够对于代表某种范畴例子的矢量进行分类，这种范畴是由所贮存的原型矢量实现的。对于动物的生存，这个任务实际上是关键性的。在现实中，种种或多或少的类似的感觉（例如怀着敌意的动物）必须进行鉴别并归于某一范畴。
    某一种联想网络可以进行矢量完善或矢量校正。所谓的自动联想网络可以产生一种输出，使之在仅仅给出贮存矢量的一部分作为输入时，尽量地接近预先贮存的矢量。在现实中有噪声的（例如一个人的图像），必须根据所贮存的图像来加以完善。一个霍布类型的规则，可以通过加强在神经元之间的相关活性程度的关联权重来完成这一任务。
    一种增加这样的复杂网络能力的方法是，对于输出单元引入非线性的阈值。线性的联想网络（例如图4．8a）具有前向反馈拓扑，信息从输入单元流向输出单元。霍布类型的学习程序认为，神经单元的局域的相互作用通过自组织而收敛到正确的总输出。网络中的循环信息意味着某种反馈构造。在图4.8b中，每一单元都接受从外部的输入，同时也接受网络中内部单元的反馈。权重由水平线和垂直线的交接点来表示。
    显然，图4．8b模型的复杂系统是一种非线性的反馈网络，它允许范围广泛的可能的动力学。约翰·霍普菲尔德讨论了一个著名的例子（1982）。他的非线性反馈网络的类型具有收敛解的动力学。对于它们的兴趣不仅仅是由于对大脑的建模，而且是由于（正如我们将在关于人工智能的第6章见到的）发展出新的网络技术。对于我们的复杂系统探究方式，值得注意的是，霍普菲尔德是一位物理学家，他把运用于自旋玻璃体物理学的数学方程运用到了神经网络上。

    铁磁体的动力学是大家熟知的一个热平衡态的保守自组织的例子。在伊辛模型中，铁磁体由自旋体点阵构成，每一方向都可以是向上（↑）或向下（↓）的。每一自旋体都可以与其近邻发生相互作用。在最低能量状态中，所有的自旋体都以相同方向排列。在高温下，自族体的方向是随机的，因为热能使得涨落大于相互作用能。如果减低温度，自旋体就变得按照相同方向排列。显然，自族体的行为类似于磁体（参见2．4节）。在动力学上，它表现为寻求作为某个吸引子状态的最近的局域能量极小值（图4．9a）。但是，只有所有的相互作用是吸引作用，才有在相同方向上的所有自旋体点的单个能量极小值。在吸引相互作用和排斥相互作用混合的情形下，复杂系统如自旋玻璃体可以具有许多局域能量极小值。

    霍普菲尔德提出，神经系统的功能是在态空间发展起来的一些局域稳定点。态空间的其他的点流向作为系统吸引子的稳定点。由于对稳定点的偏离的消失，这种动力学是一种自校正程序。另一方面，稳定点适当地将一个并不完善的始态矢量丢失的部分弥补起来。因此，这种动力学可以用来完善有噪声的输入。
    霍普菲尔德的模型是相当简单的，包括有阈值的逻辑单元。加和的突触输入并将此加和与阈值进行比较。如果此加和处于阈值或阈值之上，就产生出1，否则就产生出0。除了自联结之外，神经元相互联结时，就认为该网络恢复了。数学上，相应的联结矩阵的主对角线为零。霍普菲尔德提出，运用霍布类型的学习规则来构建联结矩阵元。复杂系统的演化如自旋玻璃体伊辛模型遵循非线性的反馈动力学。能量差异项逐渐减少，直到它到达某一个——可能是局域的——极小值。
    字符特征识别问题是人们熟悉的一个简单应用。此复杂的网络由2维格子的相互作用的布尔变量来代表。一个模式（例如字母A）可以被联想到格子中，其中黑点代表激活态变量（其值为1），空点代表其值为零的变量。这里假定，字母作为所希望的动力系统状态被联想到吸引子（不动点）。我们可以想像，通过多次看见正确的字母，人的大脑中贮存了正确的字母形状。如果某个不完善的、部分受损的字母显示给该系统，它就应该能够重新构造出正确的形状——这是以前已经学会的（图4．9b）。

    因此，模式识别就意味着自组织的模式演化。这种过程指向某些吸引子，作为所希望的系统状态。我们回忆一下，一个吸引子就是从一定条件出发，系统将向其演化的一种状态。吸引盆由起始条件来定义，起始条件推动着在吸引子方向的系统的轨迹。正如我们在前面的章节中已看见的，一个吸引子可以是包含不动点的或稳定态的唯一状态，如同在霍普菲尔德网络和自旋玻璃体系统的例子。但是，一个周期相继的状态（“极限环”）或几种形式的混沌吸引子（在耗散系统中）也是可能的。因此，霍普菲尔德网络对于以复杂系统的吸引子来建立神经状态的模型，仅仅是初级的、简化的方式。
    霍普菲尔德注意了自旋玻璃体中的局域能量极小值与联想的大脑原型之间的类似性。在自旋玻璃体的形式网络中，吸引子可以被设计为原型矢量。在图4．10a中，霍普菲尔德系统的态空间用能量地形图形象地表示出来，这里利用了它与自旅玻璃热力学的类似性。网络上所有可能的状态都由平面上的点来代表。表面的高度表示相应的网络状态的能量。
    图4．10b中的相图显示，轨迹从不同的起始点向稳定的局域最小值的收敛。平面上的每一点就是该网络的一种状态。能量地形图具有霍普菲尔德动力学轨迹的吸引盆。稳定点（“吸引子”）处于盆的底部。在模式识别的例子中，原型字母与稳定点相关联。因此，模式完善的过程是一种反省形式，在形式上可与保守自组织的退火过程相比较。在此物理学例子中，终态是自旋玻璃体、磁化的铁磁体或冻结的晶体的有序结构。

    一般地说，霍普菲尔德网络仅仅收敛到低能态的局域最小值。在某些应用中，局域最小值是与特定的贮存项目相联系的，也许是不必要到达某种全局最小值的。不过，在许多情况下是需要全局最小值的。这种问题的一个解，是由个体单元的随机运动而不是确定论运动来提供的。

    图4．11a中，通过一个沿着能量地形曲线运动的小球很可能最终是落入最深的最小值，从而显示了问题的求解。从一定的起始状态出发，小球将向能量最小值或曲线的底部运动。如果能量地形是由多个靠得很近的极小值标志的，结果就取决于最初的起始条件。如何来阻止网络粘在某个局域极小值上呢？这种想法是以一定的能量增量来动摇能量地形，该增量是逃离局域极小值B（低谷）而进入全局极小值A所需要的。
    于是，在力学上，小球从B进入A比从A进入B的可能性要大。平均来看，小球应该终止于低谷A。在热力学语言中，动摇地形的动能相应于系统温度的增加。在适当高的温度情况下，在低谷之间的转移几率不再是可忽略的。在热平衡态，占有不同凹地的几率仅仅取决于它们的深度。
    实际上，模拟退火的方法是人们所熟悉的，并用于全局优化上。正如我们已经提到的，退火是加热一种材料（例如金属或玻璃）到高温、然后逐步地减低温度的过程。但是，该材料将仅仅终止于其全局能量最低点，如果退火过程进行得足够慢的话。例如，金属的突然冷却将留下仅仅有局域极小值的材料，处于易脆状态。模拟退火使得有可能逃离局域极小值，跳跃到较高的能量状态。
    在气体热力学中，气体由其相转移的几率来描述。波耳兹曼对处在均匀温度分布的气体，推导出来气体状态的几率分布。欣顿、西杰诺夫斯基等人认为，这种分布可以运用于描述神经相互作用。在这种模型的情形，加进系统中的低温项被解释为小噪声项。它是神经与气体中分子的随机热运动的类似物。
    这种形式上的等价，是上述网络被称为“波耳兹曼机”的原因。但是，这里并非是物理主义，并非打算把神经相互作用还原为气体分子相互作用。在波耳兹曼的形式表达式中，可以证明，冷却得充分慢时波耳兹曼机可保证找到所希望的全局极小值。显然，具有模拟退火动力学的神经网络，是能够通过搜索模式的态空间给出全局最小值的。
    一种按照这种动力学的可能的学习规则，是与网络及其环境之间的几率相匹配的。该网络的所有可能状态在热平衡时都是可能的，具有波耳兹曼分布的相对几率。如网络中状态的几率与环境状态的几率相同，那么网络便得到一个适当的环境模型。因此，学习规则必须能够调整波耳兹曼机中的权重，以便减少网络模型与环境之间的差距。
    最初，学习规则让系统自由地运行。每一单元的状态几率可以估计出来。然后，输入和输出单元就被强制或被迫取得适当的值。其次，单元的几率值是估计出来的。局域的权重变化正比于与该权重耦合的单元的几率的差。
    形式上，权重的变化规则要求
    △Wij＝E（＜ssuisussujsu＞强制-＜ssuisussujsu＞自由）
    式中E是比例常数（“学习速率”），Si是第i个单元的二进制单元，sisj在网络达到平衡后的时间的平均值是＜sisj＞。在强制的条件下，输入和输出单元都固定在其正确值上。在自由条件下，这些单元都不是固定不变的。于是，学习规则并未受到指示。如果输入在自由的条件下是固定不变的，学习规则就是受指导的。
    在图4．11b中，波耳兹曼机的网络中的单元采取了二进制值，它们之间的联结是相互的。连接的权重可以进行训练，也就是把模式提供给存在着和不存在输出模式的输入单元，并应用波耳兹曼学习现则。在学习过程中，网络中的所有的权重都发生了变化。并不直接接受外界信息的隐含单元，可以使得该网络产生出在输入模式和输出模式之间的复杂的联想。因此，在其中间层有隐含单元的波耳兹曼机具有内部的对于环境的表示，而这对于仅仅具有可见（输入和输出）单元的网络则是不可能的。
    从神经生理学的观点看，由“教师”指导的学习在自然界看来是颇为不现实的。动物对感觉输入分析中进行的特征提取或范畴划分必定是自组织的。在输入矢量中出现得越是频繁的特征，就越是可能归属于一定的范畴。网络的输出必须学会使相应的原型矢量收敛为吸引子。
    如何设计一个网络使得在没有外部教师指导的情况下产生出分类标准呢？一些作者提出，这种自组织取决于多层系统中的非线性相互作用和有选择地强化联结。这种学习程序是在选择和竞争的达尔文过程中组织起来的。

    图4．12中，所设计的竞争学习系统的多层构造，可产生出诸如分类和范畴划分这样的突出的认知任务。活性单元由实心点来代表，而惰性单元则由空心点来代表。输入层与第2层的每一元素的联结是激发的。第2层可以划分为若干组，每组中每一元素都抑制所有的其他元素。同一组中的元素处于相互竞争之中，以对输入模式作出反响。按照拉梅尔哈德和奇普塞的法则，在同一组中，一个单元只有在它能够赢得与其他单元的竞争时才是能够学习的。学习就意味着活性联结的增加和惰性联结的减少。
    一个简单的分类任务是小孩的词汇认知。显然，两个字母的词AA，AB，BA和BB可以划分成几个范畴，例如，以A开头的词汇集合[AA，AB]或以B开头的集合[BA，BB]，抑或是结束于A的[AA，BA]或结束于B的[AB，BB]。在一个计算机辅助的实验中，双字词代表一个多层的网络，其中一层的竞争单元以两单元一组组织起来。该系统能够检测出字母的位置。其中的一个单元自发地作为起始字母A的检测器而起作用，而另一个则检验B作为起始字母。

    在进一步的实验中，增加了字母数，改变了网络结构。尽管这些实验看来仅仅是说明了有限的能力，它们至少是原则上体现了无指导的神经系统中的认知行为的形成。它们已经开始了某种有趣的研究，在复杂系统的框架中把神经生理学与认知科学联系起来，4.4节中将更详细地对此加以讨论。另一种通过竞争学习进行的自组织认知系统的研究方式，是托伊沃·科亨仑提出的。他是一位物理学家，也对于联想记忆进行了生理学的研究。他的神经系统的数学建模在人工智能的工程应用中已显示出重要性（参见第5章）。科亨仑的思想是通过自组织特征的映射来给大脑建模，这种想法源于自动化和生理学上已经确立了的事实。大脑中的大多数神经网络是二维的层状处理单元，它们可以是细胞或细胞组。这些单元是通过侧面的反馈而相互联结的。例如，在新皮质中，每一个主要细胞大约有1 个相互联结。
    对于神经元与其近邻的突触耦合，只要神经元之间的距离小于一定的临界值，这种耦合就是激活的。神经元之间的距离大于此临界值则是抑制的。而距离更大一些时，耦合又是微弱激活的。侧面相互作用的程度在数学建模时使用的曲线，其形状类似于墨西哥帽子（图4．13a）。

    显然，侧面耦合的互相影响倾向于在空间结合成群。图4．13b示意了一个二维成群的例子，它是由一个21×21个处理单元的方格来模拟的。这种成群现象（“活性泡”）取决于正反馈或负反馈的程度，它们可能受到神经网络中的化学效应的影响。在神经的实在中，“活性泡”并不具备计算机辅助模拟的规则形式。图4．13c示意了浣熊的脑皮层中活性的分布，它并非是一个形状规则的形象，而是相当混乱的图像。
    然而，成群现象在大脑的自组织过程中可以是有用的。虽然起初神经网络的活性是均匀分布的，但根据自组织学习过程我们可以观察到神经区域的逐步的专业化。在提供了输入模式以后，具有最大活性的神经元及其邻居被选用来进行学习。神
    经权重的变化，落在以最大活性神经元为中心的一定半径中的环状邻域中。这种学习规则可以用来检测和划分输人的图形或说话模式数据的相似性。
    在形式上，科亨仑考虑了从输入信号u的空间V到二维映射A上的非线性投影P。图4．14说明了学习的步骤：输入值u选定一个中心s。在s的邻域中，所有的神经元都在u的方向上转移其权重Ws。转移的程度随着与中心s的距离的增加而减少，这里用不同的灰度来表示。
    映射通过自组织收敛于某个具有不同活性区域的平衡态。投影应该将输入信号的规则性映射到神经映射上。因此，P在数学上被称为拓扑不变映射。实际上，由感觉输入信号规则性所表示的大脑环境的结构，应该被投影到大脑的神经映射上：大脑应该获得适当的关于世界的模型。

    大脑通过自组织映射进行建模的现实性如何？神经区域的数值的变化，取决于物种生存所感受到的感觉刺激的重要性。在神经区域中，有一些中心，它们能够以比环境更大的精确性对刺激进行分析并将其再现出来。例如，在哺乳动物的眼睛中，对于视觉信息的精细分析是由“小凹”进行的，小凹是一个沿视网膜光轴的非常小的区域，其中有非常高密度的光敏接受子。因此，信号的分解主要在神经区域的这种中心进行，要比在周围的区域强得多。类似的不成比例的表象，也可以在体感系统和原动皮层中观察到。手对于人的生存的重要性表现在体感和原动皮层占有相当大的区域，比代表体表的区域要大。
    与这些结果相反，猫、狗和猿的听觉皮层并不将外部世界的频率投影到特定的中心。蝙蝠具有特殊的定向系统，这对于它的生存是必要的，这是一个例外。蝙蝠能够发出许多种不同的超声频率，并通过这些信号的反射来测定物体的距离和大小。蝙蝠相对于其他物体的速度可以用超声波反射中的多普勒效应来测定。甚至是细微的昆虫也能够被这种灵敏的系统检测出来。
    蝙蝠的特性，能够用其听觉皮层上的自组织映射在实验上确证。图4．15a中将蝙蝠脑中的听觉皮层示意在矩形图中。图4．15b中把该矩形图放大了，示意出听觉皮层中最佳频率分布。一维频率谱不断地单调地从听觉皮层的后区提供给前区。引起神经元最大激活的频率称作那个神经元的最佳频率。划线区域是初级听觉皮层。图4．15c显示了图4．15a中斜线区域中的最佳频率分布。绝大多数测量点都集中在超声回波频率的周围。前一后区中一半以上用来分析超声回波的多普勒效应。十分显著的是，用自组织映射进行的计算机辅助模拟中，产生出如图4．15c所示的听觉皮层的实际表象。
    灵长目动物的脑由许多区域构成，其中有若干神经网络拓扑。例如，视网膜在个体发生的早期已经发育起来。它的神经拓扑有5个独立层：光感受器，水平细胞，极性细胞，无长突神经细胞，视网神经节细胞。人的光感受层大约有120×105个感受细胞。视网输出，由所有的神经节细胞的脉冲速率的空-时模式来代表，沿着光神经传向丘脑。对于人，大约有1．2×106个神经节。因此，视网膜的确是一个复杂系统。然而，人们还没有完全理解大于200×106个视网神经元的复杂性。大脑皮层是系统发育上最年青的大脑区域。大脑皮层在大脑中的百分数在进化中不断地增加。鱼那样的低等脊椎动物并没有进化起来大脑皮层。大脑皮层在爬行动物和鸟类中只占小部分，到狗、猫，直到猿和人，它就越来越多。在灵长目动物中，大脑皮层分化成了不同的多层神经网络拓扑的区域，例如视觉、感觉、原动和联想皮层。小脑由小脑皮层构成，其中有许多具有特定感觉原动功能的多层亚区域。

    大脑系统的多样性被描述为一个密集的神经元集合，其中具有特殊的网络拓扑，通过许多神经而相互通信，神经由以千计的轴突构成。与数字计算机有独立的中心处理、记忆和贮存单元不同，大脑和中枢神经系统可以作为一个多目标平行处理网络的集合体来建模。每一网络都能够独立进行感觉、原动和联想功能的信息处理和信息贮存。
    显然，人们熟悉的程控中心化数字计算机原理并不适用于生物脑。神经网络的自组织过程对于大脑的结构是十分重要的。在非常长的系统发育过程中，复杂的结构形式产生出来。我们往往并不完全清楚它们的目的。在宏观尺度上，特定的神经区域联系着特定信号，具有不同的感觉功能，也可以是不同水平的信息处理操作，还可以是对于人以及对于有机体的动物性和植物性功能。尽管它们分布在大脑的不同区域，它们却可以理解为自组织的复杂性或集体效应。
    自组织作为一种学习程序，揭示了有机体并非完全由基因所决定，基因中包含了详细描述有机体的蓝本。大脑组织化的每一阶段都涉及某种自组织。基困难以存贮大脑的复杂结构。大脑皮层有大约10[14]个突触，个体发育难以从所有可能性中选择出正确的联结图式，如果这些可能性都是类似的。因此，个体发育必须运用神经系统的自组织去处理其复杂性。但是，不认识个体发育的原理，就不能理解其大脑皮层的结构。
    在前面的章节中，我们已经研究了物理学、化学、生物学、地质学和天文学的复杂系统中有序模式的形成。整体有序是在其中有大量局部相互作用元素的复杂系统中形成的。在液体或晶体中有相互作用着的原子或分子，在进化的恒星系统中有相互作用着的子系统，在如同大脑这样的复杂神经系统中有相互作用着的神经元和突触。我们还向读者提示了贝纳德涡旋（“滚动柱”），它们是在液体的热涨落中出现的。
    整体的有序是如何由局部的相互作用来安排的？例如，分子之间的相互作用力在液体中发生着非常短距离的相互作用，而由分子相互作用引起的涡旋运动的模式却可以是大尺度上的有序。这种有序在物理学、化学和生物学进化中出现的原理，对于大脑极其重要，其中相邻细胞元素之间的局部相互作用，创造出来整体有序的状态，导致有机体中的相干行为。此种有序模式是由复杂系统中的元素之间的作用力和起始条件、边界条件所安排的。在贝纳德涡旋的例子中，作用力是流体相互作用、热传导、膨胀和引力。例如，边界条件是液体的温度。在大脑中，联结的模式是由细胞单元相互作用的若干种规则安排的。因为神经元往往是由非常长的轴突联结起来的，两个神经元的局部的相互作用并不意味着它们在脑解剖学上的空间接近，而是它们由轴突的紧密联结。
    尽管这种一般结构对于所有类型的神经元和突触都是普遍的，但是也有许多质的和量的差异。例如，无脊椎动物的神经系统是确定论的，个体神经元的特定部位具有高度编码的信息。而哺乳动物的新皮层中的联想系统，对于特定输入模式的特定反应，却是由促进着对于外部信息进行反馈的学习规则实现的。
    复杂系统模型对于真实的神经网络适合程度如何呢？从方法论的观点看，我们必须清醒地意识到，模型不可能朴素地与实在的每一功能和元素相一致。模型是为了特定目的进行的抽象，它能或多或少地解释和模拟中枢神经系统的某一部分，而对其他部分则没有涉及。有时，模型网络受到批评，说它们如同黑箱，仅仅在一定程度上正确地实现了输入－输出功能。但是，关于生物神经网络是怎样实现其功能的，却什么也没有揭示出来。隐含单元如同量子物理学中的隐变量仅仅是理论概念，被假定是系统实现所观察、可测量的输入和输出值之间关系的一种内在因素。除了可能的多层网络的构造之外，动力学和学习程序是模拟中的根本性问题。
    模型网络的参数调节程序减少到最小误差的现实性怎样？许多模型网络的学习规则，对于一组权重收敛到正确地进行分类，需要难以接受的过多的时间。尽管有时也会得到一个成功的权重调节，但是这决不意味着它的优化。1960年，瓦丘和霍夫提出了一种简单而优秀的学习规则，它受到技术优化推理的启发，而不是从生物观点来看待大脑。瓦丘－霍夫规则及其种种翻版，近年来在技术网络中已经得到了广泛的运用（参见第5章）。
    该规则假定，对于一种输入模式，可由适应性神经元对于输入模式的输出进行分类，它们的取值为a＋1或a－1。因此，这里假定了“教师”，他知道对于该输入的答案是什么。适应性神经元计算出输入活性的加权和乘以突触权重。在假定的输出与计算出来的和之间，系统可能给出错误的信号。根据它们之间的差，突触的权重进行了调整，重新计算出和，使得错误的信号变成零。

    瓦丘和霍夫策略的目标在于，把错误信号的平方减少到其最小可能值。所有输入权重系数的可能的值，导致某个误差值。在图4．16中，这种情况由权重空间的误差面表示出来。
    误差面的最小值并不被人精确地知道，因为不可能见到整个误差面。但是，局部的拓扑图是可以测量的。因此，绝大多数减少误差的调整方向是可以计算的。所谓的梯度下降方法，在微分几何学和物理学中是大家熟悉的，对于权重的调节总是改变权重使得系统沿误差面的最陡下降方向运动。
    在图4．16中，对误差面的梯度进行了计算，以找到最陡下降方向。权重按增量值△W沿着这一方向变化。重复该程序，直到权重达到W理想，这相应于最小的误差。对于非线性的网络，误差面可能有许多个极小值。一般地说，梯度下降的问题涉及落入局部极小值。然后，凹底也就不代表全局的最小误差。
    瓦丘和霍夫证明，存在着一个简单的二次误差面，其中只有一个全局最小值。数学上，计算出某一点的梯度意味着计算出误差平方对于权重的偏导数。瓦丘和霍夫证明了，这种导数正比于误差信号。因此，对于误差信号的测量就提供了运动的方向，以能矫正误差。技术上，具有完整知识的“教师”的存在可以为特定的目标进行调整。但是，假设自然界中的学习过程是有指导的学习程序却是不妥当的。
    在网络模型中，所谓的后向传播是人们最为熟悉的有指导算法。它是简单的瓦丘和霍夫规则的推广。总之，后向传播是神经网络中一种调节权重的学习算法。每一单元的误差是预期值减去实际输出值，可以在网络的输出端进行计算，并反复地返向网络中。这种方法使得系统可以决定如何改变网络中的权重，以改进其总体表现。图4．17示意了通过整个多层网络的后向传播方法。

    尽管后向传播的模型可以像生物学网络一样发挥作用，但它并没有假定真实的大脑也是由后向传播组织起来的。真实网络中的许多参量值往往都是通过解剖学、生理学和药理学中的测量和实验获得的。例如，细胞类型和细胞的数目可以大致估计出来。拓扑和构造可以得到描述，特定的突触究竟是激活的还是抑制的也可以得到确定，如此等等。但是，特定的权重却是未知的。当它们数以千计时，大脑网络的全局最小值和模型网络精确一致、权重相等的几率，却是相当低的。
    因此，模型网络的误差极小化策略一般说来可能只是一种假设，但是它们对于处理可能有数千参量的复杂性问题却是必要的。如果模型网络与大脑网络的拓扑、构造和突触动力学的相似度相当高，它们就允许人们预见大脑网络的某些局域或全局的性质。神经生理学中的后向传播可以正当地作为一种寻找局域极小值的研究工具，但不是作为对于神经生理学分析的一种替代，神经生理学分析可以揭示神经网络的真实的学习程序。
    误差极小化策略在自然进化中有悠久的传统，而不是在脑的学习程序中首次出现的。例如，生态群体的自然选择就可以作为一种模型，此过程将误差梯度逐渐减小到代表了某种环境生存生境的误差极小值。但是，参数调节程序可能仅仅找到了某个局域极小值，而不必是全局最小值。据我们所知，进化一般并不能找到最好的可能解，而仅仅能找到某种对于生存是充分好的满意解。在整个进化过程中，只有局部极小值才是可以从经验上对其进化生存价值进行评价的。这种评价取决于所选择的模型的观察和测量约束。
    因此，从方法论的观点看，那样一种总是全局地、完整地优化自然的观念不过是一种形而上学的虚构。思辨性的叫做“自然”或“进化”的神性观念，产生于乐观主义的文艺复兴时代，它不过是为了取代带着创世计划的基督教上帝。康德已经批判地指出，总体自优化的自然只不过是一种人的虚构，在任何意义上都不可能从经验上得到证实。不可能存在具有独立的中心处理单元，能够将进化策略进行整体、长期优化的超级计算机，在真实的进化过程中，存在的只是局域性的有一定满意度的解，它甚至带有许多缺陷，是不完善的。它们的复杂性与拉普拉斯的简化的完备世界模型是相抵触的。
    4．3大脑和意识的形成
    如何用复杂的脑模型中神经相互作用来解释认知特征呢？莱布尼茨已经提出了一个问题：如果把大脑解释为只不过是一台机器，意识、思维和感情是不可能在大脑的元素中找到的。康德强调，要使得一个物理系统具有生气，组织力是必要的。直到这个世纪，一些物理学家、生物学家和哲学家仍然相信某种非物质的组织生命因素：“生命力”（柏格森）或“隐德来希”（杜里舒）。从复杂系统的观点看，科勒的格式塔心理学是一种有趣的探索方式，涉及到这样一种物理系统，其中复杂的心灵结构自发地从系统自己固有的动力学中产生出来。通俗地说，被感知客体的宏观的“格式塔”（形式），大于其原子组件的加和，不能归结到微
    观尺度上。
    科勒有这样一种思想，视觉现象的产生不可能在热力学模型的框架中得到解释。但是在那时，他指的是波耳兹曼的平衡态线性热力学。他提出：“静态视觉场下的物体过程是稳恒平衡分布的，从光学系统自身固有的动力学中发展起来”。科勒甚至认识到，有机体并不是封闭系统，并力图把有序态的形成解释成一种直觉理解的协同作用。在这方面，科勒已经正确地将一个协同系统中的基本相互作用的微观水平和形成有序态的宏观水平清楚地区分开来了。但是，他仍然缺乏适当的复杂动力学系统框架为远离热平衡的热力学提供某种形式化处理。
    对于微观尺度上脑过程的神经相互作用和宏观尺度上的认知结构的形成，复杂系统探究方式提供了一种建立模型的可能性。因此，看来有可能填补起来大脑的神经生理学与精神的认知科学之间的鸿沟，这在传统上被看成是无法解决的难题。
    复杂模型包括了描述系统动力学的态空间和非线性演化方程。人的大脑中有大约1011个非感觉神经元，可以用1011维的空间来表示。甚至典型的子系统中也包含有10[8]元素。在一个108维的并且只有10层激活神经的态空间，就至少有
    个表示激活矢量的不同位置。如果我们假定，每一神经元与另一子系统的10[8]神经元之间有103个突触联结，那么就必须区别出大约1011个突触。结果，如果每一突触仅仅有10种相区别的权重，我们在一个子系统中就获得了
    个权重这样一个巨大的数字。这种复杂性对于编码、表示和处理信息提供了数目巨大的可能性，在数学上可以用矢量和张量变换对此进行建模。
    在科亨仑的竞争学习网络中，系统的自组织使得近邻矢量映射到近邻的网络点上。业已假定，类似的印象由类似的矢量来表示，它们与原型矢量之间只有微小的距离。在复杂系统的框架中，原型矢量被解释为吸引子。因此，两个相区别的范畴或类型就由态空间的两类不同的吸引子来表示（图4．7b）。认知辨识的学习过程，就由网络的训练过程来建模，其中包括调节权重使输入矢量（例如某个视觉或听觉模式）以最大相似性归属于原型矢量。
    神经态空间的原型概念，允许某些有趣的认知过程解释。当输入印象只是部分地给出时，一个网络如何能够认知一个模式呢？对于动物在野外的生存来说，矢量完善的任务是至关重
    要的。让我们想像一下，一只沙漠中的郊狼察觉在草丛中的兔子尾巴（图4．18）。输入到郊狼的视网膜上的，只是那只兔子的尾巴。郊狼的视觉系统以习得的兔子原型矢量来完成输入矢量，从而能够假定或“假设”在草丛中有一只兔子。在此意义上，我们可以认为，郊狼有一个由大脑中相应的原型激活模式来代表的兔子的“概念”。
    保罗·丘奇兰德甚至提出将人的高级认知能力用原型矢量探究方式来解释。因此，解释性的理解就被归结到被充分训练的网络中的特定原型矢量的激活。原型矢量包含巨大的信息量，对于不同的人来说可能是不同的。原因在于，不同的人并不总是拥有相同的项来满足某一原型束的约束。的确，人们很可能有不同程度的解释性理解，尽管他们以几乎相同的方式来划分一种客体或情形。例如，一个细木工人，比起其他绝大多数人来，对于什么是一把椅子具有更高程度的理解。然而，他们在绝大多数情况下都将有一致的见解。因此，原型-激活模型是相当现实的，因为它考虑了人的概念和理解的模糊性。

    认识论和认知心理学中，通常都对不同种类的解释进行了区分。分类解释（“为何鲸鱼是哺乳动物？”）、因果解释（“为何石头下落？”）、功能解释（“为何鸟有翅膀？”）以及其他的解释，它们相应于集束的因果关系、功能性质等等的原型激活。甚至把握社会状况也是一个激活社会相互作用原型的过程，这是在生活中受到的训练和教育。
    在复杂系统探究方式中，精神状态是与大脑的神经激活模式相关联的，这里是用复杂态空间的状态矢量来建模的。涉及对外部世界的感知的外部精神状态，是可以检验的，并与大脑的神经激活关联起来。我们如何来检验和解释并不涉及外部世界事件，而只是涉及精神状态自身的意识的内部状态？
    众所周知，我们甚至能够反思我们的自我反映，并反思关于我们自我反映的反映，如此等等，处于某种重复作用过程中，它原则上是没有极限的（图4.18b）。自我体验和自我反映导致了自我意识的概念，它在传统上被看作精神哲学和认知心理学的基本概念。自我意识被定义为人格的关键性特征。在历史上已经讨论过的自我意识的定义，并非只具有哲学上的意义。显然，这些不同程度的思辨性定义，在医学和法律上都有重要的影响。对于人具有意识——因而应对其行动负责——必须满足何种标准？有没有关于意识的医学标准？意识是如何受到扰动甚至消失的？动物的意识是怎样的？我们的感受是否跟我们的邻人或动物的感受相同？

    这里的基本问题是：①意识的形成是否由特定的脑过程引起；②是否可以用复杂系统为脑过程的意识形成建立模型。方法论的困难表现为，像疼痛、气味等等主观感受只在反省时才是可能的。这些主观感受和意识状态常常被叫做现象状态。一些哲学家批评过，大脑状态的物理学描述没有抓住什么是现象状态的本质。相反的观点则认为，现象状态概念可以归结为大脑的神经生理学状态的概念。这些争论只不过是传统的物理主义和精神主义（或反物理主义）的现代变种。两种立场都是空想的还原论和夸张，它们既不能得到研究的支持，也不可能对研究有很好的帮助。
    按照复杂系统探究方式，神经生理学状态和精神状态都用数学公式来建模，而没有还原论的雄心。一些哲学家由于对于数学的偏见而出现严重失误，因为他们似乎相信公式只能标示“物理’狱态。例如，读者可以回想一下，霍普菲尔德系统包含着一个“能量”公式是用物理自旋系统的能量公式进行的类推。然而，在霍普菲尔德系统的框架中，不要把所谓的“能量”与固态物理学中的能量混为一谈。数学表达式仅仅决定了网络的动力学，这是可以由神经生理的脑或硅片的计算机或来自某个未知星系的有机体来模拟的。
    如果数学模型适合于观察到的数据，它是经验上可证实的。在其他的情况下，它必须要改变或放弃。我们必须意识到，关于精神状态和意识的可检验的、可证实的理论，并不能使我们与他人有同样的感受。例如，一位内科医生或外科医生，他希望医治一个病人的胃痛并不需要如同病人那样感受胃痛。他必须拥有良好的关于胃的解剖学、生理学、生物化学、心理学等等的知识。用复杂系统探究方式的术语来说，他必须知道胃及其动力学的可能状态。在此意义上，精神和意识状态的模型可以发展起来并经受检验，而不需要任何的还原主义主张。
    显然，在意识的现象状态和大脑的神经生物学功能之间有许多可检验的相关作用。人们都知道，短时间的缺氧可以导致意识丧失。电刺激、精神病药物、麻醉和身体损害也都可以影响意识的程度。这不仅仅是可以通过自我实验（自动脑电仪）来体验，而且还可以通过对功能缺损进行观察和测量来进行临床检验。原因在于，大脑是一个开放系统，其状态依赖于远离热平衡的与环境之间的物理学、化学和生物学代谢。
    意识和无意识状态表现出依赖于相当复杂的神经生理学系统，此系统中包含了各种水平上的反馈圈和相互关联。图4．19示意了大脑皮层及其初级感知皮层和联想皮层的网络。来自感官的特定的输人（“传入”），通过特定的传输子系统和途径，达到初级皮层投影区。来自子系统的非特定的输入达到皮层称作“中脑网络的形成”。网络的形成标志了一种复杂的神经元和神经纤维的网络，包括广泛分布的突触联结。众所周知，他在声觉、唤醒和注意中起着根本性作用。
    复杂网络中的损害会导致对意识的种种干扰。这种种干扰可以是全局的或局域的，造成整体唤醒中特定的意识经验缺损。神经生理学可以从实验上表明，意识的程度取决于大脑皮层中对特定的和非特定的两股不同传入信号流的处理。于是问题便成为，意识的精神状态是如何从这些网络中形成的。用莱布尼茨的术语说，我们见到了如同碾磨机嵌齿轮那样相互作用的元素，但是却无法填平神经生理学机制与意识的精神状态之间的鸿沟。传统的神经生理学持有约定论观点，认为神经网络之间具有突触的严格联结，就如同莱布尼茨的机械的碾磨机模型中的嵌齿轮的严格联结那样，电脉冲通过神经网络的传播，就使得大脑功能成为可能。

    复杂系统探究方式提供了一种自组织网络改变其突触联结的观点，突触联结的改变是由突触的激活引起的，并依赖于激活的程度。在神经复杂系统的框架中，相互作用的神经元的微观水平，与自组织产生的细胞集合体整体模式的宏观水平相互区别。在前面的章节中，已经提到了，自组织神经细胞集合体的概念是霍布引入的。克里斯多夫·冯·德·马尔斯伯、科亨仑和其他人进一步改进了它。如果网络中某些神经元的同时激活是由具有一定模式的输入所引发的，那么根据霍布类型的学习规则通过同步激活就会形成集合体。
    由马尔斯伯提出的修改是，集合体的生成并非一个缓慢过程，而是由快速的突触变化产生的。这些所谓的“马尔斯伯突触”被用来建立快速权重调节的动力学的模型。今天，经验已经表明，大脑中存在霍布型和马尔斯伯型具有高度可塑性的突触，其相互作用规则可以由分子机制来实现。网络中集合体的形成取决于其神经元的激活程度。
    关于意识和无意识状态，假定一个细胞群体的整体激活，如同皮层中的网络组织形成所造成的情形（图4．19），一般将增加集合体形成的概率。因此，汉斯·弗格尔已经提出，意识程度的不同在于其生成集合体的速率不同。例如，细胞集合体的生成速率，决定着表示外部世界的数量、复杂性和持续性的感觉模式。意识是自反映的自参照状态（图4．18a）。因此，意识状态是以表示内部状态（而不仅仅是外部世界状态）的细胞集合体为基础的。例如，我不仅仅有一棵绿树的印象，我还意识到我在看着这棵树。而且，我对于我意识到我在看着这棵绿树的状态可以进行反思，并连续地重复产生出元-元……表示，终于从现象的印象和感受达到抽象的、高度精致的自反映状态。一旦超过了产生速率的临界阈值，现象状态就必定出现。意识的缺损出现在临界阈值水平之下。
    运用特殊的脑电图变化，即以相应的集合体生成速率的增加来代表注意的一定程度，可以对这个假说进行检验。由于细胞集合体的生成速率是以特定的改变着权重的突触为基础的，意识的程度可以由干预突触联结进行检验。实际上，用影响突触可塑性的化学物质麻醉了的病人，体验了生动梦境、虚幻感觉、视听幻觉以及没有组织起来的思想。在此意义上，意识可以被看作系统产生表示和元表示的能力的结果。
    具有高速率生成集合体的神经网络比低速率生成集合体的神经网络，可以产生出更为复杂的表示。因此，在生成速率充分大时，复杂系统将发展起自参照和元认知活性。我们可以设想一种意识程度的尺度，它们相应于生命进化中复杂程度不同的神经系统的意识程度，包括从昆虫到人。随之而来的是，在复杂系统的框架中，意识的形成决非是进化的副现象。它是一种合规律的整体状态的出现，即按照复杂系统的动力学，在临界条件得到满足时，通过其元素的微观相互作用而产生出宏观有序模式。
    如果复杂系统探究方式是正确的，那么生物进化的神经系统则不过是自参照系统的特定实现，其他很可能是以不同于人脑的生物化学的物质材料为基础的具有自参照能力的技术系统，也就原则上不能排除在外（参照第5章）。我们甚至有能力把一种复杂系统的表示翻译成另一种不同系统的表示。由于两种系统的表示并不精确地一致，我们可能难以获得与他人、动物或其他的不同系统完全精确一致的感受。但是，我们会得到关于它们的感受或思想的某种知识形式的表示或某种理论。在此意义上，主观性保留了下来，即使在技术模拟的情形下，人类通信中的解释学也保持着宽广领域。
    关于传统的心-身问题，复杂系统探究方式表明，认知活动既不完全独立和相异于脑活动，不是简单地等同，也不是一种附带现象。思维和感受被假定为，既是神经过程的产物，也是生产者，而它们不必等同。在复杂系统框架中，脑模型是一种自组织系统，它处在远离热平衡和接近于不稳定点的阈值之处发挥作用。在神经不稳定态，不同的集体激活模式都向相干宏观模式演化，这样的宏观模式在神经生理学上是以某种细胞集合体为基础的，在心理学上表示为一定的感受和思想。
    我们都有这样的经验，在情绪不稳定态下某种感受可以支配其他实际感受，甚至引导我们的行动。在协同学中，稳定模和不稳定模的竞争用役使原理来解释。读者可能还记得，在进行决策时，一种思想或概念开始“役使”其他可能的思想或概念。这些非平衡的相变，在最小信息的意义上，受非常少的几个序参量所支配。的确，作出决策以后而行动，意味着巨大复杂性的减少。过多的知识对于行动是阻碍，或如歌德所说：“行动的人总是肆无忌惮。”
    认知现象被当作脑动力学的宏观性质和序参量，序参量支配着其间的微观过程。因此，所谓的心-脑相互作用，不过是一种不适当的、陈旧的形而上学的过时表述而已，它们假定了某些诸如力学中的碰撞球那样的相互作用实体。复杂神经系统中相变过程，从微观的神经相互作用中形成宏观性质，这可用来为脑科学和认知科学的交叠领域建立模型。
    协同学中把相变解释为某种对称破缺，这可以用对称势中粒子的阻尼运动来形象地说明（图4．20a）。
    在势能的极大值，粒子的位置是对称的，但却是不稳定的。微小的涨落决定了粒子将到达两个同等稳定状态中的一个状态。在复杂系统探究方式中，图4．20a中的两个低谷被解释为两个吸引子。显然，感觉的模糊性和视觉系统自发地决定采取其中的一种解释，这是一个人们熟悉的心理学对称破缺的例子。在图4.20b中，存在一种图形的背景不稳定性。我们是否看见了白色或黑色的交叉？图4．20c显示了一种意义的模糊性。图中是一位老年妇女还是一位青年妇女？

    在心理学中，对称破缺是由复杂系统的非线性因果关系支配的（“蝴蝶效应”），这大体上意味着，一个小的原因将引出大的结果。起始个体透视方式的微小细节，也是一种认知的倾向，可以“役使”其他的模式，并导致一种支配性观点。一个神经生理学的模型，必须模拟相应的细胞集合体的相变。
    动物行进例如马的步态中的相变是大家所熟知的。随着速度的增加，马的运动模式也改变了，从行走变成了小跑再到奔驰，以使能量消耗最小化。这是在非平衡相变中经常观察到的滞后现象，这种现象被解释为神经系统中稳定态或吸引子的结果。思维中也出现相变。“啊哈-经历”和突然的“洞见”却是从涨落和不稳定性情形中出现的令人惊奇的现象。历史上，有许多著名的例子，科学家、工程师、艺术家和作曲家在“创造性”的不稳定性和困惑情形下，突然发现新的问题答案、作出新的发明、闪现出绘画新思想、创作新旋律等等。
    复杂系统探究方式并未提供封闭的心理学信条，而是提供了一种跨学科研究纲领，去探索认知科学中的老问题和新问题，并使得它们更靠近经验的和实验的分析。因此，人们已经提出，要探讨细胞集合体的变化速率和学习、创造性、认知灵活性和形象化能力之间的相关性。认知不稳定性现象被假定是神经过程的微观不稳定性的宏观性质。思维和期望被解释为支配着整个系统的活动性的序参量，如果它在接近不稳定点起作用。在心理学实验中可以见到这种理论的确证，实验通过暗示引起幻觉，并引起相应的可测量的生理效应。通过记录区域的脑血流量，表明甚至是思维或行动的意向也会增加原动区的神经活性。
    有谁会否认思想可以改变世界而并非仅仅是解释世界？在心理疾病现象领域，例如，安慰剂效应表明，单纯信念或主导思想就不仅仅可以改变情绪状态，而且还可以改变生理状态。显然，心理疾病状态是接近不稳定点的。相应的序参量并非只是心理学家的理论概念，还是控制和支配着（“役使着”）中枢神经系统活性的真实模式。
    最后的例子表明，自组织复杂系统在心理学中的应用不能仅仅由它们的预见性和定量可测量性来进行评价。复杂系统的一种固有性质是，它在微观尺度上的非线性动力学和对于初始条件的敏感性依赖，不允许人们对于系统的终态作出预见。在大脑和认知研究中，我们面临着巨大的复杂性，难以进行精确计算和长期预报。然而，复杂系统探究方式，揭示了心-脑系统的本质特征，比如它对于细微的内在涨落和外在世界变化的高度敏感性。
    4．4意向性和脑爬虫体
    除了意识之外，人的精神还有另一个基本特征——意向性，这是历来受到强调的。
    意向性是神经状态对于外部世界的事物对象或状态的参照性：我看见了某事物，我相信某事物，我期望某事物，我害怕某事物，我想要某事物，等等。有意向的精神状态可以与没有任何参照性的无意向状态区别开来：我紧张，我害怕，我累了，我幸福，我沮丧，等等。

    意向性现象也可以用简单的例子来形象地说明。在图4．21中，每一观察者都看见一个方块，尽管在此并没有给出任何物理上的方块形状。线条的构型对视觉系统提示了，存在着一特殊的封闭对象。在观察者和刺激物构型之间出现了意向性参照。
    意向性对象或状态可以是虚构的也可以是真实的。显然，人类文化充满着关于意向性对象或状态的记号和符号，包括从交通信号到宗教符号。甚至从纪念碑和教堂到工厂这样的建筑物，也可以代表意向性对象。在人类文化的长期发展中，构筑起来语言的意向性意义。在传统的认识论中，某些哲学家如弗兰茨·布伦特诺甚至主张，意向性是人的精神指称世界的一种特殊能力。意向性被理解为精神的一种特性，它不可能归结为物理学的、化学的或生物学的性质。
    一些现代哲学家如约翰·西尔斯主张，意向性是人类精神的一种本能特征。但是，他们也认为人类大脑的生物学进化也发展了精神参照世界的意向性能力。
    实际上，意向性并非大脑所独有。它也是某些复杂系统的特性，可以用生命进化中的吸引子动力学来为其建立模型。社会昆虫的筑巢就是一个集体意向性动力学的例子。这种复杂系统的特性是自催化机制。通过这种机制，建筑巢穴生态系统——白蚁群体与其环境——的目标定向的工作得以进行下去。在复杂系统探究方式中，人们假定，这种社会系统已经说明了诸如大脑和中枢系统那样的较高级发展系统中观察到的规范性质。
    巢穴的构筑过程涉及微观水平上500万只以上昆虫的协调，并导致一定的宏观建筑模式的演化。例如，非洲白蚁构筑的巢穴高度超过15英尺，重量超过10吨。每一白蚁都是独立于其他白蚁进行工作的。但是，它们的行动局部上由某些化学物质的分布所决定，这些化学物质是白蚁自己分泌出来的。建筑材料用化学物质打上了标记。最初，建筑材料是随机分布的，然后以某种不断增加着规则性的方式，直到建筑结构的出现，它是在受到化学物分布支配的昆虫的局部相互作用中出现的。
    此模式决定了几个作为集体活动目标的中心，在数学上这可以解释为扩散场的吸引子。在前面的章节中，吸引子是作为解引入的，它为从不同初始条件出发的多条轨迹所共有。局部的轨迹对于吸引子，或是收敛的或是发散的。在物理或化学场的模型中，吸引子定义了局部区域，其中势能梯度呈现下降趋势，指向零。包围吸引子的区域叫做吸引盆，由向吸引子收敛或发散的梯度流来定义。昆虫的流的模式总体上是由它们的工作空间的吸引子的布局来组织的，这是昆虫动力学的相图。众所周知，吸引子并非总能实现的。如果某些控制参量改变了，一种模式也可能变得不稳定而被破坏，随之又出现新的吸引子模式。
    图4．22a显示了围绕着两个吸引子的化学扩散梯度，它将是两根柱子的基础。因为两根柱子对于白蚁是两个竞争的吸引子，就决定了它们之间有一个鞍点。在后来的建筑步骤中，图4．22a的起初的二维场之后出现了三维场（图4．22b），支配了柱状构造的方向。在图4．22c中，以一个化学扩散梯度的吸引子示意了拱的形成。

    显然，在生态尺度上的意向性并不要求其中单个的系统组件必须意识到其行动的总体后果。意向性仅仅是系统动力学在较长的发展中从总体上展现出来的。图4．22d示意了筑巢的意向性复杂系统的自催化循环。因为它并非有指导的学习过程，那里也就没有诸如“上帝”或“自然”那样的指导性权威的“目标”或“计划”。那不过是一种简化的拟人隐喻，它没有正确地描述所论自组织复杂系统的非线性因果关系。然而，总体上，从复杂的非线性相互作用中出现了意向性的集体行为。

    由于大脑和中枢神经系统都是复杂系统，其非线性的动力学支配着它们的神经元和突触，它们实现了意向性行为模式也就不奇怪了。意向性并非是从天上掉下来的一种奇迹，一种引导着人的精神并将其与自然区别开来的奇迹。它是一种整体模式，是特定的复杂系统在一定条件下形成的。但是，意向性有不同的水平，这取决于增加着的进化复杂性。
    意向并非必定是意识。在图4．21中，我们视觉系统的意向性对象是一块方块，我们并没有施加有意识的意志。所谓的幻觉也是我们的视觉系统一种意向性模式，它自发地产生出来而没有加入我们的有意识的意志。图4．23展示了流形的弯曲效应，它显得是由不同的形象吸引子的排斥于梯度引起的。两条等距平行线显得被左边一对排斥子梯度和被右边的一个排斥子梯度改变了它们的曲率。观察者视觉系统的态空间，由于不同视觉梯度场的结果，表现出不同的曲率，尽管线段在物理图形中仍然保持等距和平行。

    甚至有意识的意向性模式也并非人所独有。一条狗的跳跃不只是为跳跃，而是为了捕食、欢迎主人等等。在有意识的目标定向的意义上，意向性在不同程度上是所有动物的特性。随之而来的问题是，意向性行为如何用复杂系统探究方式来建模，模型又如何在实验中进行检验。
    在这方面，意向性定义为一种有倾向性的行为模式，它可以改变其固有行为模式的动力学性质，例如稳定性。因此，心理学家可以为行为模式的内在动力学建立模型，尽管这样的模式可能被其他有倾向行为的动力学模式所改变。这里我们提醒读者，支配着某些行为模式的内在动力学，是可以用非平衡相变和序参量来建模的。凯尔索、哈肯和其他人已经分析了如下的简单例子：要求人们平行地运动他们的手指（图4．24a），在频率低时他们容易做到这一点。当要求受试人增加其手指的运动频率时，手指会突然地以对称的、反平行的方式运动，失去了有意识的意向性（图4．24b）。
    为了给这种行为模式的相变建立模型，频率被解释为一种控制参量，描述手指运动的宏观变量是相中。该行为可以在与相变化相联系的能量地形中建立模型。该地形必定是对称的，因为左手指和右手指具有同等的功能。相的角度必定是周期的（图4．25）。如果频率增加了，地形及其起始形状较陡的低谷就会变形。最初的缓慢运动中，模式是稳定的，相应于处于x值的稳定相（图4．25a）。最后，处于x值的低谷消失了，起初处于该低谷的小球也向下滚进到最深的最小值，这相应于手指的对称运动（图4．25c）。

    在一些实验中，要求主观上有意向地去实现双手协调的两种模式之间的转变。短暂的过程所相应的转变时间，已经进行了测量。两种模式的稳定性，用序参量的涨落来度量。相对的相动力学用非线性演化方程来进行建模。

    图4．26a示意了按照这个具有两个势能极小值方程的内在动力学。意向性信息对于相对相的动力学的贡献，用图4．26b中的势来表示。把内在的和意向性的动力学加和，得到完整的动力学，结果示意在图4．26c中。在地形中的小球，在O＝0时比O＝180时沿着陡峭斜坡要滚动得快一些，这相应于经验上测量的转变时间。显然，意向可以通过使得其中一种模式失稳而另一种模式稳定化，从而改变内在动力学。意向性信息在此被看作模式动力学的一部分，吸引着系统向所倾向的模式运动。在此意义上，意向性信息定义了态空间的一个吸引子，此内在动力学模型就建立在此态空间中。

    意向性和语言的意义常常被当作人类思维的根本性特征。意向性状态的例子有疼痛、酥痒、骚痒、信念、害怕、希望、欲望、感觉经验、行动经验、思维、感受等等。它们都使用相应的语句来表达，如“我觉得胃疼”、“我希望得到一辆小汽车”、“我相信上帝”等等。西尔斯提出，精神状态与其他的生物状态如乳汁分泌、光合作用或消化一样地真实。他认识到，精神状态是生物脑的一种宏观态，由微观尺度上的神经元之间的神经生理相互作用引起。因此，它们是不可能由单个神经元的神经生理状态来验证的。
    在大脑的微观态和宏观态之间的区分，是用例如与液体的微观态和宏观态的比拟来加以说明的：液体的宏观态不可能还原为单个分子，或换言之，单个分子不可能是液体。在此意义上，信念、欲望、口渴、视觉经验都是大脑的真实因果特征，如同
    桌子的固体性或水的液体性一样真实。意向性状态自身可以由大脑的结构引起并由大脑的结构来实现。西尔斯主张，对此并不存在形而上学障碍。
    然而，他特别指出，任何纯粹的模型都不足以充分地模拟意向性，因为形式性质并非意向性的组成部分。他持有这种看法的理由是以“中文小屋’思想实验为基础的。把一个只懂得英文的人锁在一间小屋内，室内贮藏了大量的中文符号，并有一套用英文写下的复杂的翻译规则，籍以对中文符号序列进行操作。他不断地通过一条窄缝接收中文符号序列（图4．27）。他应用那些翻译规则，进一步产生出中文符号序列，并通过窄缝显示出来。
    对于小屋中的那个人来说，并不了解储藏的序列中包含了大量的用中文写下的关于某一主题的信息。通过窄缝输入序列的是关于这些主题的问题或见解。输出的序列的是对于这些收到的输入见解的反应或建议。所用的翻译规则是一种形式程序，模拟了以中文为母语的说话人的通常行为。在中文小屋中的那个人，正确地应用此形式翻译规则，但不理解中文符号序列，这些中文符号序列对于他是无意义的。
    西尔斯认为，形式符号的操作本身并没有任何意向性，因为它们对于使用者来说是完全无意义的。在此情形中，意向性是形式符号如字词、句子等等的特征，它们涉及到“所指”的事物（符号的语义关系）以及使用者（符号的实用关系）。西尔斯断定，这种特征仅仅是大脑的精神状态所固有的。

    他的论证是针对“计算机模拟”的缺陷的，因为他把模拟限定在由程序控制的图林计算机的形式算法。但是我们已表明，大脑具有典型的自组织、自参照复杂系统的特征，这与程序控制的计算机完全不同（参见第6章）。复杂系统的自组织和自参照性并不局限于人类或哺乳动物的大脑。它们仅仅是特殊的复杂系统的生物化学和神经生理学的实现，是在生物进化中产生出来的。因此，原则上，不可能排除，这些具有特征动力学的复杂结构可能通过人的技术以完全不同的材料来实现。结果是，正如自参照和自组织的特征使得意向性成为可能，那么，用不同于生物脑的复杂模型来加以至少是部分地模拟意向性，也就是原则上不能排除的。
    在传统哲学中，意向性常常以所谓的人的“自我”为基础，被认为能够涉及世界和自身（作为自参照性的“自我意识”）。但是自我隐藏在大脑的何处？传统的观点，如种种柏拉图主义或唯灵论或唯物主义，甚至仍然为一些现代的脑研究人员所持有。例如，在约翰·艾克尔斯爵士看来，自我表现为一种与大脑相互作用的心灵实体，只在本性上完全不同。但是应该怎样坚持或拒绝这种假设呢？它只是一种以高度形而上学为代价的假定，人们可以相信它也可以不相信它。
    假设也许是该受批判的，可能是虚假的，但是对于进一步的研究是有益的。因此，形而上学的代价是太高了。哲学上的奥卡姆剃刀要求我们扔掉多余的假设，保留形而上学实体的经济假定，把看来是经验研究所不可或缺的假设数目限制到最小。复杂系统探究方式是一种数学的跨学科模型的研究纲领，避免了形而上学教条。从长远看，它可能失效。但是这种建模策略已经在若干科学和技术中得到许多成功的确证，而且更重要的是，它为进一步的经验研究提示了一些富有成果的概念。另一方面，传统的唯物论以单个神经元来解释神经生理学过程的精神状态，则是错误的。
    然而，在脑研究中，出现的问题是：大脑中的哪一部分是“自我”中心？皮层是大脑的一部分，它使我们能够进行学习、记忆和思维，并创造出所有的人类文化和人类文明。但是，如果皮层主要当作具有一定学习程序的复杂联想记忆存贮来进行建模，那么它就仅仅是一种复杂的、高度精致的设备，是在生物进化中为增进适者生存而进化起来的设备而已。
    的确，皮层是人的大脑进化中最年青的部分。大脑中有一些老得多的但更为初级的结构，这样的结构也可以在鸟类、爬行动物、两栖动物和鱼类中找到。一些科学家假定，基本的感受性如性欲、疼痛和所有的伺服机制，是爬行动物的生存所必要的，从根本上说是在这些早期的大脑结构中实现的。这种中心将会刺激所有各种活动，把皮层仅仅用作为巨大而有效的联想装置。因此，在这种解释中，“自我”就被大脑中的小爬虫体代替了，大脑以某些高度复杂的设施如皮层来发挥作用，从而在越来越复杂的环境中生存下来。意向性由于皮层而变得可能，但却是由人的大脑中的爬虫体的基本本能激起的。
    具有高度有效的神经生存手段的爬虫体的概念，比起上一世纪流行的达尔文信条——猿是人的祖先，显得更加损伤我们的虚荣心。当然，从科学的观点看，这不是我们自尊心的受损，而是促使我们对“神经爬虫体”概念进行批判。主要的根据在于，我们的感受性并不停留在爬虫体水平上，而是在生物和文化的进化中得到了发展。
    我们的性欲和疼痛感受性都是相当复杂，因为它们受到由人脑产生出来的相当复杂、精致的文明的影响。因此，从爬虫体时代直到今天，是某种复杂的反馈改进了我们的感受性和欲望。文学、艺术和心理学的历史表明，性欲和疼痛都是处于永恒进化中的人脑的高度精致的状态。因此，甚至传统的人的灵魂的概念，在复杂系统框架中仍然是一个或多或少有些敏感的问题。但是，我们必须放弃关于人的精神和灵魂的传统观念，它们被看作某种奇怪实体，以某种原则上不可思议的方式控制着人的身体并与之相互作用。
    5复杂系统和人工智能的进化
    机器能够思维吗？图林提出的这个著名问题在复杂系统框架中具有新的讨论意义。本章先对莱布尼茨和他的机器思维纲领（通用数学）以来的计算机科学史作一简短回顾（5．1节）。现代的可计算性理论使我们能够进行问题的复杂性分类，即划分对它们的算法或计算程序的计算时间的函数的级别。现代计算机科学感兴趣的，不仅仅是通用问题求解的复杂性而且还有基于知识程序的复杂性。在特定的领域中模拟人类专家问题求解行为的专家系统，是一个著名的例子。我们还要进一步问一问，是否可以期待从量子计算机和量子复杂性理论中得到更有效的问题求解方法（5．2节）。
    但是在采用程序控制的计算机算法机械化时遇到几个严重的障碍，是增加计算能力所不能克服的。例如，模式识别、运动协调和其他复杂的人的学习任务，都是图林类型计算机程序所难以把握的。人工神经网络实现了复杂动力学系统的原理。它们得到了非线性动力学在固态物理学、自旋玻璃体物理学、化学平行计算机、光学平行计算机、激光系统中和对于人脑的成功应用的鼓舞（5．3节）。人工神经网络已经在神经仿生学、医学和机器人学中得到了一些应用。新技术应用的另一个更为推测性的方面是赛博空间。虚拟现实在世界范围的远距离通信者的社会中已经成为一个关键词（5．4节）。显然，图林的“机器能否思维？”这个问题不可能由复杂系统探究方式作出最终的回答，尽管我们可以运用人工神经网络来完成一些有趣的认知任务。

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页


克劳斯·迈因策尔—复杂性中的思维—5、复杂系统和人工智能的进化

5、复杂系统和人工智能的进化

    机器能够思维吗？图林提出的这个著名问题在复杂系统框架中具有新的讨论意义。本章先对莱布尼茨和他的机器思维纲领（通用数学）以来的计算机科学史作一简短回顾（5．1节）。现代的可计算性理论使我们能够进行问题的复杂性分类，即划分对它们的算法或计算程序的计算时间的函数的级别。现代计算机科学感兴趣的，不仅仅是通用问题求解的复杂性而且还有基于知识程序的复杂性。在特定的领域中模拟人类专家问题求解行为的专家系统，是一个著名的例子。我们还要进一步问一问，是否可以期待从量子计算机和量子复杂性理论中得到更有效的问题求解方法（5．2节）。
    但是在采用程序控制的计算机算法机械化时遇到几个严重的障碍，是增加计算能力所不能克服的。例如，模式识别、运动协调和其他复杂的人的学习任务，都是图林类型计算机程序所难以把握的。人工神经网络实现了复杂动力学系统的原理。它们得到了非线性动力学在固态物理学、自旋玻璃体物理学、化学平行计算机、光学平行计算机、激光系统中和对于人脑的成功应用的鼓舞（5．3节）。人工神经网络已经在神经仿生学、医学和机器人学中得到了一些应用。新技术应用的另一个更为推测性的方面是赛博空间。虚拟现实在世界范围的远距离通信者的社会中已经成为一个关键词（5．4节）。显然，图林的“机器能否思维？”这个问题不可能由复杂系统探究方式作出最终的回答，尽管我们可以运用人工神经网络来完成一些有趣的认知任务。
    5．1莱布尼茨和通用数学
    复杂系统的一个最为推测性的应用是人工智能（AI）的进化。在经典的AI传统中，大脑被理解为最先进机器的计算机硬件，而神经是相应的具有确定性算法的软件程序。甚至基于知识的专家系统也被设想为高度发展的AI编程语言的算法表示。但是数理逻辑的理论结果（丘奇、图林和哥德尔等人）以及编程的实际问题限制了经典AI框架中的思维机械化。
    一种关于作为自然进化产物的“脑计算机”的理论已经提出，主张用复杂神经网络的非线性动力学（“自组织”）来为大脑的本性及其精神状态建立模型。由此引起的问题是，对于它们的动力学的洞见，是否会获得一种新的革命性技术的“蓝图”，并由此来追索大脑和精神的自然进化。实际上，人的知识和知识技术的发展表现为一种技术的进化，它导致了如同生物进化中的突变那样的技术创新。
    最初的水平是由如锤子、杠杆等简单工具实现的。高一级水平上，发明了运用力和能量的机器。今天，程序控制的计算机和信息处理自动机已经变成了日常生活中的工具。计算机科学家在他们的机器的历史发展中把硬件和软件划分成若干代。在人工智能研究中，人们可以说“第2代计算机”，指的是从数字处理机到知识处理系统，如专家系统。专家系统被认为是至少部分地模拟人类专家。
    计算机科学的早期历史根源可以追溯到经典机器时代。随着自动执行初等算术操作的机械装置的发展，思维的机械化也就开始了。一台机械计算机一步一步地执行顺序指令。因此，它的动力学是由机械的单向因果性所决定的，本质上不同于复杂系统平行主义和自组织。一般地说，机械计算机的传统设计中包括如下的装置。
    首先是输入机制，数字由此输入到机器中。选择机制选取机械运动，对寄存机制中的数值进行加法或减法运算。寄存机制对于显示存储在机器中的数值是必要的，技术上是用一系列的轮子或圆盘来实现的。如果进行了一次计算，是因为结果寄存器中的一个数字从9提升到了0，然后必须由运行机制将这一运算传播到下一个数字甚至穿过整个结果寄存器。控制机制保证了所有的齿轮在每一次加和循环以后正确地到位，以避免错误结果或阻塞机器。消去机制必须对寄存机制进行重新设置，使之处于零位。
    希伯莱语教授、东方语言学家、数学家、天文学家和地理学家威廉姆·希克尔德（1592－1635）被看成是第一位能够进行四则运算的机械计算机的发明者。他的机器中，加法和减法部分是由自动运行机制驱动齿轮来实现的。乘法和除法机制是以亲普尔的乘法表为基础的。杰出的法国数学家和哲学家布莱斯·帕斯卡尔（1623－1662）发明的加法和减法机中，其精致可进行四则运算的运行机制原理在今天的路程计中仍然运用着。
    正是莱布尼茨的可进行四则运算的机械计算机中包含了如下机械装置：输入机制、选取机制、进行运算的寄存器、以及消去机制。莱布尼茨机成了手摇计算机的原型。如果我们对莱布尼茨机的技术细节和特殊机械构造进行抽象，那么我们就获得了一种理想计算机模型，它在原则上能够计算所有的自然数的可计算函数。

    图5．1是这种理想计算机的图式，其中有摇把C，3个数字寄存器SM、TM和RM。设置操纵杆SH可以使自然数输进（输入）机制SM。如果摇把向右方转动，SM的内容就加入到结果机制RM的内容中，转动机制TM的内容就提高1。摇把C向左方转动，从RM的内容中减少SM的内容，并使TM的内容减少1。
    加法意味着如下的结果：在计算开始时，消去机制程序由设置TM和RM到零来完成。然后，第1个数用SH设置在SM中。摇把C向右转动，就把这个数字送入了RM。换言之，在RM中把数字加到了零上。现在，第2个数字输入到SM，并通过向右转从而加到RM的内容中。两个数字的和可以在RM上读出。在向右摇动两次曲柄以后，TM显示出2。乘法仅仅是意味着反复相同数字的反复加法。乘积b·a是数字a加到自己身上b次。
    莱布尼茨甚至设计了仅仅有两个数字0和1的二进制数字系统的机械计算机，二进制是他早些年发现的。他描述了一个机制，可以把十进制翻译成相应的二进制，并且反之亦然。由于现代的电子计算机只有两种状态1（电脉冲）和0（没有电脉冲），莱布尼茨的确成为计算机科学的先驱之一。
    莱布尼茨的机器遇到了许多技术上的问题，因为那时的材料和技术工艺都难以满足要求。然而，他的设计是通用数学的一般研究纲领的一部分，通用数学机的意图是要通过计算程序（“算法”）并通过机械计算机来模拟人的思维。莱布尼茨提出了他的通用数学的两个基本学科。
    ars iudicandi允许每一种科学问题，在编码成为数字符号以后，都可由适当的算术算法来解决。ars inveniendi允许科学家去寻找和计算出科学问题的可能解。莱布尼茨的通用数学看来已经预见了我们这个世纪著名的希尔伯特纲领，此纲领号召对数学知识进行形式化和公理化。实际上，莱布尼茨发展起来了一些程序，对语言进行形式化和编码。他深深地坚信，存在着用机械装置解决世界上所有问题的通用算法。
    结果，他主张自然系统如细胞、植物、动物甚至人类都是复杂性程度不同的计算机。莱布尼茨在他的《论形而上学》（1686）中强调，活系统的因果解释的机械描述并不与在科学中有巨大启发价值的目的论观点相抵触，（22）。他在《单子论》中（18），引入了一种个体实体（单子）作为基本的自动机，它以状态（“感觉”）的（连续）系列为特征。基本的自动机构成了集合体，其程度不同的复杂性以不同的关联性为标志，并可以解释为复合的自动机。在他的《神正论》（200）中，莱布尼茨讨论了活系统中的等级结构和从属关系：
    ……事物的关联和秩序引起了，每种动物和每种植物的身体都包含了其他动物和其他植物，或其他活的有机体：结果是存在着从属关系，一种身体，一种实体都服务于另一种。
    活系统的统一性是由其组织形式来保证的，对此莱布尼茨采纳了亚里士多德的观点，称之为“隐德来希”。但是莱布尼茨仅仅是借用了一种老的形而上学术语，以引出他自己的新概念。对于莱布尼茨来说，只有在从属关系和等级程度高低不同的意义上，一个系统才有一定程度的统一性。一个其中所有的实体之间有同等关联的集合体，就没有等级秩序，比起初级的细胞有机体，它的结构性就较差，而在植物、动物和人类中，我们都可以观察到一种不断增长的从属关系。
    对于莱布尼茨来说，目的性术语具有启发性价值，尽管大自然原则上可以用机械因果性来解释。但是，把莱布尼茨说成是一位生命力论的信徒是一个基本的错误和误解。主要的区别在于，对于莱布尼茨来说，解释活系统决不需要新的原理或生命力。在一定程度的复杂性中，目的论术语仅仅是启发性地适用于描述自然系统。但是，与自然系统不同，人造的机械自动机是由人在有限步骤中构造出来的。只有无限分析才能够揭示出自然自动机的复杂性，它是与世界上的每一单个自动机（“实体”）相关联的。显然，莱布尼茨设计了一种复杂系统理论，但是仍然是处于经典力学框架中，仍然是一种可决定的通用算法的信念。
    在19世纪，英国的数学家和经济学家查尔斯·巴贝奇不仅仅构造了第一台程序控制的计算机（“分析机”），而且还研究了它的经济和社会后果。他的名著《论机械和制造的经济》（On theEconomy of Machinery and Manufactures，1841）的先声是亚当·斯密的经济规律思想，这与牛顿的力学规律是并行不悖的（对照6．2节）。在《国富论》中，斯密把钢针的工业生产描述为一个算法程序，预见了亨利·福特的工业中程控批量生产的思想。
    5．2从图林机到基于知识的系统
    弗雷格和罗素的现代形式逻辑以及希尔伯特和哥德尔的数学证明理论，主要受到了莱布尼茨通用数学纲领的影响。手摇计算机（图5．1）是对于5．1节所述莱布尼茨机的抽象，可以方便地推广到马尔文·闵斯基的所谓寄存机。它使人们在现代计算机科学中可以定义一般的可计算性概念。
    一台手摇计算机只有两个寄存器TM和RM，只能输入相当小的自然数。一台理想的寄存器具有有限个寄存器，它们都可以贮存任意有限个数量。寄存器用自然数i＝1，2，3，……标记。寄存器i的内容用（i）来标记。作为一个例子，装置（4）：＝1意味着，寄存器4的内容为1。如果其内容为0则寄存器是空的。
    在手摇计算机中，加法或减法仅仅由两个寄存器（SM）和（RM）来实现，（SM）＋（RM）或（SM）－（RM）都将存入寄存器RM。在寄存机中，减法<I>－的结果应为0，如果大于<I>。这种修改的减法标记为<I>－。一般地，理想寄存机的程序是用如下的基本步骤作为建筑块来定义的：
    ①向（i）中加人1并把结果置人寄存器i，即（i）：（i）＋1；
    ②从（i）中减去1并把结果置人寄存器i，即（i）：＝（i）－1；
    这两个基本步骤可以运用如下的概念进行合成：
    ③如果P和Q都是明确定义的程序，那么P→Q也是明确定义的程序。P→Q意味着，机器必须在执行程序P之后执行程序Q。
    ④程序的重复，这对于乘法是必要的，例如，重复相加受到如下问题的控制：一定的寄存器是否是空的。
    这种反馈可以示意如下：

    如果P是明确定义的程序，执行P直到寄存器i中的内容变成零。
    程序的每一基本操作①和②都计为一步计算。一个简单的例子是如下的加法程序：

    机器的每一状态都表示为如下的矩阵，它不断地把（j）的内容y加到寄存器（i）的内容X中，同时使得（j）的内容逐步减少到零。x＋y加和的结果显示在寄存器中：

    一台具有程序F的寄存机定义为，计算出n个自变量的函数值f，即对于寄存器1，…，n中任意的自变量x1，…，xn（对于所有其他寄存器均为零），执行程序F，在有限步骤后停止，此时寄存器1，…，n中函数的自变量和寄存器n＋1中的函数值为f（x1，…，xn）

    按照相应的矩阵进行运算。函数f称作由寄存机RM可计算的（RM－可计算性），如果由程序F计算f。
    一定程序F计算一个函数f所需的步骤数，由该程序所决定，并取决于函数的自变量。程序F的复杂性用函数SF（x1，…，xn）来度量，它计算出按照程序F进行计算的步骤。例如，x＋y的加法程序的矩阵显示了，y步加上1的基本步骤和y步减去1的基本步骤是必要的。因此，SF（x，y）＝2y。由于RM可计算函数f可以由若干种程序进行计算，函数g称作函数f的步骤计算函数，如果有一个程序F去计算f，且对于所有的自变量x1，…，xn有g（x1，…，xn）＝SF（x1，…，xn）。一个函数的复杂性定义为最好程序的复杂性，最好程序即进行函数计算时花费步骤最少的程序。
    显然，闵斯基的寄存机是一种对于莱布尼茨的手摇计算机的直觉概括。但是，历史上另一种等价表述的机器是阿兰·图林和埃米尔·波斯特在1936年首先提出来的。图林机（图5．2a）可以执行任何有效的程序，如果该程序是正确编程的。它的构成：
    a）控制箱，其中置入某个有限程序；
    b）潜在无限的带子，带子上划分出小方格；。
    c）计数装置，或将每一结果打印在带子的每一方格中，沿着带子的移动或停机都处于控制箱的命令控制下。

    如果图林机使用的符号限制在竖线I和空格*，那么可以证明，RM可计算函数是图林机可计算的，反之亦然。我们必须记住，每一自然数都可以一个x条竖线的序列来表示（例如3表示为III），每一竖线都占据图林带子上的一个方格。空格*用来标记空的方格（或相应的数字为零）。特别是，对于分开代表着数目的坚线序列，空格是必要的。因此，图林机计算一个自变量为x1，…，xn的函数f，始于带子上的…*x1*x2*…*xn，停机于…*x1*x2*…*xn*f（x1，…xn）*…。
    从逻辑学的观点来看，一台通用计算机是技术上实现了的通用图林机，——如美国的约翰·冯·诸葛曼小组构造的计算机以及德国的康拉德·朱斯独立构造的计算机。它可以执行任何种类的图林程序。同样，我们可以定义一种通用的寄存机，它可以执行任何种类的寄存程序。实际上，通常设计的冯·诺意曼机包括中心处理器（程序控制器），记忆装置，算法单元和输人－输出装置。它以长序列方式一步一步地运行。今天的一台冯·诺意曼计算机实际是一台通用化的图林机。图林机的效率可以由引进几条带子而增加，它们不必是一维的，每一条带子有一个或多个读写头，但是都要报告给单个控制箱，控制精协调着机器的所有活动（图5．2b）。因此，这种更有效的机器的每一计算都可以由一台普通的图林机来实施。从复杂系统探究方式来看，一台多带图林机仍然是一种程序控制的计算机，与自组织系统如神经网络有本质上的差异。

    除了图林机和寄存机以外，可计算函数还可以用许多其他数学上等价程序来定义。递归函数由函数置换和重复来定义，它始于某种显然是可计算的基本函数（例如相继函数n（x）＝x＋1）。所有这些由图林机、寄存机、递归函数等来定义的可计算性，可以被证明是数学上等价的。显然，每一种这样的精确概念都定义了一种程序，这样的程序是直觉上有效的。
    因此，阿朗索·丘奇提出了他的著名公设，有效程序这个非形式的直觉概念与图林机那样的等价的精确概念是一致的。丘奇的公设当然是不可能证明的，因为这里是数学上精确的概念与非形式的直觉概念的比较。然而，几种精确的可计算性概念的数学等价在直觉上是丘奇公设的有效确证。结果是，我们可能在不涉及特定的有效程序（“算法”）如图林机、寄存机、递归函数等时，来谈论可计算性、有效性和计算函数。按照丘奇的公设，我们特别可以说，每一可计算程序（算法）都可以由图林机进行计算。所有的递归函数作为一种机器程序，都可以由通用计算机进行计算。
    现在，我们能够定义决策和可计数的有效程序，而莱布尼茨的通用数学纲领就已经提出了这样的要求。自然数的集合M的特征函数fM定义为fM（x）＝1，如果x是M的一个元素，否则fM（x）＝0。因此，子集M被定义为有效可决定的，如果其特征函数对于一个数无论是否属于M，都是有效可计算的（或递归的）。
    集合M定义为有效（递归）可计数的，如果存在有效（递归）程序f可相继地产生出其元素（对于M中所有元素x1，x2，…，有形式f（1）＝x1，f（2）＝x2，……）。容易证明，所有递归（可决定的）集都是递归上可计数的（或递归的）。但是，存在着这样的集合，它是递归上可计数的，但却不是可决定的。这是第一条线索，它意味着，莱布尼茨的基于通用可决定程序信念的乐观纲领存在着局限性。
    对于自然智能和人工智能，有效可计算性范式意味着精神是由程序控制机器表示的。神经结构涉及的是符号数据结构，而精神过程也就是操作算法。历史上，AI的核心是在1956年的达特茅斯会议期间建立起来的。参加会议的约翰·麦卡锡、阿兰·纽厄尔、赫伯特·西蒙以及来自其他不同学科领域的一流研究人员，形成了新的AI科学共同体。他们都受到图林的“机器能否思维？”问题的启发，这个问题是图林在著名的《计算机器和智能》（1950）一文中提出来的。
    在莱布尼茨的通用数学的传统中，人们可能会相信，人的思维可以用某种通用演算来形式化。在其现代的翻版中，人们可能会假定，人的思维可以用某种强有力的形式编程语言来表示。无论如何，形式表达式都是符号序列，是可以用自然数进行编码的。于是，对于对象的断言就相应于关于数字的函数，结论就将从某种有效的计数程序中得出，如此等等。实际上，现代计算机的机器语言就是由数字序列构成的，对于机器的每一状态和程序进行了编码。因此，计算机的操作可以描述为有效的或递归的数字程序。
    如果人的思维可以用递归函数来表示，那么按照丘奇公设，它就可用图林程序来表示，而图林程序可以用图林机计算。因此，人的思维也就可以用通用计算机来加以模拟，在此意义上，对于图林提出的问题也就必定要回答“是”。人的思维是可以编码、可用递归程序来表示的，这一前提当然是可疑的。甚至数学思维的过程也可以远比递归函数更为复杂。按照丘奇的公设，递归性或图林可计算性仅仅是可计算性的一种理论限度。
    下面我们希望考虑在这种限度之下和之上的复杂性程度问题。在这种限度之下，有许多涉及到一定限度的实际问题，其限度涉及到如何增加算法的速度。特别是在数学问题中，有一些种类的问题，它们的算法求解本来要比解决其他一些问题困难得多。因此，图林机有不同程度的可计算性，计算机科学中的复杂性理论使之精确化。
    问题（或相应的函数）的复杂性分类可以由复杂性程度来标志，这给出了函数的阶，函数描述了依赖于其输入长度的算法（或计算程序）的计算时间（或基本计算步骤的数目）。输入的长度可以用十进制的数目来度量。按照计算机的机器语言，可以方便地将十进制数字编码成仅仅用0和1的二进制码，并用二进制字符来定义其长度。例如，3的二进制码是11，其长度为2。函数f具有线性的计算时间，如果f的计算时间不大于c·n，其中n是输入长度，c是常数。
    两个（二进制）数的加法显然只具有线性计算时间，例如，对于3＋7＝10中应的二进制计算
              0　 1　 1
        1　　1　 1
        __________________
           1　0　　1　 1
    其中需要5个基本计算步骤把两个二进制数加和（包括运算）。我们提醒读者，加和二进制数字相加的基本步骤是0＋0＝0，0＋1＝1，1＋1＝10，以及运算。可以方便地假定，两个将要相加的数具有同等长度。否则，我们简单地把较短的数加上一系列的零，例如，111和011而不是和11。一般地，如果将要相加的特定的数对的长度为n，则一个数的长度为n/2，因此，我们需要不大于n/2＋n/2＝n个基本计算步骤，其中包括了运算。
    函数f具有二次计算时间，如果对于所有的长度为n的输入和常数c，f的计算时间不大于c·n2。
    一个简单的二次计算时间的例子是两（二）数相乘。例如，对于7·3二21，相应的二进制计算：
        1 1 1·0 1 1
        ___________________
                0 0 0
                    1 1 1
              1 1 1
        ——————————
                 1　0 1 0 1
    按照前面的约定，我们有n＝6。基本二进制乘法的步数是n／2·n／2＝n[2]／4。包括进运算，基本二进制相加的步数是n／2·n／2－n／2＝n2／4－n／2。总起来，我们得到n2／4＋n2／4－n／2＝n2／2－n／2，它小于n2/2。
    函数f具有多项式计算时间，如果f的计算时间不大于c·nk，假定它是多项式P（n）的首项。函数f具有指数计算时间，如果f的计算时间不大于c·2P（n）。许多实际的和理论的问题都属于这种P复杂性，所有P类函数都是可以用确定论的图林机在多项式时间中加以计算。
    数学史上有一些优美的图论问题可以说明复杂性理论的基本概念。1736年，著名的数学家利昂纳德·欧拉（1707－1783）解决了图论中的第一个问题。在东普鲁士的首都柯尼斯堡，所谓的老普里戈尔河和新普里戈尔河在普里戈尔河连接起来了。在18世纪，河上建造了7座桥，把南面s、北面n、东面e与小岛i联系起来（图5．3）。是否有这样一条路线，即每座桥只走一次而可以返回到最初的起点？

    欧拉把问题归结为图论。区域n，s，i，e用图的顶点来代替了，在两个区域之间的桥用相应顶点之间的边来代替（图5．3b）。
    在图论的语言中，欧拉的问题就成为，对于每一顶点，是否存在一条线路，它仅仅通过每一条边一次而最终返回到起点（“欧拉环”）。对于任意的图形，欧拉证明：欧拉环存在，当且仅当每一顶点都具有偶数条边（“欧拉条件”）。对于图5．3a，它并不满足这种条件，因此在这里欧拉问题不可能有解。一般地，存在用欧拉条件来检验任意的图的算法，如果它是欧拉环。算法的输入包括所有顶点1，…，n的集合V，所有边的集合E，它是所有顶点对的集合的子集。这种算法的计算时间线性地依赖于图的大小，它由定点数和边数之和来定义。
    1859年，数学家威廉姆·哈密顿（1805－1865）引入了一个颇为类似的问题，但比欧拉的问题更复杂。哈密顿考虑的是任意的图，它仅仅意味着有限的顶点的集合，通过边联系起来的一定数目的顶点对。哈密顿问题是：是否有一个通过每一顶点（而不是欧拉问题中的通过每一边）的封闭环（“哈密顿环”）。图5.3c示意了有一个哈密顿环的图，其中按照数字顺序通过每一顶点。

    不过，与欧拉问题的情形不同，我们并不知道这样的条件：它精确地表明一个图中是否包含哈密顿环。我们仅仅能够定义一种算法，来检验任意的图是否包含有哈密顿环。该算法检验所有的顶点的排列，以确定它们是否形成了一个哈密顿环。由于n个顶点有n！种不同的排列，该算法找到某个解的步骤不大于c·n！，其中c是常数。容易证明，n！阶相应于n[n]阶。结果是，对于哈密顿问题，一个算法需要指数的计算时间，而欧拉问题的算法求解需要的是线性计算时间。因此，哈密顿问题实际上是计算机无法解决的，甚至对于小的数目n也如此。
    大的计算时间的主要原因在于，确定论的计算机只能一步步地对于其中巨大数量的一个个情形进行检验。更方便的是运用非确定论的计算机，它允许在有限的可能数目中随机地选择计算程序，而不是以系列的方式一步步地进行。让我们再一次考虑哈密顿问题。假定一个输人图具有n个顶点u1，…，un。一个非确定论的算法以非确定论的、随机的方式选择了一定的顶点顺序Vi1，…，Vin。然后，该算法进行检验：这种顺序是否形成了一个哈密顿环。问题也就是，对于所有的数字j（j＝1，…，n－1），相继的顶点Vij和Vij＋1以及起初的开始顶点Vin和Vi1是否是由边联系起来的。这种非确定论算法的计算时间线性地依赖于图的大小。
    一般地说，NP意味着这样类型的函数的复杂性，它们用非确定论图林机进行计算时需要多项式时间。哈密顿问题是一个NP问题的例子。另一个NP问题是“旅行推销员问题”，除了种种边都有一定的数目规定以外，它与哈密顿问题非常相似。人们要解决的是：对于这一问题的哈密顿环，找出其数字的和的极小值，或更直觉地说，找出其旅行的距离的极小值。
    所有的P问题由定义，都是NP问题。但是，复杂性理论的关键性问题在于是否有P＝NP，或换言之，由非确定论计算机以多项式时间解决的问题，是否也可以由确定论计算机以多项式时间来加以解决。
    哈密顿问题和旅行推销员问题，是所谓的NP完全问题的例子。这意味着，任何其他的NP问题都能够以多项式时间转化成它。结果是，如果一个NP完全问题实际上被证明是P问题（例如能够构造以多项式时间来解决哈密顿问题的一个确定论算法），那么接着还有是否所有的NP问题实际上都是P问题。否则，如果P≠NP，那么NP完全问题就不可能用确定论算法以多项式时间来解决。
    显然，复杂性理论表达了图林机或图林类型机的算法能力的程度。它在科学应用和工业应用中具有实际的后果。但是，它是否意味着人的思维的极限呢？复杂性理论的基本问题（例如N＝NP或N≠NP）涉及到算法的速度、计算时间、存贮能力等等的度量。另一个问题是，人们如何开始发现复杂性程度不同的算法。这是计算机科学家的创造性工作，是算法的复杂性理论中不考虑的。
    另一方面，哥德尔的著名定理常常被认为限制了计算机和人的思维的数学能力。他的不完全性定理说，对于形式数论的每一协调的公理化扩展，就有一个（封闭的）不确定的表达式。实际上，他的定理陈述了，在整数的真陈述在其逻辑内不可能得到证明的意义上，任何合理的协调的算术逻辑都是不完整的。甚至如果我们用不可确定的表达式来扩展我们的公理化，那么也会有另一表达式在扩展的形式化中是不可确定的。哥德尔的结果表明，在莱布尼茨和希尔伯特传统中对于完整协调的算术逻辑的形式化追求，是注定要失败的。
    而且，哥德尔证明，算术逻辑——它可能是不完整的——使用可以在其逻辑内表示的方法来使之协调，也是不可能的。在哥德尔的著名结果提出来若干年以后，金藤（1909－1945）证明了初等数论的协调性，他运用了所谓的EO归纳法，该方法是通常的归纳法对自然数的无限扩展。但是，金藤的扩展的证明法的协调性却还是有疑问的，有待证明。换言之，证明方法的复杂性并不低于被证系统的复杂性。因此，只可能有相对协调的证明，所用证明方法必须得到证明，所用来进行证明的方法又需要得到证明，如此等等。对于人的思维，不存在绝对的可以由形式算法提供的协调性基础。
    但是，哥德尔定理对人的思维的限制是有某些基本假设条件的：我们必须把定理的证明作为人的智能的关键。公理仅仅适用于这样的精神模型：它是由其中所有知识都仔细形式化了的机器构成的。而且，哥德尔定理仅仅是对协调机的限制，而模糊性、不协调性和迷惑性都是人的决策的典型特征。如果我们在作出是否要行动的决定之前先要作出长时间的仔细的定理证明，那么我们就不可能有长期的生存。还应该考虑到，图林机具有固定的数据结构，而人的精神则是对新奇经验开放的，并能够从错误中进行学习。因此，哥德尔定理对于机器的限制，就如同对于人的大脑封锁新信息的进入一样。
    1936年，丘奇和图林证明了根本没有一种算法能决定一个一阶预测逻辑的表达式是否是同义反复的真理。随之即有，为找到某种数学证明，我们必须具有某些启发性思想。
    所以，AI的第一阶段（1957-1962）是受启发性编程问题支配的，这意味着在可能的分支树中自动地寻求人的问题求解，其间借助启发性来控制和评价。一个例子是纽厄尔、肖和西蒙的“逻辑理论家”（1957），它首次对罗素和怀特海的《数学原理》中前面的38条定理提供了证明。他的启发性来自一些人在心理学测验中使用的约略估量法。
    1962年，这些模拟程序被推广和扩展到所谓的“一般问题求解者”（GPS），它被假定为人的问题求解的启发性框架。但是GPS只可能解决形式化微观世界中的一些无意义的问题。另一个启发性编程的例子是，在博奕（下棋、将军）中寻求取胜策略。最初的模式识别程序（例如词语和符号的词汇表和句法表）都是以统计方法为基础的。但是从长远的观点看，这些早期的任何程序，都没有证明一般认知模拟程序中的欣快信念。至少，它的形而上学鼓舞了麦卡锡发明编程语言LISP，它是作为一种功能的编程语言引入的，用于处理可怕的符号表，成为今天基于知识的系统的一种最强大的编程语言。
    在一般方法失败以后，AI研究者们传播了一种预设的“语法信息处理”程序。AI的第二阶段（1963－1967）以专业程序的发展为特点。这样的专业程序，例如有求解简单代数问题的STUDENT，进行类似物体的模式识别的ANALOGY，等等。麻省理工学院的马尔文·闵斯基是这个时期的头面人物，他放弃了进行心理学模拟的主张：“目前的探索，其特点是聪明地选取问题从而得到复杂智能活动的幻象来进行的预设求解。成功的实用编程方法依赖于专业知识，这个思想首次被加以强调，成为后来基于知识的系统的中心概念。
    对于问题求解的一般原理的追求，在理论计算机科学中仍在继续：J．A．罗宾逊引入了所谓的以预测逻辑演算和赫布兰德的完全性定理为基础的求解原理，允许用逻辑反驳程序去发现证明。
    在AI中推动实用和专业编程方法，在第三个阶段（1967－1972）得到了加速发展。其标志是构造出专业系统、知识表示方法和对于自然语言的兴趣。发明了在数学应用中取得成功的MACSYMA程序的J．摩西描述了AI中范式的变化：“事实上，1967年是我的精神的转折点，那时候我充分地感受到一般原理的旧思想必须放弃……并抓住了我称作专业技能至上的证据。”
    这一时期的另一个著名例子是DENDRAL程序，它运用了质谱学中化学家的专业知识，以发现分子的结构式。这个阶段中的一个范式的例子变成了机器人的SHRDLU程序，机器人可以操纵不同组件组成的小世界。这种系统可以用英语理解和回答关于这个组件世界的问题，执行操作这个组件世界的指令，并把次序划分为一系列操作，理解干了什么并为什么这样干，并用英语描述它的行动。
    在第四阶段（1972－1977），知识的描述、组织和处理成为了把工程学和AI哲学结合起来的中心范式。米彻尔·费根鲍姆引入了“知识工程”这一术语，用于所谓专家系统的发展。一个例子是用于医学诊断的MYCIN程序，它模拟了一个具有细菌感染专业医学知识的内科医生。
    一种新的知识表示方法是马尔文·闵斯基提出的框架概念。一种用于符号性知识处理的新的编程语言是PROLOG（“逻辑编程”），它可以与LISP相比拟。
    AI的第五阶段（1977－1986）被说成是托马斯·库恩的意义上的“常规”阶段，指的是专家系统范式正在运行并实现了商业化。一些工具发展起来，以建设诸如大规模汽车生产使用的新专家系统。AI正在从实验室和哲学家的研究中崛起，正在变成世界性的知识工业的关键性技术。
    接下去，我们重点讨论专家系统，因为这里看来具有最令人感兴趣的哲学问题。一个专家系统是一种计算机程序，其中已经装入了知识和能力，使得它可以在专家水平上进行操作（例如化学中的DENDRAL和医学中的MYCIN）。人类专家的推理过程示意在图5．4中。

    一些专家系统甚至可以揭示为何它们拒绝一定的推理途径而选择其他的途径。设计者们在努力工作以实现这一点，因为他们知道，专家系统的最终运用取决于它对于使用者的可信度。如果它的行为是透明的、可解释的，那么它的可信度就会增加。
    但是，与人不一样，专家系统的知识是限于某种专业信息基础的，而没有关于世界的概括性、结构性知识。因此，专家系统在数字计算机的约定程序和人之间发挥着某种中间功能（图5．5）。

    一个专家系统包括如下的组件：知识基础、问题求解组件（推理系统）、解释组件、知识获取组件和对话组件。它们的协调示意在图5．6中。

    知识是专家系统运行中的关键性因素。知识具有两种类型：第一种类型是领域事实，它们书写在该领域的教科书和杂志中；对于一个领域的实践同样重要的是第二种知识，叫做启发性知识，是在该领域中的良好实践和进行判断的知识。正是实验性的知识，猜测高超艺术为一位专家经过多年工作所能获得的。
    顺便说一下，知识库与数据库不同。例如，一位医生的数据库是关于病人的记录，包括病人历史、重要症状的测量、所开药物和药物反应。这些数据必定要通过医生的医学知识来解释，以进一步进行诊断并制订医治方案。知识库是医生在他的医学教育中和在实习阶段、高级训练阶段、专业训练阶段和医学实践中学会的东西。它包括事实、倾向、信念和启发性知识。
    启发性知识是最难获得的，因为专家很少自觉地认识到它是什么。所以，跨学科训练的知识工程必须去获得专家的规则，将其表示为编程语言，并植入工作程序中。这个专家系统的组件叫做知识获取。它在专家系统的知识处理过程中的中心功能示意在图5．7中。

    最重要的知识表示方法是产生系统、逻辑、框架和语法网络。除了知识以外，专家系统还需要一种推理程序，一种用以理解和作用于知识和问题数据及其组合的推理方法。这些程序是独立于特定的知识库的，是建立在多种哲学方法论基础上的，为此我们将在后面分析几个专家系统的例子。
    专家系统的解释组件的任务是向使用者解释程序的步骤。问题“如何”也就是要对该系统导出的事实或断言进行解释；问题“何时”则是要求，指出一个系统的问题或秩序的前提。
    对话组件处理专家系统与使用者的通信。自然语言的处理器当然可以使甚至未受过专门训练的使用者也容易接受。
    从技术的观点看，专家系统的局限性是显然的。首先是知识表示问题。所论领域的知识如何表示为计算机记忆装置中的数据结构并为问题求解所接受？其次是知识利用问题。推理器应该如何设计？第三是知识获取问题。获得知识是如何可能的？这对于自动的问题求解是非常重要的，以使得计算机容易将人的专业知识转移到符号数据结构中。
    专家系统的最后一个也是最重要的问题是哲学问题。如何将专家系统的专业知识库与关于世界的一般化结构化的知识结合起来？这种一般化结构化的知识会影响人的专家的决策和行动。
    因此，当医生作出进行手术的决策时，还将考虑到有关病人的生活条件（家庭、工作等）的非对象性以及他对于生命的态度。特别是，例如在当今有关死亡尊严的争论中，对于生和死这种基本问题；医生的总体态度和见识也是融入到他的决策中的，尽管立法上在寻求建立一般的行为标准，但对此却是难以进行规范的。例如，在法律的专家系统中也表现出同样的问题。法官会置规范系统的自治性于不顾，最终将发现某种可能决策的正式范围，在此他将倾向于他自己关于生命和世界的观点。对于这种主观性影响，不要抱怨缺乏客观性，而是要看作一种作出更为人道的医学和裁决的机会。不过，对此并没有排除，未来的计算机科学应该去进一步地扩展以专家系统为基础知识，这种知识今天还是非常专业化的。当然，根本性的局限也是明显的，是专家系统的本质所导致。
    专家系统是问题求解程序的技术实现。因此，实际上存在着的专家系统可以由特定的要解决的问题来进行分类。图5．8示意了专家系统最重要问题的类型。
    输入
    问题类型
    输出
    测量数据、症状等
    →分类或诊断→
    规则/模式的识别
    约束
    →设计→
    满足性质的对象
    初始态、目标态
    →计划→
    将初始态转变到目标态的行动顺序
    初始态
    →模拟→
    未来的后果状态
    图5．8专家系统的问题类型
    一类已经深入分析过的问题涉及到“诊断”，例如医学中的诊断。这种专家系统的输入由测量的数据、症状等等所构成，它在结果中提供了从数据规则中识别出来的模式。另一类问题涉及到“设计”。此问题是如何发现在相应约束下的产物。计划问题的解答要求某种行动序列，把初始态转变成目标态。模拟问题从模型的初始态出发，必须计算其后续状态并进行评价。
    问题求解策略是由产生规则推导出来的，这里必须由所谓的规则解释者进行选取。如果有几种规则是可用的，冲突求解策略将决定哪一条规则是适用的。例如，可能的规则可以用优先性和一般性的程度整理出次序。然后，选取具有最高程度的优先性或专业性的规则就可能是合适的。
    在推理中的规则组合可以由所谓前向和后向链接来实现。前向链接从一定的数据和事实A出发，运用此演绎机制直至推导出一定的目标D（图5．9）。

    从方法论的观点看，专家系统的前向和后向链接程序，只不过是众所周知的古典逻辑学家和哲学家帕波斯的发现确证的必要性或充足理由的方法。不足为奇的是，几乎所有专家系统的推理策略都是以众所周知的哲学方法论为基础的。
    今天，AI中运用的大多数哲学理论都不是直接从哲学文献中获取来的，但是这无损于它们的哲学意义。然而，有一些著名专家系统的作者却是直接受到了哲学家的影响。
    要弄明白AI是哲学逻辑和方法论，人们只要仔细考虑一些专家系统。它们的问题分类决定了何种策略适合于问题求解。一般地说，一种策略的目的也就是减少问题的复杂性。
    DENDRAL程序所涉及的任务，是从数据中决定出分子的结构，数据中包含着化合物的分子式和化合物的质谱。输出整理成有序的表格，列出各种可能的结构式。其问题求解的策略被称作“产生和检验”，其算法是产生出与给定的分子式一致的有机分子的拓扑结构，以及产生出分子中的化学键最可能从何处断裂的规则。简言之，我们可以说，该程序是采用尽早修剪掉坏的分枝的方法来减少求解生成树的复杂性。方法论上，它涉及某种确证标准。
    一般地，如下的要点具有重要性，而不论其化学应用如何：
    a）有某个形式对象的集合，其中包含了解答。
    b）有某种产生机制，例如某种对于该集合的完整计数过程。
    c）有某种检验，例如判断所鉴定出的某种产生出来的元素是否在解答集中。
    这种一般方法由如下的算法来定义，例如由如下的遵从丘奇定理的递归函数来定义：
    函数GENERATE－AND-TEST（SET）：
    如果要检验的集合SET为空，
    那么失败，
    否则让ELEM是SET的“如下”元素；
    如果ELEM是目标元素，
    那么将其作为解答，否则对于集合SET在没有元素ELEM情况下重复这一函数。
    对于翻译成AI编程语言LISP，必须引入一些递归辅助函数，例如GENERATE（产生一定集合的某个元素），GOALP（是判断函数，如果论据是解答集的一部分则提供T（真），否则NIL），SOLUTION（为“输出”准备的解答元素），和REMOVE（提供集合减去给定元素）。当设计一张符号表时，考虑到LISP中通常的缩写，例如DE（定义）、COND（条件）。EQ（方程）、T（真）以及LISP的约定（例如括号规则），如下的算法在LISP中是可接受的：（DE GENERATE-AND-TEST（SET）（COND（（EQ SET NIL）’FAIL）
    （T（LET（ELEM（GENERATE SET））
    （COND（（GOALP ELEM）（SOLUTION ELEM））
    （T（GENERATE－AND－TEST
    REMOVE ELEM SET）））））））
    对于给定的化学分子式，所有的化学结构都系统地产生出来，例如对于Csu5suHsu12su，第一步是：

    一些化学结构被排除了，因为它们是不稳定的或相矛盾的。下一步，计算出相应的质谱并与经验上确定的质谱进行比较。这个比较也就是检验过程。GENERAIE－AND－TEST从而在技术上实现了一种方法论，排除了不可能的假定并检验可能的变体。
    META-DENDRAL程序是设计来改进DENDRAL程序的，涉及何种分子键将在质谱仪中被打破。所以META－DEN－DRAL运用了DENDRAL程序再加上确证的预测标准，这被亨佩尔批判地分析过。
    帮助医生进行诊断感染的MYCIN程序，是一种后向链接的演绎系统。MYCIN的知识库中，大约有300种血液细菌感染生成方式。下面是一个典型例子：
    如果感染的类型是基本的细菌血症，怀疑的入侵点是胃肠道，培养部位是一处无菌部位，那么这就表明此种有机体是拟肠杆菌。
    运用这样的知识，MYCIN进行后向运行。对于所有100种诊断假设，MYCIN试图逼近从实验室结果和临床观察获得的基本事实。由于MYCIN工作在推论往往不确定的领域中，它的设计者把看来合情概率推理的理论与基本的产生装置结合起来。该理论用来为与/或（AND／OR）树中每一个结论建立起所谓的确定性因子（图5．10）。

    这里，Fi是使用者指定给一事实的确定性因子，Ci表明一结论的确定性因子，Ai是产生规则所预期的可信度。确定性因子在AND节点和OR节点处指向前面的式子进行计算。如果一个确定性因子为0．2或更小，相应事实的真假被看作是未知的，就规定其值为0。
    该程序计算出归纳合理性的大小取决于保证事实的多少。这种方式使我们想起鲁道夫·卡纳普的归纳理论。卡纳普自然是不相信培根的普遍归纳结论的。结论总是演绎性的。对此不需要波普尔式忠告，否则专家系统不会运行。然而，像MYCIN系统中所用的概率测量则使得该系统对于使用者更透明。
    另一方面，也可以这样说，在此采用了“假说和检验”策略的波普尔纲领，即产生出最有趣的假说并进行严峻检验。有这样的程序，有助于用统计数据构造起线性的因果解释。另一些程序运用昔日哲学家的知识，归纳推理是单调的，即意味着从一组前提归纳地导出的结论，可能并不是前提的协调拓展。例如，鸟会飞，吱吱叫是鸟，于是推论出吱吱叫会飞，但是它不会飞，如果我知道吱吱叫是鸵鸟。
    另一种策略是将复杂问题分解成简单部分或复杂性较小的子问题，例如乔治·波利亚的启发性数学手册《如何求解》中就使用了这种策略。因此，应用领域必须允许分解为独立的部分。但是，显然，相关性复杂网络并不总能分解而不改变系统的原先状态。例如，人类环境的生态网络或精神病医生必须要分析的复杂的心灵相关性。系统并非总是其部分之加和。
    科学哲学中的一些划界可以翻译为以知识为基础的系统的性质。如果研究使得理论概念得到广泛运用而成为一个理论的固有特性，那么发现过程就可以描述为依赖理论的（理论推动的）。相反的观点，通常叫做培根观点，把大批数据作为其起始点。那么，发现过程就称作数据推动的。在理论的和数据的知识处理之间的划界，在AI中是众所周知的。
    现在我将从以知识为基础的系统中勾画出一些程序，这些系统使得各种各样学科的任务得以完成，其优点前面也已经提到了。我的第一个例子涉及到数学。AM是一个以知识为基础的系统，可以说，它从数论中递归地产生出和重新发现了概念。与经验科学中的程序形成鲜明对照的是，AM成功的标准并非是一个概念与经验数据的吻合，“有趣”的方面却是它产生出例子、新问题等等的能力。这种程序是1977年用LISP语言写出的，始于诸如集合、表格、相等和操作这样的基本概念，可以提出引导发现过程的建议。启发过程是在原来的基础上提出新任务并创立新概念。新的任务按照其有趣的程度整理成一定次序。由若干不同启发过程提出的种种任务，比由单个规则提出的任务更为有趣。
    运用这种措施来引导它对数学概念空间进行搜索，AM为整数、乘法和质数定义了概念，并发现了关于质数的命题（例如因子唯一分解性定理）。
    不过，更深入的分析表明，对发现的历史过程进行模拟的要求是难以满足的。AM的成功完全决定于编程语言LISP的特征。然而，分析显示了与人们研究过程的有趣类似。
    如同其名称LISP表明的，符号表是系统地作出的。两个表可以递归地定义为相等的，当两者是原子的且原子是相等的，否则当表头是相等的且表的其余部分是相等的。在LISP中，递归的布尔函数标记如下：
        （DE LIST－EQUAL（XY）
          （COND（（OR（ATOM X）（ATOM Y））
        （EQ X Y））
        （T（AND
        （LIST－EQUAL（CAR X）（CAR Y））
        （LIST－EQUAL（CDR X）（CDR Y））））））
    这里，CAR和CDR分别是LISP中，对于给定的符号表进行表头和表的其余部分分类的基本操作。AM的一个启发的概括规则推广了等价这一术语。然后，两个表被称作“广义相等的”，如果两者是原子的且原子是相等的，否则表的其余部分是“广义相等的”。在LISP中：
        （DEL－E－1（XY）
          （COND（（OR（ATOM X）（ATOM Y））
        （EQ X Y）
        （T（L－E－1（CDR X）（CDR Y）））））
    由此推广，所有具有相同长度的表都被看作是等价的。它们定义了叫做“数”的一类。儿童面对具体对象时实现的这种发现过程，由AM通过变换规则进行了模拟。加法是两个表的连接。由启发变换规则来形成已产生概念的逆时，发现了质数概念。在AM基础上改进的EURISKO（1983），不仅仅可以发现新的概念，还可以发现新的启发过程。
    一系列叫做BACON的程序对定量经验定律的发现进行了分析。BACON系统的名字取自弗朗西斯·培根，因为其中运用了培根关于科学推理性质的思想。它们是数据驱动的知识处理系统，其中包括数据收集，找出在两个或更多个变量之间的规则并对其进行检验。BACON的基本方法并不需要涉及数据的语法意义，它们对于数据进行操作，不对数据的结构作任何特殊的假定。有时，需要人们对于独立项进行实验控制，传统的“一次改变一项”的方法可以用来从相关变量中分开每一独立项的效应。BACON程序可以再产生出物理定律，包括波义耳定律、开普勒第三定律、伽利略定律和欧姆定律。
    有关考察表明，这种以知识为基础的系统至少要遵从这样的前提条件：对于不同学科间规律的关联，应该满足同样的方法论和启发框架条件。相应的以知识为基础的系统，不仅仅是再产生一定的定律，这些定律是在不同的历史背景中发现的，而且也对称地产生出完整的方法论概念的范围和挑选出有趣的应用。最新的BACON程序不仅仅是数据推动的，因而是严格的意义上的“培根式的”，而且还是理论推动的。在其对称性和守恒定律的理论前提下，它产生出了例如动量守恒定律。
    另一系列程序能够从经验数据中归纳出定性定律（GLAUBER，STAHL，DALTON）。这些程序还可以从一些现象中归纳出结构性和解释性模型。定性定律通常是化学中的定律。
    科学家与机器之间的竞争并非是有意的。不过，对于科学定律和理论做出系统的结构性分类已经实现。它可以使人们对科学定律及其发现条件的复杂性进行新的洞察。
    对于科学发现的多种多样活动的若干方面，诸如发现定量定律，产生出定性定律，推导出物质的成分和提出结构模型。一种整合的发现系统已经显示出曙光，它把个别系统作为组件结合起来。每一组件都接受其他一个或多个组件的输入。
    例如，STAHL集中在确定化学物质的成分上，而DAL－TON则关心反应中涉及到的微粒数目。因此，STAHL可以看作是，为DALTON所论的问题奠定了详细的结构模型基础。以这种方式，有可能发展起越来越复杂的以知识为基础的系统，将研究分解为知识处理和问题求解。
    甚至在这样的扩大了的研究框架中，我们仍然没有涉及到实验计划或新测量手段的发明所依赖的机制。任何固有的概念与实施测量的实验安排结合起来，都可以用作一种科学的工具。在此情形下，工具的发现恰好也就与概念自身的发现是重合的。
    还有一些以知识为基础的系统，它们考虑了实验的设计以及它们与其他科学研究活动的相互作用。在图5．11中示意了一个叫做KEKADA的系统（由西蒙研究小组发明），其中有假说产生者、实验选取者和预期设定者等等。它已经发展到为生物化学中的实验设计建立模型（克雷布斯1935年发现尿素循环）。如同知识工程师，西蒙和他的小组分析了克雷布斯的实验室记录，定义了他的研究方法论规则，并将其翻译成LISP类型的编程语言。

    如果该系统没有确定哪一任务继续进行，问题选取者就将决定该系统将继续进行某一任务。当遇到了新的问题时，假说产生者就造出假说。假说或策略建议者将选取一种策略继续进行下去。然后，实验建议者将提出将要进行的实验。两种类型的启发过程可能都需要决策者。实验者的结果由假说修订者和确证修订者来加以解释。合适时，问题产生者可能把新问题加入进来。如果实验的结果与对于实验的预期相抵触，那么对于这种迷惑人的现象的研究就成为一个任务，并列入议程。
    甚至该系统的组件也是一种操作者，它是由产生规则表来定义的。除了专业领域启发过程以外，系统还包含一般的规则，它们是一般研究方法论的部分。引人瞩目的是，特定的规则定义了这样的情形，即实验结果是某种“迷惑人的现象”。科学发现因此就成为了由问题求解启发过程引导的一个渐进过程，而不是由个别的“洞察闪光”或突然飞跃所导致的。这些以知识为基础的系统的例子，在例如程序DENDRAL是化学家的实验室助手的意义上，可以解释为哲学家对科学进行研究的助手。借助它们，可以对某些启发性规则产生的整个可能规律的空间进行调查。但是，它们是精确的助手，而不是主人。它们的“洞察的闪光”，这种由系统识别到的“惊奇之举”，是取决于程序框架的，是由主人设定的。
    激发了早期AI研究者的图林问题怎么样呢？“机器能否思维”？机器有“智能”吗？在我看来，这种问题对于计算机技术是一种形而上学的问题，因为“思维”和“智能”都不是清晰定义的计算机科学或AI的概念。
    这就是我们今天所能说的一切。如果一个程序产生出一种结构，该结构可以解释为一种新概念，那么所用变换规则就隐含地包含了这种概念和相应的数据结构。引导这些规则应用的算法，使得这种隐含给出的概念和数据结构变得明白起来。在关于AI的哲学讨论中，多数含混都是由AI的术语引起的，它是在技术意义上引入的，但是却结合进了一些往往是陈旧的和精致的哲学和心理学意义。在其他学科中，我们不得不与传统的术语和概念生活在一起，同样，如果将它们从其技术内容中抽象出来，那么它们就可能是高度含混的。“人工智能”（AI）中的“智能”概念就是一个例子。
    一个常常迷惑哲学家的术语是AI中“知识”的用法。让我再一次强调，在“以知识为基础的系统”术语中的“知识”具有技术上的意义，并不声称要解释整个哲学的、心理学的或社会学的知识概念。在AI技术中，作为实际的计算机科学的部分，完全没有涉及到哲学还原论。
    在所谓的“以知识为基础的系统”中的“知识处理”意味着一种新的复杂信息处理，这要与过去的仅仅是数字的数据处理区别开来。它涉及到翻译和解释的复杂变换规则，其特点是处于编程语言（今天是LISP或PROLOG）层次结构的较高水平上。这种水平接近于自然语言，但是当然不是等同于自然语言，而只是抓住了人类知识的广泛意义的一些方面（图5.12）。然而，知识处理仍然是程序控制的，并处在莱布尼茨的思维机械化的传统中。
    如果人的精神被认为一种图林类型的计算机，那么支配着人的身体和大脑的自然规律之间就没有什么关联。计算机软件中的算法程序并不取决于物理机械的硬件，而取决于数学上理想化的图林机概念。但是如果把人的精神理解为自然进化的产物，那么关于人的精神的形成的物理、化学和生物学的规律的关联性就必须加以考察。在现代物理学中，基本的物质理论是量子力学。在经典物理学中，物理系统的相互作用被设想成与人类观察者完全无关的过程，而现在看来人的意识也在测量过程中起着关键性的作用。首先，我将要尽量地批判这些解释，但是采取怀疑式的探究方式。然而，业已表明，量子力学是高效的广义量子计算机和量子复杂性理论的物理学框架，它们与经典的图林机和经典的复杂性理论是不相同的。

    显然，图林机可以在经典物理学框架中得到解释（图5．13）。这种计算机是一个物理系统，其动力演化使之从一组输入状态之一进入到一组输出状态之一。状态以某种系列方式加以标记。让机器处于一定输入水平的某个状态，随之进行某种确定性运动，然后再测量其输出状态。对于一个经典确定性系统，所测得的输出标记是输入标记的一个函数f。原则上，该标记值可以由外部观察者进行测量，这就是说该机器计算出了函数f。但是，经典的随机计算机和量子计算机并不计算上述意义上的函数。一台随机计算机的输出状态是随机的，依赖于输入状态的可能输出只是某种几率分布函数。量子计算机的输出状态，尽管完全是由输入状态确定的，但并非可观测的，因此观测者一般很难发现其标记。原因何在？我们必须记住量子力学的一些基本概念，这在2．3节中已经谈论过。
    经典的确定论机器：
    输入
    →
    输出
    经典可观测量
    确定论演化
    经典可观测量
    经典随机计算机：
    输入
    →
    输出
    经典可观测量
    随机演化
    经典可观测量
    量子计算机
    输入
    →
    输出
    量子可观测量
    确定论演化
    量子可观测量
    图5.13经典的和非经典的计算机
    在量子力学中，如动量或位置这样的矢量，必须用算符来代替，此种算符满足某种依赖于普朗克量子的非对易关系（图2．18）。由哈密顿函数描述的经典系统被量子系统代替，例如，电子或光子用哈密顿算符来描述。量子系统的状态由希尔伯特空间的矢量来描述，由其哈密顿算符的本征矢量来确定空间距离。算符状态的因果动力学是由叫做薛定谔方程的偏微分方程确定的。经典的可观测量是可对易的，而且总是取确定值，而非经典的量子系统的可观测量则不可对易，一般没有共同的本征矢量，结果也就没有确定的本征矢量。对于量子状态的可观测量，可以计算的只是统计的预期值。
    与经典力学的一个主要区别在于叠加原理。它揭示了量子力学的线性特征。在一个关联的纯量子叠加态，可观测量只有不定的本征值。简言之，量子力学的叠加或线性原理提供了复合系统相关（“关联”）状态，这得到了EPR实验的高度确证（Alain Aspect，1981）。从哲学上看，（量子）整体要大于其部分的加和。
    叠加原理对于量子系统的测量有重要的后果。在量子形式化中，一个量子系统和一套测量装置由两个希尔伯特空间来表示，它们以张量积组合起来H＝H1 [image] H2。以H1和H2分别出于两个独立的状态 [image] 和 [image] ，在时刻O，测量系统的始态 [image] （O），相应有 [image] （O）＝ [image] [image] [image] 。两个系统的因果发展是由薛定谔方程确定的，即 [image] （t）＝U（t） [image] （O），U（t）是归一化算符。由于U（t）的线性，态 [image] （t）是与不定本征值关联的，而测量仪器在时刻t显示出一定的测量值，它们显示出不同的测量值。因此，线性的量子动力学不可能解释测量过程。
    以更通俗的方式来说明测量过程，可以用薛定谔的一个关于猫的思想实验，其中涉及“死”和“生”两个状态的线性叠加（图5．14a）。设想一只猫，被关在一个封闭箱子中。箱子中装有镭，镭一小时发生一次衰变，其几率为1/2。如果发生了衰变，电路闭合，引起相应机制的动作，使得小锤打破装有氰氢酸的小瓶，从而杀死这只猫。该箱子继续保持封闭一小时。
    按照量子力学，猫的两种可能状态——死和生——都是不确定的，直到观测者打开箱子才能得到结论。对于箱子中的猫的状态，如薛定谔解释的，量子力学预见了一种相关（“关联”）的叠加态，即猫的死和活各占一半。按照测量过程，“死”和“活”状态被解释为测量指示器，代表着镭“发生了衰变”或“未发生衰变”状态。
    在玻尔、海森伯和其他人的哥本哈根解释中，测量过程被解释为所谓的“波包坍缩”，即把叠加态分裂成测量仪器的两个状态，并测得了量子系统有两个确定的本征值。显然，我们必须把量子系统的线性动力学与测量的非线性动作区别开来。原因在于，世界的非线性常常被解释为人的意识突现。

    欧基尼·威格纳（1961）主张，薛定谔方程的线性，对于有意识的观测者可能不适用，应该以某种非线性程序来代替，据此其中的任何一种选择都可以得到解决（图5．14b）。但是，威格纳的解释使我们不得不去相信，复杂的量子线性叠加仅仅在宇宙中出现了人这样的意识的角落，才将被分解为独立的部分。在弹子球、行星和星系的宏观世界中，EPR关联性是测量不到的，它只在基本粒子如光子的微观世界中才显示出来。显得十分奇怪的是，在宏观世界的独立系统状态——它们可以用具有确定测量值的经典力学来描述的，却是由人这样的意识引起的。

    埃弗里特的量子力学的“多世界”解释，将人的意识分裂成不同分支，使不同的、互不相容的世界受到抑制（图5.14c），从而仿佛避免了非线性还原的问题。

    在测量过程中，测量仪器和量子系统的动力学的描述使用的方程 [image] （t）＝ [image] ci（t） [image] i [image] [image] i，式中状态（ [image] i）涉及测量仪器的测量值。埃弗里特认为，态矢量 [image] （t）不分裂成部分状态，但是出现了所有的分支 [image] i [image] [image] i状态 [image] （t）描述了多重的同时存在的真实世界， [image] i [image] [image] i相应于第i个平行的世界。因此，所测量的分系统决非一个纯态。在埃弗里特的意义上， [image] n可以解释为相对态，它依赖于观察者或测量仪器的状态： n＝Cn-1（ [image] n， [image] ）H2。如果 [image] n被看作记忆状态，那么具有一定记忆的观察者只可能意识到他自己的世界分支 [image] n× [image] n。但是，他能够观测其他的分世界。
    埃弗里特解释的优点在于，叠加的非线性还原并不需要解释。而缺陷在于他的多世界的本体论信念，这样的世界原则上是不可观察的。因此，埃弗里特的解释（如果数学上协调）需要奥卡姆剃刀。
    在科学史上，拟人的或目的论的论据往往表明，科学在此存在着解释的分歧或失败。因此，一些科学家如罗杰尔·彭罗斯提出，量子力学的线性动力学对于解释出现意识的宇宙演化是不能令人信服的（爱因斯坦说它是“不完善的”）。他争辩道，线性量子力学和非线性广义相对论的统一理论，至少在原则上可以解释世界上的独立宏观系统状态，而不必牵涉到拟人的或目的论原理。在彭罗斯主张的统一理论中，物理系统的线性叠加，当系统对于相对论引力效应充分大时，就会分裂成独立状态。彭罗斯计算了在一个引力子水平上，对于这种效应的最小的曲率单位的情况。该思想是，这种水平应该令人满意地落在线性量子力学定律的原子、分子等等的量子水平与日常经验的
    经典水平之间。彭罗斯论据的优点在于，量子世界的线性与宏观世界的非线性将可能用统一的物理理论来解释，而不必牵涉任何人F的干预。当然，我们仍然缺乏可检验的统一理论（参照2．4节）。
    然而，由此引出的问题是，量子力学是否提供了人的大脑进化的框架，或至少为新的计算机技术去取代经典的计算机系统提供了框架。量子力学的基本思想是量子状态的叠加，这种叠加是由某种测量实现的线性量子动力学和叠加归并的结果。因此，一个量子计算机世界需要一种逻辑门的量子版本，在此输出将是某种统一算符应用于测量的输入和最终作用的结果。量子系统（例如光子）的叠加提醒我们计算的平行性。如果我们感兴趣的是对于许多计算结果的某种适当组合，而不是其部分的细节，量子计算机将变得非常有用。在此意义上，量子计算机可以在相对短的时间内实现可能的数量巨大的平行计算的叠加，从而克服经典计算系统的效率问题。但是，量子计算机仍将按照某种算法方式运行，因为它们的线性动力学是确定论的。测量的非线性将带来非确定论方面。因此，我们不可能期待，量子计算机将以超出图林机能力而以非算法算符方式运行。所以，量子计算机（如果它们构造出来了）对于复杂性理论和克服实际的计算约束可能更有趣。
    关于人的大脑，我们想要争辩的是，量子水平上的基本粒子、原子和分子对于其进化是必要的，而不是需要其他的东西——物理学相关态的归并所必要的大脑精神状态。实际上，相当多的神经元对于单个量子及其叠加和牵连状态的归并并不敏感。但是，这些量子状态当然不可能被大脑的精神状态所察觉。我们既不能意识到叠加，也不能意识到它们由非线性的随机事件引起的分裂成单个状态。然而，在大脑的精神状态的形成和相互作用中涉及到量子效应，它们还远未被满意地理解。
    5．3神经计算机和协同计算机
    在逻辑、经典力学和量子力学之后，我们还要考察复杂动力学系统对于计算机科学和人工智能发展的关系。显然，图林类型机的算法机制面临着严重的障碍是不可能随经典或量子计算机能力的增长而克服的。例如，模式识别和其他的关于人的感知的复杂任务，不可能由程序控制的计算机来把握。人脑的结构看来是完全不同的。
    在科学史上，大脑是用最先进的机器技术模型来说明的。因此，在机械化时代，大脑的功能被看作是沿着神经对于肌肉进行作的液压。随着电子技术的出现，大脑被拿来与电报或电话交换机进行比较。由于计算机的发展，大脑也就被当作最先进的计算机。在上一章中，我们见到，甚至量子计算机（如果它们被构造出来）也不可能使它们的能力增加到超出图林类型算法的复杂性。
    与程序控制的系列计算机不同，人的大脑和精神的特征包括矛盾性、不完全性、顽健性和抗噪声、混沌态、对于初始条件的敏感性最后但并非最不重要的是还有学习过程。这些特征在复杂系统探究方式中是众所周知的。关于图林类型和复杂系统的构造，一个根本的局限性来自经典系统的顺序的、集中的控制，而复杂动力系统是内在平行的和自组织的。
    然而，历史上，最初的神经网络计算机的设计仍然受到了图林机概念的影响。在麦卡洛克和皮茨的著名文章《神经活动中思想内在性的逻辑演算》（1943）中，作者提出了一种被神经元作为阈值逻辑单元的复杂模型，单元中有激发和抑制突触，这里就运用了罗素、希尔伯特、卡纳普及其他人的数理逻辑概念以及图林机概念。一个麦卡洛克-皮茨神经元在时刻n＋1发放一个沿其轴突的脉冲y，如果在时刻n它的输入x1，…，xm和权重WI，…，Wm的权重和超过了神经元的阈值O（图5．15a）。

    麦卡洛克-皮茨神经元的特殊应用是如下的逻辑关联模型：或门（图5．15b）模拟了句子x1和x2的逻辑析取x1ORx2（形式上是x1Ⅴx2），它为假，仅当x1和x2是假句子，否则它是真的。真值是二元表示0（代表假）和1（代表真）。对于阈值Θ=1和权重W1＝1和W2＝1，或门以x1w1-x2w2≥Θ的方式发放，只要x1或x2或者x1和x2都是1。
    与门（图5.15c）模拟了x1ANDx2的逻辑合取x1并x2（形式上是x1x2），它为真，仅当x1和x2是真句子，否则它是假的。对于阈值Θ＝2和权重w1＝1和w2＝1，与门以x1w1＋x2w2≥Θ的方式发放，仅仅当x1和x2都是1。
    非门（图5．15d）模拟逻辑否定NOTx1（形式上是x1），它为真，仅当x1是假的，否则它是假的。对于阈值Θ＝0和权重w1＝－1，非门以x1w1≥Θ的方式发放，仅当x1为0。因此如果x1是1，那么非门并不发放，这意味着输出y＝
    x1＝0
    一个麦卡洛克－皮茨神经网络是一个麦卡洛克－皮茨神经元系统：把每一神经元的输出分解成为线路而相互关联起来，其中一些输出还与其他神经元的输入相关联（图5．16）。尽管这种系统概念非常简单，但是任何“经典的”冯·诺意曼计算机都可以用这种神经元网络进行模拟。1954年，约翰·冯·诺意曼写了一篇报告稿。它以首次明确阐述存贮程序的思想而闻名，存贮程序与其要操作的数据都可驻留在计算机的记忆装置中。该历史文献表明，冯·诺意曼完全意识到用麦卡洛克－皮茨网络进行计算的可能性。

    数学上，一台冯·诺意曼计算机可以设想为一台有限自动机，包括有限输入集X、有限输出集Y和状态的有限集Q。有限自动机的动力学用下一状态的函数＆来定义，将时刻t的状态q和输入X变换为时刻t＋1的状态＆（q，X），以及将输出函数B与状态q关联成为输出B（q）。
    一台冯·诺意曼计算机的组件，诸如输入-输出单元、存贮器、逻辑控制单元和算法单元，都容易表明是有限自动机。甚至一台现代的数值计算机，它是由数千元素集成在芯片上的网络，也可以理解为麦卡洛克-皮茨类型的神经网络。一般地说，每一寄存机、图林机或递归函数，都可以用适当的有限自动机网络来模拟。但是这些麦卡洛克-皮茨神经网络的应用仍然是在程序控制系列计算机的框架中工作。
    最先试图将图林的通用计算机概念扩展到自繁殖自动机思想又是约翰冯诺意曼。他注意到，一台建造其他机器的机器，会降低被建造机的复杂性，因为它使用的材料不可能多于由建造机所给定的材料。与这种传统的机械观点相反，生物进化中的活的有机体看来至少是可以与其父代一样复杂，而在长期进化中会增加其复杂性（赫伯特·斯宾塞）。
    冯·诺意曼的细胞自动机概念，把活的有机体设想为细胞的自繁殖网络从而首次提出了为其建立数学模型的线索。态空间是均一点阵，它被划分为相同的元胞如同棋盘。一台初等的元胞自动机是一个元胞，它可以具有不同的状态，例如可以有“占态”（用一个记号）、“空态”或“色态”。初等自动机的集合体，被叫做一台复合自动机或构型。每一自动机都以其环境即相邻元胞为标志。自动机的动力学是由同步变换规则确定的。冯·诺意曼证明，活系统的典型特征，它们的繁殖自身的趋势，都可以用（平面上的）2 0个元胞的自动机来模拟，在此每一元胞有29种可能的状态，4个相邻角上的元胞则作为环境。
    这种思想由约翰·康韦发展了，他的元胞自动机可以模拟活系统群体的生长、变化和死亡。下面是一个简单的例子，其中元胞有两种可能的状态“占态”（记号）或“空态”，使用同步规则：
    1）生存规则：一个有2至3个占态相邻元胞的占态元胞保持不变化。
    2）死亡规则：一个元胞丢失了它的记号，如果它有3个以上的邻居元胞（“群体过密”）或少于两个邻居（“孤立”）。
    3）新生规则：如果一个空的元胞正好具有3个占态的相邻元胞，那么它就获得一个记号。
    图5．17a示意了一种构型在第三代的“死亡”，图5．17b示意在第二代的“生存”。康韦的理论还有一些更令人吃惊的结果，它们是通过计算机实验发现的。

    元胞自动机不仅仅是优美的计算机游戏。它们还是描述了其动力学演化的非线性偏微分方程复杂系统的离散化和量子化模型。让我们再想像一块类似棋盘的元胞的平面。一条有限的元胞串，构成了一台1维元胞机自动机，其中每一个元胞都可以取两种状态之一（“黑”（0）或“白”（1）），它仅仅与其两个最近相邻发生关联，在此它们交换关于其状态的信息。1维元胞自动机的紧随的（下一个）状态是空时平面紧随的元胞串，其中每一都由取得一种或两种状态的元胞构成，依赖于它们先前的（上一个）状态和它们的两个最近相邻。图5．18b－e表示4个元胞自动机在60步中的时间演化。因此，1维元胞自动机的动力学是由3个变量的布尔函数确定的，其中的每一个变量都可以取值0或1。

    对于3个变量和两个值，3个近邻有2[3]＝8种可能性。在图5．18a中，它们是按照相应的3个数字的二进制数排序的。对于3个近邻中的每一个，必定有一个规则确定中间元胞的随后状态。对于8个数字的序列和两种可能状态，有2[8]＝256种可能的组合。这些可能的组合之一，确定了一个1维元胞自动机的动力学，这示意在图5．18a中。
    每一规则，由8个数字的二进制数的状态来标志，这些状态是每一随后的元胞串可以采取的。这些二进制数可以按照它们的相应的十进制数来排序。
    这些规则的时间演化标志了1维元胞自动机的动力学，从随机的初始条件出发产生出非常不同的元胞模式。计算机实验给出了演化的元胞模式所要采取的如下的吸引子类型。经过一些步骤以后，类型1的系统到达了与起始条件无关的平衡均匀态。这种平衡终态示意为完全的白平面，并相应于某种作为吸引子的不动点（图5．18b）。
    类型2的系统，经过一些步骤后，表现出恒定的或周期的演化模式，它是相对独立于其起始条件的。模式的特定位置可能依赖于起始条件，但不是总体模式结构都取决于起始条件。
    类型3的系统向混沌态作为终态吸引子演化，而没有任何的总体周期性。这些混沌模式敏感地取决于起始条件，并表现出具有分数维数的自相似行为（图5．18d）。类型4的系统产生高度复杂的结构，具有局域传播形式（图5．18e）。类型3和4的系统对于微小的涨落是敏感的，微小的涨落可以影响秩序的总体变化（“蝴蝶效应”）。因此，在这些情形中，演化过程不可能作出长期预测。
    显然，这4种类型的元胞自动机模拟了自组织过程中大家熟悉的非线性复杂系统的吸引子行为。在前面的章节中，我们已经看见了许多物质、生命和精神－大脑进化的例子。在第6章中，我们将要考虑许多与人类社会进化的类似性。一般地，自组织被理解为复杂系统中的相变。宏观模式从微观元素的复杂非线性相互作用中出现。相变的不同终态相应于数学上不同的吸引子。
    在图2．27a－e中，已经对于流体的不同吸引子进行了考察，流速是逐步加速的。这些流体模式，与相应的元胞自动机的演化模式有许多相似之处。在最初的水平上，流体到达了均匀的平衡态（“不动点”）。在较高速度时，可以观察到两个或多个顶点的分叉，相应于周期的和准周期的吸引子。最后，有序衰退为确定论混沌，它是复杂系统的分形吸引子。元胞自动机的类型3和类型4对于建立过程模型极为有趣。类型3提供了混沌系统的演化模式。类型4表现了耗散系统的演化模式，这样的系统有时具有拟有机形式，它们可以在有机体和群体的进化中观察到。
    从方法论的观点看，一个一维的元胞自动机提供了一种离散的量子化相图模型，描述了依赖于一个空间变量的具有非线性偏微分演化方程的复杂系统的动力学行为。人们局限在离散模型的原因是多方面的。非线性系统的复杂性往往太大了，难以在合理的时间内计算出近似数值。在这种情形下，一个离散的模型对于系统的长期的总体动力学行为，可以提供大致的，但是充分的信息。如果进化规则的相关性被扩大到元胞串中的两个邻居以上，动力学行为就不同了。
    二维的元胞自动机，在康韦的生命游戏中已经使用了，可以被解释为采取非线性演化的复杂系统的离散模型，依赖于两个空间变量。显然，当非线性系统的复杂性增加，以及由求解微分方程或甚至由计算数值近似来确定其行为变得越来越无望时，元胞自动机是非常灵活有效的建模工具。
    从历史角度看，元胞自动机的现代发展可追溯到冯·诺意曼早期的自繁殖自动机思想。除了自繁殖以外，与传统的计算机相比较，还有另一个特征对于自然复杂系统是根本性的。人的大脑具有学习的可能性，例如，通过感知进行学习。在麦卡洛克－皮茨网络提供的大脑的一级逻辑模型中，人工神经元的功能对于所有时间都是不变的。麦卡洛克－皮茨成功地揭示出，这种类型的形式神经元网络可以计算任何有限的逻辑表示。
    但是，为了使神经计算机能够执行复杂的任务，有必要去发现自组织机制，使神经网络能够进行学习。唐纳德·霍布1949年提出的第一个神经生理学习现则，在神经计算机的发展中具有重要意义。神经元突触的敏感性并非一成不变，而是在改变着自身，以有利于重复出过去已经反复出现过的发放模式。
    1958年，罗森布洛特设计了第一台学习神经计算机，它以名字“感知机”而闻名。罗森布洛特原先是一位生理学家，专注于人的学习过程的生理学活动。他设计的学习机具有复杂的适应性行为，工程师和物理学家都很感兴趣。因此，用不着惊奇，生理学家的新颖思想被工程师抓住了，那些工程师对机器人和计算机技术，比对于模拟人脑中的过程，具有更大的兴趣。从技术的观点来看，神经计算机的学习程序是否与心－脑系统的学习过程类似不是根本性的。它们必须在管理复杂的适应行为时是有效的，但是可以利用完全不同于已知的生物进化中的方法。
    罗森布洛特的神经计算机是一种馈向网络，采用二进制阈值单元，有3个层次。第一层是感知面，叫做“视网膜”，它由刺激细胞构成（S单元）。S单元与中间层相联接，其间的权重固定，在学习中不发生变化。中间层的元素叫做联想细胞（A单元）。每一A单元都有某些S单元的固定权重的输入。换言之，一些S单元将其输出投射到一个A单元上。一个S单元还可以将其输出投射到几个A单元上。中间层是完全与输出层相联接的，输出层的元素叫做反应细胞（R单元）。中间层与输出层之间的权重是变量，因此是能够学习的。
    感知机被看作神经计算机，它可以将感知模式分成可能的若干组。在两组的情况下，每一R单元学习以激活和去活方式去区别输入模式。感知机的学习程序是受指导的。因此，必须清楚地认识与所要学习的模式相应的所希望的每一R单元的状态（激活或未被激活）。要学习的模式提供给了该网络，在中间层和输出层之间的权重按照学习规则进行适应。重复此程序，直至所有的模式产生出正确的输出。
    学习程序是一种简单的算法：对输出层的每一元素i，实际上输出o，它是由一定模式产生出来的，与所希望的输出d；相比较。如果oi＝di，那么该模式就已正确地分类。如果所希望的输出di等于1以及实际上的输出oi等于0，那么在时刻t的所有的权重wij（t）以及激活单元（oj＞0）在随后的步骤t＋1树放大，或形式上有wij（t＋1）＝Wij（t）＋σoj。常数u是学习速率，它可以按照其大小增加或减少学习的速度。如果所希望的输出等于0，实际上输出等于1，那么所有具有激活元素的权重都会消失，或形式上有wij（t＋1）＝wij（t）－σoj。
    感知机看来是以无所不能的神经网络开创了一个计算机技术的新时代。感知机小组在早期的文章中进行了如此的夸张。但是，1969年，尖锐的批评使得这种热情消失了。那一年，马尔文·闵斯基和西摩·帕佩特出版了一本著名的书《感知机》，书中以数学精确性讨论了感知机的局限性。对于这一分析的反应是，大多数研究小组都放弃了它们对于神经网络和复杂系统探究方式的兴趣，而转向经典的AI和计算机技术，看来这比感知机迷的“猜测”要更有益。
    但是1969年以后的这种科学共同体的态度，当然是又一次反应过度了。无批判的热情和无批判的谴责，对于科学的进化都是不合适的做法。达尔文进化用了成千上万年，才使得我们的大脑具有了模式识别的能力。如果我们的工程师只用几年就成功地构造出来类似的神经计算机，那就是奇迹了。
    关键是随后的一些问题。感知机能够干什么？不能干什么？感知机为何不能干？回答这些问题的一个基本步骤是闵斯基和帕佩特证明的所谓感知机收敛定理。它保证了原则上可用此种网络学习并可在有限的学习步骤中发现解。在这种意义上，系统收敛到一个解已经得到了证明。
    但是由此引出的问题是，特定的解是否原则上可以用感知机进行学习。一般地说，我们必须确定适用于感知机的问题类型。一些简单的例子表明，感知机并非如最初热情中所相信的那样是通用的。例如，一台感知机是不可能区别偶数和奇数的。一个特例是所谓的奇偶性问题对于初等逻辑的如下应用。
    感知机不能学习排除OR（缩写为XOR）。这种无法解决的认知任务是感知机应用于AI的一个严重局限。此原因容易说明。排除OR对于xXORy，仅当或x或y为真时为真，并非
    x和y都为真。一条OR语句的xORy，仅当x和y都为假时为假，否则为真。如下的表提供了布尔函数OR和XOR的值：

    现在，设想一个网络，有两个输入单元x和y，以及一个输出单元z，它们可以采取状态1（激活）和0（末激活）。要模拟XOR，对于一个偶的输入（两个输入单元都是激活的或都是末激活的），输出应该为0，而对于一个奇的输入（一个单元是激活的，另一个是末激活的），输出应该为1。在图5．19a，b中OR和XOR的可能输入构型示意在一个坐标系中，其中输人x和y作为坐标。

    坐标x和y的每一对（x，y）具有相应的值z，它是用白点（0）或黑点（1）来标记的。一个线性的阈值元素Θ计算加权输入x和y，权重是w1和w2，形式上即是Θ＝w1x＋w2y。一个简单的求导提供了一条直线，示意在图5．19a，b中。直线的位置是由权重w1和w2确定的。它将阈值元素的激活和末激活的状态隔离开来。
    为了求解（“学习”）OR问题或XOR问题，权重w1和w2必须以这样的方式加以调整，使点（x，y）以及值z＝1与具有0值的点隔离开。这种线性的隔离对于OR问题从几何上是可能的，但是对于XOR问题是不可能的。一般地说，感知机对于输入模式的分类，局限在线性隔离模式的范围。
    这种结果能够容易地被推广到两个以上输入单元和真值。许多问题在线性不可隔离的意义上，类似于XOR。实际上大多数有趣的计算问题都具有这种特征。XOR问题可以由加上一个隐含单元到具有两个输入与输出相关联的网络中来解决。隐含的元素是与输入和输出都关联的（图5.19c）。

    当两个输入都是0时，具有正值的隐含中间单元就关闭了。一个0信号到达输出，以及由于在这种情况下阈值为正，所以输出为零。如果两个输入中只有一个为1，隐含单元保持关闭，输出单元由输入和输出之间的直接关联而接通。最后，当两个输入都是1，隐含的单元发放到1，并以负的权重-2抑制了输出的接通。

    因此，隐含单元允许某种适当的内部表示。XOR问题已经成为一个在三维坐标体系中用二维平面进行线性分隔的问题，3维坐标系以输出单元的3个输入为坐标。分割是可能的，因为输入（1，1），现在z平面上移动到了点（1，1，1）（图5．19d）。
    一台感知机只有一个中间层，它是可以学习的处理元素。对于多层网络，问题是，对于与外界没有关联的多层神经元，产生的错误是不可能直接察觉的。一个错误可以是直接在输出层和其下的中间层之间产生的。
    多层神经网络可能具有的表示能力和问题求解能力，取决于学习层的数目和在这些层中的单元数目。因此，对于神经计算机的一个至关重要的问题就是要研究计算的复杂性，因为神经网络的复杂性的增加是从感知机的局限性中走出来的方式。
    在4．2节中，我们已经讨论了在多层神经网络中的后向传播（图4．17）。一个后向传播的学习算法使得我们去定义甚至处于隐含层上的一个错误的信号。输出层上的错误是递归地向后传播给下面的层次的。该算法是能够构造具有许多隐含层的网络的，其神经元能够进行学习。比起单层网络来，多层网络在其隐含的层次中可以表示多得多的信息，所以后向传播网络对于克服感知机的弱点是非常有用的模型。
    但是，后向传播仅仅从技术上提供了成功的模型，这些模型一般并不与生物进化相类似。它们的权重调整看来很不同于人们所知道的生物突触的行为。计算机技术的目的并不在于模拟大脑，而是在合理的时间内实现的问题有效求解。另一方面，我们必须要放弃孩童式的幻想，认为自然是类似上帝的工程师，进化中他总是在发现最好的解。正如我们在前面的章节已经强调的，自然中没有集中化的控制和编程单元。常常只有局部的解。它们一般并非是“最优”的。
    1988年，戈尔曼和西杰诺夫斯基设计了一种馈向网络，并用误差后向传播方法对其进行训练，试图将其用于区别岩石与矿石的声纳系统。要区别出岩石与矿石的回声是相当困难的，甚至用受过训练的人耳也难以胜任，而这对于海底的工程是相当重要的，海底工程需要能区别爆炸矿石和岩石的声纳系统。用于这种目的的网络构造中，输入层有60个单元，隐含层有1－24个单元以及两个输出单元，每一个代表将要进行区别的原型“矿石”或“岩石”（图5．20）。

    最初，一定的声纳回声是用频率分析器来处理的，它分解成60个不同的频率带。每一复盖间隔的值域在0和1之间。这些60个值是一个输入矢量的组分，输入矢量给予相应的输入单元。它们由隐含的单元进行变换，导致了两个输出单元之一的激活，这里的值也在0和1之间。因此在一个经过训练的很好调节了权重的网络中，一种矿石的回声导致输出信号（1，0），而岩石的回声则具有输出信号（0，1）。
    为了训练此网络，我们必须向它输入矿石和岩石回声的样品。在每一种情况下，输出单元的实际值，都按照相应的输入，进行了测量并与预期值进行比较。其差异是错误信号，引发单元中的权重发生小的变化。用这种梯度下降的程序，网络的权重就缓慢地进行了调整。
    戈尔曼和西杰诺夫斯基的矿石－岩石网络是复杂系统对于AI的一种应用。当然，它并没有声称，此系统在模拟人的大脑来区分像“矿石”和“岩石”这样两个概念。但是，我们可以说，这种技术系统也具有某种内部表示，即表示了作为其隐含层中原型矢量的两个概念。在这种限制的意义上，人工系统是有“智能”的，因为它可以完成在人脑情况下用智能来进行评价的任务。人工网络并不局限于对概念进行二元区分。1986年，西杰诺夫斯基和罗森伯格设计了一种叫做NETalk的网络，它已经学会了如何阅读。它采取从英语教科书中形成的字符串，并将它们转化成音素串以输入到语音合成器中。惊人的事实并不是它像小孩似的口吃的声音，在通俗书中它已经被赞为辉煌的成功。NETalk的基本能力是对于若干拼音概念的内部表示。对于字母表中的每一字母，至少有一个音素指定给它。对于许多字母，其中有若干音素需要标记，这取决于词汇的上下文。
    西杰诺夫斯基和罗森伯格运用了3层馈向网络。它有一个输入层，一个中间隐含层和一个输出层。尽管后向传播与生物学大脑中“自然地”实现颇为不同，但与其他的解相比，它都表现为最快的学习程序。输入层注视课文的七字符窗口，例如，图5．21a中的短语“The－phone－is－”中的词“phone”。每一个七字符都被29个神经元相继地进行了分析，每一神经元代表了字母表中的一个字母，也包括括号和标点。因此，正好是每一具有29个元素的神经子系统的一个神经元被激活。
    输出层包括26个神经元，每一个神经元表示一个拼音组分。对于拼音的位置有6个组分，对于发音有8个组分，对于音高有3个组分，对于标点法有4个组分，对于重读和音节划分有5个组分。于是，从这4组组分中，每一声音都有4种特征。输出层有7×29＝203个神经元，与80个隐含层内部神经元联结起来，它又是与输出层的26个神经元相互联结的（图5.21b）。在这些层中的神经元是不联结的。输入和输出层的神经元也是不直接联结的。
    隐含层的神经元接收来自203个输入神经元的信号，但是只把26个信号送给输出层。由于内部神经元是阈值单元，具有阈值T1，…，T8，输出是乘以特定权重的，这些积的和的大小决定了此神经元是否激活（图5．21c）。现实中，激活的发生是按照一个连续的“sigmoid曲线”，并非某种数字跃迁。
    最初，权重是随机固定的。因此，NETalk始于无意义的结结巴巴的发音。在学习阶段，NETalk运用了特殊的供小孩阅读的课文，其发单是人人皆知的。随机的声音与所希望的声音进行比较，权重由后向传播进行校正。令人瞩目的是，这种程序是一种自组织，而不是一种基于规则的发育程序。对于由实际输出来近似所希望的输出造成的权重改变，仅仅存在一种总体上的要求。对这种课文运行10遍以后，网络已经能够有理解地进行发音。经过50遍以后，就只有5％的错误了。在这一阶段，对于未知的供小孩阅读的课文的发音，错误也只有22％。

    今天，像NETalk这样的网络还必须用传统的冯·诺意曼计算机来模拟，因为还没有直接的复杂网络的硬件。因此，每一神经元必须顺序进行计算。甚至在今天，自组织复杂网络的原理还主要是在软件上实现的，而不是在硬件上实现的。然而，我们将谈论“神经计算机”，因为硬件的实现只是一个未来的技术发展问题，有赖于诸如固体材料或光学程序这样的新技术，而不是原则性的理论局限问题。
    由神经网络进行的映射，看来是颇为成功的，用于财政、保险和股票交易预见中是有益的。原因在于，对于股票行情的短期预测以混沌时间系列为基础，如果预测的时间周期减少，那么它就变得越来越混沌。
    通常的统计程序仅仅在长期预测中才是成功的，它假定了股票的发展可以平稳进行，而又不丢失有关信息。好的统计程序的精确性在60％－75％之间。但是，短期的预测则是颇为有限的。传统的统计程序为了平稳股市的发展，必须要忽略短期预测的基本特性，即经常发生着的小的交换涨落。通常的统计程序中，相关计算因子必须明确给出。一个经过良好训练并适当设计的神经网络能够识别出关联因子，而毋需明确的编程。它能够以自组织的程序权衡输入数据并减少预测的错误。而且，它可以采取改变系统环境的条件，而不像计算机程序必须由编程者明确改变。为了设计一个用于股票预测的神经网络，必须对股市数据进行二进制编码使之作为输入数据。输入矢量的构成中，包括若干分矢量，它们代表着交换量，从昨天来的绝对变化，变化方向，从前天来的变化方向，以及与昨天相比的大于1％的相关量。如果输入矢量具有固定的长度，例如40个单元，那么分矢量的长度可以有些不同，依赖于它们所希望的相关。该系统可以有两个输出单元。左边单元的激活标志了股票值的减少，而右边单元的激活则标志了增加。
    在学习阶段，网络中输入的是一定时期实际上的每天的交换率，例如从1989年2月9日至1989年4月18日。以这种学习数据为基础，该网络对于后面19天的发展进行预测。预测结果与实际上的曲线进行比较，以测量该系统的精确性。已经用后向传播方法对于几个多层结构进行了考察。它们以自组织方式发展起来对于预测特定的总体启发性。例如，如果一次预测接近该日期以后某天的实际值，那么错误就是相对小的。这种拇指规则的启发方式，在于这一事实：行情趋势的变化比起它保持不变来是更为不可能的。图5．22a，b示意了，预测曲线（＋）和对于银行（Commerzbank）、公司（Mercedes）的实际股票行情曲线（－）。

    显然，后向传播的馈向网络在技术上非常有趣，尽管它们看来与生物大脑中的信息处理没有多少相似性。在4．2节中，我们已经分析了具有反馈（图4．8b）和霍布类型学习（图4．9a）的霍普菲尔德系统，它显得也是生物大脑的工作方式。在均匀的布尔神经元网络的情形，神经元的两种状态可以与处于外磁场中的电子自旋的两个可能值联系起来。一个霍普菲尔德模型是一个动力学系统，与金属退火过程类比，将它看作是一种能量函数。由于它是非增的单调函数，系统进入局部能量极小值，相应于局部的稳定稳恒态（不动吸引子）。

    因此，霍普菲尔德系统的动力学演化可以相应于精神认识。例如，一个代表字母“A”的始态噪声图像向代表正确图像的终态演化，它用若干个例子来对系统进行了训练（图4．9b）。物理解释使用了平衡热力学的相变。正确的模式与不动点或平衡终态相联系。一个更灵活的推广是波耳兹曼机，它具有非确定论处理器元的随机网络构造，以及分布的知识表示，数学上相应于一个能量函数（图4．11b）。
    关于弛豫的一般思想是，一个网络收敛到以局域相互作用为基础的或多或少总体平衡状态。通过反复地修订局部的联接（例如在霍普菲尔德系统通过霍布学习策略），网络作为一个整体终于弛豫地进入了稳定的、优化的状态。我们可以说，局域相互作用导致了协同寻求，它不是受指导的，而是自组织的。一些网络对于精神类型的活动运用了协同寻求策略，例如，对于寻找可能的假设。设想竞争假说的一定范围由神经单元来表示，它们可以激活或抑制自己。于是该系统就离开了不太可能的假设，而奔向更可能的假设。
    1986年，麦卡洛克和拉梅尔哈德把这种认知解释运用于模拟两可图的识别。两可图是在格式塔心理学中为人们所熟知的问题。图5．23a示意了一个协同寻求的网络，模拟识别尼克尔立方体两种可能的取向之一。每一单元就是一种涉及尼克尔立方体的一个顶点的假设。缩写是B（黑）、F（前）、L（左）、R（右）。U（上）、L（下）。假设网络由两个联接的子网络构成，每一子网络相应于两种可能解释之一。

    不相容假设是负的联接，一致性假设是正的联接。权重的分配使得2个负的输入与3个正的输入格均衡。每一单元都具有3个正的相邻联接和2个竞争的负的联接。每一单元都接受来自激发的一个正的输入。要寻求的假设子网络是最适合于输入的网络。微小的涨落（观察者特定视野的某个小的细节）可以决定哪一种长期的取向被观察到。
    为使网络的动力学形象地表示出来，假定所有的单元都是关闭的。然后，一个单元接收了一个随机的正值输入。网络将向一个子网络的所有单元都被激活而所有其他网络的单元都被关闭的状态变化。在认知解释中，我们可以说，此系统已经弛豫地进入了尼克尔立方体两可图左面和右面的两种解释之一。

    图5.23b示意了3种不同的演化模式，它们敏感地依赖于不同的起初条件。环路的大小表明每一单元的激活程度。在第3种变化中，达到的是一种决非处在平衡态中的未确定的终态。显然，这种网络的构造原理是协同计算、分布表示和弛豫程序，这是人们在复杂系统动力学中所熟知的。
    过去已经提出来许多人工神经网络的设计。它们是受到不同的原理如物理学、化学、生物学、生理学的启发，有时只是出于技术的目的。复杂系统探究方式的共同原理是什么？在前面的章节中，协同学引进了作为处理非线性作用复杂系统的跨学科方法论。对于推动从许多科学学科中确立的共同原理来建立特殊复杂系统的模型，协同学看来是一种成功的自上而下的策略。其主要思想是：复杂系统整体状态的形成可以解释为，处于远离热平衡的学习策略中系统元素的（宏观的）相互作用的演化。整体的有序状态解释为相变的吸引子（不动点、周期、准周期或混沌）。
    例如，模式识别被解释为类似于应用在物理学、化学和生物学中的演化方程的相变。我们获得了一种跨学科的研究纲领，它使我们把神经计算的自组织解释为由共同原理支配的物理的、化学的和神经生物学的演化的自然结果。正如在模式形成的情形下，一种特定的识别模式（一张原型的脸）用序参量描述为一组所属特征的集合。
    一旦其中属于该序参量的部分特征给定了（例如一张脸的一部分），序参量将完成所有的其他特征，所以整个系统是作为联想记忆发生作用的（例如给出脸的一部分使脸面根据贮存的原型脸重建出来）。按照哈肯的役使原理，识别出来的模式的特征相应于模式生成期间受役使的子系统（图5．24）。

    如果将作为原型学习的一小部分脸部提供给一台协同计算机，那么它就能够用编码了的姓名来完成整张脸（图5．24b）。不同程度的模糊图像序列相应于协同计算机中状态的相变。
    当一个不完整的模式提供给神经元，在不同神经元状态——每一状态都相应于一个特定的原型模式——之间的竞争就开始了。这种竞争中取胜的是相应于原型模式的神经元系统的整体状态，它对所提供检验的模式有最大的相似性。与对于模式形成有效的动力学完全相似，当一个检验的模式提供给协同计算机时，它将把检验的模式从起始状态（t＝0）拉向一个特定的终态，相应于原型模式之一。
    检验模式的演化，可以用势场中具有一定位置矢量的粒子的阻尼运动来说明。图5.24c示意了一个这种二维势场的例子。这两个原型相应于两个低谷。如果提供了一个模式，它的特征不可能精确地表明与原型的特征一致，那么该粒子的位置就处于势场的低谷之外。显然，识别是一种对称破缺，这已在图4．20a中的一维例子中进行了说明。

    在协同学系统中，势场地形的形状可以由调整序参量来改变。由于协同学系统是开放的，控制参量可以代表能量、物质、信息或其他来自系统环境刺激的输入。当控制参量低于某个临界值，地形可以具有一个稳定的位置如图4．20a中的用虚线标出的一个低谷。在涨落引起的每一激发以后，序参量弛豫地向其静止态演化。当控制参量超过了一定的临界值时，先前稳定的状态就变得不稳定了而被图4．20a中两个低谷的两个稳定状态所取代。
    协同计算机的学习程序相应于势场地形的构造。势强度用地形形状表示，示意神经联接的突触力。协同学探究方式的一个优点在于，标志着一个模式的数量巨大的微观细节是用一个宏观序参量来确定的。因此，协同计算机运用了典型的复杂性约化方法，这种方法已经应用在自然进化的协同学模型中（对照3．3节）。
    序参量方程允许一种新的（非霍布的）学习，即一种最小化突触数量的策略。与旋晶类型的神经计算机（例如霍普菲尔德系统）相比较，神经元不是阈值元素，而是实施简单的乘法和加法。但是，旋晶类型的神经计算机与协同学计算机的基本区别在于：旋晶类型的复杂系统是物理学上的封闭系统。因此，它们的模式生成是由保守自组织推动的，没有任何的能量、物质或信息从外部输入。由保守自组织形成的典型模式是冬天窗户上的“死的”冰花，它们是在低能低温的平衡态冻结起来的。保守自组织的相变可以完全用波耳兹曼的平衡热力学原理来解释。
    在3．3节中，我们已经解释了活系统的模式生成。它只有在远离热平衡时输入能量、物质或信息，才是可能的。这种自组织叫做“耗散”自组织（普里戈金）或“协同”自组织。然而，它们甚至也是可以在物理学、化学进化中发现的。因此，作为活系统的人脑敏感地依赖于来自外部世界的涨落，它将为协同学框架中的新计算机技术提供“蓝图”或模型。自旋玻璃类型的神经计算机对于特定的技术目的可以是实用的、成功的。但是，由于它们是物理上封闭的系统，在原则上不同于如人脑这样的活系统中发生的东西。
    协同计算机的模式识别过程自发地产生出对于平移、旋转和标度的不变性。这些识别特征相应于现实的情形。例如，脸部并非总是如同学习阶段给出的那样，而是它们可以平移、旋转、缩小和放大、靠近和置远。协同计算机的一个出色的应用，是振荡的识别（例如两可图）和感知滞后现象。图5．25a示意了一个人们熟悉的滞后现象的例子。当人们的注视力开始从图的左边移向右边，一张男人的脸将在大约6幅模式以后变成一个女孩脸。当人们从相反的方向来进行，从感知到女孩变到一张男人的脸只有在接近左端时才发生。

    图5.25b示意了协同计算机在特征序参量的时间演化中的感知过程。间断线指的是解释“女孩”，实线指的是感知“脸部”。第一幅图示意了，从男人脸的感知向女孩的感知的转移，第二幅图示意了从女孩的感知向男人脸的感知的转移。
    也许可以提出反对意见，认为至今协同计算机仍然必须用传统的串行计算机来模拟。协同计算机的原理仅仅是在软件领域中实现了，而不是在机器的硬件中得到了实现。但是协同学及其跨学科应用将导致它的材料和技术上的实现。如同激光是一个为人们所熟悉的协同学模型（对照2．4节），它可能在协同学原理的光学计算机的构造中起着根本性作用。在激光中，不同的模出现依赖于激光阈值的临界值。它们可以由它们的光子数来标志。在微观水平上，光子数目的变化率是用非线性演化方程来描述的，依赖于模的获得、丢失和饱和。在宏观水平上，序参量相应于标志若干种光波迹的场幅度（图2．28a，b）。
    这是主张一种3层的构造，数据的输入层可以用全息图映射到激光上。激光及其序参量是中间层。它利用它的模，通过自组织起着决策装置的作用。在役使原理意义上的生存的模，
    激发起新的特征集合。这种水平被设想为输出层。协同计算机的激光构造当然必须得到实验的证实和改进。一台协同计算机将是一种真正的远离热平衡的耗散系统。
    显然，复杂动力学系统对于模拟认知行为和技术系统也很有用。人脑可以作为非线性复杂系统来建模，其动力学可以受到不动点、周期或准周期吸引子，甚至是混沌吸引子的支配。例如，实验上已经证明，混沌是一种有效的大脑再置的机制。在对兔子的嗅觉球进行了研究以后，人们对于种种气味的识别已经用神经网络趋向环状渐进状态的滞后现象进行了建模。混沌态在发散、消除先前的气味记忆时就出现了。在发散期间，特定气味作为输入推动了系统趋向相应于该气味的极限环。
    混沌态的技术应用是颇为有趣的，因为混沌系统能够产生信息。人们熟知的是，混沌系统敏感地依赖于其起始条件。因此，在动力学演化过程中，两条轨迹可以在一定时间惊人地分开，甚至它们的起始条件仅仅有微小差别时也是如此。由于任何观测都只能以有限精度来实现，因此就可能存在着两种不同的状态，其间的距离要小于我们的分辨能力。在初始状态，观测者看它们是相等的。但是，经过一段时间以后，一个混沌系统就使得在初始看来等同的状态之间的差异表现出来。
    实际上，人们已在若干工业领域中对神经计算机的技术应用进行了探索。例子有机器人学、航空学和宇航学（敏感和适应系统，空中导航等等）、医学（医疗数据、治疗和诊断等等的评价和控制）、工业生产（质量控制、产品优化等等）、安全技术、国防、通信技术、银行、邮政等等。技术中的复杂系统探究方式不应该被看作是对于经典AI的竞争甚或对立。在目前的技术发展状态，神经网络和经典的AI系统如专家系统看来是很有用的，并适用于不同的应用领域。对于信号、图像、语音、语音合成、机器人中感觉运动协调等等的分析和识别，复杂系统显得比经典的AI系统更为合适。显然，这些神经网络的例子并非是单个的计算机或机器人，而是指不同程度的复杂功能，它们集成在多任务的复合系统中。从拟人的观点看，由神经网络实际上管理的这些问题，可以划入“低级水平”的问题。
    在本章中，以AI类型专家系统为基础的推理模型已经失败了，因为它们精确的串行的程序行为是不容出错、没有灵活性的。与专家系统和知识工程相反，自组织的复杂过程不可能由明确形式化的专家知识来进行控制。另一方面，具有推理算法的以规则为基础的系统，在所有的具有逻辑结构的问题上都是成功的。例如，与感觉运动的协调相对照，逻辑编程显得是一种“高级水平”的知识。然而，低级水平的非线性动力学系统的问题却可以具有极其高度的复杂性。当然，非线性复杂系统并不局限于低级水平的知识，正如我们在前面的章节中已经看到的那样。复杂系统的原理看来是颇为适合于为高级功能建模，例如为概念、思维、自参照状态等等人脑的功能建模。但是，神经网络的技术仍然处于初期阶段。
    在当今和未来的技术中，具有多模的基于规则和复杂动力学系统的多相系统对于专门用途的研究是有意义的。一个语音理解系统的构成中，可以包含实施语音识别的神经网络和可以进行句法和语法分析的基于规则的符号模式。混成系统集成了推理和动力学技术，可能对于若干种医学目的是很有用的。例如，设想一个系统，它可以用神经网络来识别和控制医学参量，并结合了与以规则为基础的演绎系统，此种演绎系统可以从识别出的数据中对于特殊的疾病进行诊断。如同大自然中的情形，一个工程师不应该教条地局限在某个“最优”策略上，而是要有目的地发现解答，最终把若干个解集成起来，但不必是最优解的集成。
    5.4神经仿生学和电子空间
    我们所有实现神经和协同计算机的技术努力，其目的是什么？复杂系统探究方式将使我们能够在科学、技术、工业、经济以及甚至在文化生活中，创建一种新的计算机辅助方法论。但是我们决不要忘记，必须对技术发展的方向及其伦理学目标作出决定。今天，目标是多种多样的，包括认识论的兴趣和科学的兴趣，还有技术、经济、文化以及最后——但不是最少——还包括军事上的应用。毫无疑问，医学研究和应用必定在所有这些研究目标等级中处于较高等级上。这里要提醒持有老观念的读者，医学的目的不仅仅在于从事科学的认知和研究，而且还在于运用。运用也不仅仅是工程意义上知识的技术应用，而且也是为了医治、帮助和康复。知识和研究不过是实现医学的这种基本目的的工具，自从希波克拉底时代以来医学的基本目的就是保护生命。
    人的中心器官是大脑。因此，医学上保持大脑健康的任务这种重大责任就落在了神经医生身上。他们必须将其医学治疗看作是针对整个心-脑实体。为了对人的心-脑实体提供最仔细的可能医学治疗，需要一个应用性研究来致力于拓展和提高诊断和治疗能力，包括可能的神经手术、手术计划、手术技术和术后恢复。正如我们已认识到的，人的心-脑实体是进化中最复杂的系统。包括计算神经科学、物理学、工程学、分子生物学、医学和认识论的跨学科研究纲领，对于处理这种复杂系统是必要的。这也就是为什么，一些科学家已经开始了对大脑和精神的跨学科研究纲领，包括伦理学和人类学方面。我们将其称为“神经仿生学”。
    一般地，“仿生学”意味着用技术的和人工的程序和系统模拟自然功能和过程。众所周知的例子是，飞机和潜水艇的设计模仿了鸟类和鱼类身体的空气动力学。历史上，仿生学是人类的一种古老的梦想，即试图以用技术手段去模拟自然原理，从而解决复杂的生命问题。在这种传统中，神经仿生学意味着，阐明普通的技术－生物学如何去加强自然神经元的发生学和功能性质以及发展起神经修复术，制备出以硅片和（或者）有机材料为基础的类似于大脑的计算机系统。这并非一幅令人毛骨悚然的弗兰克斯坦的妖怪图景。为了推动人们投身于这些研究目标，只需要让人们看一看患有大脑肿瘤或受意外伤害的病人的凄凉情景就可以了。
    神经外科是关注中枢神经系统和人脑的专门医学学科。由于大脑是人的人格和智能的生物媒体，神经外科医生不仅仅要弄清有关大脑的神经学的原理，而且还要获取人的精神及其功能的知识。神经外科已经在病人治疗上取得了进步。通过引入诊断影视程序如计算机化和核磁共振断层照相术，手术中运用微手术程序，在这方面取得了显著的成功。
    不过，关于脑疾病人治疗的根本性问题仍然没有解决。例如，成人的中枢神经系统中，从功能角度看，仅仅可以换掉非常有限的受损区组织。这是由于与身体中的其他细胞截然不同，神经细胞在胚胎阶段完成以后不可能进一步分裂。只有胚胎的组织才有这样的潜能，可以使自己适合于周围的宿主组织。所以，疾病或事故引起神经细胞组的损坏往往导致永久性功能障碍。在这个应用领域，人工复杂系统及其自组织原理将受到高度关注。
    医学史上曾有过用自体移植物来恢复受损的周围神经的尝试。这种方法是以这样的事实为基础的：甚至成人也有能力再生神经细胞的伸展，这种伸展从脊髓索状组织伸向末梢区域直到目标器官。因此，部分功能上不重要的敏感神经被从身体中的适当地点移走，并插入想要恢复的被打断的神经区域。然而，被打断神经纤维的再生至今还没有得到完全的理解。因此，控制移植物的生长是不可能的，移植物中包括了数百的单个神经细胞伸展——它们应到达目标器官。由于中枢神经细胞是不可能再生的，对于非常接近脊髓索状组织的中心受损，移植也是无效的。
    对于周围神经移植的一个改进是在分子生物学的领域中提出来的。对于神经细胞及它们联接的细胞如星状细胞和施旺细胞的生理学和生物化学的理解，可能导致新的神经移植方法。一种中枢神经系统中组织替代的高级方法是身体中自己的细胞移植，这样的细胞在移植前已是遗传上选择过并适应了的。神经生长因子的效应、在移植源和受体大脑的目标区域之间的关系，以及许多其他分子生物学的问题都必须加以调查研究。这些方法是以遗传工程的知识为基础的。
    另一个周围神经移植的可能的方法，是运用人工的而不是生物的移植体。用人工替代物来恢复神经系统的受损部分，这在医学和神经病学中都已经进行了尝试。
    人工移植体配有学习算法作为自然的“蓝本”。与MCP（麦卡洛克和皮茨）网络不同，它们是工作在真实时间中的BPN（生物脉冲处理）网络。图5．26示意了这种神经－技术植入体的一般图式：学习神经网络编码感觉和运动控制信号，使之成为许多平行脉冲序列，它们被一组植人的微接触体接受，以刺激未受损的神经（图5．26a）。由神经寄存的信号，被神经网络解码，用来控制运动修补体（图5．26b）。
    人们对于脊髓索状组织受损的病人，也尝试了借助于BPN系统的电刺激来增进其站立和行走功能。假定末梢组织器是未受损的，末梢神经的电刺激引起了肌肉的收缩。这是由适应性学习网络的平行脉冲引起的，学习网络对病人的感觉系统的听觉命令进行编码（图5．26a）。这个系统具有学习能力，因为它通过把感觉反馈到运动的腿上，以适应特定的病人条件。但是，此系统仍然依赖于病人的意识和说话。在下一步的研究中，脑的无意识的意向性必须由脊髓索状组织中寄存的信号进行解码。然后这些信号可以被例如无线电波送往具有适应性神经编码器的接受器中，再引起如图5．26a所示的肌肉收缩。

    有一项雄心勃勃的神经技术项目，它针对的是一定类型的盲人。视网膜色点炎病人的视网膜层受到一定损坏，而视网膜是负责感觉轮廓、表面、颜色和其他的视觉特征的。受损的视网膜层由神经修补术沟通。在所谓的视网植人体的构造中，观景由镜框中的光子接受器（例如半导体）寄存，其中装备了某种适应性的神经网络。外部世界的光信号由神经网络（BPN）处理，神经网络能够学习像人眼一样为接受域建立模型。它们的信号被编码，并测距地输给诱导接受器，在此受损视网膜上排列有电极，以刺激光神经和中枢神经系统（CNS）。在更先进的研究阶段，将不再需要视镜排列，具有适应性神经网络的接受单元可以直接地植人眼中。在最初的试验中，神经技术不可能完全地取代种种视觉功能；然而，所存贮的轮廓和表面的感知，将有助于病人把握方向，这就是目前努力的目标。
    如果不同肌肉组的刺激可以直接在修复神经的末端分枝处进行，而不用无机金属电极，那么就可以获得决定性进展。这就必须要使用分子装置来实现生物技术的传导性，即要使用从有机分子设计制造出的电子元件。过程控制器控制着电极并处理信息，它必须以人工神经网络为基础，才能够实现高速数据处理，满足人的行走和站立的要求。显然，这些复杂神经网络的发展需要分子生物学、计算神经科学和高技术硬件工程的跨学科合作。
    人工替代受损神经功能的例子还有内耳的耳蜗移植。如果听觉神经是未受损的，通过微手术置入一个有25个极的电极作为皮质器官的代替物。听觉神经现在由适当的电极脉冲来激发，它们模拟了声音模式。脉冲是由串行的以语言知识进行了编码的微处理器来控制的。但是，在进行困难的移去听觉神经的赘生物手术中，有听觉神经受损坏的危险，结果会造成病人变聋。今天有可能把人工神经网络直接联接在中心听觉通道的区域。于是听觉可以得到恢复而不论听觉神经丢失与否。生物技术、计算神经科学和工程技术的跨学科合作再一次表明是必要的。
    一般来说，神经外科手术必须要考虑到如下的临床观点：神经外科的诊断、手术计划、手术技术和神经的康复，这些是受生物技术和计算神经科学中的复杂系统探究方式支持的。在诊断方面，计算机化的断层显示过程已经开创了一个新时代。由于神经外科医生不得不处理一种进化中的最复杂的器官，手术计划和进行模拟已成为准备取得成功医治的一个基本步骤。在这一方面，复杂性意味着病人的人格特征，涉及他或她的特定病史，一定致病过程的病理，个体的解剖特征以及一个手术的可能手术后果。
    一种新的方法已经用于实践。一个神经外科手术可以用CAD（计算机辅助设计）辅助技术来进行模拟。用计算机产生出一个病理解剖的三维构造，它是由一个特殊的程序来控制的。在模拟中可以发现潜在的困难，从而在实际的手术中得以避免。手术技术的不断发展将减少实际的大型开放手术。立体视镜和内窥镜技术对于减少手术引起的损伤是重要的方法。激光技术与神经外科内窥镜、术内显示过程、计算机控制的调节技术结合的进一步发展，将成为一种有广泛应用的复杂手术工具。
    在波士顿的麻省普通医院的一个研究小组，已经用磁共振成像技术（MRI）揭示了人的任务激活的功能成像图，这种任务激活是在视皮层中由光刺激引起的。按时间周期地注入对比剂。采用快速NRI扫描而不用注射，甚至初级的视觉皮层成像也实现了。图5.27显示了作为神经网络的脑认知活动的真实的时间成像。这些高级的基于计算机的复杂神经网络的图像，不仅仅有助于受损的病人，而且最终使我们看见自己的思维和情感。

    发展人工神经网络的最重要动力来自这样的事实：以化学元素硅为基础的高度集成电路的生产，将达到它的物理极限。这种技术以程序控制的微处理器原理为基础，不可能进一步微型化。自组织的高度平行计算和策略对于处理大脑的复杂性是必要的。因此，运用某种新的底物来作为信息处理系统的基础，就显得必要了。在此迈出的第一步是开始发展以生物元件为基础的分子电子器件。在神经细胞之间的电信号可能通过有机传导物进行传导。
    关于计算神经科学，神经网络的计算机模拟可以有助于鉴明由中枢神经系统和大脑实际运用的算法。现在研究的人工神经网络模型，主要是用矢量计算机、工作站、特殊的合作处理器或移植芯片（transputer arrays）来进行模拟研究。但是，当然，复杂网络中的空间－时间平行计算的优点，在用经典计算机来进行模拟时已是全部地或部分地丢失了。只有用特殊设计的神经硬件，才能满足实时任务的要求。
    在未来的神经仿生学应用中，神经芯片的训练将引起巨大复杂性的非线性作用动力学，这样的芯片可用作人的神经纤维之间的界面。芯片的设计者面临着相互联结的问题：如果成千上万的权重线路要以物理方式联接起来成一个神经元，并要作出数千个神经元，那么这个线路区域将达到这样的数量级，即线路引起的时间延迟将超过代表神经元功能块的运行时间。由于技术结构尺寸的减少受到经济上和物理上的限制，仿生学的设计者现在对相互联结问题倾向于一种构造解。首先，他们要考察神经网络的真实处理时间；其次，要考虑在何种程度上有可能偏离理想的大规模平行计算。
    显然，平行计算硬件将显著增加软件的复杂性，并需要新的方法。强大的操作系统。编程工具和灵活的使用者界面都必须这样设计，使得容易与系统进行界面通信。这种任务，在由计算机科学知识程度不一的人员组成的跨学科队伍中将变得特别重要；以知识为基础的专家系统可以有助于研究小组成员，使之与仿生软件一起工作，并将它们集成进研究小组中。编程神经网络硬件将完全不同于经典的冯·诸葛曼计算机的编程。一位编程者必须要鉴明必要的网络拓扑和构造，还必须说明具有相互联结图式的神经元的行为。因此，运用多相的、混成的系统——集成神经网络系统和经典的以知识为基础的系统（在5.2节中已描述），成为神经仿生学中的现实观点。
    有些人可能担心，混成的计算机系统及其复杂性的增长不经过高度的专门训练，是不可能把握的。现在的计算机系统和使用者之间的界面必须加以发展。计算机生成图像的操作，应该在“虚拟现实”中直接由语音、视觉和触觉来进行。使用者将获得这样的印象，即通过若干种与其感官相连的技术设备来获得计算机产生的现实的印象。

    视觉印象是由操作者及位置感知器——它可以作为眼睛罩戴上——产生的。一个小话筒与语音识别系统联系起来，把人的命令翻译给系统。所谓的“数据手套”把手和手指的运动变换成电信号，产生出触觉并进行建模（图5．28）。
    在数据手套中，在两层布之间埋设了光学纤维。它们以特定的模式把光信号变换成电信号。例如，这一技术在航空学中已经有了实际的应用。美国国家航空与宇宙航行局对于机器人的发展很感兴趣，通过模拟空间站中宇航员的手的运动，机器人可以在空间执行复杂而危险的行动。看来可能的是，数据手套原理，甚至适用于模拟整个身体的运动和反应的数据服。
    这种情形对于人类的想像力有久远的影响。因此，化学中的分子建模，不仅仅可以用计算机来实现，而且也可以用引入触觉要素来实现。通过数据手套的手段，化学家可以想像抓住一个分子，感觉到它的表面并以所希望的方式对它进行操作。工程师试图通过特殊的技术系统，产生出这些接触和用力的效应。在虚拟现实中，通过数据手套进行的人的操作，必定要接受触觉到的影像客体的反馈。经验世界的复杂性，应该在所有方面被模拟。
    宇航学和化学的例子中，模型的虚拟现实相应于宏观和微观宇宙中的某种真实现实。但是，图像计算机产生的奇妙世界景色，仅仅是作为电子实在而存在。在技术可能性与科学幻想之间的界限看来是模糊的。在计算机产生的“远程现实”中，人们感觉到如同影像物体。已经有人建议构造一种所谓的“家庭现实发动机”，它把使用者移入所希望的和不希望的幻想的虚拟世界。如果你愿意，你就可以与玛丽莲·梦露有性关系，或是与阿尔伯特·爱因斯坦进行讨论，这都是计算机产生的虚拟实在——预言家就这样向人们保证。科幻作家如威廉姆·吉布逊描述了由计算机产生的世界——“电子空间”，它将由人们作为惊人的幻觉而经历：
    电子空间，每天由成千上万合法操作者经历的交感幻觉，无论在哪个国家，只要是学习了数学概念的孩子……都可以从人类社会中所有的计算机库数据中提取出来的数据图形表示，获得不可思议的复杂性。光线布满精神的非空间中，数据奔流激荡，如同城市中的照明，退去了……
    这些见解，当然对于我们文化的发展提出了根本性的批判。人们被锁在塞满自己隐私的箱子中，或操作着由超级克雷和神经网络产生的虚拟现实，这看来是一幅如同奥韦尔的《老兄》（Big Brother）中那样的可怕图景。
    除了那些伦理学问题以外，还有一些严重的认识论问题，它们是计算机产生复杂人工世界的可能性问题。在传统的认识论中，哲学家如贝克莱和休谟采取了唯我论和怀疑论的立场，认为任何手段都不可能证明外在世界的实在性。我们所有的印象也许都是由我们的大脑及其精神状态产生出来的幻象。这些迷惑人的问题，并非是如同孩子般的不诸世事的哲学家的玩笑。它们应该是推动我们去考察和分析我们的论据的有效性的动力。现代逻辑学家和精神哲学家如希拉里·普特南已经以如下的方式对这些问题进行了翻译，它使我们想起了著名的图林试验。
    设想一个人被一位“邪恶科学家”动了一次手术。他的大脑已经从身体上移去，置入充满营养物的罐子中，保持大脑还活着。其神经末梢与混成的神经计算机联接起来，使此人——他的大脑——仍然获得对一切事物完全正常的幻觉。他所经历的一切，都来自计算机对于神经末梢的电刺激。如果此人想要举起他的手，计算机的反馈将使他“看见”和“感觉”到手被举起，尽管存在着的仅仅是大脑中相应的模式，而非物理的眼睛或耳朵。那位邪恶的科学家可以使这个可怜的人经历任何情形。普南特说：
    这个受害者甚至可以觉得自己正在阅读这些令人愉悦的但是相当荒谬的假设：一位邪恶的科学家把人们的大脑从身体中移去，并将它置入充满营养物的罐子中，保持此大脑活着。再将其神经末梢与超级科学计算机联接起来，使此人即他的大脑获得幻觉……
    如果我们的大脑以这种方式置于一口罐子中，我们能够说我们还是自己吗？普南特争辩道，我们不能。我们实际上是置于一口罐子中的大脑这个命题不可能是真的，因为它是自驳斥的。自驳斥的命题是这样一种命题，其真意味着其伪。一个逻辑上的例子是万能定律：所有的普遍陈述都是假的。如果它是真的，那么因为它的普遍性，它就必定是假的。一个认识论的例子是定理“我不存在”，如果这是由我所思维到的，它就是自驳斥的，因此，笛卡尔的论据是，人们可以确信自己的存在，只要人一想到这个定理。我们是置于罐子中的大脑这一命题就具有这一性质。
    假定我们是置于营养液罐子中的大脑，传入神经末梢与超级神经计算机联接，产生出大脑的所有感觉产物。由于置于罐子中的人的大脑在很好地发挥功能，当然它就有意识和智能。但是，它的关于树、马等等的思想和形象都与实际的树。马等等没有因果联系，因为实际的树、马等等是处于罐子中的大脑的外部世界，而这些思想和形象是由我们的超级神经计算机产生的。因此，如果我们假定，我们是置于具有所有这些条件的罐子中的大脑，那么词汇“罐子”、“营养液”等等，也就不涉及一个实际的罐子、营养液等等，而是涉及由我们的超级神经计算机产生的一定的思想和形象。结果是，“我们是置于罐子中的大脑”这个句子是假的（图5．29）。

    我们必须意识到这样的可能性，即我们是置于罐子中的大脑，并非被物理学、而是被逻辑和哲学排除。物理学上的可能世界——我们是置于罐子中的大脑——与物理学定律是相容的。但是，在一个思想实验中，我们甚至能够必然地导出超出物理世界的真结论。
    这些特征的原因看来要归于自参照性的结构，这是心-脑系统高级能力的典型特征。在4．3节和4．4节中，我们已经论证了，自参照性可能是使得意识和自我意识成为可能的根本特征，不仅仅是对于作为生物进化产物的心-脑系统是如此，而且甚至对于采取了完全不同硬件的人工复杂系统也是如此。
    图林自己主张一种人们熟知的检验，它可以确定一个如计算机那样的人工系统是否是有意识的：让一个人在一个键盘上与计算机进行交谈，以及与一个并不知道的人进行类似的交谈。如果他不能区分出哪一个是计算机，哪一个是人，那么计算机就是有意识的。简言之，一台计算机，如果它可以通过图林检验，就是有意识的。
    关于“罐子中的大脑”的思想实验已经表明，图林的对话检验必定会在某些特定意义上失效。由人工系统使用的词语和句子并不必涉及到实际的对象和事件，而我们在人的自然语言中要涉及到它们。词语和句子的使用可以是由句法模式支配的，它们能够被以高度精致的方式编程为图林机。魏征鲍姆的程序ELIZA模拟了病人与心理学家的对话，可以提供这些可能性的最初线索。在此意义上，图林检验不可能排除，机器的谈话仅仅是一种类似于有智能的人的演讲的句法演示。然而，原则上不可能排除，自组织的复杂系统，通过以原型模式和对于环境的经验作为特殊参考，是能够学习它们的合乎句法的词语和规则的。从这种长远观点看，它是一个伦理问题，即我们是否想要发展那些高度自主的（耗散）系统。

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页


克劳斯·迈因策尔—复杂性中的思维—6、复杂系统和人类社会的进化

6、复杂系统和人类社会的进化

    人们怎样解释人类社会中政治的、社会的和经济的秩序的形成呢？本章首先扼要回顾了从古代以来的政治系统和经济系统的历史。对于政治的、经济的秩序的历史思想，人们常常使用相应时代的技术的、物理的和生物的概念来加以说明。在17世纪，托马斯·霍布斯力图把伽利略和笛卡尔的运动定律从力学移植到人类学和国家理论中。重农主义的绝对国家经济系统模型如同18世纪的机械装置（6.1节）。洛克、休谟和斯密的自由主义思想，具有牛顿物理学的历史背景。直到不久前，主流经济学还经常从线性数学、经典力学、热平衡热力学中获得灵感，有时还从达尔文进化论的模型中得到启发。像许多物理学家一样，经济学家相信他们的（线性）模型的精确可计算性，压抑了导致混沌的“蝴蝶效应”的可能性，并排除对于经济的长期预测（6.2节）。
    要描述一种经济的动力学，就必须要有包含许多经济量的演化方程，这些量可能包括数以千计的部门和数以百万计的因素。因为一事物总是依赖于其他事物，这样的方程将是耦合的、非线性的，以能建立起经济复杂性的模型。特别是，现代高技术工业的经济行为和技术创新的效应，表明最好使用复杂系统的非线性动力学来建模（6．3节）。复杂系统探究方式的关键之处在于，从宏观的观点看，政治的、社会的或文化的秩序并非仅仅是单个意向的加和，而且还是非线性相互作用的集体后果。6．4节，在复杂动力学系统的框架中分析了复杂的社会和文化问题的例子：城市中心的生长，全球性的迁移问题和复杂组织的管理问题。该章最后考察了复杂的通信网络，提供了对世界性的“地球村”的前景以及人类由于现代高技术程序而受到的奴役。
    6．1从亚里士多德的城邦到霍布斯的利维坦
    在讨论了物质、生命、心-脑和人工智能的进化以后，本书最后讨论如下的问题：人类社会的进化是否可以至少是部分地在复杂系统的框架中加以描述和建模。在社会科学中，人们通常在生物学进化和人类社会历史之间作出严格的区分。原因在于，国家的、市场的和文化的发展被假定是由人类的意向性行为所指引的，即人类的决策是以意向性和价值为基础的。
    从微观的角度看，我们实际上观察到的是一个个有着自己意向、信念等等的个体。但是从宏观角度来看，国家、市场和文化发展却大于其部分的加和。政治、社会、经济秩序的形成，表现为是由自组织步骤引起的，从而提示了复杂系统中的某些相变过程。然而，为避免任何种类的自然主义或物理主义的还原论，我们应该考虑人类社会特有的意向特征。在3．4节和4．3节中，已经在复杂系统探究方式的框架中为动物群体的演化建立了模型。诸如社会秩序、社会行为组织、巢穴的构造等等宏观结构，都用复杂系统的吸引子来解释。但是，尽管动物群体和人类社会有共同的起源，存在着共同的特征，它们之间的复杂性差异数不胜数。因此，在后续的叙述中，诸如“进化”、“本性’嘟不能限制在分子、鱼类、蚂蚁等等的机制中。它们意味着某种新的复杂动力学，对此进行的分析必须考虑到社会哲学的长久传统。
    柏拉图和亚里士多德是最早试图解释人类社会的政治、社会和经济秩序形成的哲学家。他们分析了成为西方社会和国家起源的古希腊城邦（polis）的结构。在古希腊典籍中，城邦（xoYL＆）例如雅典，是一个小城市共和国，可与后来文艺复兴时期意大利的佛罗伦萨和威尼斯的行政区相比较，或许还可以与现代瑞士市级的行政区相比较。古希腊的城邦不大，但是在政治上经济上几乎是自主的国家和社会。古希腊的哲学家提出的一种理想的模式或多或少由这些历史实例实现了。
    柏拉图区分了几种转变的阶段，它们是一个城邦在实现和谐社会的最终目标过程中必定要经历的阶段。在第一个阶段，公民必须要学习种种技能和职业、商业和贸易，以满足整个社区的种种不同需要。柏拉图相信，城邦的公民必须要根据其天赋不同实现不同的专业化。公民为了合作工作必须组织起来。柏拉图提出，通过自发的自组织，他们的产品和服务的交换实现某种工作和需求的平衡。这种平衡的经济状态的特征是“公平”价格。
    但是，柏拉图的田园诗般质朴合作的世界当然是不稳定的。人们力图追求自身的利益和获得好处。他们是自私的、不正派的，充满着嫉妒，由情欲所驱动的。于是就产生了冲突，就必须组织起政治权力以避免城邦的毁灭。柏拉图提出一种由精英、最智慧者（“哲学王”）管理国家的贵族政治。其政府的作用就是要使充满着冲突起伏的整个系统保持着某种平衡态。众所周知，柏拉图不相信民主，因为在他看来，没有受过哲学教育的普通人是无法认识真正公平的理念的。柏拉图相信，在变化着的短暂的表面世界背后，存在着一种永恒的伦理价值等级。因此，也存在着一种人们必须意识到的客观的价值尺度，以避免混沌、保持国家系统的和谐。
    显然，柏拉图在捍卫一种集权式的政治权力系统。用系统理论的语言来说，即有一种中心化的处理者，控制着系统元素的所有行动和反应。如同科学世界中的拉普拉斯妖，这里有一个柏拉图的政治神话，即由理想的、聪明的和善良的政治家领导着一种和谐平衡系统。在一个像古希腊城邦的小城市中，在某些批判性气氛下，柏拉图的最佳“哲学王”的贵族政治也许是正当的。然而，真实的历史经验已经表明，甚至有教养的、有智慧的政治领导人也难逃滥用权力的诱惑。在今天的世界上，柏拉图的精英贵族政治犹如以知识为基础的复杂社会中的专家的权力。但是，在现在信息和计算机技术高度发展的条件下，柏拉图的聪明和善良政治家的神话容易转变为奥韦尔的恐怖剧中具有万能控制力量的“大兄弟”。
    涉及古希腊城邦的第二位著名哲学家是亚里士多德。他假定，人在本性上是希望求生的社会动物。而且，他们是政治动物，因为他们希望生活得美满幸福。亚里士多德相信有机发展的人类社会，是由其成员的社会本性和政治本性所推动的。当城邦的社会和政治形式得以实现时，社会的和政治的动力学就达到了一种最终的平衡态。亚里士多德把过程作为这种社会的和政治的动力学的本质。
    不过，自然的动力学过程并非被想像为一种因果的机械运动，而是被想像为一种像植物和动物那样的有机物生长，从最初的种子的状态开始，目的是最终实现其完整形式的终态（对照2．2节）。于是，在人类是由他们的社会本性和政治本性的冲动所推动的意义上，亚里士多德的社会模型是一种自然主义模型。但是，只有为了生存的目的而进行社会组织的这种人类本能才与动物是共通的。人类以其政治本性是要实现一种公正社会而与动物相区别。亚里士多德的著名观点是，人类是追求科学和哲学真理的理性动物，也是追求社会公正的政治动物。
    公正意昧着一种完美的自然状态，如果社会是按照其平衡和谐比例来安排，犹如阿基米德天平的静态平衡一样（图6.1）。因此，在亚里士多德社会中的经济平衡是由“公平的价格”来度量的，这样的价格是物品和服务的“自然”价值。经济学也就成为亚里士多德的关于公正和国家的道德哲学中的一部分。他区分了交易公平（justitia commutativa）和归属公平（justitiadistributiva），前者涉及私人交换和公民事务，后者涉及私人和国家的关系。亚里士多德的经济公正和政治公正模型成为中世纪的主导思想。显然，在那个时代，它与亚里士多德的自然概念是一致的。
    机械自然现是由伽利略、笛卡尔和其他一些人奠基的，它导致了牛顿宏大的经典物理学系统。托马斯·霍布斯在其名著《利维坦或物质，共同财富的形式和权力，基督教会和公民》（1651）中，提出了一种机械论的近代社会和国家的模型。霍布斯生活在一个发生着巨大政治变化的时期，即中世纪结束和近代发韧的时期。中世纪传统的君主政治和贵族政治已经失去了其宗教合法性。在血腥的内战中，欧洲社会和国家陷人毁灭和混乱之中。科学上，伽利略的机械论新方法及其在物理学中的成功给霍布斯留下了深刻印象。因此，他力图运用这种方法以发现一种近代社会的机械论模型，其中没有陈旧的传统形而上学来损害它在科学和政治中的合法性。

    在伽利略力学中，有一种把一个系统（“物体”）分解成为其独立元素的分析或分解方法，以及一种再把这些独立的建筑块装配或统一成整个系统的综合方法。简言之，整体就是其部分之和。显然，伽利略描述了关键性的叠加原理，奠定了线性的机械论世界观。实际上，一个如同钟表一样的机械系统，能够分解成诸如嵌齿轮和其他机械部件那样的独立元件，这些元件装配在一起构成了其完美的功能。
    霍布斯力图把运动定律从力学转移到人类学和国家理论。人们被假定为由情感和情绪推动的，如同肉体是由机械动力推动的一样。主要的情感因素是自我保护和求生个体的本能。在霍布斯看来，追求生存的本能是人的一种自然权力，并导致对其他人的暴力和侵犯。因此，在霍布斯的人类社会的自然状态中，就存在着一切人反对一切人（bellum omnium contra omnes）的永恒斗争，而没有任何平衡态。
    另一方面，具有复杂需要的人们只能在社会中生存。因此，他们的理性支配了一种追求和平的第一自然定律。为了实现“和平定律”，就需要第二定律，即需要有一种社会契约。霍布斯指出，在这种社会契约中，所有的公民都必须把他们的自然权力转移给一位“利维坦”（“Leviathan”），唯有这位绝对君主才有权实施政治权力，统治国家。用现代语言来说，霍布斯的社会契约使得国家的权力垄断具有合法性，以保持社会处于某种绝对平衡。
    霍布斯把绝对君主权定义为制订社会契约的“所有个体之和”。显然，这种思想是伽利略的叠加性或线性的力学原理的运用。霍布斯著作的标题页上（图6．2）表明，利维坦的身体是单个个体组成的巨大复杂系统，这说明了霍布斯的线性政治原理。
    从混沌的自然状态到政治有序和平衡状态的“相变”，是由全体公民的社会契约来实现的，正是在这种意义上也就是由自组织来实现的。但是，利维坦的终态却是一个集权化的确定论系统，其中对公民不存在任何的政治“自由度”。霍布斯将物品和金钱的经济循环比作血液的循环，血液循环是由英国医生威廉姆·哈维发现的。心脏是推动整个循环的一台机械泵，收入和消费也就被比作血液的泵入和泵出。
    这种机械的经济观点，后来由法国科学家、重农主义经济学派奠基人弗朗索瓦·魁奈（1694－1774）进一步阐述。魁奈最初是路易十四宫廷里的一位医生，受到社会机体经济思想的影响，他写了关于人类身体的“动物经济”的著作。笛卡尔的机械世界观是重农主义的主导哲学。

    于是，经济系统就被描述为由齿轮、发条和钟锤组成的机械钟装置。一台时钟就是一个已经预先编好程序功能的顺序执行系统。相应地，重农主义经济是不能自我调节的。农业的进展，被重农主义经济看作推动力，被比作一台时钟中的发条和弹簧。经济生产被比作时钟中的复合运动。结果，经济的前景也就仅仅由调节类似于时钟的经济循环来保证。

    重农主义者用一张特殊的表使得财富在不同社会阶层——农民（“生产阶层”）、商人（“不生产阶层”）和地主——中的流通形象化。在图6．3a中，经济周期开始于地主阶层将他们收入的地租（假定是2亿金路易）进行分配，左栏表示地租中给予农民以购买食物和农产品的份额（1亿金路易），右栏表示给予商人，以购买货物的份额（1亿金路易）两项收入使农民和商人两个阶层能够再生产新的物品。随着农民用商人的产品，商人也用农产品，金钱也就在相应的阶层的两栏之间进行流通。这种流通形成了一种齿状曲线，直到获得了表中的底部给出的净利润。
    但是，为了开始新的经济循环，净利润的消费导致新的收入进行新的消费成为可能，这就会再生产出净利润。调节流通和净利润的重复再生产的机械过程，用带有滚动球的时钟来说明（图6．3b）。时钟借助滚动球沿着斜面齿状途径向下滚动来计时。经过一个流通周期以后，球再提高到系统的顶部，这种过程就重新开始。显然，在一个流通周期中净利润的分配可以比作此机械装置中的滚动球的齿状途径。经济流动周期的周而复始相应于把球提高后再沿着齿状途径向下滚动。

    重农主义经济学家运用了笛卡尔力学框架的物理模型。他们的因果决定论中排除了任何种类的自我调节或个体自由，完全相应于绝对主义政治系统。公民被归结为一架政治和经济机器中发挥功能的元素。
    6．2斯密的经济学和市场平衡
    重农主义以笛卡尔力学背景来设计他们的经济模型，而亚当·斯密则与他的伟大先驱艾萨克·牛顿爵士的经典物理学有关。在笛卡尔的力学中，所有的物理事件都还原为相互作用的元素之间的接触效应，如同钟表中的嵌齿轮或圆球之间的撞击。因此，笛卡尔派物理学家构造出往往是不可观察的假定机制。例如，光的折射作用想像成如同微小玻璃球一样的小球之间的相互作用。碰撞和冲力定律在笛卡尔的物理学中是基本性的。
    牛顿用他的名言“决不作假说”来批评笛卡尔的力学。他的万有引力定律是用数学方法从他的力学公设推导出来的，所作出的预见通过实验经受了经验确证。但是，他提出来用以解释虚空中万有引力的超距效应的假定的传递机制，则是不可观察的。
    在牛顿的天体力学中，物体在一个由不可见的万有引力确定的动力学平衡系统中运动。动力学平衡中自由运动个体这一物理概念，相应于政治权力独立的自由经济和社会中的自由主义思想。与自由主义思想不同，笛卡尔的自然时钟机械装置则表现为，对应于把公民作为嵌齿轮的绝对主义的国家机器。
    著名的英国哲学家约翰·洛克（1632－1704）不仅影响了牛顿物理学的认识论和方法论，而且还影响了近代民主和政体的政治理论。他追问，为什么人会自愿放弃他在自然状态中的绝对自由，并使自己服从于政治权力的控制。洛克认为，在自然状态中享有财产权是非常不安全的、不保险的，因为在无限制的自由状态中其他人总想将它从他的手中夺走。因此，自然状态是不稳定的，将转变为某种政治力量的平衡态。在洛克看来，从自然状态向有政府的社会的“相变”是由人们保持自己财产的意向所推动的。
    不过，政府并不意味着无自由的绝对君主机制。它是一种均衡的状态（平衡态），其中像立法和执法都是独立的政治权力。由于法律是由作为社会的代表机构的议会来制订的，因此就有对其公民的基本反馈作用，公民只不过放弃了他们的自然的自由，以保护他们自身和财产要求：“所有这一切不会导致其他而只将导致人民的和平、安全和公共的善”。历史上，洛克的民主思想，权力分离，财产权以及宽容的思想，主要影响了美国和法国的政体。
    如同在认识论中一样，与洛克相比，伟大的苏格兰哲学家大维·休谟（1711－1776）在政治理论中更富有批判性、更为精确。在认识论中，他教导人们，人类的意识是由感觉和情感的联想所制约的，它们可以为外部的经验所加强或减弱（参见4．1节）。所以，甚至在牛顿物理学中也不存在绝对的真理，只会有或多或少可能有用的方法。类似地，也就不存在如公正地决定着人类行为的永恒伦理价值。伦理观念只能由对于个体或公共的有用性来加以评价。总之，政治政体是否合法，也就只在于它们是否对于社会有用，是否被社会所接受。因此，休谟就成为了功利主义伦理学和政治哲学的先驱。他的朋友和苏格兰同乡亚当·斯密，很可能是受到了他的人类社会中自私行为的怀疑论人类学的启发。
    斯密的名著《国富论》（1776）通常被誉为一门独立学科的诞生。然而，斯密是一位道德哲学的教授，牛顿是一位自然哲学的教授。事实上，斯密试图把伦理学、经济学和政治学统一起来，牛顿则力图将其物理学嵌入宇宙学甚至宗教框架之中。在他的《道德信念论》中，斯密分析了同情心在人类中的作用。在他的《国富论》中，人的自私自利行为被假定为经济学的根本推动力。
    在这两本书中，斯密都试图把牛顿方法运用到伦理学和经济学中去。他把牛顿方法描述为，科学家制定了“一些基本的或证明了的原理，从这里出发，我们能够解释多种现象，并把它们联系在同一条链条之中”。与休谟相类似，斯密也不把科学的起源归功于人对于真理的热爱，而归结到一种素朴的渴望，即最大限度地“迷惘、惊奇和敬畏”。人类生命的伟大目的是要追求均一、恒定和持续地致力于改进人的生存条件。总之，人的自私倾向于追求最大的福利功能。
    按照牛顿的“决不作假设”的格言，斯密强调，人类的自私决非是经济学家的一种理论构造，而是经验的事实。自私是单个人的强大的、自然的推动力，因此也就是一种人权。但是，若干个人的微观利益的相互作用，通过市场机制造成了共同的宏观福利效果。下面是摘自《国富论》的两段名言：“我不比那些倾心于交易公共产品的人们懂的更多。”以及“我们所盼望的晚餐，不是来自屠夫、酿酒商或面包师的仁慈，而是来自他们对自己利益的关心。”

    市场机制是由供给和需求来调节的，供给和需求推动着竞争者的微观利益成为市场平衡中的宏观福利效果以及“国家的财富”。按照这样一种机械论的观点，借助通过某种“经济妖”或机械发条，微观利益被拉动到共同的平衡宏观态。按照牛顿的方法，斯密把引导着微观利益的“看不见的手”比作天文学中的“看不见的”万有引力中的超距作用。显然，斯密把经济描述成为一个其中发生着许多微观利益处于相互竞争之中的复杂系统。它们的相互作用的动力学，是一种竞争的自组织过程，其终态是实现供给和需求之间的平衡。
    物品的价值是由金钱来度量的。当然，金钱的度量不可能不小心使用。有必要区别由市场机制实现的“市场价格”和产品的“自然价格”或真实价格。经济学家不得不去发现一种“标准价值”，以能校正金钱的价值。于是，斯密已经旨在建立一种以价值理论为基础的政治经济学。要衡量社会产品，就需要价值。图6．4说明了斯密的供给和需求的自组织过程，其中的反馈图式中，r是对于物品的需求，c是供给，m是市场价格，n是自然价格。
    但是，斯密并没有像亚里士多德那样以诸如公正这样的伦理理想为背景来引入“公平”价格。他的探索是以像自私这样的人类本性的事实为基础，来分析“国家财富”的“本性”和“原因”。关于物品的自然价格，斯密和早期的古典经济学家如戴维·里卡多就试图发现诸如黄金、谷物和劳动的绝对价值尺度。
    在里卡多看来，这种共同尺度应该由他的劳动价值理论来解释。里卡多跟斯密一样，熟悉经典物理学的一般思想。因此，他相信，经济学的某些结论“如同万有引力原理一样确定无疑”。随着历史的脚步向前迈进，经济和政治的问题都发生了变化，里卡多的增长、地租和劳动理论都受到了19世纪初他自己时代的历史条件的影响。最明显的是，出现了像马尔萨斯已经考虑过的要养活不断增加的人口所带来的经济问题。
    约翰·斯图特·穆勒（1806-1873）这位英国的哲学家和经济学家，对经济学的方法论有着巨大的兴趣。他把“政治经济学”定义为推演分析的公理系统，以假定的心理学前提以及对人类行为的所有非经济方面进行的抽象为基础。这些抽象可比作如同力学中的摩擦那样的扰动因：
    扰动因有其自己的规律，如同被扰动的原因有其自身的规律一样；从这些扰动因的规律出发，扰动的本性和数量也就可以预见……特定原因的结果于是就可以加入一般原因的结果之中或从中减去。
    在上面的引语中，穆勒显然描述了经典物理学中的因果性原理，它是使长期预报成为可能的基础：相似的原因引起相似的结果。因此，穆勒的经济学方法论就与拉普拉斯经典物理学精神是一致的，假定在近似知道初始条件的情况下，运用经济学定律就可以近似正确地作出预测计算。而且，穆勒的公理假设还定义了一种简化的经济行为模型，而非复杂的经济现实。
    于是，穆勒就成为了第一位明确以虚构的“经济人”为基础的经济学理论家，处于整个复杂性之中的真正的人不见了，而原先这是斯密研究的主题。这个一般性的经济人假说扩大了某种经济性功利功能，其经验基础是某种经验，即以对穆勒同时代的人进行反省和观察为基础，但是它并非是从特定的观察或具体的事件之中推导出来的。与此类似，牛顿的一般性万有引力定律也是由对于落体或运动天体的某些特定观察从经验上证明是合理的，而不是从这些事件中推导出来的。穆勒的方法论与19世纪物理学中对形式化系统和模型的新见解相吻合。
    现代数理经济学的先驱们如瓦拉斯和帕里托传播了物理学的数学方法在经济学中的应用。这两位思想家都是所谓的洛桑学派的代表性人物。经典理论已经明显受到物理数学概念的影响。他们或多或少地谈及经济力量和机械平衡之间的大体相应。实际上，数理经济学的先行者们主要是从力学和热力学中借用词汇，例如，平衡态、稳定性、弹性、膨胀、充气膨胀、收缩、流、力、压力、阻力、反应、运动、摩擦，如此等等。
    1874年，瓦拉斯接受了斯密的如下思想：消费者和生产者行为最大化就将导致经济的所有产品和因素市场在供给和需求总量之间的平衡。从瓦拉斯以后，一般平衡理论就成为了主导概念，它要求证明在一种经济的数学模型中存在平衡态。数理经济学家力图把复杂系统的元素从其环境中分离出来，用外源参量进行说明。不过，如果外源参量自身依赖于整体系统的影响，那么，把系统与环境分离并忽略掉实际存在的反馈，从而建立起适当的经济模型就是可能的。
    一般而言，一些古典经济学家力图通过标志线性和机械性模型的某些特定的假设，来减少经济实在的复杂性。首先，他们相信理性经济人用这种虚构来看待人们的每一行为。例如，市场中的这种经济人的个体行为，应该作为一个整体被分离出来。人们的行为可以用从个体行为中抽象出来的一般行为模式来描述。于是，就有了这样的假定，人的个体行为如同遵从一定运动数学定律的机械系统中的元素一样，是规则的、可预见的。如果起始条件和环境是已知的，是可精确测量的，那么就可确信，环境之中的个体行为就犹如气体中的分子一样，其行为是确定论的。
    假定了一个社会是由其成员的加和性行动构成的，经济模型的线性也就遵从叠加原理。叠加原理意味着，社会作为一个整体，与个体行动的加和没有两样。显然，线性模型是从不可预见的、非理性的个体行为的抽象，是从环境制约的抽象，是从个体与其行动之间的非加和性（“非线性”）和协同相互依赖性的抽象。
    这些线性的方法论原理，完全相应于拉普拉斯的物理学世界观。它们对今日的主流经济学仍然具有强大的影响，尽管本世纪的物理学自身已经经历了一些重大的革命，例如产生了以不确定性关系为特征的量子力学。但是，海森伯的不确定性关系是依赖于普朗克常数的量子力学算符之间的一个特定关系的结果，它看起来似乎与经济世界全然不相干。然而，薛定谔和海森伯的量子形式仍然保持着线性（对照2．3节）。事实上，经典的线性动力学系统具有非常规则的行为方式，从而允许作出精确的预见。而一个非线性的模型却表现出混沌的行为，对其作出长期预见是不可能的，因此被看作一种蹩脚的经济学工具。
    在20世纪，数理经济学家已经越来越放弃洛桑学派的物理主义了，该学派曾试图把经济系统比拟为某种经典物理学系统。经济学家已经在力图找到他们自己的基本数学工具。动力学模型的线性假设已经由于技术上的原因而被看作是正当的。这种正式态度在约翰·梅拉得·凯恩斯1938年给罗衣·哈罗德的一封信里有如下的表述：
    在我看来，经济学是逻辑学的一个分支，是一种思维方式；而你没有坚定地拒绝试图……将其转变成一种伪自然科学……按其模型及其选取模型的艺术，以模型与当代世界相关联的做法来看，经济学是一门思维科学。
    例如20世纪20年代末受特征的经济崩溃的影响，凯恩斯和其他人都强调经济系统不具备自动自我调节能力。“资本主义的不稳定性”成为所谓的凯恩斯主义中的一个常见的说法。于是，就提出了这样的建议：要借助特定的政策例如财政主义工具从外部来使经济系统稳定化。线性模型被新古典主义理论所特别采用，人们再一次集中在对平衡经济学的研究上。
    非线性探究方式，主要是受到了那些对于古典平衡经济学理想感到不满意的经济学家的青睐。因此，凯恩斯学派的学者们在并不熟悉非线性的数学方法的情况下，经常对线性的平衡理论框架提出批评。
    约翰·冯·诺意曼和奥斯卡·摩根斯腾的《博奕论和经济行为》（1943），开创了一个非线性数理经济学的新时代。线性编程、运筹研究，以及甚至数理社会学都受到这本名著的影响。在《博奕论》一书中，冯·诺意曼和摩根斯腾合理地假定，行动中的个人总是按照某种收益性来最大化自己的利益。一般地，使一类可能的行动a1，……，am和一类可能的状态s1，……，sn配成数对（ai，sj），式中1≤i≤m且1≤j≤n，收益uij是其一个映射。可能的收益uij构成一个（m×n）矩阵。
    例如，人们已经提出来若干种在不确定性条件下进行决策的合理性标准。不确定性意味着不知道可能收益的概率。主要运用的是所谓的最大最小收益标准。在这种情况下，每一种可能的行动ai都有相应最小收益值的矩阵元，即收益矩阵（uij）中第i行ui1，……，Uin中的最小值。于是，规则要求：选取的行动使其矩阵元取最大值。简言之，最大最小值规则选取这样的行动：最不利情况下的受益最大化。该规则可以非常容易地、机械地运用于收益矩阵。
    哲学家卡尔·加斯塔夫·亨佩尔想像出来如下的一个例子。在两口缸子中，装有尺寸相同的一些球，它们无法通过触摸而加以区别。在第一口缸子中，小球是铅球和铂球；在第二口缸子中，小球是金球和银球。游戏人被允许作为获取免费礼物从其中的一口缸子中取出小球。游戏人不知道缸子中的小球的分布概率。估计铂球价值为1000，金球价值为100，银球价值为10，铅球价值为1。
    最大最小规则认为应该选取从第二口缸子中获得小球。在这口缸子中，最吃亏的情况是获得银球，而在第一口缸子中最吃亏的情况是获得铅球。显然，最大最小规则相当于一种悲观主义的世界观。在游戏中，游戏人假定了一个充满着敌意的对手。于是，最大最小规则建议采取一种最有用的行动。
    而一种乐观主义的态度则相当于所谓的最大最大收益标准。游戏人坚信，每一次可能的行动都将得到最好的可能结果。因此，看来合理的是采取获得最好可能结果的行动，这至少可以跟其他行动获得同样好的最有利结果。在上述例子中，最大最大规则建议选取第一口缸子。
    一位谨慎的游戏人也许不愿意选取最大最小规则。但在另一方面，如果知道了对手怀有敌意，最大最小规则才是合理的。一些数字的例子是支持这种解释的。对于两种可能的状态s1，s2，以及两种可能的行动a1，a2，收益矩阵如图6．5a所示。
    最大最小规则建议采取行动a2。甚至把数字1减少到非常微小的值例如0． 01，而数字100放大到非常大例如10[15]时（图6．5b），最大最小规则仍然建议采取行动a2。对于一位假定了一位绝对敌意的对手的游戏人，这种决策实际上是合理的。在任何情况下，对手都将力图阻止游戏人实现最大收益的状态。否则，采取最大最小值规则就将是不合理的，因为a1将会是更好的行动。如果状态s1实现了，游戏就不得不放弃收益增值，因为它太小了。在状态s2的情况下，他将以行动a1获得一个非常大的利益增值。

    为了判断这种决策是合理的，萨维奇引入了所谓的最小最大冒险标准。他主张，用冒险价值rij的矩阵（图6．5c）来取代收益uij的矩阵（图6．5a）。为了获得第j列中最大收益价值，必须把冒险价值rij加入到收益价值uij中。
    在矩阵6.5a中，第一列的最大收益价值是1，在第二列中是100。于是，冒险矩阵就如图6．5c所示。

    最小最大冒险规则要求：选取使得最大冒险最小化的行动。由于a2的最大冒险的价值是99，a1为1，看来合理的是选取行动a1。当然，也只有在一定的特殊条件下这个规则才是合理的。还有许多其他的合理性标准。
    接下去是所谓的悲观乐观标准。它建议在悲观的最大最小规则和乐观的最大最大规则之间获得一种答案。假定对于行动ai，收益ui1，……，uin的最小值是mi，最大值是Mi。让a是一个常数，使得0≤a≤1成为乐观悲观矩阵元。于是，行动a1相应有a矩阵元ami＋（1－a）Mi。悲观乐观规则倾向于具有较大a矩阵元的行动。当然，只有给定了一个特定的a，才定义了一个特定的标准。这些例子表明，合理性的绝对标准是不存在的，存在的只是一类相应于在一定条件下的不同乐观程度和不同悲观程度的标准。
    冯·诺意曼和摩根斯腾的《博奕论》一书中，考虑了作为个人或群体之间进行竞争或合作的相互作用结果的社会或市场的稳定性。在许多情况下，他们对于实际的经济、社会和心理复杂性采取了过度的简化。每一位游戏者只能恰好确定他的可能行动以实现某些状态和可能的受益。一般来说，博奕论采取了线性（叠加性）原理假设，在一个社会（游戏）中的许多个人的复杂相互作用被归结为若干个人的许多简单相互作用的加和。
    于是，对两人游戏的研究在博奕论中占据着重要的地位。在一个事件中，游戏人1选取行动a1、游戏人2选取行动a2，被表示为数对（a1，a2）。在此事件中，游戏人1的收益是u1（a1，a2），游戏人2的收益是u2（a1，a2）。一类重要的游戏，其特征是在每一事件中，两位游戏人的收益恰好相反，即u1（a1，a2）＋u2（a1，a2）＝0（“零和”博奕）。任何的合作都被排除了。于是，最大最小规则就显得是合理的，如果没有关于对手的合理性的特定信息。在其他情况下，合作常常是合理的。
    数学上的根本性问题是，在此博奕中存在着平衡点。如果完全没有合作，就以如下方式定义两位游戏人的可能行动的平衡点。一个事件（a1，a2）是游戏的平衡点，如果游戏人1的所有行动a1的收益值u1（a1，a2）大于或等于u1（a1，a2），以及如果游戏人2的所有行动a2的收益值u2（a1，a2）大于或等于u2（a1，a2）。
    假定游戏人2选取了行动aa，而游戏人1试图使收益最大化，那么他就可以选取行动a2；反之亦然。平衡点是稳定的，如果游戏人知道他或她的对手也处于平衡点并且没有理由要改变其行为。显然，这种平衡定义没有考虑任何动力学方面。但是，实际的社会或经济行为却是由时间中的复杂动力学所确定的。交易循环是众所周知的经济动力学的例子。于是就提出了问题：这些动力学是否受到平衡态的吸引，以及这些平衡态是否是稳定的。一般来说，博奕论并不考虑“蝴蝶效应”，即不考虑小的行为失误有时会引起总体的危机甚至引起混沌。
    冯·诺意曼和摩根斯腾的博奕论并不完全拘泥于线性数理经济学的传统，它还发展起来经济福利理论的思想。一个理性的社会被假定为选取了帕雷托优化（Pareto－optimal）的利益分配。如果没有对于其他个体福利的减少就不可能增加这一个体的福利，这种利益的分配被称为是帕雷托优化的。满足这种弱帕雷托优化福利条件仍然是不充分的，还必须考虑到潜在的联合。博奕论中的合作解理论，主要是追随了福利经济学、交际手段，以及往往惯于社交的自私政治家的思想。数学上，福利经济学的政治和社会框架的公正、无偏见以及平等竞争等概念的确定，都被归结为某种对称性原理。
    博奕论是一种精确的数学理论，它在经济学中的应用往往被估价过高了。其局限性是它对社会作了典型的线性假设。然而，博奕论是一项了不起的数学发明，它主要是由冯·诺意曼提出来的。值得注意的是，在本书所涉及的本世纪几乎所有科学领域的发展中，约翰·冯·诺意曼都是一位中心人物。他曾致力于程序控制的计算机、自动机理论、量子力学和博奕论的发展。而且，他还对自然科学和社会科学中的跨学科数学模型深感兴趣。所有这些辉煌的发展都主要是由线性原理支配着。但是，冯·诺意曼还是最先认识到自复制和自组织的重要性的科学家之一。他的元胞自动机理论就是一个著名的例子。
    6．3复杂经济系统、混沌和自组织
    从方法论的观点来看，主流经济学往往受到线性数学、经典力学、平衡态热力学模型的启发，有时也受到达尔文进化论的启发。古典经济模型中已经假设了一种理性的经济人，理性经济人通过成本最小化、利益最大化来追求收益最大化。这些理性的角色被假定通过在市场上交换商品而发生相互作用，市场是通过一定的价格机制来实现需求和供给之间的经济平衡的。
    要描述经济的动力学，就需要有包含许多经济量——也许来自数千个部门和数百万角色——的演化方程。经济学如同其他领域一样，一切事物都依赖于其他事物，为了尽量地模拟经济复杂性，这种方程就将是耦合的、非线性的。但是，甚至是完全确定论的模型也会产生出高度不规则的行为，这样的行为是不可能作出长期预测的。经济学如同气象学一样有同样的缺陷。
    在发现数学混沌和蝴蝶效应之前，人们相信有可能精确地作出长期的天气预报。作为一名计算机的先驱，约翰·冯·诺意曼认为，拥有了充分多的关于全球气象的数据，并有了超级计算机，就可以对于长期的、大范围的天气作出精确预报。在数学上他并没有错，因为在线性数学框架中，他如同经典的天文学家一样地正确。但是，流体和天气的实际长期行为惊人地不同于这些模型。
    人们怎样来处理天气和经济学中的复杂性呢？气象学中，爱德沃·洛仑兹已经提出了一种非线性动力学模型，其中由于内在的（“外在的”）扰动就会产生出混沌行为（对照2．4节）。类似地，解释经济演化的复杂性就有两种可能的方式。主流方式是假定线性的模型，其中作出某些预先的特设、难以解释的外在冲击。而非线性方式放弃了过于简化的预设有外在冲击的线性假说，并力图通过其内在的非线性动力学来解释实际上的经济复杂性。在一些情况下，非线性作用非常弱，线性近似并不造成根本性错误。
    在经济学史上，20世纪30年代的经济大萧条引起了试图从理论上解释经济的不规则性。但是，那些模型（例如卡耐基和汉森-萨缪尔森模型）都是线性的，难以解释振荡现象的形成。因此，经济学家们就假定，外部的冲击引起了所观察到的振荡。假如那时经济学家对于数学的发展更熟悉一些，他们就会早些了解到非线性的数学模型会导致循环限制，从而得出解答。
    经济学家们起初只知道不动点吸引子的稳定平衡。彭加勒把平衡态推广到包括以极限环形式进行的平衡运动。但是，对于像洛仑兹模型（图2．21）中的混沌吸引子，既没有不动点，也没有不变运动，而是一种永不重复的运动。然而，它也是一种有边界的运动，一种非游荡集合，将一定的动力学系统吸引到某个动态平衡的终态。
    历史上，20世纪的经济以其增长过程中发生着引人瞩目的崩溃中断为特征。例如，20世纪30年代（大萧条）和70年代（石油危机）。对于增长的结构，要特别关注创新和技术进步。成功创新的扩张，在经验上已经由逻辑斯蒂函数很好地表示出来，本书中在2．4节已经引入了这一函数。递归的表示中可以把整数t看作时间项，增长因子a＞0。起初，人们对于创新是全然不熟悉的。然后，随着它被人们接受，它就达到了它的最大扩张速率。再后，随着创新方式完全地结合进经济中，对它的吸收过程就慢慢地减速了。
    所形成的曲线示意在图2．22中。对于a≤3，我们获得了某个不动点吸引子，这示意在图2．22a中。对于更大的a，结果形成了一种振荡（图2.22b和图2．24b），然后是一种混饨运动（图2．22c和图2．24c）。对于a＞3，周期数随着a的增加而成倍增加（图2．23a），最后它完全变成了混沌（图2．20b）。
    创新和经济产出之间的相关如图6．6的模型所示。最初的输出q被看作是平衡的，随着增长速率△k的增加，输出也在逐渐增加。随着创新到达饱和状态，△k也减少到零，输出q跌落到最初的水平。于是，创新刺激出某种繁荣，但也就引出了随后的衰退。创新可以是节省劳动力的。如果每输出单位的劳动输入降低20％，就会引起失业。

    人们假定新思想的增长是指数式的，像舒伯特那样的经济学家主张，在一次创新冲动的尾声就将开始一轮新的创新冲动。然后，如果大致以每年4％的速度发生经济系统连续地起作用和技术概念连续地生长，那么就会激起新的一轮繁荣和新的衰退，如此等等。对于经济循环理论，创新是至关重要的，因为在一次萧条中是没有任何的新投资基础的，而新的投资又是引出新的扩张所必需的。
    一些新的思想平稳地产生出来。当足够多的思想积累起来以后，就会引进一组新的创新。它们最初的发展是缓慢的，然后随着方法的改进而得以加速。逻辑式发展标志了这种典型的创新轨迹。引入一种创新必须要有某种超前投资。投资刺激了需求。增长的需求促进了创新的传播。于是，随着所有的创新都已经被充分发掘，减速过程就将导致零增长。
    熊彼特把这种现象称作创新“游泳”。在他的三循环模型中，第一个短循环相应于资本循环，创新在此不起作用。下一个较长循环相应于创新。熊彼特承认历史统计学的显著性，并把长周期波动的证据与诸如蒸汽机、炼钢、铁路、轮船和电力这些最重要的创新联系起来，注意到它们完全地结合进经济中需要30-100年。
    一般地，他描述了以“集群”形式发生的技术进步引起的经济进化，并在逻辑斯蒂框架中来解释。一次技术集群被假定为以循环方式把一种平衡态转移为一种新的不动点。所形成的新的平衡，其特征是更高的真实工资、更高的消费和产出。但是，舒伯特的分析忽略了一个根本性问题：有效的需求决定着产出。
    从历史上看，20世纪30年代的大萧条促成了提出经济的商业循环模型。不过，最初的模型（例如汉森-萨缪尔森的模型和郎伯格-米兹勒模型）都是线性的，因而也就需要外在的冲击来解释其不规则性。标准的经济方法论为这种传统进行辩解，尽管循环分析在数学上发现了奇怪吸引子以后就已经成为可能。在非线性系统框架中，重新表述关于20世纪30年代的大萧条的传统线性模型并不困难。
    米兹勒模型是由两个演化方程来决定的。在第一个方程中，产出的变化率q正比于实际资本S与所希望的资本S’之间的差。所希望的资本正比于产出。第二个方程中涉及资本的变化率s，其产出q小于需求。需求正比于产出。由这两个演化方程决定的动力学复杂系统，将产生出简单的其振幅不断增加的谐运动。
    如果以某种非线性方式将这个系统扩展，就会导致另一种不同的行为。第三个方程中考虑到净公共剩余和赤字的反常行为。目的是要产生出有若干年周期的循环。运用所谓的茹斯勒带，提出了一种数学模型。人们得到了一条莫比乌斯带，它是自上而下翻转后只给出一面的带子（图6．7a）。追随一条轨迹，由外圈扩展到右上方。然后，它折叠起来，并随着向下运动而收缩为一个内圈，如此等等。图6.7a给出了一个两维的投映，显示了这两个循环。轨线倾向于聚集在其间的空的空间。如果将此模拟继续下去，这些带子就变得越来越稠密。

    图6．7a是一个简单而著名的混沌（“奇怪”）吸引子的例子。尽管其中每一轨迹都是精确地由演化方程所决定的，但它却是难以长期计算和预测的。在蝴蝶效应的意义上，起始条件的微小偏离，将引起轨迹途径的巨大变化。图6.7b示意了态空间中一条为期15年的输出轨迹，对此已在计算机实验中选择一些参数进行了模拟。图6.7c示意了作为相应的时间系列的发展。

    这种高度飘忽不定的行为完全是由内在系统产生出来的，没有任何的外在冲击。在经济学中，时间系列的不规则性通常是用外在冲击来解释的。但是，它们仅仅是武断的预先假设，因此是可以解释任何事物的。从方法论的观点看，其中有混沌吸引子的混沌内在模型表现得更令人满意。然而，内在的非线性模型与带有外在冲击的线性模型都必须严肃地取自经济学，并在经济学中受到检验。
    显然，一个经济系统包含了许多相互关联的和相互独立的部分，既有内在动力学也有外在影响力。一个国家的经济越来越受到世界经济运动的作用。在一个经济系统内，也有具有特定动力学的多种市场。它们受到循环的影响，例如，每年的太阳循环就决定着农业、旅游业或燃料市场的状况。因此，铁业循环和建筑循环也都是人们熟知的经济例子。因此，内在非线性并受外力冲击波的系统才是现实的经济模型。受扰动的混沌吸引子或一种超混沌，给人留下了深刻印象。正是经济事件具有飘忽不定的特征，给经济人员带来了严重的困难，他们不得不面对不可预见的未来而进行决策。
    在2．3节中，我们已经看到，自组织的复杂系统可以是保守的或是耗散的。在图2．14a，b中示意了它们的不同类型的吸引子。一些为人们熟悉的自然科学中的保守的或耗散的模型都已经运用于经济领域。1967年，哥德温提出一种保守动力学模型，以使得19世纪的阶级斗争思想精确化。他考虑了一种由工人和资本家所组成的经济系统。工人将其全部收入都用于消费，而资本家则将其全部收入都储蓄起来。哥德温运用的是作了某些修订的洛特卡和沃尔特拉的捕食者-被捕食者模型，那个模型已在3．4节中作了描述。
    哥德温的保守模型支持了这样的观点：资本主义的经济将处于不断的振荡之中。因此，轨迹描述了封闭轨道，如图3．11b所示。哥德温的模型受到了批评，批评者认为它只是表面上的，因为该模型并未直接涉及资本家和工人的职务收入份额或他们群体的大小。但是，主要是由于它的保守特征，使得哥德温的模型看来在经济上是不现实的。该模型把互不相干的一组假设放在一起，而假设之间的相互影响没有得到反映。
    因此，加入“经济摩擦”假设，就使这个模型更为现实了。在生物学中，耗散的洛特卡-沃尔特拉模型已示意在图3．11c中，其中有一个吸引子。一个耗散系统总是具有吸引子或排斥子，其形式包括不动点、极限环或奇怪吸引子。由于耗散系统具有不可逆的时间进化，任何种类的回溯预测都是排除在外的。
    现实中，人们不可能将一个动力学系统与其他动力学系统割裂开来考虑。因此，在2．2节中，我们研究了耦合的吸引系统，例如两个时钟（图2．11a，b）。组合系统的态空间由一个环形圆纹曲面代表（图2．11c，d）。整个系统的动力学，由环形圆纹曲面上的轨迹和向量场的相图来表示。
    一个耦合振荡系统的经济模型，可以由国际贸易来提供。设想一个简化了的只有总投资和储备的单种经济的宏观经济模型，其总投资和总储备依赖于收入和利率。这个系统的动力学依赖于关于收入的演化方程，收入由市场上对物品的过度需求来调节，第二个演化方程是关于利率的方程。这些方程以模型中产生出内在振荡的方式构成了一个非线性振荡子。
    3种经济的相互作用，例如，可以用3个独立的二维极限环来加以描述。如果这3种经济都处于振荡中，该系统的总运动就构成了一种三维环形圆纹曲面的运动。非线性振荡子的耦合可以理解为对三维环形圆纹曲面上的自主经济运动的扰动。这种耦合程序已经应用到了几种经济实例中，诸如国际贸易模型、商业循环模型和独立市场。
    当允许自组织的经济系统受到政治干预的影响时，就出现了至关重要的实际政策问题。在某些情况下，市场是不可能按照福利标准来发展的。如果让经济自由放任，它就可能出现涨落波动的特征。如果不考虑经济增长的复杂性和非线性，政策措施可以对这样的倾向产生相反的效应。
    对于经济突变带来的巨大社会和政治后果，已经在凯恩斯主义和新凯恩斯主义的框架中讨论过若干种政策措施。例如，当代的财政政策可以被看作一种动力学控制。它应该可以减少经济涨落的幅度。但是，战后的经验已经表明，希望把涨落减少到零是不可能的，也不可能保持就业率不变。而且，一项好的政策总是需要相当的时间来收集数据、分析结果并提出相应的立法和行政措施。结果是，任何政策当它起作用时可能就已经过时了。因此，在复杂的非线性的经济世界中，一项政策措施可能会是完全无用的。
    例如，当假定的经济动力学及其政策干预的时间途径过于简单时，凯恩斯的收入政策就可能是无效的。在复杂系统的框架中，经济政策措施可以被解释为对于振荡系统施加紧急的外部作用力。因此，它不可能排除掉经济系统出现混沌现象。在物理学中，受迫振荡是人们所熟悉的。例如，如果一个像钟摆那样的动力学系统（图2．5）处于振荡中，并且受到外力的周期性影响，那么，由于振幅不断增加、振荡总体衰减以及完全的无规则性，其结果就可能是不可预见的。
    从古典经济学到现在，商业循环理论的目标一直是建立起具有规则涨落的经济系统的动力学。按照线性力学的观点，实际的商业循环可以用规则系统来建模，对其可以再加上随机的外部冲击，而这种冲击又必须或多或少用适当的经济学假设来说明。当然，对于一个模型，当它的基本性质是由外部力量来决定的，这些外部力量又没有合理的经济学解释，这样的模型就是很难令人满意的。如果一个实际的系统是非线性的、混沌的，可能影响其经济动力学的外部作用力的进一步的信息也就可能是多余的。从方法论的观点看，按照奥卡姆的格言entia non suntmultiplicanda sine necessitate［无必要就不增加（理论）实体〕，他的著名剃刀应该用来切除这些多余的关于经济学的预先假设。
    从一个实际工作人员的观点来看，他究竟是面对一个随机的线性过程还是一个混沌的非线性过程的问题，这是一个离题的问题。这样的两种系统都使得他难以作出精确的预测。由于混沌模型敏感地依赖于起始条件，任意精确的数字计算机也不可能计算出这种系统的长期的未来演化。轨迹将指数地发散。另一方面，他却相信，面对着系统的过于复杂的行为，随机的外部冲击是可以放弃的。
    然而，具有混沌时间序列的非线性系统却并不排除局部的预见性。如果非线性系统的吸引子可以加以重构，那么数字技术就允许以足够高的精确度对系统的短期进化作出预测。短期经济预测可以是复杂系统理论在经济学中的一种有趣的应用，不过这也仍然处于其婴儿期。
    对于经济学模型来说，经济学从一开始就遇上了经验检验和确证的严重方法论问题。这与自然科学中可以进行任意多次的测量并进行实验室实验形成了鲜明的对照，经济的时间序列必须包括时间单位如天、年、季度或月份的数据。典型的标准的时间序列长度是由数百个点构成的。因此，对于经济模型的有限的可靠性就已经具有了经验的理由。当然，经验式的实验基本上是排除在外的。
    因此，关于内部经济动力学的适当知识，至少有助于建立数学模型，对其未来的发展可以用计算机实验进行模拟。如果政治家和管理者的经济和政治环境的假设得到了实现，他们就至少可以获得可能经济图景的“相图”。对于高度敏感的非线性系统的定性洞察，至少有助于防止反应过度的人们把该系统从不稳定点推向更不稳定，甚至也许是推向更大的混沌。
    经济学中的非线性模型的主要根据，是由最近的经济增长的结构变化给出的，这种结构的变化是新领域的技术发展引起的。传统的经济学理论假定了收入递减。某种物品生产和投向市场的越多，则其生产和销售就将变得越困难，获利就将越少。人们的相互作用是由负反馈来决定的，负反馈通过对经济变化引起的每一作用的反作用来稳定经济。
    在一种存在着负反馈的经济系统中，价格和市场份额的平衡就可以实现，也就可以预测。一个著名的例子是20世纪70年代发生的石油危机。20世纪70年代原油价格的突然上涨，使得人们开始节省石油，寻求可替代能源，于是又导致了石油价格在20世纪80年代的下降。在传统的经济学中，平衡即是一种对应于特定环境中的最佳结果。收入递减定理意味着存在着某个平衡点。其中有收人递减的负反馈的经济系统，对于传统的诸如农业、矿业和大宗产品等部门是典型的。
    但是，以高技术知识为基础的经济部门却获得了收入递增。高技术产品像计算机、软件、飞机、化学产品和电子产品的发展和生产，需要复杂的研究、实验、计划和设计过程，需要高额投资。但是一旦高技术产品投向了市场，生产能力的扩大却是相对便宜的，收入也就开始增加。因此，现代高技术产业就必须作为收入递增的正反馈的动力学模型来描述。
    具有正反馈的系统，不止一个平衡点，而是有若干个平衡点。它们不必是最优的。如果某种产品在市场上恰好具有竞争优势，市场主导者就将长期处于市场主导地位，甚至会在不必改进产品的情况下扩大其优势。现代高技术产业的许多例子表明，相互竞争的产品在开始时可以占有大致相等的市场份额。但是增加了某一特定产品市场份额的微小涨落决定着它的最后成功。常常会出现这样的情况，市场上的最后主导者从技术观点看却不是最好的。

    这些效应是不可能在传统的线性动力学框架中得到解释的。但是在非线性系统中它们却是人们所熟知的。图6．8表示在正反馈情况下两种技术的竞争。某些市场份额的轨迹显示在凸面上。一种技术越是支配着市场，它就越容易获得更大的市场份额。由于主导市场的位置是由随机的涨落引发的，因而它是不可预见的。在图6．8中，左边的曲线表示最后取得支配地位的技术A。在其他两种情况下，在起始的涨落之后最终取得市场支配地位的是技术B。
    这些经济模型的非线性的动力学是由最初的随机涨落和正反馈决定的。显然，可能途径的分叉是一种由最初的随机涨落导致的对称破缺，这也是在复杂物理学系统中为人们所熟悉的。读者只要回忆一下加热流体出现的定态对流卷（图2．20b），其中对流卷方向是向左还是向右就取决于起始的随机涨落。
    除了耗散系统以外，保守系统中也会出现对称破缺。我们考察一下旋晶中偶极子当温度下降时发生的自组织（图4．9a）。在热平衡态，依赖于起始的随机涨落，旋晶变成指向同一方向的排列。市场份额的动力学表现出遵从同样的方式发展。很多例子表明，因为起始随机涨落而制约了技术的发展方式。在19世纪，相邻的铁路公司在大范围中采取了相同的规范。而标准的规范只是历史随机事件的结果，而不是由于技术上的理由。
    这些复杂系统的行为由简单的演化方程所决定，如同铁磁旋晶系统发生对称破缺一样。图6．9示意了铁磁体中磁偶极子的演化。每一偶极或每一磁极都可以是向上（北极）或向下（南极）。一个偶极可以与其最近邻发生作用。在高温下，偶极子的方向是随机的。如果温度降低，基本的极性就会按相同方向排列起来。由于这些演化是一种对称破缺，就不可以预见在平衡终态究竟会实现哪一种方向。图6．9b示意了与此类似的铁路公司采取规范的自组织过程。

    在经济和社会领域中，正反馈的自我增加机制是非线性复杂系统的典型特征。例如，我们可以考察，加利福尼亚的圣克拉拉县为何会成为著名的硅谷。在20世纪40年代和50年代，一些著名的人物（如休利特、帕卡特和肖克利）在斯坦福大学附近建立了一些电子公司。这些先锋造成了高技术工程师和产品的集中，成为一个吸引子，最终900多家公司随之应运而生。在开始时，出现的是一些随机的涨落，它们有利于圣克拉拉县。因此，硅谷是如何出现的，从非线性角度来看，这并非奇迹，而是合乎规律的事件。但是，从随机性来看，它产生于圣克拉拉县就是一个奇迹。
    今天，自我增强的机制决定着高技术的国际贸易。美国和日本之间的汽车工业的竞争可以从这种框架中得到解释。起初，日本的工业向美国市场上提供小型轿车没有受到美国汽车工业的任何抵制，美国的汽车工业传统上专注于生产大型轿车。日本的汽车工业获得了市场份额，并降低价格和提高质量。于是，正反馈使日本工业侵入了美国市场。
    对于这些非线性的市场效应的洞察，可以对政治决策产生重大影响。传统的观点是假定某种收入恒定或下降，政府相信开放市场，力图阻止垄断，并希望工业将支持研究和技术发展。他们相信某种不变的世界性市场价格的平衡，拒绝任何的补贴或关税的干预。对于一个收入递减的经济系统，他们的政策是正当的，但是对于收入递增的以高技术为基础的经济部门，这就可能是危险的。
    不断增加着收入的运行机制改变着国家之间的竞争平衡。甚至最强大的国家经济，也可能在重要技术上错过发展。20世纪60年代在西欧和美国之间的技术差距（例如在计算机领域）是一个著名的冽子。技术标准或常规通常都是由正反馈来确立的。如同前述的铁路规范的例子，英语作为航空导航的标准语言，FORTRAN作为一种计算机语言，某种特殊的螺纹，如此等等，往往都是不可变更的，即使一种替换技术或规范可能会更好。它们获得了过多的市场份额。但是，最初的优越性并不能保证长期生存。
    非线性系统具有若干个可能的平衡态，但没有最终的稳定态。非线性经济即使在最初是均匀的，但由于它们的高度的敏感性和起始条件的微小偏差，也就不可能选择同样的发展道路。因此，正反馈的非线性经济不可能像计算机那样进行编程和运行，因为它的长期进化是不可预测的。复杂系统理论可以有助于设计一个经济动力学的整体相图。但是，对于找到经济福利的局部平衡，经验和直觉有时比科学知识更有帮助。对于处理高度敏感的复杂系统，政治家们必须具有高度的敏感性。
    6．4复杂文化系统和通信网络
    在社会科学和人文科学中，人们常常把生物进化和人类文化的历史进行严格的区分。主要原因在于，民族和文化的发展显然是由有意向性的带着其态度、情感、计划和理想的人类行为所引导的，而生物进化系统则假定是由无意向性的自组织过程所推动的。从微观的角度看，我们用他们的意向性和愿望观察人类个体。甚至在像动物生态这样的生物系统中，个体也有某种程度的意向性行为。
    复杂系统探究方式的关键点在于，从宏观角度看，政治、社会和文化秩序的发展，都不仅仅是单个意图的加和。亚当·斯密已经认识到，经济财富和福利的分配并不是由社会的一个个面包师和屠夫的善良愿望所施舍的。个体的自私自利的意向性可能会与集体利益相冲突。然而，他们的（非线性的）相互作用却通过“看不见的手”（斯密）或“理性的狡黠”（黑格尔）实现了集体的平衡态。
    由意向性行为的个体组成的非线性系统，也许比例如物理的原子系统或化学的分子混合物更复杂。在4．3－4节中，意向性行为和意识的建模，是被看作一种复杂神经系统的自参照整体状态，由神经元的非线性相互作用造成的。以不同复杂程度出现的集体有序现象是所有非线性系统内在的共同特征，这样的系统并不一定要与意识相联系。作为人类社会的集体秩序的政治状态，尽管其形成可以用具有意向性行为的有意识的人们的非线性相互作用引起的相变来建模，但是显然并非黑格尔错误地认为的那样有某种意识或智慧。
    因此，在复杂系统的数学框架中，“进化”概念并非专指特定的生物进化机制。在复杂系统中，所谓的演化方程描述了其元素的动力学，这些元素可以是基本粒子、原子、分子、有机体、人类、公司，如此等等。宽泛意义的另一方面是复杂性概念自身。在社会科学的情景中，有许多方面的复杂性，图6．10中示意了其中的一部分。

    在本书的复杂系统的数学框架中，复杂性首先是定义为一种非线性，这是混沌和自组织的必要条件，但不是充分条件。另一方面，线性意味着叠加原理，用通俗的说法是“整体只是其部分之和”。复杂性的第二个重要方面是由算法的结构来定义的，这在5．2节中已经讨论过。计算机科学中复杂性理论提供了一种复杂性程度的等级，例如依赖于计算机程序或算法进行计算所需要的时间。由于人们常常用计算机图形来模拟非线性复杂系统，它们的算法复杂性就可能描述为它们的自组织能力。在元胞自动机理论中已经探讨了这种关系（对照5．3节），其中为不同种类的自组织复杂系统进行了建模。
    在社会科学中，高度工业化社会的复杂性主要是由大量的公民及其关系、组织亚结构及其相互依赖性所构成。我们应该记得，在一个复杂系统中，造成形成集体（协同）有序时元素的巨大数目不是根本性的，非线性相互作用才是根本性的。读者也许还记得，具有混沌轨迹的天体3体问题就是可能的答案。
    在复杂系统的数学框架中，对于人类历史和社会文化发展的物理学或生物学还原论，在任何情况下都是不恰当的。社会和文化发展的模型，必须联系其特定的约束和限度来进行讨论。一个重要的方法论问题是，如何提供对于这些模型的经验检验和确证。因此，对复杂文化系统进行计算机辅助模拟已成为关键性工具，籍此可以对其动力学提供新的洞察，从而对我们的决策和行动大有帮助。
    历史上，对于社会科学中的非线性问题的兴趣可以追溯到托马斯·马尔萨斯。他指出，因为人口指数地增长而食物供应只能线性地增长，人口将超过食物供给。1844年，威霍尔斯特修订了该指数方程，指出人口增长的速率正比于人口生产以及资源总量与现存人口对资源消费量之差。他的著名的具有平衡吸引子特征的逻辑曲线，被运用于人口统计学、经济学和社会科学的其他许多场合。它提供了一种可能的一系列分叉和相变（包括混沌）。
    由沃尔特拉和洛特卡描述的捕食者－被捕食者生态系统的演化，是另一个被应用于社会科学的模型。例如，洛特卡－沃尔特拉模型有助于我们理解农业社会的出现。因为人类能够进行学习，他们就能够改变他们与环境相互作用的程度，使得这种作用快于大自然遗传进化的反向措施。人类社会，为了生存只有不断地改进其狩猎能力，从而消灭被捕食群体。然后，社会也将被消灭。结果是，捕食者和被捕食群体都将灭绝。但是，农业使得被捕食者的生产速率增加了。于是，人类群体就增加了，并能够在某种平衡态稳定下来。
    生物系统的进化是受其基因制约的。达尔文进化论中，新个体的出现是通过对突变体的自然选择实现的，其中突变是自发产生的。在较高等动物的群体中，由于模仿，出现了新的行为变化和适应的可能性。社会发展起来诸如法律系统、国家、宗教、贸易等等特殊的组织机构，从而使得后代的行为变化得到稳定化。
    复杂系统探究方式提供的基本性洞察是，无论是遗传进化还是行为进化，都不需要诸如进行指导的神的意志、生命力那样的总体程序或者某种总体的进化优化策略。基因的生存或者总体行为模式的形成，都可以用组成系统的个体之间的局域相互作用来加以解释。我们可以更清楚地表述为，这是一个宗教或政治世界观的问题，即究竟有没有诸如上帝、历史或者进化那样的“总程序”。在复杂系统的方法论框架中，这些假设对于作出解释是不必要的，在奥卡姆剃刀及其理论概念经济的意义上它是多余的。
    显然，诸如生物有机体、动物群体或人类社会这样的非线性系统，已经进化得越来越复杂了。我们现在的社会，与亚里士多德的城邦或重农主义者的政治系统相比较，它是一种以高度组织结构复杂性和信息网络连接为特征的社会。在19世纪，赫伯特·斯宾塞已经提到，不断增加着复杂性是进化的一般特征：“进化是结构和功能复杂性的增加……恰好是……平衡过程……”斯宾塞仍然是在热平衡的热力学框架中来进行论述的。
    在远离热平衡的热力学框架中，存在着不只一个平衡不动点，而是存在着分为不同复杂程度的吸引子的等级，从不动点开始，直到具有分形结构的奇怪吸引子。因此，无论是在生物进化中，还是在社会文化的进化中，都没有某个固定的复杂性限度，只是存在不同复杂程度的吸引子，它们代表着一定相变阶段的亚稳平衡，如果一定阈值参量得到实现，这些亚稳平衡就是可以被打破的。社会的结构稳定性也就与这些不同复杂程度的吸引子相联系。
    传统的关于自稳定、自调节系统的功能主义观点，源于技术上的恒温装置。它有助于我们理解社会为何保持不变化，但是却不能解释它们为何发生变化，平衡为何被打破。在复杂系统的框架中，对于社会的动力学，是按照不断地与其环境交换着物质、能量和信息的耗散系统的相变来理解的。社会的组织制度是一种耗散结构，它们可以产生出来，并可以在特定的阈值条件范围内保持木变。例如，在新石器时代的村落中，当已建立起来的社会结构已不可能保证食物供给时，农业制度就发生了从干旱农业向灌溉农业的转变。
    在工业化社会的历史上，我们可以找到强弱程度不同的经济涨落，它们可能引发由社会制度的崩溃和新的社会制度的形成。例如，1922年美国的经济萧条是相对温和的，时间也不长，因而没有产生社会结构的变化。与此相反，美国历史上1929年的股票市场的崩溃却是一场真正的蝴蝶效应，引发了1933年的大萧条。这一危机使得许多公司发生了财政灾难和大量的失业，而不能被已建立起来的社会组织制度来加以运作。现成结构的临界参数被超过了。新的组织制度出现了，安全和交易委员会、联邦储备保险组织和劳工管理局就应运而生，以克服萧条的影响，并防止未来商业循环中的过大波动。这种美国社会的凯恩斯回应，以罗斯福总统新经济政策而闻名。
    但是正如我们从新古典主义经济学家和第二次世界大战战后的社会发展经验中认识到的，公共福利的优化策略可能引发管理官僚制的自动力学，它使得经济动力衰退，与起初的善良的愿望相反。对系统的结构稳定性，过度的反应，跟毫无反应一样危险。另一方面，政治革命史表明，社会可能失去其稳定性，实现新的政体、组织体制和社会结构，当然，其延续性没有任何保证。
    从方法论的观点看，这里有一个问题，即如何在复杂系统的框架中来表示社会的社会文化进化。吸引子和平衡态的认识需要一个社会文化动力学的相图，来定义“社会文化状态”和“社会文化的态空间”。但是，什么是维多利亚英国和魏斯曼共和国的社会文化的态空间呢？这些问题揭示了一些明显的局限性。复杂系统探究方式在历史和社会科学中的可能性如何？
    要在纯粹的数学态空间中再现出一个历史时期的研究目标是不可能的。有关的数据常常是没有的、零乱的，并且不是定量的。在这最后一节中，具有态空间和动力学相图的复杂系统，被用来为人类社会系统的经济进化建立模型。例如，经济学家并没有声称要再现魏玛共和国的完整的经济发展。但是，对于那些影响或者依赖于政治和文化史的典型经济图景，商业循环周期的非线性内在模型或线性外在模型应该能够给予描述。
    经济模型并非是由于自己的缘故而建立的。经济学家希望理解经济的动力学，以通过对于结构的更好洞察来对决策提供支持。社会的经济动力学嵌在总体的社会文化发展之中。从其复杂性的角度看，对于社会文化的建模，人们已经进行的尝试仅仅是针对诸如城市中心这样的子系统的。这些模型抓住的是城市系统演化的典型特征，这有助于政治家和公民在适当情形更好地进行决策。
    现代工业化的社会中存在着大量的形形色色的中心，包括各种各样的尺寸、形式和特征，从非常大的人口密集的城市到小小的人口不多的村庄。我们可以问一问，这些不同中心的空间分布的原因何在，它们将如何随着时间发生进化。要对此作出回答，我们就需要了解城市系统的总的空时状态，它是由其中的人员——个人、家庭、管理者如此等等——的局域相互作用造成的，这些人员可能在追求不同的合作或冲突的利益。一个城市中心的结构有赖于商业和工业利益、货物的流通和服务、交通联系、文化吸引力、生态要求。而且这些因素都必须精确并且能够测量。城市系统与外部世界有若干种交换。因此，它可以被解释为一种耗散结构，用一种复杂动力学系统来建模。
    彼特·艾伦已经提出了一种系统，用演化方程表达了其中不同作用因素的非线性相互作用。城市系统的空时结构，包括变化着的中心、居民密度，都不是其组成因素的简单加和。它并非是某个总体优化者或某种集体收益函数的结果，而是由非线性相变引起的相继的平衡态不稳定性的结果。在此意义上，城市系统的演化，并非是柏拉图哲学王（或独裁者）控制的，也并非是笛卡尔建筑师建造的或者拉普拉斯妖所预见的。在复杂系统的数学框架中，一个城市系统的生长就如同活的有机体一样。
    在艾伦的分析中，城市系统的地理空间由具有50个局域点的三角形点阵来表示。城市系统的生长由两个方程所决定，方程描述了局域点的人口变化以及这些点提供的就业的演化。局域的人口和局域的就业能力由作为正反馈的城市放大作用连接起来。就业的集中提供了客观条件和公共基础设施，它们反过来又引起了正反馈，同时，居民和投资者又在争夺提供负反馈的中心空间。
    计算机作出的图6．11a－e示意了一个区域的人口分布的演化，该区域起初没有局域中心之间的相互作用。城市化过程表现为局域吸引子变化的格变。图6.11b处于时间t＝12单位，结构开始围绕5个主要中心发展。图6．11c中，最大中心的核心部分开始达到极大值。图6．11d示意t＝34，基本结构本质上是稳定的。两个中心已经经历了中心部分的衰退。在图6．11e中，基本的模式是稳定的。衰退、中心化和非中心化都是复杂的非线性动力学引起的。
    图6.11a－e形成了城市系统的总体演化的加速运动图像。每一幅图像是一特定时间的总动力学状态的一幅相图。当然，这种模型是进行了简化的。但是，可以给它加上更多的功能作用方面，进一步研究其精细的非线性相互作用。不过，这种模型对于探讨决策选择具有启发性，可以在计算机模拟的案例研究中进行分析。无论是局域的还是总体的变化都可以增加到该系统中。这些模拟研究，政府极为感兴趣。

    一种可能的策略是，在特定的地点给予特殊的投资以干预城市结构。这种决策策略适用于城市系统中迄今为止欠发展区域的发展。例如，投资不仅仅是一种经济手段，同时也是一种文化吸引力和交通联系。有时，一项投资可以激起某种局部的蝴蝶效应，引出某种总体后果，而与设计者的善良意愿起相反的作用。这是可能的，原因在于模型的非线性限制了长期预测的可能性。

    一个城市的动力学是复杂系统的实际例子。它表明，如果忽略了非线性的后果，个别人的良好愿望是不充分的，甚至是危险的。个体行为的集体效应是我们社会的特征。进行决策时，要尽可能地意识到这些集体效应。这些后果的重要性不仅仅出现在对于具体决策及其非线性的计算机模拟中，甚至并没有参与具体的计划活动的公民，也必须意识到社会中的复杂的相互关联性。
    煽动人们要求有对一位可以解决所有问题的强有力的政治领袖，从民主观点来看，这不仅仅是危险的。从数学角度看，由于现代高度工业化社会的复杂性，还表明它是错误的。另一方面，我们不要把希望寄托在个别的政治家或党派的身上，也不要当我们的被夸大了的预期未能实现时，又走向完全对政治丧失信心的另一端。人类社会的特征是其中的成员具有意向性。然而，如同原子团、分子混合物、细胞有机体或生态群体一样，他们也是由非线性的复杂性规律所支配的。
    社会学理论中，对于复杂性和非线性的认识论考察仍然处于初期。发展起一种能够适当处理社会问题复杂性的统计数学，可以作为通向传统社会学概念的桥梁。在复杂系统探究方式中，社会现象是由非线性方程来描述的。例如，对埃米尔·德克海姆谈到的社会中的连带性，我们可以把这种概念的功能方面归因于复杂系统的非线性和集体效应。我们可以把政治决策划分为“线性的”和“非线性的”，例如，“线性的”相应于“个人的”选择，而“非线性的”相应于行政管理、大众媒介和政党这样的组织体制环境。许多公民和组织机构的行动和反应，都可以被理解为社会统计描述中的固有涨落。社会的确定论特征并不仅仅反映了分布函数的平均值，它们是按照如同主方程那样的非线性规律随时间发展的。
    沃夫冈·维德里希的斯图加特学派已经发展起来了这种对于社会经济动力学的研究方式。其数学建模方法是从协同学和统计物理学中推导出来的，允许对社会中的集体发展进行定量描述。协同学指出了社会中的微观水平上的个体决策与宏观水平上的动力学集体过程之间的一种关系。社会科学中在微观经济学和宏观经济学、微观社会学和宏观社会学之间作出划分是大家熟悉的传统概念。维德里希的协同学探究方式是一种对于宏观过程的几率性描述，其中包括了忽略了涨落的准确定论描述的随机涨落和偏差。
    对于求解模型可以从两方面来进行考察，例如，可以用分析的方法，考察主方程或平均方程的近似解的精确性如何；也可以用数字方法或计算机辅助方法来模拟特征图景。通过在微观水平上的实际考察，确定模型的参量或借助模型模拟估计未来的发展，从而对经济系统进行分析、评价。图6．12中示意了用协同学探究方式对于社会动力学进行建模的方法论框架。

    这种协同学的建模概念已经被运用到若干种社会科学的问题中，例如，对于政治见解的集体形成，人口统计学，群体迁移，以及区域地理。协同学概念特别适合于把若干个社会部门的相互作用整合起来，诸如经济和集体形成政治见解之间的关系，或者经济和迁移过程之间的相互作用。迁移是当今一个非常重大的问题，揭示了线性的、单因果的思维是多么的危险。只有善良的个人愿望而没有考虑到个别决策带来的非线性的效果是不够的。线性的思维和行动可能激发总体的混沌，尽管我们的局部行动是出于善良的意愿。
    按照协同学探究方式，社会经济系统有两个特征水平，标志着社会中个体决策的微观方面和集体动力学过程的宏观方面。发生着涨落的几率性宏观过程，可由人类社会构型的主方程来描述。一种社会构型的每一组分，都涉及到具有特征行为矢量的亚群体。对于群体的迁移，迁入或离开某个区域的行为和决策，可以从群体的空间分布及其变化来识别。因此，模型的动力学允许我们描述群体的不同总体宏观状态之间的相变。
    经验性管理数据可以用来对这个理论进行检验。该模型可以是关于一个国家中的区域迁移，它由经济和城市发展的不同所引起；它甚至也可以是在“南”和“北”之间的惊人的世界性迁移，即在穷国和高度工业化的西欧、美国之间的迁移，这是由政治和经济的不景气所推动的。动物群体的物理输运或迁移常常是不可控制的、随机的和线性的，没有成员和集合体之间的相互作用。但是，人类的迁移则是有意向性的（受到收益考虑的驱动）、非线性的。因为这种转移率并不线性地依赖于整体的社会构型。
    两个人类群体之间的迁移相互作用可能引起若干种协同学宏观现象，比如形成稳定的混合体，形成两个独立的稳定聚居群体，或者保持着不休止的迁移过程。在迁移动力学的数字模拟和相图中，协同学宏观现象可以通过相应的吸引子识别出来。图6．13a，b示意了两个群体的均匀混合，两者的聚集或分离的倾向都比较弱。图6．13a是平均方程的相图，其中有一个稳定的平衡点。图6．13b示意了主方程的稳恒解以及具极大值的几率分布。图6．14a，b示意了两个稳定的聚居群体的形成，两群体间显示出弱的聚集倾向和强的分离倾向。图6．14a是有两个定态不动点的相图，而图6．14b描述了定态不动点的最大几率分布。

    图6．15a，b表示，两群体中存在的是中等程度的聚集倾向和强烈的对称相互作用。图6．15a示意的是一个涡旋图像，而图6．15b相应于极大值的几率分布。图6．16a，b相应于某种无休止的迁移过程，每一群体都有强烈的聚集倾向，两群体间有强烈的不对称的相互作用。图6．16a的相图显示了有不稳定起源的极限环。图6．16b中稳恒几率分布有4个极大值，它们与顺着极限环的边相连接。在社会学上，这种情况被解释为由不对你的侵入和群体迁移引起的逐步侵蚀。

    如果我们考虑在三个区域中的三个群体而不是考虑两个群体，那么非线性迁移模型中就会出现确定论混沌现象。一些数字模拟得到了最后轨迹状态是奇怪吸引子。在其他情况下，相继出现的分叉变得越来越复杂，最终转移到混沌态。

    应用于管理和组织社会学领域，是复杂系统探究方式的另一类实际应用。实际上，现代的公司已经开始将其大型组织重组和分散化，以使其在问题复杂性不断增加的情况下成功地实现组织战略。例如，他们开始支持新方式的组织流动性，允许迅速地形成以项目为中心的团体，以及按照环境的需要进行重新组合。与采取固定的社会结构组织形式相比较，流动性组织采取的是一种较高水平的合作方式。面临着社会的两难问题，流动性组织显示了一种极其多种多样的复杂的合作行为，这是由个体战略和结构变化之间的非线性相互作用引起的。
    这些社会群体的动力学可以按照复杂系统来建模。计算机模拟对于可能的行为发展方式提供总体的洞察，由此有助于管理者去实现发展的适当条件。即使复杂系统的模型是适用的，当然也不可能作出长期预测并通过集中式的领导来进行全面控制。
    这种模型是由意向性动因组成的。它们的选择决定于个体的偏爱、期待、信念以及过去的不完整的知识。合作模式是从个体在一定临界值内进行选择所导致的。当群体中一部分领悟到进行合作超过一定临界值时，个体也将采取合作。临界值取决于群体的大小，也取决于从个体的相互关联模式中形成的社会组织的结构。如果允许群体改变其社会结构，就增加了以合作方式来解决社会两难问题的潜力。组织流动性有其优点，但必须与可能丢失效率进行均衡。组织的效率，可以用它在一定时间中获得的总体收益来测量。
    在公司中，一般都存在着某种非正式结构和正式结构，非正式结构是人们之间的情感联系模式导致的，正式结构则是由等级组织支配的。非正式结构通过一种自组织过程而实现，它可以用社会中的人际关系结构来代表。这种研究方式可以追溯到20世纪50年代对于城市家庭的社会关系网的研究，现在已发展成为一种高级的计算机辅助的社会学工具。从个体相互关联的微观角度看问题，就形成了一种对于社会结构的全局透视。
    图6．17和图6．18中，这些结构被形象化为树状结构。每一分支代表着等级组织中较高水平上的一个子部门。在较低水平上的模式代表了个体，它们造成合作因素的完整循环和造成缺陷的开放循环。把两个个体分开的组织层的数目，是由每一个体从树状结构返溯到其共同起点时的模式数目所决定的。组织中两个单元之间的距离，由隔开的组织层数来度量。两个单元之间的距离越远，它们的行动之间的相互影响就越小。因此，组织树说明了一个群体中的集束数量和程度。
    关键性的问题是一个群体的结构和流动性将如何影响合作的动力学。流动性依赖于个体在社会中的移动的难易程度，以及他们是否容易取得成功并扩展到结构。在复杂系统的框架中，系统的宏观性质是从下层的组分的相互作用中衍生出来的，这里在数学上用非线性演化方程来建模。

    格兰斯和休伯曼在图6．17a－d中示意了对一个固定的社会结构中某些相转移的计算机模拟，其中由3个大集束构成了3层次的等级，每一个大集束又是由3个3元素的子集束构成的。图6．17d中的最终的总合作是由图6．17a中若干个单元的集束行动所导致的。这些单元相互加强，同时又能够推动一个层次上的单元进一步加入到合作之中。这种合作的增加可以影响结构中单元的合作，甚至可以进一步加入到合作之中。
    在一个等级结构中的某个微小的合作行动，就可能引起大范围地转向整个组织的合作。这种一连串增加的合作将导致某个不动的平衡点。但是，具有固定结构的群体容易成长起来并超出持续合作的界限。在这种情况下，群体将迅速演化到它的总偏离的平衡状态。但是即使在这种界限以内，合作模式也是亚稳的，即单元之间的合作不可能长期保持，终归会过渡到发生突然的对称破缺，出现总的偏离。
    在流动结构中，个体单元可以在组织中移动。个体根据他们所期待的长期利益而作出合作或偏离的决策。为了评价他（或她）在结构中的地位，他（或她）将把长期报酬与期望值进行比较，如果合乎他（或她）的期望，他（或她）就会呆下去，如果不合乎就会离开，离开的选择是随机的。当个体评价他（或她）的地位时，还会考虑突破现状而形成某种新集束的可能性，如果他（或她）感到这样做并不导致任何损失的话。个体单元是否容易取得突破，决定了取得突破的临界值，它是未来最大可能报酬的某个分数。
    图6．18a－e粗略显示了一个流动组织中的相变。最初（图6．19a），群体中的所有成员（按每束4人划分为4束），都是处于偏离中。图6．18b表明，几乎其中所有的成员都已经依靠自己取得了突破。在这种情况下，成员们更倾向于转向某种合作的策略，实现了图6．18c。因为不确定性，成员中不时有集束之间的切换（图6．18d）。当一束变得太大时，该束就可能开始转向偏离。在这一转移阶段（图6．18e），越来越多的成员将取得自己的突破，并重复出现类似的发展。这种类型的循环已经在模拟的组织中反复观察到了。

    正如在城市生长的情形（图6．11）或者迁移动力学中（图6．13-图6．16），对社会组织的计算机实验模拟不可能对个体行为得出确定论的预测，但是它们有助于人们理解社会动力学的敏感性和复杂性。因此，就有可能去实现适宜的环境和条件，从而改进相应社会系统中的人们的生活状况。
    社会文化进化的模型必须考虑到多个相互作用的方面。如果一个社会是由多层、多部门交叉的耗散结构构成的，我们就必须找到合适的图像去说明它们是如何形成的。在包含相互作用的耗散系统的复杂发展中，新的宏观结构的形成从长期角度看就是一种分散化和非计划事件。而且，在每一方面都包含着许多或明或暗的激励和鼓舞着人的行为的思想、感情和预计。它们无法直接地加以量化，因为它们溶解在一条被称作“生活方式”的洪流之中。然而，一个社会的生活方式是一种典型的社会文化的宏观现象，依赖于多种相互作用的可以鉴明的因素：诸如与经济、技术、工作、旅行、生态和传播媒介相联系的条件状况。
    当代世界中，技术的进化已成为一种变化的推动力量，影响着多种多样的生活方式要素。对于自组织过程，一种显著的特征是，技术的发展是自催化的，每一种创新都催化下一种创新的产生。一种主导的思想（“范式”）是把技术和社会进化解释为技术相继被取代的结果，即一种人工物被另一种人工物取代，照此从增长到饱和的发展就可以进行数学建模，表示为相互关联的逻辑斯蒂曲线。断言技术的进展是通过一系列的相变和取代而进行的，意味着它们可以看成一系列相继的逻辑斯蒂曲线。每一条曲线都达到了某种饱和水平。随着每一水平的进化创新，就发展起一条新的逻辑曲线的相变。
    在6.3节中，我们已经讨论了技术中的这些相变是与经济的增长或衰退相关联的。计算机和信息技术的发展已经前所未有地影响了几乎所有领域中的人类生活方式。看来可以将其比作一种准进化过程，即产生出复杂性不断增长的计算机和信息系统的过程。当计算机科学家们谈论新一代计算机超越了老一代计算机的复杂性时，就运用着赫伯特·斯宾塞的术语。事实上，系统功能的复杂性已经增加了。但是，另一方面，例如，问题的复杂性（由其所用计算时间来度量）就已经减少了。问题复杂性的减少就是这些技术的准进化过程的一种序参量。
    计算机和信息技术系统已经成为社会文化发展中的一项至关重要的技术，以准进化过程进化着。这种过程的复制作用具有某种信息模式，它们构成了文化，并以变化着的方式从这一人群传播到另一人群。与分子和初等有机体不同，人们有其自己的意向性，信息模式的传播过程不是通过机械式模仿来实现的，而是通过通信来实现的。将其与基因相比较，这些复制作用常被称作“縻縻”（memes）。它们包括思想、信念、习惯、道德、风尚和技术等等。
    任何能够通过信息通信方式传播的模式就是一种魔摩，甚至在其人类宿主无法表达它或是没有意识到它的存在时也是如此。重要的是，认识到人类文化的复制子是縻縻，而不是人们。正如卡尔·波普尔主张的，我们能够改变我们的思想，使得推动文化进化的不是人们的选择，而是“让我们的理论替我们死亡”。
    在复杂系统的框架中，我们当然可以谈论在数学演化方程的抽象意义上的系统“进化”。具有其特殊生物化学机制的生物进化，只是标志了复杂系统的一般数学框架中的特殊模型。因此，人类文化的进化特征，是不可能归结为生物进化的生物化学机制的。但是像“縻縻”这样的概念，不应该被误解为只是一种社会达尔文主义的行话。它们可以说明能够从数学上定义并在经验上检验的复杂系统的基本特征。
    在此意义上，世界范围的通信网络的发展，可以被解释为协助人类中的縻縻传播以建立起一种縻縻生态系统的复杂系统的进化。支撑着人类文化的縻縻是多种多样的，也是其变化和选择的机制。在6．3节，我们已经讨论了“经济縻縻”及其市场选择机制。经济市场对于其自身的人类社会环境总是具有一定程度的开放性。在它们的运行中，总是受到广泛的严格程度不一的种种力量的制约，它们是由各种法律和调控机构所施加的。
    在人类社会中，法律系统和政府活动为市场提供了某种框架。在复杂系统的框架中，它们不可能免遭进化力量的冲击。它们在政治生态系统中，以其自身的机制发生着进化，进行着法律的变异和选择。一些政治縻縻，如政治欲望、政治口号或政治纲领，可以成为社会热力学相图中的吸引子。在一个开放的民主社会中，它们可能兴旺，但也可能衰落，如果由于竞争替换的选择压力使得它们的吸引力减小的话。
    管理现代社会的复杂性的能力决定性地依赖于有效的通信网络。如同生物大脑中的神经网络一样，这些通信网络决定着有助于人类生存的学习能力。在复杂系统的框架中，我们必须为在其经济和文化环境中传播的信息技术进行动力学建模。因此，我们就涉及到信息的和计算的生态学。这样的例子是现实的，预订机票、银行联网、实验室联网都是现实的例子，它们都包括了许多各种各样的计算机网络。
    不完整的知识和迟到的信息都是开放计算系统的典型特征，在此是没有中心控制的。这些巨大的网络，从不断增加着种种计算机辅助的信息中心的联接中出现，正在变成一种自组织系统，它们不同于它们的由单个程序控制的组件。它们的非计划性增长导致了巨大的技术复合和运用的多样性，也增加着相互兼容的困难。这种解放着人类文化的独立机器人世界，呈现出一幅令人生畏的景象，可能会是许多可能令人不安的图景的最后结局。
    由于世界范围的局域信息和计算机中心的增长不可能通过中心处理者来进行规划，因而就要有一门非线性动力学，应该在复杂系统的框架中对它加以研究。甚至对简化的案例进行研究，也会对现代社会文化进化提供某些重要的洞察。计算生态的复杂相互关联性，违反了传统的等级分解要求，传统管理中进行的等级分解是将其分解为技术的、工业的或管理的部门。现代技术通信网络是增长着的开放系统，其中必定没有诸如机器或人的中心控制、同步控制或一致数据。
    不完整的知识导致了某种优化差距，而信息接受的延迟则引起其中单元的振荡。合作以及对有限资源的竞争可能导致协同效应。混沌则阻止了任何稳定的问题求解策略。马尔文·闵斯基已经研究了一种简化的集体问题模型，求解使用的一些独立的单元，它们针对一组相关问题，并发生相互作用。这种例子可以运用于计算机辅助信息系统的分布系统的模型设计中。
    贝纳多·A．休伯曼和塔得·哈格分析了一个模型，它有一些中心或成员，能够在种种可能的策略中进行选择，以完成指定的任务（图6.16）。此策略相应于他们所设想的报酬，单元反复地针对不同策略评价所设想的报酬，并转向具有最大报酬的策略。此模型的演化方程决定了过程改变其策略的速率。由于在一定时间间隔中只有一部分成员决定转向，所以系统的动力学必须用几率方程来建模。
    此种系统可以显示出种种行为，范围从不动点一直到振荡和混沌。系统中不可避免的振荡可能是延迟的信息所引起的。不完整的知识和延迟甚至可能引起混沌行为。由于报酬依赖于偏爱选择何种策略，动力学和初始条件都将阻止对于长期行为作出预见。
    世界正在成为充满数量巨大的计算系统的世界，复杂性在不断增长。其中包括有传统的冯·诺意曼机，向量巨型机，共享贮存多处理器、联接机、神经网络机和成千上万的如同阿米巴那样充满这个世界的个人计算机以及将来的分子计算机。这些计算系统正在逐步与诸如卫星、电话、光纤的种种信息系统联接起来。一个自组织的世界范围的软件和硬件系统网络的思想，已经变成现实了。

    例如，1969年，在美国国防部建立了计算机辅助的信息网络。它已经成了一个迅速成长的网络的核心。这个网络已经联接了175000台计算机、936个终端及许许多多的人。在INTERNET的增长中，没有任何中央处理器的计划或控制，而是一个或多或少有些混乱的过程。然而，组织模式从混沌中出现了，或者也将以某种全球自组织的方式衰退。
    在复杂的信息网络中，知识和信息分布在多个中心和个别的程序编制者中。它们的复杂性排除了集中计划。如同所有包括目标、资源和行动的系统一样，计算已经用经济学术语来加以描述了。显然，运用着市场机制的软件和硬件的计算市场已经出现。正如我们已经在6．2－3节中见到的，市场是一种自组织的复杂生态系统的形式。按照斯密的基本见解，比起任何程序编制者和集中控制者的计划和理解，消费者进行选择的力量将使得计算市场生态系统为人们提供更好的服务。原因在于，计算生态系统的巨大复杂性和多样性是与人们的市场联系在一起的。
    读者可以回忆一下生物生态系统的复杂性，其中有多个层次，包括细胞、器官和机体。同样地，一个计算生态系统的元素，也是按照计算系统的复杂性增长而在不同水平上结合起来的。图6．20示意了全球的USENET网络，它通过许多的局域成长因素而成长起来。该网络的发展现状是包含了37000个节点，它只是INTERNET的一部分。如果人们想要发送或接收电子邮件或利用其他的信息服务，只要找到一个局域的USENET站就可以实现所希望的全球联结。
    不过，在计算生态系统与生物生态系统之间的类似性，并不意味着任何的还原主义或生物主义。在复杂系统的框架中，计算生态系统和生物生态系统仅仅是数学演化方程的模型，由此标志了复杂系统的非线性动力学。按照闵斯基的观点，覆盖全球的计算机辅助网络可以解释为一种“市场”或“精神社会”。

    哲学上，这种新的世界性“知识媒介”或计算机辅助的“智能”，使我们想起了黑格尔的理念。他的理念是一种“客观精神”的形成，它嵌在人类社会及其法律系统、经济和官僚制度之中，克服了个人的“主观精神”。但是，这些计算生态系统，既没有人类个体的大脑神经网络具有的意识，也没有大脑神经网络所具有的意向性（参见第4章）。
    然而，问题是计算生态系统是否可以称作具有某种程度的“智能”。对于个体进行的智能测验，是判断其在一定时间中实现某种设定的目标的能力。在这里，智能并非某种形而上学的普遍概念；相反，这里设定了若干个精确程度不同的可检验的行为标准。一些作者已经建议，判断一个社会的“智能”，同样可以根据它运用给出的资源去实现目标的能力，这些目标是由一定的合法的子群体（例如议会）设定的。“智能”程度依赖于能够实现的目标的范围，实现目标的速度和所用手段的效率。这些定义的细节可以是不同的，但是，基于这些概念的“智能”实际上涉及到整体系统的宏观特征。这些定义的实际目的，是要比较计算生态系统及其成功地求解问题的程度。与此相反，诸如一个国家的集体“智能”这样的术语，在意识形态上是危险的。而且，我们必须意识到，智能的技术标准与意识这样的概念是有区别的，意识实际上是由生物进化中一定的大脑网络的自参照性所实现的。
    信息和计算的生态系统的生长，与社会的基本性变化相联系，其特征是从传统的处理货物的产业转向信息和信息服务的知识产业。信息的生产、分配和管理都已经成为以知识为基础的现代社会的主要活动。因此，在人类和信息系统之间的界面必须不断地加以改进，以实现世界范围的人类通信网络的理想。人类的表示方式，如言谈、姿势或书写，都应该为计算和信息系统直接理解。“完整人范式”和“人机网络”是未来通信世界的最重要内容。
    人类的通信不仅仅涉及到信息字符串，而且还涉及到直觉、感情和情绪。未来的通信世界有时被称作“全球村”以强调由于高技术环境导致的熟知程度。但是，对它的接受决定性地取决于与人类友好界面的实现。我们必须考虑一种新的复杂性，包括人的直觉和情绪。古老的理性理想，作为对于人类生活本质的抽象，完全地忽视了人类世界。甚至科学研究的过程也是由人的直觉所鼓舞，由人的情感所驱动，这是在未来的通信世界中必须要加以考虑的。
    一些人担心，社会文化进化的最终吸引子将不是一个全球村或世界性的城邦，而是一个巨大的“利维坦”借助着现代的高技术程序来统治着人类。在虚拟现实的计算化世界中，人类的所有表达方式都将数字化，对于人们的亲密不留下任何余地。但是，社会文化进化的复杂性将允许有多个吸引子。它们不可能由人们的决策来预见或决定，但是它们将受到人们能够实现的条件和约束的影响。在一个高度复杂性的世界中，人类自由的机会是什么？在一个高度非线性的集体效应的复杂世界中，个人的责任程度是什么？这些问题导引出结语中关于复杂性、非线性世界中的伦理学的讨论。

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页


克劳斯·迈因策尔—复杂性中的思维—7、关于未来、科学和伦理学的结语

7、关于未来、科学和伦理学的结语

    复杂系统原理主张，物理的、社会的和精神的世界都是非线性的、复杂的。这个基本的认识论结论对于我们现在的行为和未来的行为，都有重要的影响。科学和技术对于未来的发展有着至关重要的影响。因此，本书最后将展望一个复杂的和非线性世界中的未来、科学和伦理学。我们对于其未来能够知道什么？我们应当干些什么？
    7．1复杂性、预测和未来
    在古代，预测未来的能力似乎是预言家、祭司和占星术士的某种神秘能力。例如，特尔斐神谕中，占卜家皮蒂娅（公元前6世纪）在迷糊状态之中揭示了帝王和英雄的命运。在现代，人们变得相信拉普拉斯妖的无限能力：对于无摩擦的不可逆的线性保守世界，预测将是完满的。要预测一个过程的未来，我们只需要知道其精确的起始条件和运动方程，通过求解其未来时刻的方程就可以办到。科学哲学家们也早已致力于分析自然科学和社会科学中进行预测的逻辑条件。关于人的预测能力的信念，在本世纪中由于几方面的科学发展而动摇了。量子理论教导我们，一般地说，我们只能作出概率性预测（参见2．3节）。一大类现象是由确定论混沌支配的：尽管它们的运动服从牛顿物理学定律，它们的轨迹却是敏感地依赖于其起始条件的，因而排除了长期预测。在耗散系统中，如同贝纳德实验的流体层（图2．20），有序的出现不可能预测，因为这有赖于微观上的起始小涨落。诸如蝴蝶翅膀扇动那样的随机事件，原则上是可能影响全球的天气动力学的。在第6章中，我们已经知道，经济、商业和社会中的模式和关系常常会剧烈变化。在自然科学之外，人们的行动——这是社会科学中要观察的——能够而且正在影响着未来的事件。因此，预测可以变成自我满足或自欺欺人的预言，它自己在改变着已经建立的模式或过去的关系。预测是否也就只不过是盯住水晶球看呢？

    但是，几乎我们的所有决策都联系着未来的事件，需要预测关于未来环境的情景。这对于个人的决策的确如此，例如何时与何人结婚、何时和如何投资储蓄；对于影响着整个组织、公司、社会或全球状态的复杂决策也是如此。近些年来，改进经济和生态、管理和政治中的预测和决策已经得到越来越多的强调。经济震荡、生态突变、政治灾难以及诸如新市场的机会、新技术的趋势和新的社会结构，都不应该再是杂乱无章的，不应该是上帝送来的致命事件。人们希望做好准备，因此开始发展起来种种定量的预测方法，它们针对着如商业和管理中的不同的情形。从方法论的观点看，所有的定量预测工具都标志着特定的预测水平，这限制了它的可靠应用。让我们对一些预测工具的长处和短处进行一些考察吧。
    最通行的定量预测方法是时间序列程序。它们假定，在数据系列中的某种模式是可以在时间上再现的，可以外推到未来。因此，一个时间序列程序，对于预测环境因素如就业水平或超级市场每周的销售情况——在此个体的决策没有多大的影响——可能是合适的。但是，时间序列是不可能对数据模式背后的原因作出解释的。在历史上，巴比伦天文学家就运用着这种方法，他们把月亮东升的数据模式外推到末来，而没有任何基于行星运动模型的解释。在18世纪，物理学家对于太阳黑子的原因知之甚少。但是在太阳黑子的观察中，发现了一种频率和数量的模式，因而通过时间序列的连续来进行预测就成为可能。在商业和经济中，数据序列中隐含着多种模式。某种水平的模式可能在数据中并没有得到体现（例如稳定销售的产品）。某种季节性模式的出现，是按照某种季节因素引起的一系列的涨落，如有些产品的销售依赖于天气。某种循环模式可能不会以恒定的时间间隔再现自身，如金属的价格或国民总产量。某种趋势模式，出现在变量值随时间出现某种一般性增减时。在数据序列中有某种隐含模式时，此模式必须要通过将过去的数值平均化和平权化（“平滑化”）而与杂乱无章区分开来。数学上，线性的平滑化方法可以有效地运用于这样的数据：它们展示了某种趋势模式。但是，平滑化方法并不试图去证明基本隐含模式的个体组分。趋势、循环和季节性因素还可以有子模式，它们必须从分析数据序列的总模式中分离出来、分解开来。
    在时间序列程序中，某种过去的数据模式被简单地外推到未来，而一个解释性模型则假定了在（“因”）变量y（这是我们希望预测的）和另一个（“自”）变量x之间的关系。例如，因变量y是每单位生产的费用，而决定着生产费用的自变量X是单位产品的数目。在此情形下我们可以在x和y的2维坐标系中建立关系模型，画出一条直线，它在某种意义上将给出这种关系的最好的线性近似。回归分析运用此种最小面积方法，去减少实际观察值y和相应的线性近似直线上的点y之间的距离。显然，在许多情形下这种方法并非一种有效的方式。一个例子是月销售量的预测，它按照一年的季节发生非线性变化。此外，所有的经理都知道，销售量并不只受时间的影响，还受到多种多样因素的影响，如国民总产量、价格、竞争对象、生产代价、税收等等。两个因素的线性相互作用，仅仅是经济中的一种简化，就像经典物理学的线性保守世界中的两体问题一样。
    但是，一个更精确的复杂模型当然是需要更多的努力、更多的经验和更多的计算时间的。在许多决策的情形下，解释或预测一定的因变量要用到一个以上的变量。举一个普通的例子，销售经理希望预测下一年公司的总销售量，并对影响这种销售量的因素有更好的理解。因为他有一个以上的自变量，他的分析就成了多元回归分析。然而，他希望预测的因变量是表达为自变量的线性函数的。回归方程中的计算基于过去的观察样本的运用。结果是，基于此种回归方程的预测的可靠性，就主要取决于所使用的特定的样本。因此，可靠程度必定由统计显著性检测来度量。与多元回归涉及到一个方程不同，经济计量学模型可能包含多个联立回归方程。在线性方程中，求解的数学方法是基于线性代数和线性优化方法的（例如，单纯形方法）。尽管它们是线性的，经济计量模型可能是非常复杂的，有多个变量，只能用计算机程序和机器来把握。经济学中非线性编程的求解策略常常是将复杂的问题分解成子问题，使之可以近似地作为线性问题来处理。
    运用这些方法时的一个隐含的假设是，与现有历史数据吻合得最好的模型将也是能超出这些数据作出未来预测的最好模型。但是，对于大量的真实世界的情形，这种假设并不见得有效。而且，在经济学和商业中使用的绝大多数数据，忽略了测量误差，也难以进行试验控制。因此，有必要理解，当已建立起来的过去模式发生变化时，种种预测方法是如何成功的。预测在标志着每一方法的不同预测水平上是不同的。显然，不存在唯一的方法，它可以很好地预测所有的序列和预测水平。有时，过去的数据完全不能显示未来的变化。因此，如果没有内部知识，要预测一个模式的变化是不可能的。模式转移或“范式变化”是商人和经理的日常经验，而非库恩等人的传统中某些科学哲学家们的超常见解。
    有没有可以决定数据序列中的模式或关系何时发生变化的定量程序？这种方法的确存在着，其中运用追踪信号来显示预测误差中的变化，以表明何时发生了非杂乱的转移。在质量控制流程中，例如，对于小汽车的生产序列，对设备的输出要进行周期取样。只要样本的均值落在控制限度以内，设备的运行就被认为是正常的。当情况不是这样时，就停止生产并采取适当的措施，以使其重新正常运行。一般说来，定量预测方法的自动监测遵循着这种质量控制流程概念。任何时间进行的预测，其误差（即实际值减去预测值）都与控制限度的上限和下限进行对照。如果它落在可接受的范围中，外推的模式就没有变化。如果预测的误差落在控制误差之外，已建立的模式中就很可能发生了某种系统的变化。当涉及到大量的预测时，通过追踪信号进行自动监测可能是合适的。但是在只有一个序列或几个序列时，人们就只能伺机而动，去发现此商业数据的趋势中是否发生了变化。
    预测技术和市场、新产品或服务的赢利的未来趋势以及与相应的就业和失业相联系的趋势，是管理者和政治家面临的最困难但也是最紧迫的任务之一。他们决策依赖于大量的技术、经济、竞争、社会和政治的因素。自从20世纪50年代出现了商业计算机以来，人们燃起了这样的希望，即通过计算速度的加快和数据存储的增加把握这些复杂的问题。的确，任何定量的预测方法都可以编程放进计算机中去运行。因为没有任何一种方法可以适用于所有的情形，于是发展起来以计算机为基础的多预测系统，从而为管理者提供一组选择方法的清单。一个例子是预测系统SIBYL，其名称来源于古代的预言家西比尔。相传西比尔曾把著名的《西比尔占语集》出售给罗马大帝塔克文（高傲的）。
    的确，SIBYL是一个基于知识的系统（参见5．2节）的计算机化预测方法包。它提供的程序包括进行数据准备和数据处理，从屏幕上选用可利用的预测方法，所选方法的运用，对预测方法的比较、选取和组合。屏幕预测技术选择中，基于知识系统的推理组件提示了这样的方法：它们以大范围预测运用和决策规则样本为基础，是最接近于匹配特定的环境及其特点的。SIBYL的最终功能是，检验和比较其中的哪一种提供了最好的结果。使用者和系统的界面，要尽可能地友好和有效率，以适用于预测专家，也适合于新手。然而，我们决不要忘记，SIBYL只可能优化所存贮的预测方法。原则上，预测方法的预测水平，不可能由使用计算机而得到放大。与人的专家具有学习能力相反，如SIBYL这样的预测系统仍然是程序控制的，具有基于知识系统的典型局限性。
    一般说来，基于计算机的预测自动机是遵循线性思维路线的。另一方面，现代计算机的能力不断增加，鼓舞着研究人员去分析非线性问题。在20世纪50年代中叶，气象学家偏向于使用基于线性回归概念的统计预测方法。这种发展，得到了诺什·维纳对于稳恒随机过程的成功预测的支持。爱德华·洛仑兹对这种统计预测思想产生了怀疑，并决定对比非线性动力学模型从实验上来检测其有效性（参见2．4节）。天气和气候是一个有能量耗散的开放系统的例子。为这种系统建立的模型中，用相空间的点表示其状态，用轨迹来表示其行为。经过一定时间后，轨迹就达到了某个吸引集（“吸引子”），这可以是此系统的某个稳定的点（图2．14a或图3．11c）、某个周期振荡，叫做极限环（图3．11b）或奇怪吸引子（图2．21）。如果人们希望预见包含某个稳定点或极限环的系统的行为，人们可以观察到附近的轨迹会发散，不会生长，甚至会消失（图7．2）。在这种情形下，整体的起始条件将达到定态，相应的系统也就是可预测的。一个例子是，用非线性的洛特卡-沃尔特拉方程建模的生态系统，捕食和被捕食群体具有周期轨迹。附近轨迹的发散和收敛，可以用所谓的李亚普诺夫指数进行数值度量：

    我们考虑时刻t＝0起始条件为x（0）和x’（0）的两条邻近的轨迹x（t）和x’（t），矢量d（t）的长度d（t）＝[x’（t）－x（t）]。如果轨迹收敛，那么d（t）≈eΛt且Λ＜0。量Λ叫做李亚普诺夫指数，定义为
    Λ（x（0），d（0））＝
    ［（1/t）ln（d（t）（0））］
    如果其值为正，李亚普诺夫指数就给出了收敛速率。在图7．2中模型过程x’（t）对真实过程x（t）提供了可靠的预测，因为假定此系统具有依赖于其起始条件的收敛轨迹。
    一个非线性系统的相图，可以具有若干吸引子，分别是不同轨迹趋向的区域（“分区”）（参见图2．10）。对于预测演化系统的未来，知道了所有的吸引子及其起始条件x（0）还是不够的。如果系统的初始状态正好是远离一定吸引盆的，那么相应的吸引子终态是不可预测的。
    在图2.22a－c中，非线性的逻辑斯蒂映射描述了随控制参量的不断增加发生的从有序向混沌的转移。图2.23a，b描述了相应的超过一定临界值而出现的混沌区的分叉序列。如果相应的李亚普诺夫指数为正，那么系统的行为是混沌的。如果它为零，那么系统倾向于分叉。如果它为负，那么系统就处于稳定态或分叉树上的一支。在这种情形中，系统是可预测的。在其他情形中，对起始条件的敏感性就开始出现。显著之处在于，在混沌区的非线性系统决非意味着完全不可预测。在混沌未来的灰色区中的白条或“窗口”（图2．23b），显示了具有负的李亚普诺夫指数的局域有序状态。因此，在混沌的海洋中，我们可以找到可预测的有序岛。在这种情形下，至少对于短的特征时间间隔系统是可预测的。
    一般来说，可预测程度的度量使用的是开始观察后的特定时刻的观察过程和模型之间的统计相关。接近一致的值相应于满意的预测，而小的值表明了观察和预测之间存在差距。所有预测模型都有一定的可预测行为的时间，超过了以后可预测性会减少，以不同速度趋向零。对于模型的改进可能使预测行为的时间有某种程度的扩展。但是，可预测的范围依赖于涨落参量。局域不稳定混沌系统中弱的微观扰动可以在短时间中达到宏观规模。因此，局域的不稳定性惊人地减少着对预测行为的改进。预测系统的预测水平，既不可能通过改进测量仪器也不可能通过精致预测模型来改进。当我们记起洛仑兹的大气模型，使用的是具有局域的和全局稳定性的非线性系统，我们就会意识到气象学家在获取有效的长期或甚至中期预测中遇到的困难。通过不断增加的计算机的能力，天气预报就会直线地进步，这是20世纪50年代的一种幻想。
    随着非线性的模型运用于不同的研究领域，我们获得了对于振荡化学反应，物种、群体的涨落，流体湍流和经济过程的一般性洞察。例如，太阳黑子的形成，以前用时间序列的统计方法进行分析，它决非是一种杂乱的活动。它可以用非线性混沌系统来建模，具有几种特征的周期和奇怪吸引子，对其活动的预测是有限的。例如，在公共舆论形成的非线性模型中，我们可以区分出选举（“分叉”）前的可预测的稳定态与向稳定多数的转变，选举前两种可能的意见都没有受到偏爱，而不可预测的微小涨落却可能在很短的分叉间隔中引起突然的转变。这种情形使我们想起在沸腾水中气泡的形成：当一个气泡变得充分大时，它以其向上的方式稳定地生长是可预测的。但是，它的出现和初期的生长却是一种随机涨落问题。显然，非线性建模解释了现代民意测验中毕希娅们和西彼尔们的困难。
    今天，非线性预测模型并不总能够提供比标准线性程序更好的、更有效的预测。它们的主要优点在于，对真实过程中的实际的非线性动力学的解释，对局域的短期预测水平的证实和改进。但是，为了通过求解方程而预测未来的行为，首先要构造起支配了时间t的观测的适当动力学方程。甚至在自然科学中，对于如地震那样的复杂领域的适当的方程是否能够推导出来也还不清楚。我们可以希望在计算机的存贮中放入一张典型的非线性方程的表，在观察过程中系数可以自动地得到调节。与对所有可能的相关参量进行穷竭式搜索的做法相反，学习式策略可以从粗略的模型出发，只经过一段相对短的时间的运行，就可以说明相对窄的值域中的少量参量。通过神经网络的学习策略，已经实现了对于短期预测的改进。以学习数据为基础，神经网络通过自组织程序可以权衡输入数据，并减少对短期股票行情的预测误差（图5．22a，b）。若只有一部分股票市场的顾问使用这种技术支持，他们会做得很好。但是如果股票市场上的所有代理人都使用同样的学习策略，那么预测就将成为某种自欺欺人的预言。
    原因在于，人类社会不是分子或蚂蚁的复杂系统，而是具有高度意向性行动的存在物，具有或多或少的自由意志。一个特殊的自我实现的预言是俄狄浦斯效应。在此人们如同那个传说中的古希腊国王一样徒劳地试图改变他们的被预测的命运。从宏观的观点看，我们当然可以观察到一个个的个体以其自己的活动，对于代表看文化、政治和经济秩序（“序参量”）的社会的集体宏观态有贡献。然而，社会的宏观态当然并非只是对其所有部分的平均。它的序参量，以定向（“役使”）其活动、激发或抑制其态度和能力，强烈地影响着社会中的个体。这种反馈在复杂动力系统中是典型的。如果由于内部或外部的相互作用，环境条件的控制参量达到了某种临界值，宏观变量就可能运动到某种不稳定区域，在此高度发散的多种可能途径成为可能。微小的不可预测的微观涨落（例如为数很少的有影响人物、科学发现、新的技术），就可能决定了社会将在分叉处不稳定态的发散途径中取得何种途径。
    7．2复杂性、科学和技术
    尽管存在上述困难，我们仍然需要对于局部和全球的短期。中期和长期预测的可靠支持。从政治角度上看，一个最新要求是为科学和技术的未来发展建立模型，因为科学和技术已经成为现代文明中的一个关键性因素。实际上，这种发展似乎是在受科学思想和研究群体的复杂动力学支配，科学思想和科学群体是嵌在复杂的人类社会之网中的。研究群体的共同主题，长时期或短时期地吸引着研究人员的兴趣和能力。这些研究的“吸引子”，表现为支配科学家的活动，如同流体动力学中的吸引子和涡旋。当研究状态变得不稳定时，研究群体可能分解成追求特殊研究途径的小群体，它们可能会以获得答案而告结束，或可能再度分叉，如此等等。科学的动力学表现为由其复杂性不断增加的分叉树中的相变来实现。有时，科学问题得到了明确定义，并导致清楚的解答。但是，也有“奇怪的”和“扩散的”状态，如同混沌理论中的奇怪吸引子。
    历史上，对科学成长的定量探索始于统计方式，如雷诺夫关于“18世纪和19世纪的西欧物理学发展中创造性的波型涨落”（1929）的工作。罗伯特·默顿从社会学观点讨论了“科学和技术中兴趣中心的变化”，皮特里姆·索罗金分析了15世纪以来科学发现和技术发明的指数增长。他强调，发明或发现的重要性并不取决于主观的判断，而是取决于由基本创新引起的相继科学工作的数量。早在1912年，阿弗雷得·洛特卡已经设想，借助于微分方程来描述诸如疟疾和化学振荡的传播的真正流通过程。在一篇1926年的文章中（《科学产量的频率分布》），他运用了关于科学思想传播的流行模型。首先是有一个“感染思想”中心，它以流行型波的形式感染了越来越多的人。因此，从认识论的观点看，科学领域的积累和集中就使用所谓的洛特卡分布和布拉特福特分布来建模，此模型开始于某些个体作者的若干篇文章，它们成为出版物群的核心。流行模型还应用于技术创新的传播。在所有这些例子中，我们发现了众所周知的逻辑映射的S曲线（图2．22a），即开始较慢，随后是指数增长，最后又是慢增长到饱和。显然，学习过程也是用S曲线的3阶段来描述的，即个体最初的成功学习较慢，然后是迅速的指数的增长，最后又是缓慢的趋近于饱和的阶段。
    从统计分析转向动力学模型具有重大的方法论优点，即难以理解的现象如科学活动中的奇怪涨落或统计相关，都可以在计算机辅助的模拟实验中获得动态变化的图景。流行模型和洛特卡-沃尔特拉方程只是模拟科学共同体的耦合生长过程的最初尝试。不过，进化过程的基本性质如创造出新的结构要素（突变、创新等等），还没有得到反映。社会系统中的进化过程的描述，必须要包括不稳定的相变，新思想、新研究领域和新技术（如经济模型中的新产品）藉此取代掉已有东西，从而改变了科学系统的结构。在对艾根的前生物进化方程（参见3．3节）的推广中，科学系统的描述使用了一组可分清其数目的领域（即科学研究领域的子领域），其中每一领域都以一些占据的元素为标志（即科学家在特定的子领域中的工作）。自复制、衰退、交换和从外部来源的输入或自发发生等基本过程，都必须要建立模型。每一自复制或死亡过程，都仅仅改变某一个领域的占据状况。对于简单的无交换的线性自复制过程，一个领域的选择价值由该领域的“诞生”率和“死亡”率之差给出。当一个新的领域开始被占据，正是其选择价值决定了此系统对于此创新是否稳定。如果其选择价值大于任何此领域中的其他任何选择价值，新领域的生长就将超过其他领域，系统可能会变得不稳定。具有较高选择价值的新领域的进化，标志了一种简单的选择过程，它遵循达尔文的“适者生存”。
    但是我们决不要忘记，这种数学模型并不意味着把科学活动还原为生物机制。进化方程的变量和常数并不涉及生物化学量及其测量，而是科学计量学的统计表。自复制对应于新的科学家加入到他所希望从事的研究领域之中。他们的选择受到教育过程、社会需求、个体兴趣、科学学派等等的影响。衰退意味着，科学家只在科学领域中活动有限的年头，科学家可能会因种种原因（例如年龄）而离开科学系统。领域迁移意味着科学家在科学领域的交换过程，它遵循迁移模型。科学家也许会偏爱具有较大吸引力的领域，此种领域表现为具有较大的自复制率。当过程包括了领域之间的交换，这些领域具有自复制和衰退的非线性生长函数，那么一个创新的选择价值的计算就是相当复杂的数学任务。一般来说，一个具有较高选择价值的新领域，是由系统对于相应扰动的稳定性来标志的。
    实际上，科学的生长是一个随机的过程。例如，仅仅有几个先驱者投身到新领域的初始阶段，就是典型的随机涨落。科学子领域中可能占据密度的随机动力学，用主方程来建模，它使用由自复制、衰退和领域迁移的转移几率定义的转移算符。此随机模型，为科学生长过程的几种计算机辅助模拟提供了基础。相应的确定论曲线，作为对于大量一致的随机系统的平均结果，也被看作是趋势分析。结果，子领域的科学共同体的一般S形状曲线的生长规律，即具有缓慢的起始阶段、迅速生长阶段和炮和阶段，也在一些模拟中得到了证实。在一系列的模拟中（图7．3），假定了一个研究领域大约有120-160个成员。对于5个领域，选取了100个科学家作为起始条件，此起始条件紧接饱和领域。第6个领域还没有建立起来（其起始条件中成员为零）。在第一个例子中，已经对若干种情形，模拟了自复制过程对新领域生长曲线的影响。随着自复制率的增加，新领域以邻近领域为代价，增长得更加迅速。
    新领域的形成可能会有更加共存或更加选择的趋势。起始阶段的生长可能会或多或少快一些，或者也可能被延缓。科学史上一个生长被延缓的著名例子是混沌理论本身，它在起始阶段只受到非常少的科学家的注意（例如彭加勒）。尽管新领域的数学原理是相当清楚的，但是其指数增长是前些年当计算技术可以处理非线性方程时才刚刚开始。有时，一个形成中的领域不可能成长为一个真正的科学领域，因为它与众多的环境领域相比仅仅具有弱的选择优势。遗憾的是，有些技术领域如能源的替换（例如风能、太阳能），就仍然处于这种可怜状态，它们被强大的传统的或核的能源工业所包围。如果一个新的有吸引力的领域出现了，就可以看到科学家从周围领域争相进来的现象。这些人们正在适应新领域的风格和问题求解模式。这种直接的领域迁移，有时导致了科学中的时髦现象。

    众所周知，如果适当控制参量的增加使之超过一定的临界值，S形状的非线性逻辑映射就会产生出种种复杂动力学行为，如不动点、振荡、确定论混沌（图2．22）。显然，随机论模型和确定论模型都反映了科学生长的某些典型性质。这些效应是新领域的结构分化、缺省、创造、扩展，伴随着缓慢、消失、迅速生长、过度时髦和消退。对这些动力学效应的计算机辅助作图模拟中，可以用适当的序参量来标志，序参量能以科学计算数据为基础进行检验。在种种条件下的可能图景可以进行模拟，从而去预测未来发展的里程碑和领域。
    但是迄今为止，对科学研究领域进化的建模，仅仅考虑了所选择的领域中科学人力的变化。科学生长的更合适的表示，必须要考虑到科学努力中的问题求解过程。但是，要找到一个合适的态空间来表示科学领域中问题求解的发展，是一个困难的方法论问题。在生物进化的数学理论中，物种只能用高维生物特征空间的点来表示（图3．4）。一种物种的演化相应于一个点通过表现型特征空间的移动。类似地，在科学系统中，也必须建立起科学问题的高维特征空间。科学文章的构型以引证数量中的多维尺度技术进行分析，用二维或三维空间的点来表示。研究问题常常用关键词（“宏观术语”）的序列来表示，关键词根据它们在科学叙述中出现或共同出现的频率来选取。
    在连续的进化模型中，问题空间的每一点都用相应于所研究问题的矢量来描述（图7．4a）。问题空间由科学领域的所有科学问题构成，其中一些可能是未知的和还没有进入研究之中的。这种空间是距离空间，因为两点之间的距离相应于所表示的问题之间的主题关联程度。时刻t工作于问题q的科学家自身在问题空间的分布密度为x（q，t）。在此连续模型中，x（q，t）dq指的是在时刻t工作于“问题元”dq的科学家人数（图7．4b）。
    因此，此研究领域可能相应于问题空间中种种关联点的密度云。在这些较大密度区域之间的单个点，相应于科学家工作于独立的研究问题，它们可能代表了可能的新研究领域的核心。科学史表明，一组研究问题成长为一个研究领域可能要花上数十年之久。在此连续模型中，领域的迁移过程以密度变化来反映：如果一位科学家从问题q变化到问题q’，则密度x（q，t）将变小，x（q’，t）将增加。科学家在问题空间的运动，用一定的生产-输运方程来建模。函数a（q）表示，在领域q中科学家通过自复制和衰退而生长的人数变化率。因此，它是一个在问题空间具有多个极大值和极小值的函数，表示了科学领域中的吸引力的增加或减小。类似于物理势能（例如图4．10），人们可以把a（q）解释为具有山地和低谷的吸引力势能地形，代表着研究领域的吸引子和停滞区（图7．4b）。
    知识生长的动力学模型已成为科学计量学上可检验的。因此，它们可能在科学哲学及其科学生长概念、科学史及其科学文献评价之间架起桥梁。在认知计量学中，最近进行了一种尝试，对研究问题进行量化，并在由图书计量学的、认知的和社会的特征所构成的适当问题空间中，将它们表示出来。由波普尔、库恩等人提出的简化的科学史模式，就可能用可检验的假说来代替。库恩的具有“常规”科学阶段和“革命”科学阶段的不连续的序列，显然难以解决知识的生长问题。另一方面，某些历史学家的朴素信念，即认为科学的生长是永恒真理的不断增长，无论如何也是不适合于复杂研究动力学的。甚至波普尔的精致了的后期哲学，认为科学并非通过不可归约的已有定律的单极增长，而是通过假说和批判的学习策略而增长，也需要更精确和更明晰的历史地变化着的方法论、体制和组织的标准。现代计算机的计算能力不断增加，使我们能够在社会科学中进行新的模拟试验的定量探索。动力学模型的巨大优势在于，通过计算机辅助以图形方式显示出改变参数的多种形象。这些形象可能会确证。限制或反驳所选的模型。最后，我们的科学政策决策时同样需要可靠的支持。不同的未来发展图景可能会帮助我们决定，我们的有限的研究预算资源向何处投资，以及如何实现所希望的未来社会状态。

    因此，非线性建模和计算机辅助的模拟可能使我们推导出多种未来，但是不可能提供一种在它们之中作出选择的算法。为了实现所希望的未来社会状态，常规的目标必须要包括进来。20世纪60年代以来，罗马俱乐部的一系列报告引起了一种国际性争论，涉及人类的目标和可选择的未来，并有定量的长期预测的支持。在7．1节中，我们看见了对于非线性世界进行长期定量预测的限制。结果是，政治决策不可能逼出科学思想和技术创新。但是，它们的发生或不发生却决不是完全随机的事件。我们需要工具来评价所希望的目标和它们实现的机会。
    一种非定量的方法是所谓的德尔斐方法，它通过对专家组的咨询调查来帮助对科学技术的趋势进行决策和预测。“德尔斐”这个词涉及传说中的占卜家皮蒂娅（图7．1），据说她为了作出预言而收集有关顾客的信息。今天的德尔斐方法运用了科学专家的估计。每个专家之间保持隔离，使之判断不受社会压力或群体行为的影响。向每个专家征询，一定时期的可能的和（或）有希望的发明和科学突破的名称及其权重。有时，向他们征询的不仅仅是每一种发展的可能性，还要估计出每一种潜在发展的出现将对其他潜在发展的出现的影响的可能性。因此，人们就获得了一种相关的未来发展之网，这是可以用主观条件概率的矩阵来表示的。在下一阶段，专家被告知达成共识的项目。当他们被要求叙述出他们不同意大多数人的意见的理由时，若干个专家就会重新评价他们关于时间的估计，并排列出缩小了的每一种突破的范围。
    当然，德尔斐方法不可能提供唯一的答案。但是，专家意见的分布情况集中了有关潜在的主要突破的大量信息。对多数人意见的偏离，应该在专家不受到巨大压力的情况下得到缩小。但是，德尔斐方法因此不可能预见意外之事。有时，德尔斐方法得到了相关树方法的支持，以从构造的决策构中的多种可能中选择出最好的方法。决策树方法运用了决策理论的思想，以评估一定未来的希望程度，并选择出有关的科学技术的领域，其发展对于实现这些目标是必需的。
    显然，复杂的非线性世界没有唯一的预测和决策方法。我们需要某种整合的（“杂交的”）定性和定量方法的网络。最后，我们在运用这些工具和把握我们的未来时，需要有伦理学路标来指引我们。
    7．3复杂性、责任和自由
    近年来，伦理学已成为吸引力不断增加的主题，工程师、医生、科学家、管理者和政治家等各种人物对此都很感兴趣。引起这种兴趣的原因是不断增长着的环境、经济和现代技术问题、责任问题以及越来越多的警告，还包括对于高度工业化世界的批评的接受越来越少。但是我们必须意识到，我们的伦理行为标准并非从天上掉到地面来的，也并非是由某种神秘的巨大权威所诏示的。它们已经发生了变化，并将继续变化下去，因为它们植根于我们的社会文化世界的进化之中。
    在人类社会的建模中，我们决不要忘记，这里面对的，是其中有着意向性活动的人的高度非线性复杂系统的自参照性。在社会科学中，有一种特殊的测量问题：对社会行为进行观察和记录的科学家自己也是他们所观察的社会系统中的成员。政治选举中的民意测验统计的效应，是一个众所周知的例子。再者，社会的理论模型可能具有规范性功能，会影响其成员的未来行为。一个众所周知的例子是19世纪的社会达尔文主义，它试图把人类社会的发展解释成一种生物进化的线性延续。实际上，这种社会理论激发起来一种粗暴的意识形态，它为历史上的社会、经济和种族的胜利者进行的无情选择披上合法的外衣。今天，有些时髦的是，用自组织的生物模型使基本民主和生态经济的政治思想合法化。但是，自然既不好也不坏，既不爱好和平也不穷兵黩武。这些都是人类的评价。经历了多少个百万年之久的生物策略，是以无数群体和物种——由于基因缺陷、癌症等等——为代价的，因此从人类的观点看，其间充满着其他种种残忍。它们不可能为我们的政治、经济和社会的发展提供伦理学标准。
    在本书中，我们已经看到，历史上的生命、精神和社会模型，往往都是依赖于历史的自然概念和历史的技术标准的。特别是，线性的机械论因果现，在自然、社会和技术科学史上曾经是占支配的范式。它还影响了伦理规范和价值，对于它们的理解不能脱离产生它们的历史时代的认识论概念。认识论和伦理学的历史的相互关联性，并不意味着任何种类的相对主义和自然主义。对于科学理论和假说，我们必须把它们的历史的、心理学的发明和发现的内容，与确证和有效性的内容加以区分。甚至人权也有其意义变化的历史发展。黑格尔曾经主张，人类史可以被理解为“向自由的发展”。因此，在我们讨论一种复杂的非线性世界中的伦理后果时，我们需要简要回顾一下伦理标准的历史发展。
    伦理学如同逻辑学、认识论、科学哲学、语言哲学、法哲学、宗教哲学等，是一门哲学学科。历史上，“伦理学”一词可以追溯到古希腊语中的nuo＆，它原意是指习惯和实践。起初，伦理学被理解为关于道德习惯和风俗习惯的学说，目的是教会人们怎样生活。伦理学的中心问题也就是去发现一个好的道德准则，以忠告人们如何更好地生活，更正当地行动，以及更合理地决策。古希腊追随苏格拉底的哲学家们已经讨论了其中的一些基本概念。柏拉图，这位苏格拉底的学生，把苏格拉底对于更好地生活的探索推广为对于最大的善的普遍理念的追求，这种理念是永恒的、独立的历史生活，隐藏在短暂的、不断变化的物质世界背后。
    亚里士多德批评他老师的永恒价值学，认为它忽视了真实的人类生活。在亚里士多德看来，善、正义和理性的有效性都涉及政治社会（城邦）、家庭和个人之间的相互作用。城邦中正义的实现涉及自由人的自然利益的比例或平衡。幸福就是人的最大的善，它的实现是按照城邦和家庭的自然习惯和实践而成功地生活。显然，亚里士多德的伦理学概念与他的有机自然观相适应，他的自然中充满着植物、动物和人类的生长和成熟。
    在古希腊城邦解体以后，伦理学也就需要一种新标准框架。在伊壁鸠鲁的伦理学中，强调了个体生活、行动和感情的内在平等，而斯多葛派的伦理学则强调所有人的自然实现的外在平等。在基督教的中世纪，永恒价值的等级则是由神的世界秩序来保证的。在近代初期，普遍接受为伦理学基础的神学框架的解体时机就成熟了。
    笛卡尔不仅仅主张一种机械的自然模型，他还主张一种以科学理性为基础的道德系统。巴鲁赫·斯宾诺莎推导出来一个理性主义道德公理体系，与确定论的、机械的自然模型相呼应。因为人们相信自然规律与理性规律的一致，人的自由也就仅仅意味着按照理性的确定论规律而行动。最大的善，也就是指理性对于质料性人体的情感的支配作用。霍布斯捍卫一种机械的自然观和社会观，但是他却怀疑人类的理性。政治规律和习惯都只能由集权的“绝对君主”来保证。最大的善是和平，即是处于某种极权主义国家的不动的、最终的平衡。
    洛克、休谟和斯密的自由社会，则可以理解为类似于关于可分离的力和相互作用着的天体的牛顿模型。在美国和法国革命中，个体的自由被当作一种自然权利。但是在一个确定论因果关系的机械论世界中如何来论证个体的自由呢？甚至自然事件也不过是线性因果链的结果，原则上不可能从运动的力学方程中推导出来。只有人类才被假定能够自发地、自由地作出决策，激起因果行动链，而不受外部环境的影响。康德把这种人的特征称作“自由因果性”。
    人们不受任何一个人的意见和愿望的支配，只有可以为所有人接受的忠告才被看作是合理的。用康德的话来说，只有那些被普遍接受的“准则”才可以被看作是普遍的道德规律。这个正式的道德普遍性原理，是康德的著名的理性范畴规则：我们的行动应该遵从这些规则，它们被正当地看作普遍的道德规律。个人的自由受到他（或她）的邻居的自由所制约。在另一处著名表述中，康德说，人作为一种自由动物不应该被误解为侵犯别人利益的工具。因此，除了受确定论规律支配的机械论自然界，还有一个具有自由和道德规律的内部理性世界。康德的自由伦理见解，已经融进了所有现代宪法国家的正式原则中。
    但是，在真实的政治和经济世界中自由规律如何才能实现呢？在工业化的最初阶段，英裔美国人的功利主义伦理学（源于边沁和穆勒）要求对个人的幸福作出评判。多数人的幸福被看作是最大的伦理学的善。与康德建议的正式的个体自由原理不同，功利主义的幸福原理可以被解释为对于它的物质性完善。在美国宪法中，它被明确地解释为自然人权。功利主义的哲学家和经济学家把对于幸福的要求看作一种收益函数，即以优化的最小代价来实现多数人的最大福利。这种功利主义原理已经成为福利经济学的伦理学框架。
    现代哲学家例如约翰·罗尔斯就认为，功利主义原理与康德的伦理普遍性要求结合起来，有助于实现现代福利政治中的公平分配的需要。从方法论的观点看，功利主义的伦理的、政治的和经济的模型相应于一种自组织的复杂系统，其中具有单个的平衡不动点，由社会收益函数的优化来实现，与实现多数人的物品的公平分配相联系。
    显然，康德的伦理学以及英裔美国人的功利主义都是判断我们的行动的规范要求。它们可以为个体所接受，也可能不被接受。黑格尔主张，个体的主观的伦理标准是历史中的客观的历史过程的产物，是由社会的组织体制来实现的。因此，他把社会中个体的主观道德和主观理性与组织的客观道德和客观理性进行了区分。历史上，黑格尔的以市民社会的现实的习俗和道德为基础的伦理学，使我们想起亚里士多德的现实的古希腊城邦的伦理学。但是，亚里士多德的社会秩序是静态的，而黑格尔假定了一种国家及其组织体制的历史进化。
    从方法论的观点看，值得注意的是，黑格尔已经把个体的微观水平与社会及其组织体制的宏观社会进行了区分，宏观水平不仅仅是其中公民的加和。而且，他把社会的进化描述为并非由单个个体的意向性和主观理性所决定的，而是由集体理性的自组织过程所决定的。然而，黑格尔相信的是一种颇为简单的进化模型，其相继的平衡态导致了一个最终的不动点，这个不动点是由一个公平的市民社会的吸引子所实现的。黑格尔以后的真实的历史过程表明，他的自组织的、以理性的历史力量推动人类社会到最终公平态的信念，是一个危险的幻想。众所周知，他的模型由右翼和左翼的极权主义政治家所修改和滥用。
    弗里德里希·尼采抨击了这种客观理性信念以及作为唯心论意识形态的永恒伦理价值的信念，指出它们与真正的生活力量不相符合。尼采的生命哲学受到达尔文进化生物学的影响，它在19世纪末已经成为一种流行的哲学。尽管尼采已在他的著述中批判了民族主义和种族主义，但是他对生命和生存斗争的胜利者的颂扬却在我们这个世纪的政治中被严重误用了。然而，他另一方面表明了从自然科学中借用的概念影响了政治和伦理思想。
    在我们这个世纪，马丁·海德格尔继续了尼采的虚无主义以及他对现代文明的批判。在海德格尔看来，人类的技术进化是一种没有任何取向的自动作用，这就忘记了人和人性的根本基础。如海德格尔这样的哲学家，不可能也不会改变或影响这种进化。他仅仅有容忍这种强加的命运的自由。但是，海德格尔是以什么方式来反对技术文明而不只是屈从、听天由命并逃匿到某种没有技术的、历史上从未存在过的田园诗式的乌托邦里去呢？看来，这是对于自然和社会中的拉普拉斯万能计划和普遍控制能力信念的极端反动。
    本书中已经讨论过的复杂系统方式的伦理学后果是什么呢？首先，我们必须意识到，复杂系统理论不是一种形而上学的过程本体论。它也不是一种传统哲学意义上的认识论信念。这种方法论的原理，对于自然科学和社会科学中建构非线性复杂系统的模型，提供了一种启发性的图式。如果这些模型不能够进行数学处理，其性质不能够进行量化，那么我们得到一种经验模型，这样的模型也许与数据符合，也许不相符合。而且，它力图在奥卡姆剃刀的意义上最小程度地运用假设。因此，他是一种数学的、经验的、可检验的和有启发性的经济的方法论。而且，它还是一种跨学科研究纲领，结合了多种自然科学和社会科学。不过，它并非一种传统哲学意义上的伦理学信念。
    然而，我们的自然和社会的复杂性非线性过程的模型，对于我们的行为却具有重要的影响。一般来说，在一个非线性复杂现实中，线性的思维方式是危险的。我们已经认识到，传统的自由概念是以线性的行为模型为基础的。在这种框架中，所有事件都是某种明确定义的起始原因的结果。因此，如果我们采取一种线性的行为模型，那么对一事件或结果的责任就显得是唯一地决定了。但是，由局部的亿万自私的人们的非线性相互作用造成了全球性危害的情形又怎样呢？记住，作为一个例子，我们需要的是一个良好均衡的复杂的生态和经济的系统。由于生态混沌可以是全球性的、不可控制的，一些哲学家例如汉斯·琼纳斯就主张，我们应该停止一切可能引起某些未知后果的行动。但是，我们却决不可能预见一个复杂系统的长期发展。难道我们因此应该后退到海德格尔那样的屈从态度上吗？问题在于，无所事事并不能必然地稳定一个复杂系统，却可能将它推进到另一种亚稳态。然而，对于复杂系统作出短期的预测则是可能的，例如在经济学中是可以作出努力来加以改进的。
    在一个线性的模型中，人们相信结果的范围类似于它的原因的范围。因此，一个该受惩罚的行动，法律上的惩罚就是按照受损程度的大小来进行。但是，微小涨落的蝴蝶效应，最初不过是某个人、某个群体或某个公司引发的，最后却导致了某种全球性的政治和经济危机，对此又该怎样办呢？例如，考虑管理者和政治家的责任，他们的失误可能引起数以千计或数以百万计的人们的灾难。
    人类的生态的、经济的和政治的问题都已经成为全球性、复杂的和非线性的问题，传统的个人责任的概念也就让人怀疑。我们需要的是新的集体行为模型，它们依赖于我们有着种种差别的一个个成员及其见解。个体的决策自由并没有被废弃，但却要受到自然和社会中复杂系统集体效果的制约，从长期看复杂系统是不可预测和不可控制的。因此，只有个人的良好愿望是不够的。我们必须考虑它们的非线性效果。全球的动力学相图提供了在一定环境下的可能图景。它们有助于实现合适的条件，去促进所希望的发展，并防止有害的发展。
    例如，电子化的全球村可能意味着一种对于个人自由的严重威胁。如果在巨大的通信网络中容易获得公民的信息并对其进行评判，那么就必须老老实实地承认，这有被利益组织滥用的危险。如同在传统的物品经济学中，可能出现信息的垄断，而不利于其他的人们、阶级和国家。例如，考虑前面讲到的“第三世界”或“南方”，其信息服务系统没有那么发达，它们在一个全球性的通信村中就可能得不到公平的机会。
    我们的医生和心理学家必须学会把人看作心和身的复杂非线性事物。线性的思维可能有损于作出成功的诊断。医疗中采取局部的、孤立的和“线性的”疗法，可能会引起负向的协同效应。因此，值得注意的是，对于复杂的医学和心理学情形进行建模必须要保持高度敏感性并谨慎从事，以治愈和帮助病人。复杂系统探究方式不可能给我们解释生命是什么。但是它向我们表明，生命是多么复杂和敏感。因此，它可以帮助我们自觉意识到我们生命的价值。显然，对于政治学、经济学、生态学、医学以及生物科学、计算科学和信息科学的伦理学，从复杂系统理论可以得到一些结论。这些伦理学结论强烈地依赖于我们关于自然和社会中复杂的非线性动力学的知识，但是它们并非是从复杂系统的原理中推导出来的。因此，我们并不捍卫任何的伦理学自然主义或还原主义。城市发展、全球生态、人的器官或信息网络的动力学模型，都仅仅是提供了有不同吸引子的可能图景。问题在于，我们应该评价出，哪个吸引子应是我们在伦理学上所偏爱的，并通过实现合适的条件而有助它的实现。伊曼努尔·康德在3个著名的问题中概括了这些哲学问题：

    第一个问题涉及认识论，关系到我们的认识的可能性和限度。对于自然和社会的非线性动力学，复杂系统理论解释了我们能够知道什么和无法知道什么。一般说来，这个问题要求进行科学研究，以改进我们关于复杂性和进化的知识。
    第二个问题涉及伦理学和对我们的行动的评价。一般说来，这个问题要求我们，在处理自然和社会中高度敏感的复杂系统时保持高度的敏感性。我们既不要冒进也不要后退，因为冒进以及后退都可能推动系统从一种混沌态变到另一种混沌态。我们既要谨慎也要积极，遵从进化中的非线性和复杂性条件。在政治上，我们应该意识到，任何一种单向因果性都可能导致教条主义、狭隘偏执和狂热盲信。
    康德的最后一个问题是“我可以希望什么？”这涉及最大的善，传统上宗教哲学中是作为summum bonum（最大的限度）来讨论的。初看起来，它好像是超出了复杂系统理论的范围，复杂系统理论只允许我们在长期问题上导出某种总体图景，在特定条件下作出短期预测。但是，当我们考虑人类的长期的社会文化进化，人们为之奋斗的最大的善就获得了他们个人生命的尊严。这并不依赖于个体的能力、智能程度或由偶然的出生带来的社会优越性。它是一种人们在历史的斗争中的自决定的自由行动。在复杂性不断增加的继续进化中，我们必须尽力保护最大的善。

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页


克劳斯·迈因策尔—复杂性中的思维—译者后记

译者后记

    20世纪初以来，相对论拓展了对广袤宇宙的追索，量子力学深化了向物质深层的进军，系统科学、非线性科学、自组织理论则代表着对复杂性的新探索。本世纪科学技术的突飞猛进，特别是80年代以来的新技术革命迅速地改变着我们赖以生存的物质条件，改变着我们的生活方式。
    科学技术的新动向、新成就必然影响时代的社会生活、社会文化以及人们的思维方式。量子力学和相对论诞生以后，种种系统理论从20世纪中叶兴起，自组织理论于70年代前后问世，非线性科学80年代以来逐渐成为学术热点，90年代信息技术进入了新的发展阶段。探索和理解复杂性，成为走向21世纪的科学技术主旋律，必然对我们走向21世纪的思维方式产生深刻影响。
    克劳斯教授的《复杂性中的思维》，从科学前沿探索与人类心智探险史的结合中，涉猎从物理世界的进化到生命世界的进化，从意识的起源到认知科学的兴起，从社会政治系统到社会经济系统的运行，从哲学史到哲学前沿的反思，阐述了探索复杂性将引起人们思维方式的变化，引起世人对共同未来的关怀。《复杂性中的思维》是一本扣人心弦的著作。
    有鉴于此，当我完成《自组织的自然观》（北京大学出版社，1996）书稿后见到《复杂性中的思维》（第一版）时，有了将它译成中文出版的念头。在中央编译出版社、原书作者以及德国施普林格出版社的积极支持下，按《复杂性中的思维》第二版翻译的中文版，现在摆到了我国读者面前。

                                                      曾国屏
                                            1997年元月于清华大学

    ------------------
    何必网上苦苦寻觅，北极星书库让您轻松拥有！
后一页